Double-Take Powershell Overview

Double-Take REST SDK 8.0
Double-Take Powershell Overview

Double-Take includes Windows PowerShell cmdlets that you can use to control most Double-Take features. This guide includes all of the Double-Take cmdlets available. However, this guide does not explain how to use Windows PowerShell. You should reference your Windows PowerShell documentation and the many web sites devoted to PowerShell to learn how to use and script with Windows PowerShell.

The following terms and definitions will help you understand Double-Take basics. See the User's Guide for your Double-Take product for complete details on how that product works.

  • Source—The source is the server that has the data you want to protect or migrate. Typically this is a machine on the production network that serves data to clients.

  • Target—The target is the server that maintains the replicated copy of the data that is being protected on the source. Typically this is a backup server that may be local or in a remote data center. For migration jobs, this is the final destination for your data.

  • Workload—A workload is a logical definition of the data that is being protected or migrated on the source. A workload can be a simple set of paths, for example, C:\Data or /usr. It may also be a more complex logical item that maps to multiple paths. For example, protecting a virtual machine means you are protecting multiple, specific virtual machine files, or protecting Microsoft SQL means you are protecting a SQL database and its related files.

  • Workload manager—The workload manager is a web service that creates and configures the Double-Take workload.

  • Job—A job is a logical unit that includes the source, target, and the workload. The job is what you create and monitor in order to protect or migrate your data.

  • Job manager—The job manager is a web service that creates, monitors, and controls the Double-Take job.

  • Connection—The engine connection is the underlying stream that sends the actual replicated data between the source and target servers. Jobs are higher-level objects that use the lower-level connection to protect data.

  • Architecture—Each Double-Take installation has two services, the Management Service and Engine.

    • Management Service—This service is displayed as Double-Take Management Service in the Windows services list and jsvc on Linux. The service hosts the job manager and provides monitoring and control for all job types. For WCF clients, the service listens on port 6325. For non-WCF clients, the service listens on port 6326. This service offers a SOAP-based XML web services interface.

    • Engine—This service is displayed as Double-Take in the Windows service list and DT on Linux. The service transmits the replicated data between the source and target servers. By default this service listens on port 6320. You do not interact directly with this service.

  • Roles—Any Double-Take installation can be a source, target, or both. The existence of a job between two servers and which direction data is being transmitted determines the server’s role.

  • Security—Double-Take enforces security by using local groups on each server where Double-Take is installed. There are two levels of security. Administrator access allows full control of Double-Take on a server, and monitor access allows read-only views of job information. When you connect to the job manager on a server, you will need to provide the credentials of a user who is a member of one of the local groups on that server.

  • Job creation—To create a job, you will first communicate with the source to create a workload. You will then use that workload object and communicate with the target to create the job.

  • Monitoring and controlling jobs—To monitor and control jobs, you will communicate with the job manager on the target of the job.


Add-DtLogicalRule

Add-DtLogicalRule

Short description

Long description

Syntax

Add-DtLogicalRule [-ComputerName] <string> [-WorkloadId] <guid> -Path <string> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Path<String>
Required? | true
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Example of how to use this cmdlet

Another example of how to use this cmdlet


Add-DtPhysicalRule

Add-DtPhysicalRule

Adds a physical rule to a workload on a local or remote computer running the Double-Take Management Service.

Adds a physical rule to a workload on a local or remote computer running the Double-Take Management Service. Physical rules specify whether to include or exclude specific paths to items on the file system on the local or remote computer.

Syntax

Add-DtPhysicalRule [-ComputerName] <string> [-WorkloadId] <guid> [-Path] <string> [-Exclude] [-Recurse] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Path<String>
Required? | true
Position? | 3
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Exclude<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Recurse<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command adds a recursive include rule for the C:\Data path.

Add-DtPhysicalRule -ComputerName server01 -WorkloadId 330ce3e2-e1d7-4c51-b1b7-48e875c8d899 -Path C:\Data -Recurse

Description ----------- This command adds a recursive include rule for the C:\Data path to the newly created workload piped to it.

New-DtWorkload server01 FilesAndFolders | Add-DtPhysicalRule -Path C:\Data -Recurse


Confirm-DtJobOptions

Confirm-DtJobOptions

Short description

Long description

Syntax

Confirm-DtJobOptions [-TargetComputerName] <Object> [-JobOptions] <Object> -SourceComputerName <Object> [-JobType <Object>] [-SourceCredential <Object>] [-TargetCredential <Object>] [<CommonParameters>]

Confirm-DtJobOptions [-TargetComputerName] <Object> [-JobId] <guid> [-JobOptions] <Object> [<CommonParameters>]

Parameters

-TargetComputerName<Object>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-JobOptions<Object>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-JobType<Object>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SourceComputerName<Object>
Required? | true
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SourceCredential<Object>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-TargetCredential<Object>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-TargetComputerName<Object>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-JobId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-JobOptions<Object>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Example of how to use this cmdlet

Another example of how to use this cmdlet


Connect-DtServer

Connect-DtServer

Connects to the Double-Take Management Service on a local or remote computer.

The Connect-DtServer cmdlet connects to the Double-Take Management Service on a remote computer, establishing a persistent connection to the remote computer.

Syntax

Connect-DtServer [-ComputerName] <string[]> [[-Credential] <Object>] [-Persist] [<CommonParameters>]

Parameters

-ComputerName<String[]>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Credential<Object>
Required? | false
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Persist<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command connects to the specified server using the supplied credentials.

Connect-DtServer -ComputerName server01 -Credential $cred

Description ----------- This command connects to the specified server, persisting the connection between PowerShell sessions.

Connect-DtServer server01 administrator -Persist


Disconnect-DtServer

Disconnect-DtServer

Disconnects from the Double-Take Management Service on a local or remote computer.

The Disonnect-DtServer cmdlet disconnects from the Double-Take Management Service on a remote computer, removing the persistent connection to the remote computer if one exists.

Syntax

Disconnect-DtServer [-ComputerName] <string[]> [<CommonParameters>]

Parameters

-ComputerName<String[]>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command disconnects the specified server.

Disconnect-DtServer -ComputerName server01


Get-DtAccessLevel

Get-DtAccessLevel

Gets the access level for the specified Double-Take server.

Gets the access level for the specified Double-Take server.

Syntax

Get-DtAccessLevel [-ComputerName] <string> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtAccessLevel -ComputerName server01


Get-DtAuthorizationHeader

Get-DtAuthorizationHeader

Gets an authorization header that can be used to make REST calls to the specified Double-Take server.

The Get-DtAuthorizationHeader cmdlet returns a hash table that can be used for the Headers to authorize access when using Invoke-RestMethod to invoke REST methods through the Double-Take Management Service on the specified computer.

Syntax

Get-DtAuthorizationHeader [-ComputerName] <string[]> [<CommonParameters>]

Parameters

-ComputerName<String[]>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtAuthorizationHeader -ComputerName server01


Get-DtEmailOptions

Get-DtEmailOptions

Gets e-mail options from the specified Double-Take server.

Gets e-mail options from the specified Double-Take server.

Syntax

Get-DtEmailOptions [-ComputerName] <string> [[-Fields] <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtEmailOptions -ComputerName server01


Get-DtEventLogEntry

Get-DtEventLogEntry

Gets event log entries from the specified Double-Take server.

Gets event log entries from the specified Double-Take server.

Syntax

Get-DtEventLogEntry [-ComputerName] <string> [-Filter <string>] [-LastId <int>] [-PageSize <int>] [-Fields <string[]>] [<CommonParameters>]

Get-DtEventLogEntry [-ComputerName] <string> -Id <int> [-Fields <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Filter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-LastId<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-PageSize<Int32>
Required? | false
Position? | named
Default Value | 1000
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Id<Int32>
Required? | true
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command gets the first 100 event log entries from server01.

Get-DtEventLogEntry -ComputerName server01

Description ----------- This command gets the first 10 event log entries from server01.

Get-DtEventLogEntry -ComputerName server01 -PageSize 10

Description ----------- This command gets the next 100 event log entries from server01, starting after the entry with ID 100.

Get-DtEventLogEntry -ComputerName server01 -LastId 100


Get-DtJob

Get-DtJob

Gets jobs from the specified Double-Take server.

Gets jobs from the specified Double-Take server.

Syntax

Get-DtJob [-ComputerName] <string> [-Id] <guid> [-Fields <string[]>] [<CommonParameters>]

Get-DtJob [-ComputerName] <string> [-Filter <string>] [-SortBy <string[]>] [-Page <int>] [-PageSize <int>] [-Fields <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Id<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Filter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SortBy<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Page<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-PageSize<Int32>
Required? | false
Position? | named
Default Value | 100
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command gets the first 100 jobs from server01.

Get-DtJob -ComputerName server01

Description ----------- This command gets the first 10 jobs from server01.

Get-DtJob -ComputerName server01 -PageSize 10

Description ----------- This command gets the next 100 jobs from server01, starting on page 2.

Get-DtJob -ComputerName server01 -Page 2


Get-DtLogicalItem

Get-DtLogicalItem

Short description

Long description

Syntax

Get-DtLogicalItem [-ComputerName] <string> [-WorkloadId] <guid> [-ParentPath <string>] [-Filter <string>] [-SortBy <string[]>] [-Fields <string[]>] [-Page <int>] [-PageSize <int>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-ParentPath<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Filter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SortBy<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Page<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-PageSize<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Example of how to use this cmdlet

Another example of how to use this cmdlet


Get-DtNetworkInterface

Get-DtNetworkInterface

Gets the network interfaces from the specified Double-Take server.

Gets the network interfaces from the specified Double-Take server.

Syntax

Get-DtNetworkInterface [-ComputerName] <string> [-Id] <guid> [-Fields <string[]>] [<CommonParameters>]

Get-DtNetworkInterface [-ComputerName] <string> [-Filter <string>] [-SortBy <string[]>] [-Page <int>] [-PageSize <int>] [-Fields <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Id<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Filter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SortBy<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Page<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-PageSize<Int32>
Required? | false
Position? | named
Default Value | 100
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtNetworkInterface -ComputerName server01

Get-DtNetworkInterface -ComputerName server01 -Filter 'Name eq "Local Area Network"'

Get-DtNetworkInterface -ComputerName server01 -Sort 'Name' -Fields 'Name,Description'


Get-DtOption

Get-DtOption

Gets server options from the specified Double-Take server.

Gets server options from the specified Double-Take server.

Syntax

Get-DtOption [-ComputerName] <string> [[-Options] <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Options<String[]>
Required? | false
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtOption -ComputerName server01


Get-DtPhysicalItem

Get-DtPhysicalItem

Gets physical items from the specified Double-Take server.

Gets physical items (files and directories) from the specified Double-Take server. DevNote: This command is likely to be renamed and redesigned to better match Get-Item/Get-ChildItem.

Syntax

Get-DtPhysicalItem [-ComputerName] <string> [-WorkloadId <guid>] [-ParentPath <string>] [-Filter <string>] [-SortBy <string[]>] [-Fields <string[]>] [-Page <int>] [-PageSize <int>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-ParentPath<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Filter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SortBy<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Page<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-PageSize<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtPhysicalItem -ComputerName server01

Get-DtPhsyicalItem -ComputerName server01 -ParentPath 'C:\Windows'

Get-DtPhysicalItem -ComputerName server01 -Filter 'IsContainer eq True' -Sort '-Name' -Fields 'Name,Path'


Get-DtProductInfo

Get-DtProductInfo

Gets product information from the specified Double-Take server.

Gets product information from the specified Double-Take server.

Syntax

Get-DtProductInfo [-ComputerName] <string> [[-Fields] <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtProductInfo -ComputerName server01


Get-DtRecommendedJobOptions

Get-DtRecommendedJobOptions

Short description

Long description

Syntax

Get-DtRecommendedJobOptions [-Workload] <Object> [-TargetComputerName] <Object> [-JobType <string>] [<CommonParameters>]

Parameters

-Workload<Object>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false

-TargetComputerName<Object>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-JobType<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Example of how to use this cmdlet

Another example of how to use this cmdlet


Get-DtServer

Gets the connected Double-Take servers.

The Get-DtServer cmdlet gets the servers that have been connected to with Connect-DtServer. Without parameters, a "Get-DtServer" command gets all of the servers. With a ComputerName specified the command only gets the specified server, possibly returning the actual server name if an IP or other type of alias is used.

Syntax

Get-DtServer [[-ComputerName] <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String[]>
Required? | false
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtServer

Get-DtServer -ComputerName 192.168.0.1


Get-DtServerInfo

Get-DtServerInfo

Gets server information from the specified Double-Take server.

Gets server information from the specified Double-Take server.

Syntax

Get-DtServerInfo [-ComputerName] <string> [[-Fields] <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByValue, ByPropertyName)
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Get-DtServerInfo -ComputerName server01


Get-DtWorkload

Get-DtWorkload

Retrieves workload information from the Double-Take Management Service on a local or remote computer.

Retrieves workload information from the Double-Take Management Service on a local or remote computer.

Syntax

Get-DtWorkload [-ComputerName] <string> [-Filter <string>] [-SortBy <string[]>] [-Fields <string[]>] [-Page <int>] [-PageSize <int>] [<CommonParameters>]

Get-DtWorkload [-ComputerName] <string> [-WorkloadId] <guid> [-Fields <string[]>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Filter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SortBy<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Page<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-PageSize<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Fields<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command gets all of the workloads on server01.

Get-DtWorkload server01

Description ----------- This command gets the specified workload by ID.

Get-DtWorkload server01 11e74356-3563-472e-95bf-5edafa05ed83


Get-DtWorkloadType

Get-DtWorkloadType

Gets the workload types that can be created on the specified server.

Gets the workload types that can be created on the specified server. The workload types that can be created depend on the license installed on the the server, and optionally on the server that will be the target of a job as well.

Syntax

Get-DtWorkloadType [-ComputerName] <string> [[-TargetComputerName] <string>] [-All] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-TargetComputerName<String>
Required? | false
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-All<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command retrieves all of the workload types where 'isLicensed' and 'isPresent' are set to $true, based on the license installed on server01.

Get-DtWorkloadType -ComputerName server01

Description ----------- This command retrieves all of the workload types where 'isLicensed' and 'isPresent' are set to $true, based on the licenses installed on server01 and server02.

Get-DtWorkloadType -ComputerName server01 -TargetComputerName server02

Description ----------- This command retrieves all of the workload types with 'isLicensed' and 'isPresent' set based on the licenses installed on server01 and server02.

Get-DtWorkloadType server01 server02 -All


Invoke-DtMethod

Invoke-DtMethod

Invokes a REST method on the Double-Take Management Service on a local or remote computer.

Invokes a REST method on the Double-Take Management Service on a local or remote computer.

Syntax

Invoke-DtMethod [-ComputerName] <string> [-RelativeUri] <uri> [-QueryParameters <hashtable>] [-Body <Object>] [-ContentType <Object>] [-Method <WebRequestMethod>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-RelativeUri<Uri>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-QueryParameters<Hashtable>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Body<Object>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | true (ByValue)
Accept Wildcard Characters? | false

-ContentType<Object>
Required? | false
Position? | named
Default Value | application/json
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Method<WebRequestMethod>
Required? | false
Position? | named
Default Value | Get
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command queries the access level using the REST method on the remote Double-Take Management Service.

Invoke-DtMethod -ComputerName server01 -RelativeUri 'api/access_level' -Method Get


New-DtJob

New-DtJob

Short description

Long description

Syntax

New-DtJob [-JobOptions] <Object> -TargetComputerName <Object> -SourceCredential <Object> -TargetCredential <Object> [-JobType <string>] [<CommonParameters>]

Parameters

-JobOptions<Object>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-TargetComputerName<Object>
Required? | true
Position? | named
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-SourceCredential<Object>
Required? | true
Position? | named
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-TargetCredential<Object>
Required? | true
Position? | named
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-JobType<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Example of how to use this cmdlet

Another example of how to use this cmdlet


New-DtWorkload

New-DtWorkload

Creates a new workload on the specified Double-Take Management Service on a local or remote computer.

Creates a new workload on the specified Double-Take Management Service on a local or remote computer.

Syntax

New-DtWorkload [-ComputerName] <Object> [-WorkloadType] <string> [-Image <guid>] [-Snapshot <guid>] [<CommonParameters>]

Parameters

-ComputerName<Object>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-WorkloadType<String>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Image<Guid>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Snapshot<Guid>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command creates a new FilesAndFolders workload on server01.

New-DtWorkload -ComputerName server01 -WorkloadType FilesAndFolders


Remove-DtJob

Remove-DtJob

Removes a job from the Double-Take Management Service on the local or remote server.

Removes a job from the Double-Take Management Service on the local or remote server.

Syntax

Remove-DtJob [-ComputerName] <string> [-JobId] <guid> [[-ImageId] <guid>] [[-VhdDeleteAction] <string>] [[-VhdsToDelete] <string[]>] [-DeleteReplica] [-DiscardTargetQueue] [-DeleteImage] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-JobId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-DeleteReplica<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-DiscardTargetQueue<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-DeleteImage<SwitchParameter>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ImageId<Guid>
Required? | false
Position? | 3
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-VhdDeleteAction<String>
Required? | false
Position? | 4
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-VhdsToDelete<String[]>
Required? | false
Position? | 5
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command removes the specified workload from the server.

Remove-DtJob -ComputerName server01 -JobId 11e74356-3563-472e-95bf-5edafa05ed83


Remove-DtLogicalRule

Remove-DtLogicalRule

Short description

Long description

Syntax

Remove-DtLogicalRule [-ComputerName] <string> [-WorkloadId] <guid> -Path <string> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Path<String>
Required? | true
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Example of how to use this cmdlet

Another example of how to use this cmdlet


Remove-DtPhysicalRule

Remove-DtPhysicalRule

Removes a physical rule previously added to a workload.

Removes a physical rule previously added to a workload.

Syntax

Remove-DtPhysicalRule [-ComputerName] <string> [-WorkloadId] <guid> [-Path] <string> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Path<String>
Required? | true
Position? | 3
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command removes a previously added rule for C:\Data from the specified workload.

Remove-DtPhysicalRule -ComputerName server01 -WorkloadId 11e74356-3563-472e-95bf-5edafa05ed83 -Path C:\Data

Description ----------- This command removes a previously added rule for C:\Data from the workload piped to the command.

$workload | Remove-DtPhysicalRule -Path C:\Data


Remove-DtWorkload

Remove-DtWorkload

Removes a workload from the Double-Take Management Service on the local or remote server.

Removes a workload from the Double-Take Management Service on the local or remote server.

Syntax

Remove-DtWorkload [-ComputerName] <string> [-WorkloadId] <guid> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-WorkloadId<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command removes the specified workload from the server.

Remove-DtWorkload -ComputerName server01 -WorkloadId 11e74356-3563-472e-95bf-5edafa05ed83

Description ----------- This command removes the workload piped to the command.

$workload | Remove-DtWorkload


Set-DtEmailOptions

Set-DtEmailOptions

Sets e-mail options on the specified Double-Take server.

Sets e-mail options on the specified Double-Take server.

Syntax

Set-DtEmailOptions [-ComputerName] <string> [-Options] <Object> [<CommonParameters>]

Set-DtEmailOptions [-ComputerName] <string> [-Enable <bool>] [-SmtpServer <string>] [-SmtpPort <int>] [-LoginToSmtpServer <bool>] [-SmtpCredentials <Object>] [-From <string>] [-To <string[]>] [-SubjectPrefix <string>] [-IncludeEventDescriptionInSubject <bool>] [-EntryTypeFilter <string>] [-EntryIdFilter <int>] [-ConnectionSecurity <SmtpConnectionSecurity>] [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Options<Object>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Enable<Boolean>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SmtpServer<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SmtpPort<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-LoginToSmtpServer<Boolean>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SmtpCredentials<Object>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-From<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-To<String[]>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-SubjectPrefix<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-IncludeEventDescriptionInSubject<Boolean>
Required? | false
Position? | named
Default Value | False
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-EntryTypeFilter<String>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-EntryIdFilter<Int32>
Required? | false
Position? | named
Default Value | 0
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ConnectionSecurity<SmtpConnectionSecurity>
Required? | false
Position? | named
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- Sets the email options on server01.

Set-DtEmailOptions -ComputerName server01 -Options $options


Set-DtOption

Set-DtOption

Sets options on the specified Double-Take server.

Sets options on the specified Double-Take server.

Syntax

Set-DtOption [-ComputerName] <string> [-Name] <string> [-Value] <Object> [<CommonParameters>]

Set-DtOption [-ComputerName] <string> [-Options] <Object[]> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Name<String>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-Value<Object>
Required? | true
Position? | 3
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Options<Object[]>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | false
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Set-DtOption -ComputerName server01 -Options $options


Start-DtJob

Start-DtJob

Starts a Double-Take Job.

Starts a Double-Take Job.

Syntax

Start-DtJob [-ComputerName] <string> [-Id] <guid> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Id<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command starts the specified job.

Start-DtJob -ComputerName server01 -JobId 11e74356-3563-472e-95bf-5edafa05ed83

Description ----------- This command starts all the jobs on server01.

Get-DtJob server01 | Start-DtJob


Stop-DtJob

Stop-DtJob

Stops a Double-Take Job.

Stops a Double-Take Job.

Syntax

Stop-DtJob [-ComputerName] <string> [-Id] <guid> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Id<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command stops the specified job.

Stop-DtJob -ComputerName server01 -JobId 11e74356-3563-472e-95bf-5edafa05ed83

Description ----------- This command stops all the jobs on server01.

Get-DtJob server01 | Stop-DtJob


Suspend-DtJob

Suspend-DtJob

Suspends a Double-Take Job.

Suspends a Double-Take Job.

Syntax

Suspend-DtJob [-ComputerName] <string> [-Id] <guid> [<CommonParameters>]

Parameters

-ComputerName<String>
Required? | true
Position? | 1
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false

-Id<Guid>
Required? | true
Position? | 2
Default Value |
Accept Pipeline Input? | true (ByPropertyName)
Accept Wildcard Characters? | false
<CommonParameters>

This cmdlet supports the common parameters: Verbose, Debug, ErrorAction, ErrorVariable, WarningAction, WarningVariable, OutBuffer, PipelineVariable, and OutVariable. For more information, see about_CommonParameters.

Examples

Description ----------- This command suspends the specified job.

Suspend-DtJob -ComputerName server01 -JobId 11e74356-3563-472e-95bf-5edafa05ed83

Description ----------- This command suspends all the jobs on server01.

Get-DtJob server01 | Suspend-DtJob


DoubleTake.Web.Client Namespace

DoubleTake.Web.Client Namespace
Classes
 | Class | Description
Public class | AccessLevelApi |
Public class | ActivationStatusApi |
Public class | ActivitiesApi |
Public class | ApiClient |
Public class | ApiResponse |
Public class | ApiResponseT |
Public class | EmailOptionsApi |
Public class | EventLogEntriesApi |
Public class | FilesApi |
Public class | ImagesApi |
Public class | JobsApi |
Public class | NetworkInterfacesApi |
Public class | OptionsApi |
Public class | ProductInfoApi |
Public class | ServerInfoApi |
Public class | WorkloadsApi |


AccessLevelApi Class

AccessLevelApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientAccessLevelApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class AccessLevelApi : ApiClient
Public Class AccessLevelApi
    Inherits ApiClient
public ref class AccessLevelApi : public ApiClient
type AccessLevelApi =
    class
        inherit ApiClient
    end

The AccessLevelApi type exposes the following members.

Constructors
 | Name | Description
Public method | AccessLevelApi | Initializes a new instance of the AccessLevelApi class
Top
Methods
 | Name | Description
Protected method | DeleteHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | DeleteHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHttpAsyncT(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | GetHttpAsyncT(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PatchHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PollStatusTStatus | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


AccessLevelApi Constructor

AccessLevelApi Constructor
Initializes a new instance of the AccessLevelApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessLevelApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
AccessLevelApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> AccessLevelApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

AccessLevelApi Class
DoubleTake.Web.Client Namespace


AccessLevelApi Methods

AccessLevelApi Methods

The AccessLevelApi type exposes the following members.

Methods
 | Name | Description
Protected method | DeleteHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | DeleteHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHttpAsyncT(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | GetHttpAsyncT(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PatchHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PollStatusTStatus | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AccessLevelApi Class
DoubleTake.Web.Client Namespace


AccessLevelApi.GetAsync Method

AccessLevelApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<AccessLevelModel>> GetAsync(
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of AccessLevelModel))
public:
Task<ApiResponse<AccessLevelModel^>^>^ GetAsync(
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<AccessLevelModel>>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse AccessLevelModel
See Also

Reference

AccessLevelApi Class
DoubleTake.Web.Client Namespace


ActivationStatusApi Class

ActivationStatusApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientActivationStatusApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationStatusApi : ApiClient
Public NotInheritable Class ActivationStatusApi
    Inherits ApiClient
public ref class ActivationStatusApi sealed : public ApiClient
[<SealedAttribute>]
type ActivationStatusApi =
    class
        inherit ApiClient
    end

The ActivationStatusApi type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationStatusApi | Initializes a new instance of the ActivationStatusApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ActivationStatusApi Constructor

ActivationStatusApi Constructor
Initializes a new instance of the ActivationStatusApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
ActivationStatusApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> ActivationStatusApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

ActivationStatusApi Class
DoubleTake.Web.Client Namespace


ActivationStatusApi Methods

ActivationStatusApi Methods

The ActivationStatusApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationStatusApi Class
DoubleTake.Web.Client Namespace


ActivationStatusApi.GetAsync Method

ActivationStatusApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivationStatusModel>> GetAsync(
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ActivationStatusModel))
public:
Task<ApiResponse<ActivationStatusModel^>^>^ GetAsync(
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivationStatusModel>>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ActivationStatusModel
See Also

Reference

ActivationStatusApi Class
DoubleTake.Web.Client Namespace


ActivitiesApi Class

ActivitiesApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientActivitiesApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivitiesApi : ApiClient
Public NotInheritable Class ActivitiesApi
    Inherits ApiClient
public ref class ActivitiesApi sealed : public ApiClient
[<SealedAttribute>]
type ActivitiesApi =
    class
        inherit ApiClient
    end

The ActivitiesApi type exposes the following members.

Constructors
 | Name | Description
Public method | ActivitiesApi | Initializes a new instance of the ActivitiesApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetStatusAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PollStatusTStatus(TStatus, Int32, ActionTStatus, CancellationToken) |
Public method | PollStatusTStatus(ApiResponseTStatus, Int32, ActionTStatus, CancellationToken) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ActivitiesApi Constructor

ActivitiesApi Constructor
Initializes a new instance of the ActivitiesApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivitiesApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
ActivitiesApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> ActivitiesApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

ActivitiesApi Class
DoubleTake.Web.Client Namespace


ActivitiesApi Methods

ActivitiesApi Methods

The ActivitiesApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetStatusAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PollStatusTStatus(TStatus, Int32, ActionTStatus, CancellationToken) |
Public method | PollStatusTStatus(ApiResponseTStatus, Int32, ActionTStatus, CancellationToken) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivitiesApi Class
DoubleTake.Web.Client Namespace


ActivitiesApi.GetPartialAsync Method

ActivitiesApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialAsync(
    Guid id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    id As Guid,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialAsync(
    Guid id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        id : Guid *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ActivitiesApi Class
DoubleTake.Web.Client Namespace


ActivitiesApi.GetStatusAsync Method

ActivitiesApiGetStatusAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> GetStatusAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function GetStatusAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ GetStatusAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member GetStatusAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

ActivitiesApi Class
DoubleTake.Web.Client Namespace


ActivitiesApi.PollStatus Method

ActivitiesApiPollStatus Method
Overload List
 | Name | Description
Public method | PollStatusTStatus(TStatus, Int32, ActionTStatus, CancellationToken) |
Public method | PollStatusTStatus(ApiResponseTStatus, Int32, ActionTStatus, CancellationToken) |
Top
See Also

Reference

ActivitiesApi Class
DoubleTake.Web.Client Namespace


ActivitiesApi.PollStatus(TStatus) Method (TStatus, Int32, Action(TStatus), CancellationToken)

ActivitiesApiPollStatusTStatus Method (TStatus, Int32, ActionTStatus, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<TStatus>> PollStatus<TStatus>(
    TStatus initialStatus,
    int pollDelay = 100,
    Action<TStatus> updateCallback = null,
    CancellationToken cancellationToken = null
)
where TStatus : ActivityStatusModel

Public Function PollStatus(Of TStatus As ActivityStatusModel) (
    initialStatus As TStatus,
    Optional pollDelay As Integer = 100,
    Optional updateCallback As Action(Of TStatus) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of TStatus))
public:
generic<typename TStatus>
where TStatus : ActivityStatusModel
Task<ApiResponse<TStatus>^>^ PollStatus(
    TStatus initialStatus,
    int pollDelay = 100,
    Action<TStatus>^ updateCallback = nullptr,
    CancellationToken cancellationToken = nullptr
)
member PollStatus :
        initialStatus : 'TStatus *
        ?pollDelay : int *
        ?updateCallback : Action<'TStatus> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _pollDelay = defaultArg pollDelay 100
        let _updateCallback = defaultArg updateCallback null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<'TStatus>>  when 'TStatus : ActivityStatusModel

Parameters

initialStatus
Type: TStatus
pollDelay (Optional)
Type: SystemInt32
updateCallback (Optional)
Type: SystemAction TStatus
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Type Parameters

TStatus

Return Value

Type: Task ApiResponse TStatus
See Also

Reference

ActivitiesApi Class
PollStatus Overload
DoubleTake.Web.Client Namespace


ActivitiesApi.PollStatus(TStatus) Method (ApiResponse(TStatus), Int32, Action(TStatus), CancellationToken)

ActivitiesApiPollStatusTStatus Method (ApiResponseTStatus, Int32, ActionTStatus, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<TStatus>> PollStatus<TStatus>(
    ApiResponse<TStatus> initialStatus,
    int pollDelay = 100,
    Action<TStatus> updateCallback = null,
    CancellationToken cancellationToken = null
)
where TStatus : ActivityStatusModel

Public Function PollStatus(Of TStatus As ActivityStatusModel) (
    initialStatus As ApiResponse(Of TStatus),
    Optional pollDelay As Integer = 100,
    Optional updateCallback As Action(Of TStatus) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of TStatus))
public:
generic<typename TStatus>
where TStatus : ActivityStatusModel
Task<ApiResponse<TStatus>^>^ PollStatus(
    ApiResponse<TStatus>^ initialStatus,
    int pollDelay = 100,
    Action<TStatus>^ updateCallback = nullptr,
    CancellationToken cancellationToken = nullptr
)
member PollStatus :
        initialStatus : ApiResponse<'TStatus> *
        ?pollDelay : int *
        ?updateCallback : Action<'TStatus> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _pollDelay = defaultArg pollDelay 100
        let _updateCallback = defaultArg updateCallback null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<'TStatus>>  when 'TStatus : ActivityStatusModel

Parameters

initialStatus
Type: DoubleTake.Web.ClientApiResponse TStatus
pollDelay (Optional)
Type: SystemInt32
updateCallback (Optional)
Type: SystemAction TStatus
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Type Parameters

TStatus

Return Value

Type: Task ApiResponse TStatus
See Also

Reference

ActivitiesApi Class
PollStatus Overload
DoubleTake.Web.Client Namespace


ApiClient Class

ApiClient Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
More...

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ApiClient
Public MustInherit Class ApiClient
public ref class ApiClient abstract
[<AbstractClassAttribute>]
type ApiClient =  class end

The ApiClient type exposes the following members.

Properties
Name | Description
PollingInterval |
Top
Methods
 | Name | Description
 | AuthorizeAsync(String, String, String, String, String, CancellationToken) |
 | AuthorizeAsync(String, NullableInt32, String, String, String, String, CancellationToken) |
 | CheckAuthorizationAsync |
Protected method | DeleteHttpAsync(String, CancellationToken) |
Protected method | DeleteHttpAsync(String, Object, CancellationToken) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHttpAsyncT(String, CancellationToken) |
Protected method | GetHttpAsyncT(String, Object, CancellationToken) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PatchHttpAsyncT(String, T, CancellationToken) |
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) |
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Protected method | PollStatusTStatus |
Protected method | PostHttpAsync(String, CancellationToken) |
Protected method | PostHttpAsync(String, Object, CancellationToken) |
Protected method | PostHttpAsyncT(String, T, CancellationToken) |
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) |
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) |
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) |
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Protected method | PutHttpAsync(String, CancellationToken) |
Protected method | PutHttpAsync(String, Object, CancellationToken) |
Protected method | PutHttpAsyncT(String, T, CancellationToken) |
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) |
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) |
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) |
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientAccessLevelApi
DoubleTake.Web.ClientActivationStatusApi
DoubleTake.Web.ClientActivitiesApi
DoubleTake.Web.ClientEmailOptionsApi
DoubleTake.Web.ClientEventLogEntriesApi
DoubleTake.Web.ClientFilesApi
DoubleTake.Web.ClientImagesApi
DoubleTake.Web.ClientJobsApi
DoubleTake.Web.ClientNetworkInterfacesApi
DoubleTake.Web.ClientOptionsApi
DoubleTake.Web.ClientProductInfoApi
DoubleTake.Web.ClientServerInfoApi
DoubleTake.Web.ClientWorkloadsApi


ApiClient Properties

ApiClient Properties

The ApiClient type exposes the following members.

Properties
Name | Description
PollingInterval |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PollingInterval Property

ApiClientPollingInterval Property

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static int PollingInterval { get; set; }
Public Shared Property PollingInterval As Integer
    Get
    Set
public:
static property int PollingInterval {
    int get ();
    void set (int value);
}
static member PollingInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient Methods

ApiClient Methods

The ApiClient type exposes the following members.

Methods
 | Name | Description
 | AuthorizeAsync(String, String, String, String, String, CancellationToken) |
 | AuthorizeAsync(String, NullableInt32, String, String, String, String, CancellationToken) |
 | CheckAuthorizationAsync |
Protected method | DeleteHttpAsync(String, CancellationToken) |
Protected method | DeleteHttpAsync(String, Object, CancellationToken) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHttpAsyncT(String, CancellationToken) |
Protected method | GetHttpAsyncT(String, Object, CancellationToken) |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PatchHttpAsyncT(String, T, CancellationToken) |
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) |
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Protected method | PollStatusTStatus |
Protected method | PostHttpAsync(String, CancellationToken) |
Protected method | PostHttpAsync(String, Object, CancellationToken) |
Protected method | PostHttpAsyncT(String, T, CancellationToken) |
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) |
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) |
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) |
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Protected method | PutHttpAsync(String, CancellationToken) |
Protected method | PutHttpAsync(String, Object, CancellationToken) |
Protected method | PutHttpAsyncT(String, T, CancellationToken) |
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) |
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) |
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) |
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.AuthorizeAsync Method

ApiClientAuthorizeAsync Method
Overload List
Name | Description
AuthorizeAsync(String, String, String, String, String, CancellationToken) |
AuthorizeAsync(String, NullableInt32, String, String, String, String, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.AuthorizeAsync Method (String, String, String, String, String, CancellationToken)

ApiClientAuthorizeAsync Method (String, String, String, String, String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<bool> AuthorizeAsync(
    string networkId,
    string userName,
    string password,
    string clientId = null,
    string clientSecret = null,
    CancellationToken cancellationToken = null
)
Public Shared Function AuthorizeAsync (
    networkId As String,
    userName As String,
    password As String,
    Optional clientId As String = Nothing,
    Optional clientSecret As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Boolean)
public:
static Task<bool>^ AuthorizeAsync(
    String^ networkId,
    String^ userName,
    String^ password,
    String^ clientId = nullptr,
    String^ clientSecret = nullptr,
    CancellationToken cancellationToken = nullptr
)
static member AuthorizeAsync :
        networkId : string *
        userName : string *
        password : string *
        ?clientId : string *
        ?clientSecret : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _clientId = defaultArg clientId null
        let _clientSecret = defaultArg clientSecret null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<bool>

Parameters

networkId
Type: SystemString
userName
Type: SystemString
password
Type: SystemString
clientId (Optional)
Type: SystemString
clientSecret (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task Boolean
See Also

Reference

ApiClient Class
AuthorizeAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.AuthorizeAsync Method (String, Nullable(Int32), String, String, String, String, CancellationToken)

ApiClientAuthorizeAsync Method (String, NullableInt32, String, String, String, String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<bool> AuthorizeAsync(
    string networkId,
    Nullable<int> port,
    string userName,
    string password,
    string clientId = null,
    string clientSecret = null,
    CancellationToken cancellationToken = null
)
Public Shared Function AuthorizeAsync (
    networkId As String,
    port As Nullable(Of Integer),
    userName As String,
    password As String,
    Optional clientId As String = Nothing,
    Optional clientSecret As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of Boolean)
public:
static Task<bool>^ AuthorizeAsync(
    String^ networkId,
    Nullable<int> port,
    String^ userName,
    String^ password,
    String^ clientId = nullptr,
    String^ clientSecret = nullptr,
    CancellationToken cancellationToken = nullptr
)
static member AuthorizeAsync :
        networkId : string *
        port : Nullable<int> *
        userName : string *
        password : string *
        ?clientId : string *
        ?clientSecret : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _clientId = defaultArg clientId null
        let _clientSecret = defaultArg clientSecret null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<bool>

Parameters

networkId
Type: SystemString
port
Type: SystemNullable Int32
userName
Type: SystemString
password
Type: SystemString
clientId (Optional)
Type: SystemString
clientSecret (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task Boolean
See Also

Reference

ApiClient Class
AuthorizeAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.CheckAuthorizationAsync Method

ApiClientCheckAuthorizationAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public static Task<bool> CheckAuthorizationAsync(
    string networkId,
    Nullable<int> port = null
)
Public Shared Function CheckAuthorizationAsync (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
) As Task(Of Boolean)
public:
static Task<bool>^ CheckAuthorizationAsync(
    String^ networkId,
    Nullable<int> port = nullptr
)
static member CheckAuthorizationAsync :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> Task<bool>

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32

Return Value

Type: Task Boolean
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.DeleteHttpAsync Method

ApiClientDeleteHttpAsync Method
Overload List
 | Name | Description
Protected method | DeleteHttpAsync(String, CancellationToken) |
Protected method | DeleteHttpAsync(String, Object, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.DeleteHttpAsync Method (String, CancellationToken)

ApiClientDeleteHttpAsync Method (String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> DeleteHttpAsync(
    string requestUri,
    CancellationToken cancellationToken
)
Protected Function DeleteHttpAsync (
    requestUri As String,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
Task<ApiResponse^>^ DeleteHttpAsync(
    String^ requestUri,
    CancellationToken cancellationToken
)
member DeleteHttpAsync :
        requestUri : string *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
DeleteHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.DeleteHttpAsync Method (String, Object, CancellationToken)

ApiClientDeleteHttpAsync Method (String, Object, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> DeleteHttpAsync(
    string requestUri,
    Object queryParameters,
    CancellationToken cancellationToken
)
Protected Function DeleteHttpAsync (
    requestUri As String,
    queryParameters As Object,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
Task<ApiResponse^>^ DeleteHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    CancellationToken cancellationToken
)
member DeleteHttpAsync :
        requestUri : string *
        queryParameters : Object *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
DeleteHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.GetHttpAsync Method

ApiClientGetHttpAsync Method
Overload List
 | Name | Description
Protected method | GetHttpAsyncT(String, CancellationToken) |
Protected method | GetHttpAsyncT(String, Object, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.GetHttpAsync(T) Method (String, CancellationToken)

ApiClientGetHttpAsyncT Method (String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<T>> GetHttpAsync<T>(
    string requestUri,
    CancellationToken cancellationToken
)

Protected Function GetHttpAsync(Of T) (
    requestUri As String,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of T))
protected:
generic<typename T>
Task<ApiResponse<T>^>^ GetHttpAsync(
    String^ requestUri,
    CancellationToken cancellationToken
)
member GetHttpAsync :
        requestUri : string *
        cancellationToken : CancellationToken -> Task<ApiResponse<'T>>

Parameters

requestUri
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse T
See Also

Reference

ApiClient Class
GetHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.GetHttpAsync(T) Method (String, Object, CancellationToken)

ApiClientGetHttpAsyncT Method (String, Object, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<T>> GetHttpAsync<T>(
    string requestUri,
    Object queryParameters,
    CancellationToken cancellationToken
)

Protected Function GetHttpAsync(Of T) (
    requestUri As String,
    queryParameters As Object,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of T))
protected:
generic<typename T>
Task<ApiResponse<T>^>^ GetHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    CancellationToken cancellationToken
)
member GetHttpAsync :
        requestUri : string *
        queryParameters : Object *
        cancellationToken : CancellationToken -> Task<ApiResponse<'T>>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse T
See Also

Reference

ApiClient Class
GetHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PatchHttpAsync Method

ApiClientPatchHttpAsync Method
Overload List
 | Name | Description
Protected method | PatchHttpAsyncT(String, T, CancellationToken) |
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PatchHttpAsync(T) Method (String, T, CancellationToken)

ApiClientPatchHttpAsyncT Method (String, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PatchHttpAsync<T>(
    string requestUri,
    T content,
    CancellationToken cancellationToken
)

Protected Function PatchHttpAsync(Of T) (
    requestUri As String,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
generic<typename T>
Task<ApiResponse^>^ PatchHttpAsync(
    String^ requestUri,
    T content,
    CancellationToken cancellationToken
)
member PatchHttpAsync :
        requestUri : string *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PatchHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PatchHttpAsync(T) Method (String, Object, T, CancellationToken)

ApiClientPatchHttpAsyncT Method (String, Object, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PatchHttpAsync<T>(
    string requestUri,
    Object queryParameters,
    T content,
    CancellationToken cancellationToken
)

Protected Function PatchHttpAsync(Of T) (
    requestUri As String,
    queryParameters As Object,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
generic<typename T>
Task<ApiResponse^>^ PatchHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    T content,
    CancellationToken cancellationToken
)
member PatchHttpAsync :
        requestUri : string *
        queryParameters : Object *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PatchHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PatchHttpResponseAsync Method

ApiClientPatchHttpResponseAsync Method
Overload List
 | Name | Description
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PatchHttpResponseAsync(T, TResult) Method (String, T, CancellationToken)

ApiClientPatchHttpResponseAsyncT, TResult Method (String, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PatchHttpResponseAsync<T, TResult>(
    string requestUri,
    T content,
    CancellationToken cancellationToken
)

Protected Function PatchHttpResponseAsync(Of T, TResult) (
    requestUri As String,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename T, typename TResult>
Task<ApiResponse<TResult>^>^ PatchHttpResponseAsync(
    String^ requestUri,
    T content,
    CancellationToken cancellationToken
)
member PatchHttpResponseAsync :
        requestUri : string *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T
TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PatchHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PatchHttpResponseAsync(T, TResult) Method (String, Object, T, CancellationToken)

ApiClientPatchHttpResponseAsyncT, TResult Method (String, Object, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PatchHttpResponseAsync<T, TResult>(
    string requestUri,
    Object queryParameters,
    T content,
    CancellationToken cancellationToken
)

Protected Function PatchHttpResponseAsync(Of T, TResult) (
    requestUri As String,
    queryParameters As Object,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename T, typename TResult>
Task<ApiResponse<TResult>^>^ PatchHttpResponseAsync(
    String^ requestUri,
    Object^ queryParameters,
    T content,
    CancellationToken cancellationToken
)
member PatchHttpResponseAsync :
        requestUri : string *
        queryParameters : Object *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T
TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PatchHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PollStatus(TStatus) Method

ApiClientPollStatusTStatus Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TStatus>> PollStatus<TStatus>(
    ApiResponse<TStatus> response,
    IProgress progress,
    void cancellationToken
)
where TStatus : ActivityStatusModel

Protected Function PollStatus(Of TStatus As ActivityStatusModel) (
    response As ApiResponse(Of TStatus),
    progress As IProgress,
    cancellationToken As Void
) As Task(Of ApiResponse(Of TStatus))
protected:
generic<typename TStatus>
where TStatus : ActivityStatusModel
Task<ApiResponse<TStatus>^>^ PollStatus(
    ApiResponse<TStatus>^ response,
    IProgress^ progress,
    void cancellationToken
)
member PollStatus :
        response : ApiResponse<'TStatus> *
        progress : IProgress *
        cancellationToken : unit -> Task<ApiResponse<'TStatus>>  when 'TStatus : ActivityStatusModel

Parameters

response
Type: DoubleTake.Web.ClientApiResponse TStatus
progress
Type: SystemIProgressT
cancellationToken
Type: SystemVoid

Type Parameters

TStatus

Return Value

Type: Task ApiResponse TStatus
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PostHttpAsync Method

ApiClientPostHttpAsync Method
Overload List
 | Name | Description
Protected method | PostHttpAsync(String, CancellationToken) |
Protected method | PostHttpAsync(String, Object, CancellationToken) |
Protected method | PostHttpAsyncT(String, T, CancellationToken) |
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PostHttpAsync Method (String, CancellationToken)

ApiClientPostHttpAsync Method (String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PostHttpAsync(
    string requestUri,
    CancellationToken cancellationToken
)
Protected Function PostHttpAsync (
    requestUri As String,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
Task<ApiResponse^>^ PostHttpAsync(
    String^ requestUri,
    CancellationToken cancellationToken
)
member PostHttpAsync :
        requestUri : string *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PostHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpAsync Method (String, Object, CancellationToken)

ApiClientPostHttpAsync Method (String, Object, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PostHttpAsync(
    string requestUri,
    Object queryParameters,
    CancellationToken cancellationToken
)
Protected Function PostHttpAsync (
    requestUri As String,
    queryParameters As Object,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
Task<ApiResponse^>^ PostHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    CancellationToken cancellationToken
)
member PostHttpAsync :
        requestUri : string *
        queryParameters : Object *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PostHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpAsync(T) Method (String, T, CancellationToken)

ApiClientPostHttpAsyncT Method (String, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PostHttpAsync<T>(
    string requestUri,
    T content,
    CancellationToken cancellationToken
)

Protected Function PostHttpAsync(Of T) (
    requestUri As String,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
generic<typename T>
Task<ApiResponse^>^ PostHttpAsync(
    String^ requestUri,
    T content,
    CancellationToken cancellationToken
)
member PostHttpAsync :
        requestUri : string *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PostHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpAsync(T) Method (String, Object, T, CancellationToken)

ApiClientPostHttpAsyncT Method (String, Object, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PostHttpAsync<T>(
    string requestUri,
    Object queryParameters,
    T content,
    CancellationToken cancellationToken
)

Protected Function PostHttpAsync(Of T) (
    requestUri As String,
    queryParameters As Object,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
generic<typename T>
Task<ApiResponse^>^ PostHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    T content,
    CancellationToken cancellationToken
)
member PostHttpAsync :
        requestUri : string *
        queryParameters : Object *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PostHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpResponseAsync Method

ApiClientPostHttpResponseAsync Method
Overload List
 | Name | Description
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) |
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) |
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PostHttpResponseAsync(TResult) Method (String, CancellationToken)

ApiClientPostHttpResponseAsyncTResult Method (String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PostHttpResponseAsync<TResult>(
    string requestUri,
    CancellationToken cancellationToken
)

Protected Function PostHttpResponseAsync(Of TResult) (
    requestUri As String,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename TResult>
Task<ApiResponse<TResult>^>^ PostHttpResponseAsync(
    String^ requestUri,
    CancellationToken cancellationToken
)
member PostHttpResponseAsync :
        requestUri : string *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PostHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpResponseAsync(TResult) Method (String, Object, CancellationToken)

ApiClientPostHttpResponseAsyncTResult Method (String, Object, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PostHttpResponseAsync<TResult>(
    string requestUri,
    Object queryParameters,
    CancellationToken cancellationToken
)

Protected Function PostHttpResponseAsync(Of TResult) (
    requestUri As String,
    queryParameters As Object,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename TResult>
Task<ApiResponse<TResult>^>^ PostHttpResponseAsync(
    String^ requestUri,
    Object^ queryParameters,
    CancellationToken cancellationToken
)
member PostHttpResponseAsync :
        requestUri : string *
        queryParameters : Object *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PostHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpResponseAsync(T, TResult) Method (String, T, CancellationToken)

ApiClientPostHttpResponseAsyncT, TResult Method (String, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PostHttpResponseAsync<T, TResult>(
    string requestUri,
    T content,
    CancellationToken cancellationToken
)

Protected Function PostHttpResponseAsync(Of T, TResult) (
    requestUri As String,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename T, typename TResult>
Task<ApiResponse<TResult>^>^ PostHttpResponseAsync(
    String^ requestUri,
    T content,
    CancellationToken cancellationToken
)
member PostHttpResponseAsync :
        requestUri : string *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T
TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PostHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PostHttpResponseAsync(T, TResult) Method (String, Object, T, CancellationToken)

ApiClientPostHttpResponseAsyncT, TResult Method (String, Object, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PostHttpResponseAsync<T, TResult>(
    string requestUri,
    Object queryParameters,
    T content,
    CancellationToken cancellationToken
)

Protected Function PostHttpResponseAsync(Of T, TResult) (
    requestUri As String,
    queryParameters As Object,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename T, typename TResult>
Task<ApiResponse<TResult>^>^ PostHttpResponseAsync(
    String^ requestUri,
    Object^ queryParameters,
    T content,
    CancellationToken cancellationToken
)
member PostHttpResponseAsync :
        requestUri : string *
        queryParameters : Object *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T
TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PostHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpAsync Method

ApiClientPutHttpAsync Method
Overload List
 | Name | Description
Protected method | PutHttpAsync(String, CancellationToken) |
Protected method | PutHttpAsync(String, Object, CancellationToken) |
Protected method | PutHttpAsyncT(String, T, CancellationToken) |
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PutHttpAsync Method (String, CancellationToken)

ApiClientPutHttpAsync Method (String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PutHttpAsync(
    string requestUri,
    CancellationToken cancellationToken
)
Protected Function PutHttpAsync (
    requestUri As String,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
Task<ApiResponse^>^ PutHttpAsync(
    String^ requestUri,
    CancellationToken cancellationToken
)
member PutHttpAsync :
        requestUri : string *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PutHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpAsync Method (String, Object, CancellationToken)

ApiClientPutHttpAsync Method (String, Object, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PutHttpAsync(
    string requestUri,
    Object queryParameters,
    CancellationToken cancellationToken
)
Protected Function PutHttpAsync (
    requestUri As String,
    queryParameters As Object,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
Task<ApiResponse^>^ PutHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    CancellationToken cancellationToken
)
member PutHttpAsync :
        requestUri : string *
        queryParameters : Object *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
cancellationToken
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PutHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpAsync(T) Method (String, T, CancellationToken)

ApiClientPutHttpAsyncT Method (String, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PutHttpAsync<T>(
    string requestUri,
    T content,
    CancellationToken cancellationToken
)

Protected Function PutHttpAsync(Of T) (
    requestUri As String,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
generic<typename T>
Task<ApiResponse^>^ PutHttpAsync(
    String^ requestUri,
    T content,
    CancellationToken cancellationToken
)
member PutHttpAsync :
        requestUri : string *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PutHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpAsync(T) Method (String, Object, T, CancellationToken)

ApiClientPutHttpAsyncT Method (String, Object, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse> PutHttpAsync<T>(
    string requestUri,
    Object queryParameters,
    T content,
    CancellationToken cancellationToken
)

Protected Function PutHttpAsync(Of T) (
    requestUri As String,
    queryParameters As Object,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse)
protected:
generic<typename T>
Task<ApiResponse^>^ PutHttpAsync(
    String^ requestUri,
    Object^ queryParameters,
    T content,
    CancellationToken cancellationToken
)
member PutHttpAsync :
        requestUri : string *
        queryParameters : Object *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T

Return Value

Type: Task ApiResponse
See Also

Reference

ApiClient Class
PutHttpAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpResponseAsync Method

ApiClientPutHttpResponseAsync Method
Overload List
 | Name | Description
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) |
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) |
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) |
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) |
Top
See Also

Reference

ApiClient Class
DoubleTake.Web.Client Namespace


ApiClient.PutHttpResponseAsync(TResult) Method (String, CancellationToken)

ApiClientPutHttpResponseAsyncTResult Method (String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PutHttpResponseAsync<TResult>(
    string requestUri,
    CancellationToken cancellationToken
)

Protected Function PutHttpResponseAsync(Of TResult) (
    requestUri As String,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename TResult>
Task<ApiResponse<TResult>^>^ PutHttpResponseAsync(
    String^ requestUri,
    CancellationToken cancellationToken
)
member PutHttpResponseAsync :
        requestUri : string *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PutHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpResponseAsync(TResult) Method (String, Object, CancellationToken)

ApiClientPutHttpResponseAsyncTResult Method (String, Object, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PutHttpResponseAsync<TResult>(
    string requestUri,
    Object queryParameters,
    CancellationToken cancellationToken
)

Protected Function PutHttpResponseAsync(Of TResult) (
    requestUri As String,
    queryParameters As Object,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename TResult>
Task<ApiResponse<TResult>^>^ PutHttpResponseAsync(
    String^ requestUri,
    Object^ queryParameters,
    CancellationToken cancellationToken
)
member PutHttpResponseAsync :
        requestUri : string *
        queryParameters : Object *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PutHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpResponseAsync(T, TResult) Method (String, T, CancellationToken)

ApiClientPutHttpResponseAsyncT, TResult Method (String, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PutHttpResponseAsync<T, TResult>(
    string requestUri,
    T content,
    CancellationToken cancellationToken
)

Protected Function PutHttpResponseAsync(Of T, TResult) (
    requestUri As String,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename T, typename TResult>
Task<ApiResponse<TResult>^>^ PutHttpResponseAsync(
    String^ requestUri,
    T content,
    CancellationToken cancellationToken
)
member PutHttpResponseAsync :
        requestUri : string *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T
TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PutHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiClient.PutHttpResponseAsync(T, TResult) Method (String, Object, T, CancellationToken)

ApiClientPutHttpResponseAsyncT, TResult Method (String, Object, T, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected Task<ApiResponse<TResult>> PutHttpResponseAsync<T, TResult>(
    string requestUri,
    Object queryParameters,
    T content,
    CancellationToken cancellationToken
)

Protected Function PutHttpResponseAsync(Of T, TResult) (
    requestUri As String,
    queryParameters As Object,
    content As T,
    cancellationToken As CancellationToken
) As Task(Of ApiResponse(Of TResult))
protected:
generic<typename T, typename TResult>
Task<ApiResponse<TResult>^>^ PutHttpResponseAsync(
    String^ requestUri,
    Object^ queryParameters,
    T content,
    CancellationToken cancellationToken
)
member PutHttpResponseAsync :
        requestUri : string *
        queryParameters : Object *
        content : 'T *
        cancellationToken : CancellationToken -> Task<ApiResponse<'TResult>>

Parameters

requestUri
Type: SystemString
queryParameters
Type: SystemObject
content
Type: T
cancellationToken
Type: System.ThreadingCancellationToken

Type Parameters

T
TResult

Return Value

Type: Task ApiResponse TResult
See Also

Reference

ApiClient Class
PutHttpResponseAsync Overload
DoubleTake.Web.Client Namespace


ApiResponse Class

ApiResponse Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiResponse
DoubleTake.Web.ClientApiResponseT

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ApiResponse
Public Class ApiResponse
public ref class ApiResponse
type ApiResponse =  class end

The ApiResponse type exposes the following members.

Properties
 | Name | Description
Public property | Headers |
Public property | IsSuccessStatusCode |
Public property | RawContent |
Public property | StatusCode |
Top
Methods
 | Name | Description
Public method | EnsureSuccessStatusCode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ApiResponse Properties

ApiResponse Properties

The ApiResponse type exposes the following members.

Properties
 | Name | Description
Public property | Headers |
Public property | IsSuccessStatusCode |
Public property | RawContent |
Public property | StatusCode |
Top
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse.Headers Property

ApiResponseHeaders Property

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HttpResponseHeaders Headers { get; }
Public ReadOnly Property Headers As HttpResponseHeaders
    Get
public:
property HttpResponseHeaders^ Headers {
    HttpResponseHeaders^ get ();
}
member Headers : HttpResponseHeaders with get

Property Value

Type: HttpResponseHeaders
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse.IsSuccessStatusCode Property

ApiResponseIsSuccessStatusCode Property

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSuccessStatusCode { get; }
Public ReadOnly Property IsSuccessStatusCode As Boolean
    Get
public:
property bool IsSuccessStatusCode {
    bool get ();
}
member IsSuccessStatusCode : bool with get

Property Value

Type: Boolean
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse.RawContent Property

ApiResponseRawContent Property

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HttpContent RawContent { get; }
Public ReadOnly Property RawContent As HttpContent
    Get
public:
property HttpContent^ RawContent {
    HttpContent^ get ();
}
member RawContent : HttpContent with get

Property Value

Type: HttpContent
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse.StatusCode Property

ApiResponseStatusCode Property

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HttpStatusCode StatusCode { get; }
Public ReadOnly Property StatusCode As HttpStatusCode
    Get
public:
property HttpStatusCode StatusCode {
    HttpStatusCode get ();
}
member StatusCode : HttpStatusCode with get

Property Value

Type: HttpStatusCode
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse Methods

ApiResponse Methods

The ApiResponse type exposes the following members.

Methods
 | Name | Description
Public method | EnsureSuccessStatusCode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse.EnsureSuccessStatusCode Method

ApiResponseEnsureSuccessStatusCode Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public void EnsureSuccessStatusCode()
Public Sub EnsureSuccessStatusCode
public:
void EnsureSuccessStatusCode()
member EnsureSuccessStatusCode : unit -> unit
See Also

Reference

ApiResponse Class
DoubleTake.Web.Client Namespace


ApiResponse(T) Class

ApiResponseT Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiResponse
DoubleTake.Web.ClientApiResponseT

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ApiResponse<T> : ApiResponse

Public Class ApiResponse(Of T)
    Inherits ApiResponse
generic<typename T>
public ref class ApiResponse : public ApiResponse
type ApiResponse<'T> =
    class
        inherit ApiResponse
    end

Type Parameters

T

The ApiResponseT type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Headers | (Inherited from ApiResponse.)
Public property | IsSuccessStatusCode | (Inherited from ApiResponse.)
Public property | RawContent | (Inherited from ApiResponse.)
Public property | StatusCode | (Inherited from ApiResponse.)
Top
Methods
 | Name | Description
Public method | EnsureSuccessStatusCode | (Inherited from ApiResponse.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ApiResponse(T) Properties

ApiResponseT Properties

The ApiResponseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Content |
Public property | Headers | (Inherited from ApiResponse.)
Public property | IsSuccessStatusCode | (Inherited from ApiResponse.)
Public property | RawContent | (Inherited from ApiResponse.)
Public property | StatusCode | (Inherited from ApiResponse.)
Top
See Also

Reference

ApiResponseT Class
DoubleTake.Web.Client Namespace


ApiResponse(T).Content Property

ApiResponseTContent Property

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public T Content { get; }
Public ReadOnly Property Content As T
    Get
public:
property T Content {
    T get ();
}
member Content : 'T with get

Property Value

Type: T
See Also

Reference

ApiResponseT Class
DoubleTake.Web.Client Namespace


ApiResponse(T) Methods

ApiResponseT Methods

The ApiResponseT generic type exposes the following members.

Methods
 | Name | Description
Public method | EnsureSuccessStatusCode | (Inherited from ApiResponse.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ApiResponseT Class
DoubleTake.Web.Client Namespace


EmailOptionsApi Class

EmailOptionsApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientEmailOptionsApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EmailOptionsApi : ApiClient
Public NotInheritable Class EmailOptionsApi
    Inherits ApiClient
public ref class EmailOptionsApi sealed : public ApiClient
[<SealedAttribute>]
type EmailOptionsApi =
    class
        inherit ApiClient
    end

The EmailOptionsApi type exposes the following members.

Constructors
 | Name | Description
Public method | EmailOptionsApi | Initializes a new instance of the EmailOptionsApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PutAsync |
Public method | TestAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


EmailOptionsApi Constructor

EmailOptionsApi Constructor
Initializes a new instance of the EmailOptionsApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmailOptionsApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
EmailOptionsApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> EmailOptionsApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

EmailOptionsApi Class
DoubleTake.Web.Client Namespace


EmailOptionsApi Methods

EmailOptionsApi Methods

The EmailOptionsApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PutAsync |
Public method | TestAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailOptionsApi Class
DoubleTake.Web.Client Namespace


EmailOptionsApi.GetAsync Method

EmailOptionsApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<EmailOptionsModel>> GetAsync(
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of EmailOptionsModel))
public:
Task<ApiResponse<EmailOptionsModel^>^>^ GetAsync(
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<EmailOptionsModel>>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse EmailOptionsModel
See Also

Reference

EmailOptionsApi Class
DoubleTake.Web.Client Namespace


EmailOptionsApi.GetPartialAsync Method

EmailOptionsApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialAsync(
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialAsync(
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

EmailOptionsApi Class
DoubleTake.Web.Client Namespace


EmailOptionsApi.PutAsync Method

EmailOptionsApiPutAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> PutAsync(
    EmailOptionsModel options,
    CancellationToken cancellationToken = null
)
Public Function PutAsync (
    options As EmailOptionsModel,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ PutAsync(
    EmailOptionsModel^ options,
    CancellationToken cancellationToken = nullptr
)
member PutAsync :
        options : EmailOptionsModel *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

options
Type: DoubleTake.Web.ModelsEmailOptionsModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

EmailOptionsApi Class
DoubleTake.Web.Client Namespace


EmailOptionsApi.TestAsync Method

EmailOptionsApiTestAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> TestAsync(
    EmailTestModel options,
    CancellationToken cancellationToken = null
)
Public Function TestAsync (
    options As EmailTestModel,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ TestAsync(
    EmailTestModel^ options,
    CancellationToken cancellationToken = nullptr
)
member TestAsync :
        options : EmailTestModel *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

options
Type: DoubleTake.Web.ModelsEmailTestModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

EmailOptionsApi Class
DoubleTake.Web.Client Namespace


EventLogEntriesApi Class

EventLogEntriesApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientEventLogEntriesApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EventLogEntriesApi : ApiClient
Public NotInheritable Class EventLogEntriesApi
    Inherits ApiClient
public ref class EventLogEntriesApi sealed : public ApiClient
[<SealedAttribute>]
type EventLogEntriesApi =
    class
        inherit ApiClient
    end

The EventLogEntriesApi type exposes the following members.

Constructors
 | Name | Description
Public method | EventLogEntriesApi | Initializes a new instance of the EventLogEntriesApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetByIdAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetPartialByIdAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


EventLogEntriesApi Constructor

EventLogEntriesApi Constructor
Initializes a new instance of the EventLogEntriesApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventLogEntriesApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
EventLogEntriesApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> EventLogEntriesApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

EventLogEntriesApi Class
DoubleTake.Web.Client Namespace


EventLogEntriesApi Methods

EventLogEntriesApi Methods

The EventLogEntriesApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetByIdAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetPartialByIdAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventLogEntriesApi Class
DoubleTake.Web.Client Namespace


EventLogEntriesApi.GetAsync Method

EventLogEntriesApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<EventLogModel>>> GetAsync(
    string filter = null,
    Nullable<int> lastId = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional filter As String = Nothing,
    Optional lastId As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of EventLogModel)))
public:
Task<ApiResponse<IEnumerable<EventLogModel^>^>^>^ GetAsync(
    String^ filter = nullptr,
    Nullable<int> lastId = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?filter : string *
        ?lastId : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _lastId = defaultArg lastId null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<EventLogModel>>>

Parameters

filter (Optional)
Type: SystemString
lastId (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable EventLogModel
See Also

Reference

EventLogEntriesApi Class
DoubleTake.Web.Client Namespace


EventLogEntriesApi.GetByIdAsync Method

EventLogEntriesApiGetByIdAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<EventLogModel>> GetByIdAsync(
    int id,
    CancellationToken cancellationToken = null
)
Public Function GetByIdAsync (
    id As Integer,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of EventLogModel))
public:
Task<ApiResponse<EventLogModel^>^>^ GetByIdAsync(
    int id,
    CancellationToken cancellationToken = nullptr
)
member GetByIdAsync :
        id : int *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<EventLogModel>>

Parameters

id
Type: SystemInt32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse EventLogModel
See Also

Reference

EventLogEntriesApi Class
DoubleTake.Web.Client Namespace


EventLogEntriesApi.GetPartialAsync Method

EventLogEntriesApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetPartialAsync(
    string fields,
    string filter = null,
    Nullable<int> lastId = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional filter As String = Nothing,
    Optional lastId As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetPartialAsync(
    String^ fields,
    String^ filter = nullptr,
    Nullable<int> lastId = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?filter : string *
        ?lastId : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _lastId = defaultArg lastId null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

fields
Type: SystemString
filter (Optional)
Type: SystemString
lastId (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

EventLogEntriesApi Class
DoubleTake.Web.Client Namespace


EventLogEntriesApi.GetPartialByIdAsync Method

EventLogEntriesApiGetPartialByIdAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialByIdAsync(
    int id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialByIdAsync (
    id As Integer,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialByIdAsync(
    int id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialByIdAsync :
        id : int *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemInt32
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

EventLogEntriesApi Class
DoubleTake.Web.Client Namespace


FilesApi Class

FilesApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientFilesApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FilesApi : ApiClient
Public NotInheritable Class FilesApi
    Inherits ApiClient
public ref class FilesApi sealed : public ApiClient
[<SealedAttribute>]
type FilesApi =
    class
        inherit ApiClient
    end

The FilesApi type exposes the following members.

Constructors
 | Name | Description
Public method | FilesApi | Initializes a new instance of the FilesApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetByIdAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetPartialByIdAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


FilesApi Constructor

FilesApi Constructor
Initializes a new instance of the FilesApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FilesApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
FilesApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> FilesApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

FilesApi Class
DoubleTake.Web.Client Namespace


FilesApi Methods

FilesApi Methods

The FilesApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetByIdAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetPartialByIdAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilesApi Class
DoubleTake.Web.Client Namespace


FilesApi.GetAsync Method

FilesApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<FileItemModel>>> GetAsync(
    string parentId = null,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional parentId As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of FileItemModel)))
public:
Task<ApiResponse<IEnumerable<FileItemModel^>^>^>^ GetAsync(
    String^ parentId = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?parentId : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _parentId = defaultArg parentId null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<FileItemModel>>>

Parameters

parentId (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable FileItemModel
See Also

Reference

FilesApi Class
DoubleTake.Web.Client Namespace


FilesApi.GetByIdAsync Method

FilesApiGetByIdAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<FileItemModel>> GetByIdAsync(
    string id,
    CancellationToken cancellationToken = null
)
Public Function GetByIdAsync (
    id As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of FileItemModel))
public:
Task<ApiResponse<FileItemModel^>^>^ GetByIdAsync(
    String^ id,
    CancellationToken cancellationToken = nullptr
)
member GetByIdAsync :
        id : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<FileItemModel>>

Parameters

id
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse FileItemModel
See Also

Reference

FilesApi Class
DoubleTake.Web.Client Namespace


FilesApi.GetPartialAsync Method

FilesApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetPartialAsync(
    string fields,
    string parentId = null,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional parentId As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetPartialAsync(
    String^ fields,
    String^ parentId = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?parentId : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _parentId = defaultArg parentId null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

fields
Type: SystemString
parentId (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

FilesApi Class
DoubleTake.Web.Client Namespace


FilesApi.GetPartialByIdAsync Method

FilesApiGetPartialByIdAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialByIdAsync(
    string id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialByIdAsync (
    id As String,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialByIdAsync(
    String^ id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialByIdAsync :
        id : string *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemString
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

FilesApi Class
DoubleTake.Web.Client Namespace


ImagesApi Class

ImagesApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientImagesApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImagesApi : ApiClient
Public NotInheritable Class ImagesApi
    Inherits ApiClient
public ref class ImagesApi sealed : public ApiClient
[<SealedAttribute>]
type ImagesApi =
    class
        inherit ApiClient
    end

The ImagesApi type exposes the following members.

Constructors
 | Name | Description
Public method | ImagesApi | Initializes a new instance of the ImagesApi class
Top
Methods
 | Name | Description
Public method | DeleteImageAsync |
Public method | DeleteImageSnapshotAsync |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageAsync |
Public method | GetImagePartialAsync |
Public method | GetImagesAsync |
Public method | GetImageSnapshotAsync |
Public method | GetImageSnapshotPartialAsync |
Public method | GetImageSnapshotsAsync |
Public method | GetImageSnapshotsPartialAsync |
Public method | GetImagesPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadImageAsync |
Public method | LoadImageSnapshotAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnloadImageAsync |
Public method | UnloadImageSnapshotAsync |
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ImagesApi Constructor

ImagesApi Constructor
Initializes a new instance of the ImagesApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImagesApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
ImagesApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> ImagesApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi Methods

ImagesApi Methods

The ImagesApi type exposes the following members.

Methods
 | Name | Description
Public method | DeleteImageAsync |
Public method | DeleteImageSnapshotAsync |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetImageAsync |
Public method | GetImagePartialAsync |
Public method | GetImagesAsync |
Public method | GetImageSnapshotAsync |
Public method | GetImageSnapshotPartialAsync |
Public method | GetImageSnapshotsAsync |
Public method | GetImageSnapshotsPartialAsync |
Public method | GetImagesPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadImageAsync |
Public method | LoadImageSnapshotAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnloadImageAsync |
Public method | UnloadImageSnapshotAsync |
Top
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.DeleteImageAsync Method

ImagesApiDeleteImageAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> DeleteImageAsync(
    Guid id,
    Nullable<bool> keepVhds = null,
    CancellationToken cancellationToken = null
)
Public Function DeleteImageAsync (
    id As Guid,
    Optional keepVhds As Nullable(Of Boolean) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ DeleteImageAsync(
    Guid id,
    Nullable<bool> keepVhds = nullptr,
    CancellationToken cancellationToken = nullptr
)
member DeleteImageAsync :
        id : Guid *
        ?keepVhds : Nullable<bool> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _keepVhds = defaultArg keepVhds null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
keepVhds (Optional)
Type: SystemNullable Boolean
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.DeleteImageSnapshotAsync Method

ImagesApiDeleteImageSnapshotAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> DeleteImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    CancellationToken cancellationToken = null
)
Public Function DeleteImageSnapshotAsync (
    id As Guid,
    snapshotId As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ DeleteImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    CancellationToken cancellationToken = nullptr
)
member DeleteImageSnapshotAsync :
        id : Guid *
        snapshotId : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
snapshotId
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImageAsync Method

ImagesApiGetImageAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ImageInfoModel>> GetImageAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function GetImageAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ImageInfoModel))
public:
Task<ApiResponse<ImageInfoModel^>^>^ GetImageAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member GetImageAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ImageInfoModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ImageInfoModel
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImagePartialAsync Method

ImagesApiGetImagePartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetImagePartialAsync(
    Guid id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetImagePartialAsync (
    id As Guid,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetImagePartialAsync(
    Guid id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetImagePartialAsync :
        id : Guid *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImagesAsync Method

ImagesApiGetImagesAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<ImageInfoModel>>> GetImagesAsync(
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetImagesAsync (
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of ImageInfoModel)))
public:
Task<ApiResponse<IEnumerable<ImageInfoModel^>^>^>^ GetImagesAsync(
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetImagesAsync :
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<ImageInfoModel>>>

Parameters

filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable ImageInfoModel
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImageSnapshotAsync Method

ImagesApiGetImageSnapshotAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<SnapshotEntryModel>> GetImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    CancellationToken cancellationToken = null
)
Public Function GetImageSnapshotAsync (
    id As Guid,
    snapshotId As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of SnapshotEntryModel))
public:
Task<ApiResponse<SnapshotEntryModel^>^>^ GetImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    CancellationToken cancellationToken = nullptr
)
member GetImageSnapshotAsync :
        id : Guid *
        snapshotId : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<SnapshotEntryModel>>

Parameters

id
Type: SystemGuid
snapshotId
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse SnapshotEntryModel
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImageSnapshotPartialAsync Method

ImagesApiGetImageSnapshotPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetImageSnapshotPartialAsync(
    Guid id,
    Guid snapshotId,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetImageSnapshotPartialAsync (
    id As Guid,
    snapshotId As Guid,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetImageSnapshotPartialAsync(
    Guid id,
    Guid snapshotId,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetImageSnapshotPartialAsync :
        id : Guid *
        snapshotId : Guid *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
snapshotId
Type: SystemGuid
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImageSnapshotsAsync Method

ImagesApiGetImageSnapshotsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<SnapshotEntryModel>>> GetImageSnapshotsAsync(
    Guid id,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetImageSnapshotsAsync (
    id As Guid,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of SnapshotEntryModel)))
public:
Task<ApiResponse<IEnumerable<SnapshotEntryModel^>^>^>^ GetImageSnapshotsAsync(
    Guid id,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetImageSnapshotsAsync :
        id : Guid *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<SnapshotEntryModel>>>

Parameters

id
Type: SystemGuid
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable SnapshotEntryModel
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImageSnapshotsPartialAsync Method

ImagesApiGetImageSnapshotsPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetImageSnapshotsPartialAsync(
    Guid id,
    string fields,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetImageSnapshotsPartialAsync (
    id As Guid,
    fields As String,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetImageSnapshotsPartialAsync(
    Guid id,
    String^ fields,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetImageSnapshotsPartialAsync :
        id : Guid *
        fields : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.GetImagesPartialAsync Method

ImagesApiGetImagesPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetImagesPartialAsync(
    string fields,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetImagesPartialAsync (
    fields As String,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetImagesPartialAsync(
    String^ fields,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetImagesPartialAsync :
        fields : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

fields
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.LoadImageAsync Method

ImagesApiLoadImageAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> LoadImageAsync(
    Guid id,
    string ownerId,
    CancellationToken cancellationToken = null
)
Public Function LoadImageAsync (
    id As Guid,
    ownerId As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ LoadImageAsync(
    Guid id,
    String^ ownerId,
    CancellationToken cancellationToken = nullptr
)
member LoadImageAsync :
        id : Guid *
        ownerId : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
ownerId
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.LoadImageSnapshotAsync Method

ImagesApiLoadImageSnapshotAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> LoadImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    string ownerId,
    CancellationToken cancellationToken = null
)
Public Function LoadImageSnapshotAsync (
    id As Guid,
    snapshotId As Guid,
    ownerId As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ LoadImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    String^ ownerId,
    CancellationToken cancellationToken = nullptr
)
member LoadImageSnapshotAsync :
        id : Guid *
        snapshotId : Guid *
        ownerId : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
snapshotId
Type: SystemGuid
ownerId
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.UnloadImageAsync Method

ImagesApiUnloadImageAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> UnloadImageAsync(
    Guid id,
    string ownerId,
    CancellationToken cancellationToken = null
)
Public Function UnloadImageAsync (
    id As Guid,
    ownerId As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ UnloadImageAsync(
    Guid id,
    String^ ownerId,
    CancellationToken cancellationToken = nullptr
)
member UnloadImageAsync :
        id : Guid *
        ownerId : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
ownerId
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


ImagesApi.UnloadImageSnapshotAsync Method

ImagesApiUnloadImageSnapshotAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> UnloadImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    string ownerId,
    CancellationToken cancellationToken = null
)
Public Function UnloadImageSnapshotAsync (
    id As Guid,
    snapshotId As Guid,
    ownerId As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ UnloadImageSnapshotAsync(
    Guid id,
    Guid snapshotId,
    String^ ownerId,
    CancellationToken cancellationToken = nullptr
)
member UnloadImageSnapshotAsync :
        id : Guid *
        snapshotId : Guid *
        ownerId : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
snapshotId
Type: SystemGuid
ownerId
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

ImagesApi Class
DoubleTake.Web.Client Namespace


JobsApi Class

JobsApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientJobsApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobsApi : ApiClient
Public NotInheritable Class JobsApi
    Inherits ApiClient
public ref class JobsApi sealed : public ApiClient
[<SealedAttribute>]
type JobsApi =
    class
        inherit ApiClient
    end

The JobsApi type exposes the following members.

Constructors
 | Name | Description
Public method | JobsApi | Initializes a new instance of the JobsApi class
Top
Methods
 | Name | Description
Public method | CreateJobAsync |
Public method | CreateSnapshotAsync |
Public method | DeleteJobAsync |
Public method | DeleteSnapshotAsync |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FailbackJobAsync |
Public method | FailoverJobAsync |
Public method | FixJobOptionsAsync(Guid, JobOptionsModel, IEnumerableVerificationStepModel, IProgressT, Void) |
Public method | FixJobOptionsAsync(String, JobCredentialsModel, JobOptionsModel, IEnumerableVerificationStepModel, IProgressT, Void) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJobAsync |
Public method | GetJobPartialAsync |
Public method | GetJobsAsync |
Public method | GetJobsPartialAsync |
Public method | GetLogMessagesAsync |
Public method | GetQualificationResultsAsync |
Public method | GetSnapshotPartialAsync(Guid, Guid, Guid, CancellationToken) |
Public method | GetSnapshotPartialAsync(Guid, Guid, Guid, String, CancellationToken) |
Public method | GetSnapshotsAsync |
Public method | GetSnapshotsPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PauseJobAsync |
Public method | PersistSharesAsync |
Public method | QualifyAsync |
Public method | RecommendFailbackOptionsAsync |
Public method | RecommendFailoverOptionsAsync |
Public method | RecommendJobOptionsAsync |
Public method | RecommendRestoreOptionsAsync |
Public method | RestoreJobAsync |
Public method | ReverseJobAsync |
Public method | StartJobAsync |
Public method | StopJobAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UndoFailover |
Public method | UpdateCredentialsAsync |
Public method | UpdateJobAsync |
Public method | UpdateRecommendedJobOptionsAsync |
Public method | VerifyJobOptionsAsync(Guid, JobOptionsModel, IProgressT, Void) |
Public method | VerifyJobOptionsAsync(String, JobCredentialsModel, JobOptionsModel, IProgressT, Void) |
Top
See Also

Reference

DoubleTake.Web.Client Namespace


JobsApi Constructor

JobsApi Constructor
Initializes a new instance of the JobsApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobsApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
JobsApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> JobsApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi Methods

JobsApi Methods

The JobsApi type exposes the following members.

Methods
 | Name | Description
Public method | CreateJobAsync |
Public method | CreateSnapshotAsync |
Public method | DeleteJobAsync |
Public method | DeleteSnapshotAsync |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FailbackJobAsync |
Public method | FailoverJobAsync |
Public method | FixJobOptionsAsync(Guid, JobOptionsModel, IEnumerableVerificationStepModel, IProgressT, Void) |
Public method | FixJobOptionsAsync(String, JobCredentialsModel, JobOptionsModel, IEnumerableVerificationStepModel, IProgressT, Void) |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetJobAsync |
Public method | GetJobPartialAsync |
Public method | GetJobsAsync |
Public method | GetJobsPartialAsync |
Public method | GetLogMessagesAsync |
Public method | GetQualificationResultsAsync |
Public method | GetSnapshotPartialAsync(Guid, Guid, Guid, CancellationToken) |
Public method | GetSnapshotPartialAsync(Guid, Guid, Guid, String, CancellationToken) |
Public method | GetSnapshotsAsync |
Public method | GetSnapshotsPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PauseJobAsync |
Public method | PersistSharesAsync |
Public method | QualifyAsync |
Public method | RecommendFailbackOptionsAsync |
Public method | RecommendFailoverOptionsAsync |
Public method | RecommendJobOptionsAsync |
Public method | RecommendRestoreOptionsAsync |
Public method | RestoreJobAsync |
Public method | ReverseJobAsync |
Public method | StartJobAsync |
Public method | StopJobAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UndoFailover |
Public method | UpdateCredentialsAsync |
Public method | UpdateJobAsync |
Public method | UpdateRecommendedJobOptionsAsync |
Public method | VerifyJobOptionsAsync(Guid, JobOptionsModel, IProgressT, Void) |
Public method | VerifyJobOptionsAsync(String, JobCredentialsModel, JobOptionsModel, IProgressT, Void) |
Top
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.CreateJobAsync Method

JobsApiCreateJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<Guid>> CreateJobAsync(
    CreateOptionsModel createOptions,
    Nullable<Guid> requestedId = null,
    CancellationToken cancellationToken = null
)
Public Function CreateJobAsync (
    createOptions As CreateOptionsModel,
    Optional requestedId As Nullable(Of Guid) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of Guid))
public:
Task<ApiResponse<Guid>^>^ CreateJobAsync(
    CreateOptionsModel^ createOptions,
    Nullable<Guid> requestedId = nullptr,
    CancellationToken cancellationToken = nullptr
)
member CreateJobAsync :
        createOptions : CreateOptionsModel *
        ?requestedId : Nullable<Guid> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _requestedId = defaultArg requestedId null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<Guid>>

Parameters

createOptions
Type: DoubleTake.Web.ModelsCreateOptionsModel
requestedId (Optional)
Type: SystemNullable Guid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse Guid
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.CreateSnapshotAsync Method

JobsApiCreateSnapshotAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> CreateSnapshotAsync(
    Guid id,
    Guid connection,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function CreateSnapshotAsync (
    id As Guid,
    connection As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ CreateSnapshotAsync(
    Guid id,
    Guid connection,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member CreateSnapshotAsync :
        id : Guid *
        connection : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
connection
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.DeleteJobAsync Method

JobsApiDeleteJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> DeleteJobAsync(
    Guid id,
    bool deleteReplica = false,
    bool discardTargetQueue = false,
    bool deleteImage = false,
    Guid imageId = null,
    VhdDeleteActionTypeEnum vhdDeleteAction = VhdDeleteActionTypeEnum.KeepAll,
    IEnumerable<string> vhdsToDelete = null,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function DeleteJobAsync (
    id As Guid,
    Optional deleteReplica As Boolean = false,
    Optional discardTargetQueue As Boolean = false,
    Optional deleteImage As Boolean = false,
    Optional imageId As Guid = Nothing,
    Optional vhdDeleteAction As VhdDeleteActionTypeEnum = VhdDeleteActionTypeEnum.KeepAll,
    Optional vhdsToDelete As IEnumerable(Of String) = Nothing,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ DeleteJobAsync(
    Guid id,
    bool deleteReplica = false,
    bool discardTargetQueue = false,
    bool deleteImage = false,
    Guid imageId = nullptr,
    VhdDeleteActionTypeEnum vhdDeleteAction = VhdDeleteActionTypeEnum::KeepAll,
    IEnumerable<String^>^ vhdsToDelete = nullptr,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member DeleteJobAsync :
        id : Guid *
        ?deleteReplica : bool *
        ?discardTargetQueue : bool *
        ?deleteImage : bool *
        ?imageId : Guid *
        ?vhdDeleteAction : VhdDeleteActionTypeEnum *
        ?vhdsToDelete : IEnumerable<string> *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _deleteReplica = defaultArg deleteReplica false
        let _discardTargetQueue = defaultArg discardTargetQueue false
        let _deleteImage = defaultArg deleteImage false
        let _imageId = defaultArg imageId null
        let _vhdDeleteAction = defaultArg vhdDeleteAction VhdDeleteActionTypeEnum.KeepAll
        let _vhdsToDelete = defaultArg vhdsToDelete null
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
deleteReplica (Optional)
Type: SystemBoolean
discardTargetQueue (Optional)
Type: SystemBoolean
deleteImage (Optional)
Type: SystemBoolean
imageId (Optional)
Type: SystemGuid
vhdDeleteAction (Optional)
Type: DoubleTake.Web.ModelsVhdDeleteActionTypeEnum
vhdsToDelete (Optional)
Type: System.Collections.GenericIEnumerable String
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.DeleteSnapshotAsync Method

JobsApiDeleteSnapshotAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> DeleteSnapshotAsync(
    Guid id,
    Guid connection,
    Guid snapshot,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function DeleteSnapshotAsync (
    id As Guid,
    connection As Guid,
    snapshot As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ DeleteSnapshotAsync(
    Guid id,
    Guid connection,
    Guid snapshot,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member DeleteSnapshotAsync :
        id : Guid *
        connection : Guid *
        snapshot : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
connection
Type: SystemGuid
snapshot
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.FailbackJobAsync Method

JobsApiFailbackJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> FailbackJobAsync(
    Guid id,
    FailbackOptionsModel options,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function FailbackJobAsync (
    id As Guid,
    options As FailbackOptionsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ FailbackJobAsync(
    Guid id,
    FailbackOptionsModel^ options,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member FailbackJobAsync :
        id : Guid *
        options : FailbackOptionsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
options
Type: DoubleTake.Web.ModelsFailbackOptionsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.FailoverJobAsync Method

JobsApiFailoverJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> FailoverJobAsync(
    Guid id,
    FailoverOptionsModel options,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function FailoverJobAsync (
    id As Guid,
    options As FailoverOptionsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ FailoverJobAsync(
    Guid id,
    FailoverOptionsModel^ options,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member FailoverJobAsync :
        id : Guid *
        options : FailoverOptionsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
options
Type: DoubleTake.Web.ModelsFailoverOptionsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.FixJobOptionsAsync Method

JobsApiFixJobOptionsAsync Method
Overload List
 | Name | Description
Public method | FixJobOptionsAsync(Guid, JobOptionsModel, IEnumerableVerificationStepModel, IProgressT, Void) |
Public method | FixJobOptionsAsync(String, JobCredentialsModel, JobOptionsModel, IEnumerableVerificationStepModel, IProgressT, Void) |
Top
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.FixJobOptionsAsync Method (Guid, JobOptionsModel, IEnumerable(VerificationStepModel), IProgress, Void)

JobsApiFixJobOptionsAsync Method (Guid, JobOptionsModel, IEnumerableVerificationStepModel, IProgress, Void)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<FixJobOptionsStatusModel>> FixJobOptionsAsync(
    Guid id,
    JobOptionsModel jobOptions,
    IEnumerable<VerificationStepModel> stepsToFix,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function FixJobOptionsAsync (
    id As Guid,
    jobOptions As JobOptionsModel,
    stepsToFix As IEnumerable(Of VerificationStepModel),
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of FixJobOptionsStatusModel))
public:
Task<ApiResponse<FixJobOptionsStatusModel^>^>^ FixJobOptionsAsync(
    Guid id,
    JobOptionsModel^ jobOptions,
    IEnumerable<VerificationStepModel^>^ stepsToFix,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member FixJobOptionsAsync :
        id : Guid *
        jobOptions : JobOptionsModel *
        stepsToFix : IEnumerable<VerificationStepModel> *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<FixJobOptionsStatusModel>>

Parameters

id
Type: SystemGuid
jobOptions
Type: DoubleTake.Web.ModelsJobOptionsModel
stepsToFix
Type: System.Collections.GenericIEnumerable VerificationStepModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse FixJobOptionsStatusModel
See Also

Reference

JobsApi Class
FixJobOptionsAsync Overload
DoubleTake.Web.Client Namespace


JobsApi.FixJobOptionsAsync Method (String, JobCredentialsModel, JobOptionsModel, IEnumerable(VerificationStepModel), IProgress, Void)

JobsApiFixJobOptionsAsync Method (String, JobCredentialsModel, JobOptionsModel, IEnumerableVerificationStepModel, IProgress, Void)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<FixJobOptionsStatusModel>> FixJobOptionsAsync(
    string jobType,
    JobCredentialsModel jobCredentials,
    JobOptionsModel jobOptions,
    IEnumerable<VerificationStepModel> stepsToFix,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function FixJobOptionsAsync (
    jobType As String,
    jobCredentials As JobCredentialsModel,
    jobOptions As JobOptionsModel,
    stepsToFix As IEnumerable(Of VerificationStepModel),
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of FixJobOptionsStatusModel))
public:
Task<ApiResponse<FixJobOptionsStatusModel^>^>^ FixJobOptionsAsync(
    String^ jobType,
    JobCredentialsModel^ jobCredentials,
    JobOptionsModel^ jobOptions,
    IEnumerable<VerificationStepModel^>^ stepsToFix,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member FixJobOptionsAsync :
        jobType : string *
        jobCredentials : JobCredentialsModel *
        jobOptions : JobOptionsModel *
        stepsToFix : IEnumerable<VerificationStepModel> *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<FixJobOptionsStatusModel>>

Parameters

jobType
Type: SystemString
jobCredentials
Type: DoubleTake.Web.ModelsJobCredentialsModel
jobOptions
Type: DoubleTake.Web.ModelsJobOptionsModel
stepsToFix
Type: System.Collections.GenericIEnumerable VerificationStepModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse FixJobOptionsStatusModel
See Also

Reference

JobsApi Class
FixJobOptionsAsync Overload
DoubleTake.Web.Client Namespace


JobsApi.GetJobAsync Method

JobsApiGetJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JobInfoModel>> GetJobAsync(
    Guid id,
    string fields = null,
    CancellationToken cancellationToken = null
)
Public Function GetJobAsync (
    id As Guid,
    Optional fields As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JobInfoModel))
public:
Task<ApiResponse<JobInfoModel^>^>^ GetJobAsync(
    Guid id,
    String^ fields = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetJobAsync :
        id : Guid *
        ?fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _fields = defaultArg fields null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JobInfoModel>>

Parameters

id
Type: SystemGuid
fields (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JobInfoModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetJobPartialAsync Method

JobsApiGetJobPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetJobPartialAsync(
    Guid id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetJobPartialAsync (
    id As Guid,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetJobPartialAsync(
    Guid id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetJobPartialAsync :
        id : Guid *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetJobsAsync Method

JobsApiGetJobsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JobInfoModel>>> GetJobsAsync(
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetJobsAsync (
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JobInfoModel)))
public:
Task<ApiResponse<IEnumerable<JobInfoModel^>^>^>^ GetJobsAsync(
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetJobsAsync :
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JobInfoModel>>>

Parameters

filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JobInfoModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetJobsPartialAsync Method

JobsApiGetJobsPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetJobsPartialAsync(
    string fields,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetJobsPartialAsync (
    fields As String,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetJobsPartialAsync(
    String^ fields,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetJobsPartialAsync :
        fields : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

fields
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetLogMessagesAsync Method

JobsApiGetLogMessagesAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<LogMessageModel>>> GetLogMessagesAsync(
    Guid id,
    string source = null,
    Nullable<int> pageSize = null,
    Nullable<int> lastHash = null,
    Nullable<DateTimeOffset> lastTimestamp = null,
    string filter = null,
    string sort = null,
    string fields = null,
    CancellationToken cancellationToken = null
)
Public Function GetLogMessagesAsync (
    id As Guid,
    Optional source As String = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional lastHash As Nullable(Of Integer) = Nothing,
    Optional lastTimestamp As Nullable(Of DateTimeOffset) = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional fields As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of LogMessageModel)))
public:
Task<ApiResponse<IEnumerable<LogMessageModel^>^>^>^ GetLogMessagesAsync(
    Guid id,
    String^ source = nullptr,
    Nullable<int> pageSize = nullptr,
    Nullable<int> lastHash = nullptr,
    Nullable<DateTimeOffset> lastTimestamp = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    String^ fields = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetLogMessagesAsync :
        id : Guid *
        ?source : string *
        ?pageSize : Nullable<int> *
        ?lastHash : Nullable<int> *
        ?lastTimestamp : Nullable<DateTimeOffset> *
        ?filter : string *
        ?sort : string *
        ?fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _source = defaultArg source null
        let _pageSize = defaultArg pageSize null
        let _lastHash = defaultArg lastHash null
        let _lastTimestamp = defaultArg lastTimestamp null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _fields = defaultArg fields null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<LogMessageModel>>>

Parameters

id
Type: SystemGuid
source (Optional)
Type: SystemString
pageSize (Optional)
Type: SystemNullable Int32
lastHash (Optional)
Type: SystemNullable Int32
lastTimestamp (Optional)
Type: SystemNullable DateTimeOffset
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
fields (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable LogMessageModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetQualificationResultsAsync Method

JobsApiGetQualificationResultsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JobQualificationResultsModel>> GetQualificationResultsAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function GetQualificationResultsAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JobQualificationResultsModel))
public:
Task<ApiResponse<JobQualificationResultsModel^>^>^ GetQualificationResultsAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member GetQualificationResultsAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JobQualificationResultsModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JobQualificationResultsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetSnapshotPartialAsync Method

JobsApiGetSnapshotPartialAsync Method
Overload List
 | Name | Description
Public method | GetSnapshotPartialAsync(Guid, Guid, Guid, CancellationToken) |
Public method | GetSnapshotPartialAsync(Guid, Guid, Guid, String, CancellationToken) |
Top
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetSnapshotPartialAsync Method (Guid, Guid, Guid, CancellationToken)

JobsApiGetSnapshotPartialAsync Method (Guid, Guid, Guid, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<SnapshotEntryModel>> GetSnapshotPartialAsync(
    Guid id,
    Guid connection,
    Guid snapshot,
    CancellationToken cancellationToken = null
)
Public Function GetSnapshotPartialAsync (
    id As Guid,
    connection As Guid,
    snapshot As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of SnapshotEntryModel))
public:
Task<ApiResponse<SnapshotEntryModel^>^>^ GetSnapshotPartialAsync(
    Guid id,
    Guid connection,
    Guid snapshot,
    CancellationToken cancellationToken = nullptr
)
member GetSnapshotPartialAsync :
        id : Guid *
        connection : Guid *
        snapshot : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<SnapshotEntryModel>>

Parameters

id
Type: SystemGuid
connection
Type: SystemGuid
snapshot
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse SnapshotEntryModel
See Also

Reference

JobsApi Class
GetSnapshotPartialAsync Overload
DoubleTake.Web.Client Namespace


JobsApi.GetSnapshotPartialAsync Method (Guid, Guid, Guid, String, CancellationToken)

JobsApiGetSnapshotPartialAsync Method (Guid, Guid, Guid, String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetSnapshotPartialAsync(
    Guid id,
    Guid connection,
    Guid snapshot,
    string fields = null,
    CancellationToken cancellationToken = null
)
Public Function GetSnapshotPartialAsync (
    id As Guid,
    connection As Guid,
    snapshot As Guid,
    Optional fields As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetSnapshotPartialAsync(
    Guid id,
    Guid connection,
    Guid snapshot,
    String^ fields = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetSnapshotPartialAsync :
        id : Guid *
        connection : Guid *
        snapshot : Guid *
        ?fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _fields = defaultArg fields null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
connection
Type: SystemGuid
snapshot
Type: SystemGuid
fields (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

JobsApi Class
GetSnapshotPartialAsync Overload
DoubleTake.Web.Client Namespace


JobsApi.GetSnapshotsAsync Method

JobsApiGetSnapshotsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<SnapshotEntryModel>>> GetSnapshotsAsync(
    Guid id,
    Guid connection,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetSnapshotsAsync (
    id As Guid,
    connection As Guid,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of SnapshotEntryModel)))
public:
Task<ApiResponse<IEnumerable<SnapshotEntryModel^>^>^>^ GetSnapshotsAsync(
    Guid id,
    Guid connection,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetSnapshotsAsync :
        id : Guid *
        connection : Guid *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<SnapshotEntryModel>>>

Parameters

id
Type: SystemGuid
connection
Type: SystemGuid
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable SnapshotEntryModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.GetSnapshotsPartialAsync Method

JobsApiGetSnapshotsPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetSnapshotsPartialAsync(
    Guid id,
    Guid connection,
    string filter = null,
    string sort = null,
    string fields = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetSnapshotsPartialAsync (
    id As Guid,
    connection As Guid,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional fields As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetSnapshotsPartialAsync(
    Guid id,
    Guid connection,
    String^ filter = nullptr,
    String^ sort = nullptr,
    String^ fields = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetSnapshotsPartialAsync :
        id : Guid *
        connection : Guid *
        ?filter : string *
        ?sort : string *
        ?fields : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _fields = defaultArg fields null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

id
Type: SystemGuid
connection
Type: SystemGuid
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
fields (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.PauseJobAsync Method

JobsApiPauseJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> PauseJobAsync(
    Guid id,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function PauseJobAsync (
    id As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ PauseJobAsync(
    Guid id,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member PauseJobAsync :
        id : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.PersistSharesAsync Method

JobsApiPersistSharesAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> PersistSharesAsync(
    Guid id,
    IEnumerable<ShareModel> shares,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function PersistSharesAsync (
    id As Guid,
    shares As IEnumerable(Of ShareModel),
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ PersistSharesAsync(
    Guid id,
    IEnumerable<ShareModel^>^ shares,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member PersistSharesAsync :
        id : Guid *
        shares : IEnumerable<ShareModel> *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
shares
Type: System.Collections.GenericIEnumerable ShareModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.QualifyAsync Method

JobsApiQualifyAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JobQualificationResultsModel>> QualifyAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function QualifyAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JobQualificationResultsModel))
public:
Task<ApiResponse<JobQualificationResultsModel^>^>^ QualifyAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member QualifyAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JobQualificationResultsModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JobQualificationResultsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.RecommendFailbackOptionsAsync Method

JobsApiRecommendFailbackOptionsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<RecommendedFailbackOptionsModel>> RecommendFailbackOptionsAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function RecommendFailbackOptionsAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of RecommendedFailbackOptionsModel))
public:
Task<ApiResponse<RecommendedFailbackOptionsModel^>^>^ RecommendFailbackOptionsAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member RecommendFailbackOptionsAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<RecommendedFailbackOptionsModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse RecommendedFailbackOptionsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.RecommendFailoverOptionsAsync Method

JobsApiRecommendFailoverOptionsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<RecommendedFailoverOptionsModel>> RecommendFailoverOptionsAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function RecommendFailoverOptionsAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of RecommendedFailoverOptionsModel))
public:
Task<ApiResponse<RecommendedFailoverOptionsModel^>^>^ RecommendFailoverOptionsAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member RecommendFailoverOptionsAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<RecommendedFailoverOptionsModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse RecommendedFailoverOptionsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.RecommendJobOptionsAsync Method

JobsApiRecommendJobOptionsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<RecommendedJobOptionsModel>> RecommendJobOptionsAsync(
    string jobType,
    WorkloadModel workload,
    JobCredentialsModel jobCredentials,
    CancellationToken cancellationToken = null
)
Public Function RecommendJobOptionsAsync (
    jobType As String,
    workload As WorkloadModel,
    jobCredentials As JobCredentialsModel,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of RecommendedJobOptionsModel))
public:
Task<ApiResponse<RecommendedJobOptionsModel^>^>^ RecommendJobOptionsAsync(
    String^ jobType,
    WorkloadModel^ workload,
    JobCredentialsModel^ jobCredentials,
    CancellationToken cancellationToken = nullptr
)
member RecommendJobOptionsAsync :
        jobType : string *
        workload : WorkloadModel *
        jobCredentials : JobCredentialsModel *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<RecommendedJobOptionsModel>>

Parameters

jobType
Type: SystemString
workload
Type: DoubleTake.Web.ModelsWorkloadModel
jobCredentials
Type: DoubleTake.Web.ModelsJobCredentialsModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse RecommendedJobOptionsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.RecommendRestoreOptionsAsync Method

JobsApiRecommendRestoreOptionsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<RestoreOptionsModel>> RecommendRestoreOptionsAsync(
    Guid id,
    JobCredentialsModel credentials,
    CancellationToken cancellationToken = null
)
Public Function RecommendRestoreOptionsAsync (
    id As Guid,
    credentials As JobCredentialsModel,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of RestoreOptionsModel))
public:
Task<ApiResponse<RestoreOptionsModel^>^>^ RecommendRestoreOptionsAsync(
    Guid id,
    JobCredentialsModel^ credentials,
    CancellationToken cancellationToken = nullptr
)
member RecommendRestoreOptionsAsync :
        id : Guid *
        credentials : JobCredentialsModel *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<RestoreOptionsModel>>

Parameters

id
Type: SystemGuid
credentials
Type: DoubleTake.Web.ModelsJobCredentialsModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse RestoreOptionsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.RestoreJobAsync Method

JobsApiRestoreJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> RestoreJobAsync(
    Guid id,
    RestoreOptionsModel options,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function RestoreJobAsync (
    id As Guid,
    options As RestoreOptionsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ RestoreJobAsync(
    Guid id,
    RestoreOptionsModel^ options,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member RestoreJobAsync :
        id : Guid *
        options : RestoreOptionsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
options
Type: DoubleTake.Web.ModelsRestoreOptionsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.ReverseJobAsync Method

JobsApiReverseJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> ReverseJobAsync(
    Guid id,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function ReverseJobAsync (
    id As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ ReverseJobAsync(
    Guid id,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member ReverseJobAsync :
        id : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.StartJobAsync Method

JobsApiStartJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> StartJobAsync(
    Guid id,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function StartJobAsync (
    id As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ StartJobAsync(
    Guid id,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member StartJobAsync :
        id : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.StopJobAsync Method

JobsApiStopJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> StopJobAsync(
    Guid id,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function StopJobAsync (
    id As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ StopJobAsync(
    Guid id,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member StopJobAsync :
        id : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.UndoFailover Method

JobsApiUndoFailover Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> UndoFailover(
    Guid id,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function UndoFailover (
    id As Guid,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ UndoFailover(
    Guid id,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member UndoFailover :
        id : Guid *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.UpdateCredentialsAsync Method

JobsApiUpdateCredentialsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> UpdateCredentialsAsync(
    Guid id,
    JobCredentialsModel credentials,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function UpdateCredentialsAsync (
    id As Guid,
    credentials As JobCredentialsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ UpdateCredentialsAsync(
    Guid id,
    JobCredentialsModel^ credentials,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member UpdateCredentialsAsync :
        id : Guid *
        credentials : JobCredentialsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
credentials
Type: DoubleTake.Web.ModelsJobCredentialsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.UpdateJobAsync Method

JobsApiUpdateJobAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ActivityStatusModel>> UpdateJobAsync(
    Guid id,
    JobOptionsModel options,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function UpdateJobAsync (
    id As Guid,
    options As JobOptionsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of ActivityStatusModel))
public:
Task<ApiResponse<ActivityStatusModel^>^>^ UpdateJobAsync(
    Guid id,
    JobOptionsModel^ options,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member UpdateJobAsync :
        id : Guid *
        options : JobOptionsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ActivityStatusModel>>

Parameters

id
Type: SystemGuid
options
Type: DoubleTake.Web.ModelsJobOptionsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse ActivityStatusModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.UpdateRecommendedJobOptionsAsync Method

JobsApiUpdateRecommendedJobOptionsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<RecommendedJobOptionsModel>> UpdateRecommendedJobOptionsAsync(
    Guid id,
    JobOptionsModel candidateOptions,
    WorkloadModel workload,
    CancellationToken cancellationToken = null
)
Public Function UpdateRecommendedJobOptionsAsync (
    id As Guid,
    candidateOptions As JobOptionsModel,
    workload As WorkloadModel,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of RecommendedJobOptionsModel))
public:
Task<ApiResponse<RecommendedJobOptionsModel^>^>^ UpdateRecommendedJobOptionsAsync(
    Guid id,
    JobOptionsModel^ candidateOptions,
    WorkloadModel^ workload,
    CancellationToken cancellationToken = nullptr
)
member UpdateRecommendedJobOptionsAsync :
        id : Guid *
        candidateOptions : JobOptionsModel *
        workload : WorkloadModel *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<RecommendedJobOptionsModel>>

Parameters

id
Type: SystemGuid
candidateOptions
Type: DoubleTake.Web.ModelsJobOptionsModel
workload
Type: DoubleTake.Web.ModelsWorkloadModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse RecommendedJobOptionsModel
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.VerifyJobOptionsAsync Method

JobsApiVerifyJobOptionsAsync Method
Overload List
 | Name | Description
Public method | VerifyJobOptionsAsync(Guid, JobOptionsModel, IProgressT, Void) |
Public method | VerifyJobOptionsAsync(String, JobCredentialsModel, JobOptionsModel, IProgressT, Void) |
Top
See Also

Reference

JobsApi Class
DoubleTake.Web.Client Namespace


JobsApi.VerifyJobOptionsAsync Method (Guid, JobOptionsModel, IProgress, Void)

JobsApiVerifyJobOptionsAsync Method (Guid, JobOptionsModel, IProgress, Void)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<VerificationStatusModel>> VerifyJobOptionsAsync(
    Guid id,
    JobOptionsModel jobOptions,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function VerifyJobOptionsAsync (
    id As Guid,
    jobOptions As JobOptionsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of VerificationStatusModel))
public:
Task<ApiResponse<VerificationStatusModel^>^>^ VerifyJobOptionsAsync(
    Guid id,
    JobOptionsModel^ jobOptions,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member VerifyJobOptionsAsync :
        id : Guid *
        jobOptions : JobOptionsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<VerificationStatusModel>>

Parameters

id
Type: SystemGuid
jobOptions
Type: DoubleTake.Web.ModelsJobOptionsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse VerificationStatusModel
See Also

Reference

JobsApi Class
VerifyJobOptionsAsync Overload
DoubleTake.Web.Client Namespace


JobsApi.VerifyJobOptionsAsync Method (String, JobCredentialsModel, JobOptionsModel, IProgress, Void)

JobsApiVerifyJobOptionsAsync Method (String, JobCredentialsModel, JobOptionsModel, IProgress, Void)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<VerificationStatusModel>> VerifyJobOptionsAsync(
    string jobType,
    JobCredentialsModel jobCredentials,
    JobOptionsModel jobOptions,
    IProgress progress = null,
    void cancellationToken = null
)
Public Function VerifyJobOptionsAsync (
    jobType As String,
    jobCredentials As JobCredentialsModel,
    jobOptions As JobOptionsModel,
    Optional progress As IProgress = Nothing,
    Optional cancellationToken As Void = Nothing
) As Task(Of ApiResponse(Of VerificationStatusModel))
public:
Task<ApiResponse<VerificationStatusModel^>^>^ VerifyJobOptionsAsync(
    String^ jobType,
    JobCredentialsModel^ jobCredentials,
    JobOptionsModel^ jobOptions,
    IProgress^ progress = nullptr,
    void cancellationToken = nullptr
)
member VerifyJobOptionsAsync :
        jobType : string *
        jobCredentials : JobCredentialsModel *
        jobOptions : JobOptionsModel *
        ?progress : IProgress *
        ?cancellationToken : unit
(* Defaults:
        let _progress = defaultArg progress null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<VerificationStatusModel>>

Parameters

jobType
Type: SystemString
jobCredentials
Type: DoubleTake.Web.ModelsJobCredentialsModel
jobOptions
Type: DoubleTake.Web.ModelsJobOptionsModel
progress (Optional)
Type: SystemIProgressT
cancellationToken (Optional)
Type: SystemVoid

Return Value

Type: Task ApiResponse VerificationStatusModel
See Also

Reference

JobsApi Class
VerifyJobOptionsAsync Overload
DoubleTake.Web.Client Namespace


NetworkInterfacesApi Class

NetworkInterfacesApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientNetworkInterfacesApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class NetworkInterfacesApi : ApiClient
Public NotInheritable Class NetworkInterfacesApi
    Inherits ApiClient
public ref class NetworkInterfacesApi sealed : public ApiClient
[<SealedAttribute>]
type NetworkInterfacesApi =
    class
        inherit ApiClient
    end

The NetworkInterfacesApi type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfacesApi | Initializes a new instance of the NetworkInterfacesApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetByIdAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetPartialByIdAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


NetworkInterfacesApi Constructor

NetworkInterfacesApi Constructor
Initializes a new instance of the NetworkInterfacesApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfacesApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
NetworkInterfacesApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> NetworkInterfacesApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

NetworkInterfacesApi Class
DoubleTake.Web.Client Namespace


NetworkInterfacesApi Methods

NetworkInterfacesApi Methods

The NetworkInterfacesApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetByIdAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetPartialByIdAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkInterfacesApi Class
DoubleTake.Web.Client Namespace


NetworkInterfacesApi.GetAsync Method

NetworkInterfacesApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<NetworkInterfaceModel>>> GetAsync(
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of NetworkInterfaceModel)))
public:
Task<ApiResponse<IEnumerable<NetworkInterfaceModel^>^>^>^ GetAsync(
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<NetworkInterfaceModel>>>

Parameters

filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable NetworkInterfaceModel
See Also

Reference

NetworkInterfacesApi Class
DoubleTake.Web.Client Namespace


NetworkInterfacesApi.GetByIdAsync Method

NetworkInterfacesApiGetByIdAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<NetworkInterfaceModel>> GetByIdAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function GetByIdAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of NetworkInterfaceModel))
public:
Task<ApiResponse<NetworkInterfaceModel^>^>^ GetByIdAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member GetByIdAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<NetworkInterfaceModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse NetworkInterfaceModel
See Also

Reference

NetworkInterfacesApi Class
DoubleTake.Web.Client Namespace


NetworkInterfacesApi.GetPartialAsync Method

NetworkInterfacesApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetPartialAsync(
    string fields,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetPartialAsync(
    String^ fields,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

fields
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

NetworkInterfacesApi Class
DoubleTake.Web.Client Namespace


NetworkInterfacesApi.GetPartialByIdAsync Method

NetworkInterfacesApiGetPartialByIdAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialByIdAsync(
    Guid id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialByIdAsync (
    id As Guid,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialByIdAsync(
    Guid id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialByIdAsync :
        id : Guid *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

NetworkInterfacesApi Class
DoubleTake.Web.Client Namespace


OptionsApi Class

OptionsApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientOptionsApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionsApi : ApiClient
Public NotInheritable Class OptionsApi
    Inherits ApiClient
public ref class OptionsApi sealed : public ApiClient
[<SealedAttribute>]
type OptionsApi =
    class
        inherit ApiClient
    end

The OptionsApi type exposes the following members.

Constructors
 | Name | Description
Public method | OptionsApi | Initializes a new instance of the OptionsApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PatchAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


OptionsApi Constructor

OptionsApi Constructor
Initializes a new instance of the OptionsApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OptionsApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
OptionsApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> OptionsApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

OptionsApi Class
DoubleTake.Web.Client Namespace


OptionsApi Methods

OptionsApi Methods

The OptionsApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | PatchAsync |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionsApi Class
DoubleTake.Web.Client Namespace


OptionsApi.GetAsync Method

OptionsApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<OptionModel>> GetAsync(
    string options = null,
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional options As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of OptionModel))
public:
Task<ApiResponse<OptionModel^>^>^ GetAsync(
    String^ options = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?options : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _options = defaultArg options null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<OptionModel>>

Parameters

options (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse OptionModel
See Also

Reference

OptionsApi Class
DoubleTake.Web.Client Namespace


OptionsApi.PatchAsync Method

OptionsApiPatchAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> PatchAsync(
    IEnumerable<OptionModel> options,
    CancellationToken cancellationToken = null
)
Public Function PatchAsync (
    options As IEnumerable(Of OptionModel),
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ PatchAsync(
    IEnumerable<OptionModel^>^ options,
    CancellationToken cancellationToken = nullptr
)
member PatchAsync :
        options : IEnumerable<OptionModel> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

options
Type: System.Collections.GenericIEnumerable OptionModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

OptionsApi Class
DoubleTake.Web.Client Namespace


ProductInfoApi Class

ProductInfoApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientProductInfoApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ProductInfoApi : ApiClient
Public NotInheritable Class ProductInfoApi
    Inherits ApiClient
public ref class ProductInfoApi sealed : public ApiClient
[<SealedAttribute>]
type ProductInfoApi =
    class
        inherit ApiClient
    end

The ProductInfoApi type exposes the following members.

Constructors
 | Name | Description
Public method | ProductInfoApi | Initializes a new instance of the ProductInfoApi class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ProductInfoApi Constructor

ProductInfoApi Constructor
Initializes a new instance of the ProductInfoApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
ProductInfoApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> ProductInfoApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

ProductInfoApi Class
DoubleTake.Web.Client Namespace


ProductInfoApi Methods

ProductInfoApi Methods

The ProductInfoApi type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductInfoApi Class
DoubleTake.Web.Client Namespace


ProductInfoApi.GetAsync Method

ProductInfoApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ProductInfoModel>> GetAsync(
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ProductInfoModel))
public:
Task<ApiResponse<ProductInfoModel^>^>^ GetAsync(
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ProductInfoModel>>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ProductInfoModel
See Also

Reference

ProductInfoApi Class
DoubleTake.Web.Client Namespace


ProductInfoApi.GetPartialAsync Method

ProductInfoApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialAsync(
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialAsync(
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ProductInfoApi Class
DoubleTake.Web.Client Namespace


ServerInfoApi Class

ServerInfoApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientServerInfoApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ServerInfoApi : ApiClient
Public Class ServerInfoApi
    Inherits ApiClient
public ref class ServerInfoApi : public ApiClient
type ServerInfoApi =
    class
        inherit ApiClient
    end

The ServerInfoApi type exposes the following members.

Constructors
 | Name | Description
Public method | ServerInfoApi | Initializes a new instance of the ServerInfoApi class
Top
Methods
 | Name | Description
Protected method | DeleteHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | DeleteHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHttpAsyncT(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | GetHttpAsyncT(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | GetPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PatchHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PollStatusTStatus | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Client Namespace


ServerInfoApi Constructor

ServerInfoApi Constructor
Initializes a new instance of the ServerInfoApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerInfoApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
ServerInfoApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> ServerInfoApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

ServerInfoApi Class
DoubleTake.Web.Client Namespace


ServerInfoApi Methods

ServerInfoApi Methods

The ServerInfoApi type exposes the following members.

Methods
 | Name | Description
Protected method | DeleteHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | DeleteHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetHttpAsyncT(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | GetHttpAsyncT(String, Object, CancellationToken) | (Inherited from ApiClient.)
Public method | GetPartialAsync |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PatchHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PatchHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PollStatusTStatus | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PostHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsync(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpAsyncT(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncTResult(String, Object, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, T, CancellationToken) | (Inherited from ApiClient.)
Protected method | PutHttpResponseAsyncT, TResult(String, Object, T, CancellationToken) | (Inherited from ApiClient.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerInfoApi Class
DoubleTake.Web.Client Namespace


ServerInfoApi.GetAsync Method

ServerInfoApiGetAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ServerInfoModel>> GetAsync(
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ServerInfoModel))
public:
Task<ApiResponse<ServerInfoModel^>^>^ GetAsync(
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ServerInfoModel>>

Parameters

cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ServerInfoModel
See Also

Reference

ServerInfoApi Class
DoubleTake.Web.Client Namespace


ServerInfoApi.GetPartialAsync Method

ServerInfoApiGetPartialAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialAsync(
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialAsync(
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

ServerInfoApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi Class

WorkloadsApi Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ClientApiClient
DoubleTake.Web.ClientWorkloadsApi

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadsApi : ApiClient
Public NotInheritable Class WorkloadsApi
    Inherits ApiClient
public ref class WorkloadsApi sealed : public ApiClient
[<SealedAttribute>]
type WorkloadsApi =
    class
        inherit ApiClient
    end

The WorkloadsApi type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadsApi | Initializes a new instance of the WorkloadsApi class
Top
Methods
 | Name | Description
Public method | AddPhysicalRuleAsync(Guid, PhysicalRuleModel, CancellationToken) |
Public method | AddPhysicalRuleAsync(Guid, String, InclusionModeEnum, RecursionModeEnum, CancellationToken) |
Public method | CreateAsync |
Public method | DeleteAsync |
Public method | DeletePhysicalRule |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync(Guid, CancellationToken) |
Public method | GetAsync(String, String, NullableInt32, NullableInt32, CancellationToken) |
Public method | GetFilesAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLogicalItemsAsync |
Public method | GetPartialAsync(Guid, String, CancellationToken) |
Public method | GetPartialAsync(String, String, String, NullableInt32, NullableInt32, CancellationToken) |
Public method | GetPartialFilesAsync |
Public method | GetPartialLogicalItemsAsync |
Public method | GetPartialWorkloadTypes |
Public method | GetRecommendedPathTransformations |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkloadTypes |
Public method | SelectLogicalItem |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnselectLogicalItem |
Top
See Also

Reference

DoubleTake.Web.Client Namespace


WorkloadsApi Constructor

WorkloadsApi Constructor
Initializes a new instance of the WorkloadsApi class

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadsApi(
    string networkId,
    Nullable<int> port = null
)
Public Sub New (
    networkId As String,
    Optional port As Nullable(Of Integer) = Nothing
)
public:
WorkloadsApi(
    String^ networkId,
    Nullable<int> port = nullptr
)
new :
        networkId : string *
        ?port : Nullable<int>
(* Defaults:
        let _port = defaultArg port null
*)
-> WorkloadsApi

Parameters

networkId
Type: SystemString
port (Optional)
Type: SystemNullable Int32
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi Methods

WorkloadsApi Methods

The WorkloadsApi type exposes the following members.

Methods
 | Name | Description
Public method | AddPhysicalRuleAsync(Guid, PhysicalRuleModel, CancellationToken) |
Public method | AddPhysicalRuleAsync(Guid, String, InclusionModeEnum, RecursionModeEnum, CancellationToken) |
Public method | CreateAsync |
Public method | DeleteAsync |
Public method | DeletePhysicalRule |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetAsync(Guid, CancellationToken) |
Public method | GetAsync(String, String, NullableInt32, NullableInt32, CancellationToken) |
Public method | GetFilesAsync |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLogicalItemsAsync |
Public method | GetPartialAsync(Guid, String, CancellationToken) |
Public method | GetPartialAsync(String, String, String, NullableInt32, NullableInt32, CancellationToken) |
Public method | GetPartialFilesAsync |
Public method | GetPartialLogicalItemsAsync |
Public method | GetPartialWorkloadTypes |
Public method | GetRecommendedPathTransformations |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWorkloadTypes |
Public method | SelectLogicalItem |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnselectLogicalItem |
Top
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.AddPhysicalRuleAsync Method

WorkloadsApiAddPhysicalRuleAsync Method
Overload List
 | Name | Description
Public method | AddPhysicalRuleAsync(Guid, PhysicalRuleModel, CancellationToken) |
Public method | AddPhysicalRuleAsync(Guid, String, InclusionModeEnum, RecursionModeEnum, CancellationToken) |
Top
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.AddPhysicalRuleAsync Method (Guid, PhysicalRuleModel, CancellationToken)

WorkloadsApiAddPhysicalRuleAsync Method (Guid, PhysicalRuleModel, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ChangedItemsModel>> AddPhysicalRuleAsync(
    Guid id,
    PhysicalRuleModel physicalRule,
    CancellationToken cancellationToken = null
)
Public Function AddPhysicalRuleAsync (
    id As Guid,
    physicalRule As PhysicalRuleModel,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ChangedItemsModel))
public:
Task<ApiResponse<ChangedItemsModel^>^>^ AddPhysicalRuleAsync(
    Guid id,
    PhysicalRuleModel^ physicalRule,
    CancellationToken cancellationToken = nullptr
)
member AddPhysicalRuleAsync :
        id : Guid *
        physicalRule : PhysicalRuleModel *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ChangedItemsModel>>

Parameters

id
Type: SystemGuid
physicalRule
Type: DoubleTake.Web.ModelsPhysicalRuleModel
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ChangedItemsModel
See Also

Reference

WorkloadsApi Class
AddPhysicalRuleAsync Overload
DoubleTake.Web.Client Namespace


WorkloadsApi.AddPhysicalRuleAsync Method (Guid, String, InclusionModeEnum, RecursionModeEnum, CancellationToken)

WorkloadsApiAddPhysicalRuleAsync Method (Guid, String, InclusionModeEnum, RecursionModeEnum, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ChangedItemsModel>> AddPhysicalRuleAsync(
    Guid id,
    string path,
    InclusionModeEnum inclusion = InclusionModeEnum.Include,
    RecursionModeEnum recursion = RecursionModeEnum.NonRecursive,
    CancellationToken cancellationToken = null
)
Public Function AddPhysicalRuleAsync (
    id As Guid,
    path As String,
    Optional inclusion As InclusionModeEnum = InclusionModeEnum.Include,
    Optional recursion As RecursionModeEnum = RecursionModeEnum.NonRecursive,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ChangedItemsModel))
public:
Task<ApiResponse<ChangedItemsModel^>^>^ AddPhysicalRuleAsync(
    Guid id,
    String^ path,
    InclusionModeEnum inclusion = InclusionModeEnum::Include,
    RecursionModeEnum recursion = RecursionModeEnum::NonRecursive,
    CancellationToken cancellationToken = nullptr
)
member AddPhysicalRuleAsync :
        id : Guid *
        path : string *
        ?inclusion : InclusionModeEnum *
        ?recursion : RecursionModeEnum *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _inclusion = defaultArg inclusion InclusionModeEnum.Include
        let _recursion = defaultArg recursion RecursionModeEnum.NonRecursive
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ChangedItemsModel>>

Parameters

id
Type: SystemGuid
path
Type: SystemString
inclusion (Optional)
Type: DoubleTake.Web.ModelsInclusionModeEnum
recursion (Optional)
Type: DoubleTake.Web.ModelsRecursionModeEnum
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ChangedItemsModel
See Also

Reference

WorkloadsApi Class
AddPhysicalRuleAsync Overload
DoubleTake.Web.Client Namespace


WorkloadsApi.CreateAsync Method

WorkloadsApiCreateAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<WorkloadModel>> CreateAsync(
    string type,
    Nullable<Guid> image = null,
    Nullable<Guid> snapshot = null,
    CancellationToken cancellationToken = null
)
Public Function CreateAsync (
    type As String,
    Optional image As Nullable(Of Guid) = Nothing,
    Optional snapshot As Nullable(Of Guid) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of WorkloadModel))
public:
Task<ApiResponse<WorkloadModel^>^>^ CreateAsync(
    String^ type,
    Nullable<Guid> image = nullptr,
    Nullable<Guid> snapshot = nullptr,
    CancellationToken cancellationToken = nullptr
)
member CreateAsync :
        type : string *
        ?image : Nullable<Guid> *
        ?snapshot : Nullable<Guid> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _image = defaultArg image null
        let _snapshot = defaultArg snapshot null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<WorkloadModel>>

Parameters

type
Type: SystemString
image (Optional)
Type: SystemNullable Guid
snapshot (Optional)
Type: SystemNullable Guid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse WorkloadModel
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.DeleteAsync Method

WorkloadsApiDeleteAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> DeleteAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function DeleteAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ DeleteAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member DeleteAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.DeletePhysicalRule Method

WorkloadsApiDeletePhysicalRule Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> DeletePhysicalRule(
    Guid id,
    string path,
    CancellationToken cancellationToken = null
)
Public Function DeletePhysicalRule (
    id As Guid,
    path As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ DeletePhysicalRule(
    Guid id,
    String^ path,
    CancellationToken cancellationToken = nullptr
)
member DeletePhysicalRule :
        id : Guid *
        path : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
path
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetAsync Method

WorkloadsApiGetAsync Method
Overload List
 | Name | Description
Public method | GetAsync(Guid, CancellationToken) |
Public method | GetAsync(String, String, NullableInt32, NullableInt32, CancellationToken) |
Top
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetAsync Method (Guid, CancellationToken)

WorkloadsApiGetAsync Method (Guid, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<WorkloadModel>> GetAsync(
    Guid id,
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    id As Guid,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of WorkloadModel))
public:
Task<ApiResponse<WorkloadModel^>^>^ GetAsync(
    Guid id,
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        id : Guid *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<WorkloadModel>>

Parameters

id
Type: SystemGuid
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse WorkloadModel
See Also

Reference

WorkloadsApi Class
GetAsync Overload
DoubleTake.Web.Client Namespace


WorkloadsApi.GetAsync Method (String, String, Nullable(Int32), Nullable(Int32), CancellationToken)

WorkloadsApiGetAsync Method (String, String, NullableInt32, NullableInt32, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<WorkloadModel>>> GetAsync(
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetAsync (
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of WorkloadModel)))
public:
Task<ApiResponse<IEnumerable<WorkloadModel^>^>^>^ GetAsync(
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetAsync :
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<WorkloadModel>>>

Parameters

filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable WorkloadModel
See Also

Reference

WorkloadsApi Class
GetAsync Overload
DoubleTake.Web.Client Namespace


WorkloadsApi.GetFilesAsync Method

WorkloadsApiGetFilesAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<FileItemModel>>> GetFilesAsync(
    Guid id,
    string parentId = null,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetFilesAsync (
    id As Guid,
    Optional parentId As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of FileItemModel)))
public:
Task<ApiResponse<IEnumerable<FileItemModel^>^>^>^ GetFilesAsync(
    Guid id,
    String^ parentId = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetFilesAsync :
        id : Guid *
        ?parentId : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _parentId = defaultArg parentId null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<FileItemModel>>>

Parameters

id
Type: SystemGuid
parentId (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable FileItemModel
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetLogicalItemsAsync Method

WorkloadsApiGetLogicalItemsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<LogicalItemModel>>> GetLogicalItemsAsync(
    Guid id,
    string parentId = null,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetLogicalItemsAsync (
    id As Guid,
    Optional parentId As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of LogicalItemModel)))
public:
Task<ApiResponse<IEnumerable<LogicalItemModel^>^>^>^ GetLogicalItemsAsync(
    Guid id,
    String^ parentId = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetLogicalItemsAsync :
        id : Guid *
        ?parentId : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _parentId = defaultArg parentId null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<LogicalItemModel>>>

Parameters

id
Type: SystemGuid
parentId (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable LogicalItemModel
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetPartialAsync Method

WorkloadsApiGetPartialAsync Method
Overload List
 | Name | Description
Public method | GetPartialAsync(Guid, String, CancellationToken) |
Public method | GetPartialAsync(String, String, String, NullableInt32, NullableInt32, CancellationToken) |
Top
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetPartialAsync Method (Guid, String, CancellationToken)

WorkloadsApiGetPartialAsync Method (Guid, String, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialAsync(
    Guid id,
    string fields,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    id As Guid,
    fields As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialAsync(
    Guid id,
    String^ fields,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        id : Guid *
        fields : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

WorkloadsApi Class
GetPartialAsync Overload
DoubleTake.Web.Client Namespace


WorkloadsApi.GetPartialAsync Method (String, String, String, Nullable(Int32), Nullable(Int32), CancellationToken)

WorkloadsApiGetPartialAsync Method (String, String, String, NullableInt32, NullableInt32, CancellationToken)

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetPartialAsync(
    string fields,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialAsync (
    fields As String,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetPartialAsync(
    String^ fields,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialAsync :
        fields : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

fields
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

WorkloadsApi Class
GetPartialAsync Overload
DoubleTake.Web.Client Namespace


WorkloadsApi.GetPartialFilesAsync Method

WorkloadsApiGetPartialFilesAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetPartialFilesAsync(
    Guid id,
    string fields,
    string parentId = null,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialFilesAsync (
    id As Guid,
    fields As String,
    Optional parentId As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetPartialFilesAsync(
    Guid id,
    String^ fields,
    String^ parentId = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialFilesAsync :
        id : Guid *
        fields : string *
        ?parentId : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _parentId = defaultArg parentId null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
parentId (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetPartialLogicalItemsAsync Method

WorkloadsApiGetPartialLogicalItemsAsync Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<JObject>>> GetPartialLogicalItemsAsync(
    Guid id,
    string fields,
    string parentId = null,
    string filter = null,
    string sort = null,
    Nullable<int> page = null,
    Nullable<int> pageSize = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialLogicalItemsAsync (
    id As Guid,
    fields As String,
    Optional parentId As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional page As Nullable(Of Integer) = Nothing,
    Optional pageSize As Nullable(Of Integer) = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of JObject)))
public:
Task<ApiResponse<IEnumerable<JObject^>^>^>^ GetPartialLogicalItemsAsync(
    Guid id,
    String^ fields,
    String^ parentId = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    Nullable<int> page = nullptr,
    Nullable<int> pageSize = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialLogicalItemsAsync :
        id : Guid *
        fields : string *
        ?parentId : string *
        ?filter : string *
        ?sort : string *
        ?page : Nullable<int> *
        ?pageSize : Nullable<int> *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _parentId = defaultArg parentId null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _page = defaultArg page null
        let _pageSize = defaultArg pageSize null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<JObject>>>

Parameters

id
Type: SystemGuid
fields
Type: SystemString
parentId (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
page (Optional)
Type: SystemNullable Int32
pageSize (Optional)
Type: SystemNullable Int32
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable JObject
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetPartialWorkloadTypes Method

WorkloadsApiGetPartialWorkloadTypes Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<JObject>> GetPartialWorkloadTypes(
    string fields,
    string targetServer = null,
    string filter = null,
    string sort = null,
    CancellationToken cancellationToken = null
)
Public Function GetPartialWorkloadTypes (
    fields As String,
    Optional targetServer As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of JObject))
public:
Task<ApiResponse<JObject^>^>^ GetPartialWorkloadTypes(
    String^ fields,
    String^ targetServer = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetPartialWorkloadTypes :
        fields : string *
        ?targetServer : string *
        ?filter : string *
        ?sort : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _targetServer = defaultArg targetServer null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<JObject>>

Parameters

fields
Type: SystemString
targetServer (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse JObject
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetRecommendedPathTransformations Method

WorkloadsApiGetRecommendedPathTransformations Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<IEnumerable<PathTransformationModel>>> GetRecommendedPathTransformations(
    Guid id,
    string basePath = null,
    CancellationToken cancellationToken = null
)
Public Function GetRecommendedPathTransformations (
    id As Guid,
    Optional basePath As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of IEnumerable(Of PathTransformationModel)))
public:
Task<ApiResponse<IEnumerable<PathTransformationModel^>^>^>^ GetRecommendedPathTransformations(
    Guid id,
    String^ basePath = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetRecommendedPathTransformations :
        id : Guid *
        ?basePath : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _basePath = defaultArg basePath null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<IEnumerable<PathTransformationModel>>>

Parameters

id
Type: SystemGuid
basePath (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse IEnumerable PathTransformationModel
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.GetWorkloadTypes Method

WorkloadsApiGetWorkloadTypes Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<WorkloadTypeModel>> GetWorkloadTypes(
    string targetServer = null,
    string filter = null,
    string sort = null,
    CancellationToken cancellationToken = null
)
Public Function GetWorkloadTypes (
    Optional targetServer As String = Nothing,
    Optional filter As String = Nothing,
    Optional sort As String = Nothing,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of WorkloadTypeModel))
public:
Task<ApiResponse<WorkloadTypeModel^>^>^ GetWorkloadTypes(
    String^ targetServer = nullptr,
    String^ filter = nullptr,
    String^ sort = nullptr,
    CancellationToken cancellationToken = nullptr
)
member GetWorkloadTypes :
        ?targetServer : string *
        ?filter : string *
        ?sort : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _targetServer = defaultArg targetServer null
        let _filter = defaultArg filter null
        let _sort = defaultArg sort null
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<WorkloadTypeModel>>

Parameters

targetServer (Optional)
Type: SystemString
filter (Optional)
Type: SystemString
sort (Optional)
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse WorkloadTypeModel
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.SelectLogicalItem Method

WorkloadsApiSelectLogicalItem Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse<ChangedItemsModel>> SelectLogicalItem(
    Guid id,
    string path,
    CancellationToken cancellationToken = null
)
Public Function SelectLogicalItem (
    id As Guid,
    path As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse(Of ChangedItemsModel))
public:
Task<ApiResponse<ChangedItemsModel^>^>^ SelectLogicalItem(
    Guid id,
    String^ path,
    CancellationToken cancellationToken = nullptr
)
member SelectLogicalItem :
        id : Guid *
        path : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse<ChangedItemsModel>>

Parameters

id
Type: SystemGuid
path
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse ChangedItemsModel
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


WorkloadsApi.UnselectLogicalItem Method

WorkloadsApiUnselectLogicalItem Method

Namespace: DoubleTake.Web.Client
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Task<ApiResponse> UnselectLogicalItem(
    Guid id,
    string path,
    CancellationToken cancellationToken = null
)
Public Function UnselectLogicalItem (
    id As Guid,
    path As String,
    Optional cancellationToken As CancellationToken = Nothing
) As Task(Of ApiResponse)
public:
Task<ApiResponse^>^ UnselectLogicalItem(
    Guid id,
    String^ path,
    CancellationToken cancellationToken = nullptr
)
member UnselectLogicalItem :
        id : Guid *
        path : string *
        ?cancellationToken : CancellationToken
(* Defaults:
        let _cancellationToken = defaultArg cancellationToken null
*)
-> Task<ApiResponse>

Parameters

id
Type: SystemGuid
path
Type: SystemString
cancellationToken (Optional)
Type: System.ThreadingCancellationToken

Return Value

Type: Task ApiResponse
See Also

Reference

WorkloadsApi Class
DoubleTake.Web.Client Namespace


DoubleTake.Web.Models Namespace

DoubleTake.Web.Models Namespace
Classes
 | Class | Description
Public class | AccessLevelModel |
Public class | AceModel |
Public class | ActivationAttributeModel |
Public class | ActivationCodeModel |
Public class | ActivationStatusModel |
Public class | ActivityStatusModel |
Public class | ActivityTokenModel |
Public class | ApplicationOptionsModel |
Public class | ArchiveCriteriaModel |
Public class | ArchiveScheduleModel |
Public class | BandwidthEntryModel |
Public class | BandwidthOptionsModel |
Public class | BandwidthScheduleEntryModel |
Public class | BandwidthScheduleModel |
Public class | BandwidthSpecificationModel |
Public class | ChangedItemsModel |
Public class | CloudOptionsModel |
Public class | ClusterFilesAndFoldersQualificationResultsModel |
Public class | ClusterOptionsModel |
Public class | CompressionLevelModel |
Public class | ConnectionScheduleModel |
Public class | ConnectionStartParametersModel |
Public class | CoreConnectionDetailsModel |
Public class | CoreConnectionOptionsModel |
Public class | CoreMonitorDetailsModel |
Public class | CoreMonitorOptionsModel |
Public class | CoreQualificationResultsModel |
Public class | CreateOptionsModel |
Public class | CredentialModel |
Public class | CutoverDetailsModel |
Public class | DeleteJobRequestModel |
Public class | DirectoryItemModel |
Public class | DnsDomainDetailsModel |
Public class | DnsOptionsModel |
Public class | DnsRecordLockOptionsModel |
Public class | DnsServerDetailModel |
Public class | DynamicServiceEndpointModel |
Public class | EmailOptionsModel |
Public class | EmailTestModel |
Public class | EngineControlStatusModel |
Public class | EventLogModel |
Public class | ExtendedLowLevelStateModel |
Public class | FailbackOptionsModel |
Public class | FailoverOptionsModel |
Public class | FailoverScriptConfigurationModel |
Public class | FeatureModel |
Public class | FileItemModel |
Public class | FixJobOptionsRequestModel |
Public class | FixJobOptionsStatusModel |
Public class | FixRecommendedJobOptionsRequestModel |
Public class | FullServerFailoverOptionsModel |
Public class | FullServerJobDetailsModel |
Public class | FullServerNicMappingsModel |
Public class | ImageDeleteInfoModel |
Public class | ImageInfoModel |
Public class | ImageProtectionJobDetailsModel |
Public class | ImageProtectionOptionsModel |
Public class | ImageRecoveryJobDetailsModel |
Public class | ImageRecoveryOptionsModel |
Public class | ImageVhdInfoModel |
Public class | JobActionModel |
Public class | JobCredentialsModel |
Public class | JobInfoModel |
Public class | JobOptionsModel |
Public class | JobQualificationResultsModel |
Public class | JobStatisticsModel |
Public class | JobStatusModel |
Public class | LogicalItemModel |
Public class | LogicalVolumeModel |
Public class | LogMessageModel |
Public class | LvmOptionsModel |
Public class | MirrorParametersModel |
Public class | MonitorConfigurationModel |
Public class | MonitoredAddressConfigurationModel |
Public class | MonitoredAddressStatusModel |
Public class | MonitoringOptionsModel |
Public class | NetworkAddressMapModel |
Public class | NetworkInterfaceInfoModel |
Public class | NetworkInterfaceModel |
Public class | OperatingSystemModel |
Public class | OperatingSystemVersionModel |
Public class | OptionModel |
Public class | OrphansScheduleModel |
Public class | PathTransformationModel |
Public class | PhysicalItemModel |
Public class | PhysicalRuleModel |
Public class | PhysicalVolumeModel |
Public class | ProductInfoModel |
Public class | ProductVersionModel |
Public class | ProtectableItemModel |
Public class | RecommendedFailbackOptionsModel |
Public class | RecommendedFailoverOptionsModel |
Public class | RecommendedJobOptionsModel |
Public class | RecommendedJobOptionsRequestModel |
Public class | RecommendedRestoreOptionsModel |
Public class | ReplicaVmInfoModel |
Public class | RestoreOptionsModel |
Public class | RestoreParametersModel |
Public class | RunScriptRequestModel |
Public class | ScheduleItemModel |
Public class | ScriptPointModel |
Public class | ServerInfoModel |
Public class | ServerQualificationResultsModel |
Public class | ServiceConnectionModel |
Public class | ServiceInformationModel |
Public class | ServiceMetadataModel |
Public class | ServiceMonitoringOptionsModel |
Public class | ShareModel |
Public class | SimpleFailoverMonitorOptionsModel |
Public class | SnapshotEntryModel |
Public class | SnapshotScheduleModel |
Public class | SwitchPortInfoModel |
Public class | SystemStateOptionsModel |
Public class | TargetFileServerQualificationResultsModel |
Public class | TargetServicesOptionsModel |
Public class | TargetServicesToStopModel |
Public class | TargetStateInfoModel |
Public class | TestScriptRequestModel |
Public class | TimeWindowModel |
Public class | TransmissionScheduleModel |
Public class | UnicastIPAddressModel |
Public class | UnicastNetworkAddressInfoModel |
Public class | UnmanagedConnectionOptionsModel |
Public class | UpdateRecommendedJobOptionsRequestModel |
Public class | VcdVappOptionsModel |
Public class | VerificationStatusModel |
Public class | VerificationStepModel |
Public class | VerifyJobOptionsRequestModel |
Public class | VerifyScheduleModel |
Public class | VirtualNetworkInterfaceInfoModel |
Public class | VirtualSwitchInfoModel |
Public class | VirtualSwitchMappingModel |
Public class | VmInfoModel |
Public class | VolumeGroupModel |
Public class | VolumeModel |
Public class | VolumeOptionsModel |
Public class | VolumeQualificationResultsModel |
Public class | VraOptionsModel |
Public class | VraQualificationResultsModel |
Public class | VraWorkloadCustomizationOptionsModel |
Public class | WorkloadModel |
Public class | WorkloadSupportSummaryModel |
Public class | WorkloadTypeModel |
Enumerations
 | Enumeration | Description
Public enumeration | AccessLevelEnum |
Public enumeration | AceFlagsEnum |
Public enumeration | AceTypeEnum |
Public enumeration | ActionStatusEnum |
Public enumeration | ActiveDirectoryFailoverOptionsEnum |
Public enumeration | ActivityCompletionStatusEnum |
Public enumeration | ArchiveRestoreOptionEnum |
Public enumeration | BandwidthEntryTypeEnum |
Public enumeration | BandwidthScheduleModeEnum |
Public enumeration | BandwidthSpecificationTypeEnum |
Public enumeration | ClusterResourceStateEnum |
Public enumeration | DesktopInteractionModeEnum |
Public enumeration | EngineJobTypeEnum |
Public enumeration | FailoverAddressesOptionEnum |
Public enumeration | FailoverDataActionEnum |
Public enumeration | FailoverItemsEnum |
Public enumeration | FailoverModeEnum |
Public enumeration | FailoverProcessingOptionsEnum |
Public enumeration | FailoverReplaceActionsEnum |
Public enumeration | FailoverTriggerEnum |
Public enumeration | FailoverTypeEnum |
Public enumeration | FileSystemAttributesEnum |
Public enumeration | HealthEnum |
Public enumeration | HighAvailabilityStateEnum |
Public enumeration | HighLevelStateEnum |
Public enumeration | ImageTypeEnum |
Public enumeration | InclusionModeEnum |
Public enumeration | LicenseTypeEnum |
Public enumeration | MirrorComparisonCriteriaEnum |
Public enumeration | MirrorOperationOptionsEnum |
Public enumeration | MirrorStateEnum |
Public enumeration | OperatingSystemArchitectureEnum |
Public enumeration | OperatingSystemProductTypeEnum |
Public enumeration | PingMethodsEnum |
Public enumeration | RecursionModeEnum |
Public enumeration | ReplicationSetUsageTypeEnum |
Public enumeration | ReplicationStateEnum |
Public enumeration | RestoreOptionsEnum |
Public enumeration | RestoreStatesEnum |
Public enumeration | RestoreStatusEnum |
Public enumeration | SaturationLevelEnum |
Public enumeration | ScriptExecutionModeEnum |
Public enumeration | ScriptPointTypeEnum |
Public enumeration | SmtpConnectionSecurityEnum |
Public enumeration | SnapshotCreationReasonEnum |
Public enumeration | SsmRecoveryTypeEnum |
Public enumeration | TargetServiceStatusEnum |
Public enumeration | TargetStatesEnum |
Public enumeration | TransmissionModeEnum |
Public enumeration | VerificationStatusEnum |
Public enumeration | VhdDeleteActionTypeEnum |
Public enumeration | WeekdaysEnum |


AccessLevelEnum Enumeration

AccessLevelEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AccessLevelEnum
Public Enumeration AccessLevelEnum
public enum class AccessLevelEnum
type AccessLevelEnum
Members
Member name | Value | Description
Unknown | -1 |
NoAccess | 0 |
MonitorOnlyAccess | 1 |
FullAccess | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


AccessLevelModel Class

AccessLevelModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAccessLevelModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class AccessLevelModel
Public NotInheritable Class AccessLevelModel
public ref class AccessLevelModel sealed
[<SealedAttribute>]
type AccessLevelModel =  class end

The AccessLevelModel type exposes the following members.

Constructors
 | Name | Description
Public method | AccessLevelModel | Initializes a new instance of the AccessLevelModel class
Top
Properties
 | Name | Description
Public property | AccessLevel | the user's access level
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AccessLevelModel Constructor

AccessLevelModel Constructor
Initializes a new instance of the AccessLevelModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessLevelModel()
Public Sub New
public:
AccessLevelModel()
new : unit -> AccessLevelModel
See Also

Reference

AccessLevelModel Class


AccessLevelModel Properties

AccessLevelModel Properties

The AccessLevelModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessLevel | the user's access level
Top
See Also

Reference

AccessLevelModel Class


AccessLevelModel.AccessLevel Property

AccessLevelModelAccessLevel Property
the user's access level

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AccessLevelEnum AccessLevel { get; set; }
Public Property AccessLevel As AccessLevelEnum
    Get
    Set
public:
property AccessLevelEnum AccessLevel {
    AccessLevelEnum get ();
    void set (AccessLevelEnum value);
}
member AccessLevel : AccessLevelEnum with get, set

Property Value

Type: AccessLevelEnum
See Also

Reference

AccessLevelModel Class


AccessLevelModel Methods

AccessLevelModel Methods

The AccessLevelModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AccessLevelModel Class


AceFlagsEnum Enumeration

AceFlagsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AceFlagsEnum
<FlagsAttribute>
Public Enumeration AceFlagsEnum
[FlagsAttribute]
public enum class AceFlagsEnum
[<FlagsAttribute>]
type AceFlagsEnum
Members
Member name | Value | Description
ObjectInheritAce | 1 |
ContainerInheritAce | 2 |
NoPropogateInheritAce | 4 |
InheritOnlyAce | 8 |
InheritedAce | 16 |
See Also

Reference

DoubleTake.Web.Models Namespace


AceModel Class

AceModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAceModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class AceModel
Public NotInheritable Class AceModel
public ref class AceModel sealed
[<SealedAttribute>]
type AceModel =  class end

The AceModel type exposes the following members.

Constructors
 | Name | Description
Public method | AceModel | Initializes a new instance of the AceModel class
Top
Properties
 | Name | Description
Public property | AccessMask |
Public property | AceFlags |
Public property | AceType |
Public property | Domain |
Public property | Name |
Public property | Sid |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AceModel Constructor

AceModel Constructor
Initializes a new instance of the AceModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AceModel()
Public Sub New
public:
AceModel()
new : unit -> AceModel
See Also

Reference

AceModel Class


AceModel Properties

AceModel Properties

The AceModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessMask |
Public property | AceFlags |
Public property | AceType |
Public property | Domain |
Public property | Name |
Public property | Sid |
Top
See Also

Reference

AceModel Class


AceModel.AccessMask Property

AceModelAccessMask Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AccessMask { get; set; }
Public Property AccessMask As Integer
    Get
    Set
public:
property int AccessMask {
    int get ();
    void set (int value);
}
member AccessMask : int with get, set

Property Value

Type: Int32
See Also

Reference

AceModel Class


AceModel.AceFlags Property

AceModelAceFlags Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AceFlagsEnum AceFlags { get; set; }
Public Property AceFlags As AceFlagsEnum
    Get
    Set
public:
property AceFlagsEnum AceFlags {
    AceFlagsEnum get ();
    void set (AceFlagsEnum value);
}
member AceFlags : AceFlagsEnum with get, set

Property Value

Type: AceFlagsEnum
See Also

Reference

AceModel Class


AceModel.AceType Property

AceModelAceType Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public AceTypeEnum AceType { get; set; }
Public Property AceType As AceTypeEnum
    Get
    Set
public:
property AceTypeEnum AceType {
    AceTypeEnum get ();
    void set (AceTypeEnum value);
}
member AceType : AceTypeEnum with get, set

Property Value

Type: AceTypeEnum
See Also

Reference

AceModel Class


AceModel.Domain Property

AceModelDomain Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

AceModel Class


AceModel.Name Property

AceModelName Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

AceModel Class


AceModel.Sid Property

AceModelSid Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Sid { get; set; }
Public Property Sid As Byte()
    Get
    Set
public:
property array<unsigned char>^ Sid {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Sid : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

AceModel Class


AceModel Methods

AceModel Methods

The AceModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AceModel Class


AceTypeEnum Enumeration

AceTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum AceTypeEnum
Public Enumeration AceTypeEnum
public enum class AceTypeEnum
type AceTypeEnum
Members
Member name | Value | Description
AccessAllowed | 0 |
AccessDenied | 1 |
Audit | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ActionStatusEnum Enumeration

ActionStatusEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ActionStatusEnum
Public Enumeration ActionStatusEnum
public enum class ActionStatusEnum
type ActionStatusEnum
Members
Member name | Value | Description
Pending | 0 |
Running | 1 |
Completed | 2 |
Cancelled | 3 |
Faulted | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationAttributeModel Class

ActivationAttributeModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationAttributeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationAttributeModel
Public NotInheritable Class ActivationAttributeModel
public ref class ActivationAttributeModel sealed
[<SealedAttribute>]
type ActivationAttributeModel =  class end

The ActivationAttributeModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationAttributeModel | Initializes a new instance of the ActivationAttributeModel class
Top
Properties
 | Name | Description
Public property | Name | the name of this activation attribute
Public property | Value | the value of this activation attribute
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationAttributeModel Constructor

ActivationAttributeModel Constructor
Initializes a new instance of the ActivationAttributeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationAttributeModel()
Public Sub New
public:
ActivationAttributeModel()
new : unit -> ActivationAttributeModel
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel Properties

ActivationAttributeModel Properties

The ActivationAttributeModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | the name of this activation attribute
Public property | Value | the value of this activation attribute
Top
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel.Name Property

ActivationAttributeModelName Property
the name of this activation attribute

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel.Value Property

ActivationAttributeModelValue Property
the value of this activation attribute

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
member Value : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel Methods

ActivationAttributeModel Methods

The ActivationAttributeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationAttributeModel Class


ActivationCodeModel Class

ActivationCodeModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationCodeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationCodeModel
Public NotInheritable Class ActivationCodeModel
public ref class ActivationCodeModel sealed
[<SealedAttribute>]
type ActivationCodeModel =  class end

The ActivationCodeModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCodeModel | Initializes a new instance of the ActivationCodeModel class
Top
Properties
 | Name | Description
Public property | Attributes | the attributes of this activation code
Public property | Code | the text of the activation code
Public property | ExpirationDate | the expiration date of this activation code
Public property | IsEvaluation | a value indicating whether this activation code represents an evaluation license
Public property | IsExpired | a value indicating whether this activation code is expired
Public property | IsNodeLocked | a value indicating whether or not this activation code represents a node-locked license
Public property | IsValid | a value indicating whether or not this activation code is valid
Public property | LicenseType | the type of the license this activation code entitles the user to
Public property | MajorVersion | the major version of the release associated with this activation code
Public property | MinorVersion | the minor version of the release associated with this activation code
Public property | ProductCode | the product code associated with this activation code
Public property | ProductName | the name of the product associated with this activation code
Public property | SerialNumber | the serial number associated with this activation code
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationCodeModel Constructor

ActivationCodeModel Constructor
Initializes a new instance of the ActivationCodeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeModel()
Public Sub New
public:
ActivationCodeModel()
new : unit -> ActivationCodeModel
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel Properties

ActivationCodeModel Properties

The ActivationCodeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | the attributes of this activation code
Public property | Code | the text of the activation code
Public property | ExpirationDate | the expiration date of this activation code
Public property | IsEvaluation | a value indicating whether this activation code represents an evaluation license
Public property | IsExpired | a value indicating whether this activation code is expired
Public property | IsNodeLocked | a value indicating whether or not this activation code represents a node-locked license
Public property | IsValid | a value indicating whether or not this activation code is valid
Public property | LicenseType | the type of the license this activation code entitles the user to
Public property | MajorVersion | the major version of the release associated with this activation code
Public property | MinorVersion | the minor version of the release associated with this activation code
Public property | ProductCode | the product code associated with this activation code
Public property | ProductName | the name of the product associated with this activation code
Public property | SerialNumber | the serial number associated with this activation code
Top
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.Attributes Property

ActivationCodeModelAttributes Property
the attributes of this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationAttributeModel[] Attributes { get; set; }
Public Property Attributes As ActivationAttributeModel()
    Get
    Set
public:
property array<ActivationAttributeModel^>^ Attributes {
    array<ActivationAttributeModel^>^ get ();
    void set (array<ActivationAttributeModel^>^ value);
}
member Attributes : ActivationAttributeModel[] with get, set

Property Value

Type: ActivationAttributeModel
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.Code Property

ActivationCodeModelCode Property
the text of the activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.ExpirationDate Property

ActivationCodeModelExpirationDate Property
the expiration date of this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
member ExpirationDate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsEvaluation Property

ActivationCodeModelIsEvaluation Property
a value indicating whether this activation code represents an evaluation license

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEvaluation { get; set; }
Public Property IsEvaluation As Boolean
    Get
    Set
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}
member IsEvaluation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsExpired Property

ActivationCodeModelIsExpired Property
a value indicating whether this activation code is expired

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExpired { get; set; }
Public Property IsExpired As Boolean
    Get
    Set
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}
member IsExpired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsNodeLocked Property

ActivationCodeModelIsNodeLocked Property
a value indicating whether or not this activation code represents a node-locked license

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
member IsNodeLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsValid Property

ActivationCodeModelIsValid Property
a value indicating whether or not this activation code is valid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.LicenseType Property

ActivationCodeModelLicenseType Property
the type of the license this activation code entitles the user to

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LicenseTypeEnum LicenseType { get; set; }
Public Property LicenseType As LicenseTypeEnum
    Get
    Set
public:
property LicenseTypeEnum LicenseType {
    LicenseTypeEnum get ();
    void set (LicenseTypeEnum value);
}
member LicenseType : LicenseTypeEnum with get, set

Property Value

Type: LicenseTypeEnum
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.MajorVersion Property

ActivationCodeModelMajorVersion Property
the major version of the release associated with this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
member MajorVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.MinorVersion Property

ActivationCodeModelMinorVersion Property
the minor version of the release associated with this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
member MinorVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.ProductCode Property

ActivationCodeModelProductCode Property
the product code associated with this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
member ProductCode : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.ProductName Property

ActivationCodeModelProductName Property
the name of the product associated with this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
member ProductName : string with get, set

Property Value

Type: String
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.SerialNumber Property

ActivationCodeModelSerialNumber Property
the serial number associated with this activation code

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SerialNumber { get; set; }
Public Property SerialNumber As Integer
    Get
    Set
public:
property int SerialNumber {
    int get ();
    void set (int value);
}
member SerialNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel Methods

ActivationCodeModel Methods

The ActivationCodeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationCodeModel Class


ActivationStatusModel Class

ActivationStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationStatusModel
Public NotInheritable Class ActivationStatusModel
public ref class ActivationStatusModel sealed
[<SealedAttribute>]
type ActivationStatusModel =  class end

The ActivationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationStatusModel | Initializes a new instance of the ActivationStatusModel class
Top
Properties
 | Name | Description
Public property | AddOnCodes | the current add-on codes on this server
Public property | Codes | the current activation codes on this server
Public property | IsNodeLocked | a value indicating whether or not the license on this server is node locked
Public property | IsValid | a value indicating whether the license on this server is valid
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationStatusModel Constructor

ActivationStatusModel Constructor
Initializes a new instance of the ActivationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusModel()
Public Sub New
public:
ActivationStatusModel()
new : unit -> ActivationStatusModel
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel Properties

ActivationStatusModel Properties

The ActivationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | AddOnCodes | the current add-on codes on this server
Public property | Codes | the current activation codes on this server
Public property | IsNodeLocked | a value indicating whether or not the license on this server is node locked
Public property | IsValid | a value indicating whether the license on this server is valid
Top
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.AddOnCodes Property

ActivationStatusModelAddOnCodes Property
the current add-on codes on this server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeModel[] AddOnCodes { get; set; }
Public Property AddOnCodes As ActivationCodeModel()
    Get
    Set
public:
property array<ActivationCodeModel^>^ AddOnCodes {
    array<ActivationCodeModel^>^ get ();
    void set (array<ActivationCodeModel^>^ value);
}
member AddOnCodes : ActivationCodeModel[] with get, set

Property Value

Type: ActivationCodeModel
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.Codes Property

ActivationStatusModelCodes Property
the current activation codes on this server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeModel[] Codes { get; set; }
Public Property Codes As ActivationCodeModel()
    Get
    Set
public:
property array<ActivationCodeModel^>^ Codes {
    array<ActivationCodeModel^>^ get ();
    void set (array<ActivationCodeModel^>^ value);
}
member Codes : ActivationCodeModel[] with get, set

Property Value

Type: ActivationCodeModel
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.IsNodeLocked Property

ActivationStatusModelIsNodeLocked Property
a value indicating whether or not the license on this server is node locked

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
member IsNodeLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.IsValid Property

ActivationStatusModelIsValid Property
a value indicating whether the license on this server is valid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel Methods

ActivationStatusModel Methods

The ActivationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationStatusModel Class


ActiveDirectoryFailoverOptionsEnum Enumeration

ActiveDirectoryFailoverOptionsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ActiveDirectoryFailoverOptionsEnum
<FlagsAttribute>
Public Enumeration ActiveDirectoryFailoverOptionsEnum
[FlagsAttribute]
public enum class ActiveDirectoryFailoverOptionsEnum
[<FlagsAttribute>]
type ActiveDirectoryFailoverOptionsEnum
Members
Member name | Value | Description
None | 0 |
FailoverHostName | 1 |
FailbackHostName | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityCompletionStatusEnum Enumeration

ActivityCompletionStatusEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ActivityCompletionStatusEnum
Public Enumeration ActivityCompletionStatusEnum
public enum class ActivityCompletionStatusEnum
type ActivityCompletionStatusEnum
Members
Member name | Value | Description
Pending | 0 |
Running | 1 |
Completed | 2 |
Canceled | 3 |
Faulted | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityStatusModel Class

ActivityStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityStatusModel
DoubleTake.Web.ModelsFixJobOptionsStatusModel
DoubleTake.Web.ModelsVerificationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class ActivityStatusModel
Public Class ActivityStatusModel
public ref class ActivityStatusModel
type ActivityStatusModel =  class end

The ActivityStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityStatusModel | Initializes a new instance of the ActivityStatusModel class
Top
Properties
 | Name | Description
Public property | Duration | a value the duration of the activity at the time this status was yielded
Public property | MessageFormatParameters | the message format parameters
Public property | MessageId | a value representing a message identifier
Public property | RequesterUserName | the user that initiated the activity
Public property | Status | the current status of the activity
Public property | StatusUri | the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'
Public property | TimeStamp | the server time when the activity yielded this status
Public property | Token | a token that identifies the request that initiated the activity
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityStatusModel Constructor

ActivityStatusModel Constructor
Initializes a new instance of the ActivityStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityStatusModel()
Public Sub New
public:
ActivityStatusModel()
new : unit -> ActivityStatusModel
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel Properties

ActivityStatusModel Properties

The ActivityStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | a value the duration of the activity at the time this status was yielded
Public property | MessageFormatParameters | the message format parameters
Public property | MessageId | a value representing a message identifier
Public property | RequesterUserName | the user that initiated the activity
Public property | Status | the current status of the activity
Public property | StatusUri | the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'
Public property | TimeStamp | the server time when the activity yielded this status
Public property | Token | a token that identifies the request that initiated the activity
Top
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.Duration Property

ActivityStatusModelDuration Property
a value the duration of the activity at the time this status was yielded

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Duration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.MessageFormatParameters Property

ActivityStatusModelMessageFormatParameters Property
the message format parameters

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.MessageId Property

ActivityStatusModelMessageId Property
a value representing a message identifier

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
member MessageId : string with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.RequesterUserName Property

ActivityStatusModelRequesterUserName Property
the user that initiated the activity

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RequesterUserName { get; set; }
Public Property RequesterUserName As String
    Get
    Set
public:
property String^ RequesterUserName {
    String^ get ();
    void set (String^ value);
}
member RequesterUserName : string with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.Status Property

ActivityStatusModelStatus Property
the current status of the activity

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityCompletionStatusEnum Status { get; set; }
Public Property Status As ActivityCompletionStatusEnum
    Get
    Set
public:
property ActivityCompletionStatusEnum Status {
    ActivityCompletionStatusEnum get ();
    void set (ActivityCompletionStatusEnum value);
}
member Status : ActivityCompletionStatusEnum with get, set

Property Value

Type: ActivityCompletionStatusEnum
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.StatusUri Property

ActivityStatusModelStatusUri Property
the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StatusUri { get; set; }
Public Property StatusUri As String
    Get
    Set
public:
property String^ StatusUri {
    String^ get ();
    void set (String^ value);
}
member StatusUri : string with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.TimeStamp Property

ActivityStatusModelTimeStamp Property
the server time when the activity yielded this status

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimeStamp { get; set; }
Public Property TimeStamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeStamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimeStamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.Token Property

ActivityStatusModelToken Property
a token that identifies the request that initiated the activity

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityTokenModel Token { get; set; }
Public Property Token As ActivityTokenModel
    Get
    Set
public:
property ActivityTokenModel^ Token {
    ActivityTokenModel^ get ();
    void set (ActivityTokenModel^ value);
}
member Token : ActivityTokenModel with get, set

Property Value

Type: ActivityTokenModel
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel Methods

ActivityStatusModel Methods

The ActivityStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivityStatusModel Class


ActivityTokenModel Class

ActivityTokenModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityTokenModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivityTokenModel
Public NotInheritable Class ActivityTokenModel
public ref class ActivityTokenModel sealed
[<SealedAttribute>]
type ActivityTokenModel =  class end

The ActivityTokenModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityTokenModel | Initializes a new instance of the ActivityTokenModel class
Top
Properties
 | Name | Description
Public property | ActivityNameFormatParameters | the activity name format parameters
Public property | ActivityNameId | the activity name id
Public property | Id | the unique identifier of this token
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityTokenModel Constructor

ActivityTokenModel Constructor
Initializes a new instance of the ActivityTokenModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityTokenModel()
Public Sub New
public:
ActivityTokenModel()
new : unit -> ActivityTokenModel
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel Properties

ActivityTokenModel Properties

The ActivityTokenModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivityNameFormatParameters | the activity name format parameters
Public property | ActivityNameId | the activity name id
Public property | Id | the unique identifier of this token
Top
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel.ActivityNameFormatParameters Property

ActivityTokenModelActivityNameFormatParameters Property
the activity name format parameters

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ActivityNameFormatParameters { get; set; }
Public Property ActivityNameFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ActivityNameFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ActivityNameFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel.ActivityNameId Property

ActivityTokenModelActivityNameId Property
the activity name id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ActivityNameId { get; set; }
Public Property ActivityNameId As String
    Get
    Set
public:
property String^ ActivityNameId {
    String^ get ();
    void set (String^ value);
}
member ActivityNameId : string with get, set

Property Value

Type: String
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel.Id Property

ActivityTokenModelId Property
the unique identifier of this token

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel Methods

ActivityTokenModel Methods

The ActivityTokenModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivityTokenModel Class


ApplicationOptionsModel Class

ApplicationOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsApplicationOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ApplicationOptionsModel
Public NotInheritable Class ApplicationOptionsModel
public ref class ApplicationOptionsModel sealed
[<SealedAttribute>]
type ApplicationOptionsModel =  class end

The ApplicationOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationOptionsModel | Initializes a new instance of the ApplicationOptionsModel class
Top
Properties
 | Name | Description
Public property | AagInstances | aag instances
Public property | DagTargetPublicFolderDataPath | dag target public folder data path
Public property | DnsRecordLocks | the DNS record locks
Public property | ExchangeCredentials | the exchange credentials
Public property | IsAag | is aag
Public property | IsDag | is dag
Public property | MonitorScript | monitor script
Public property | SourceDomain | the source server's primary domain
Public property | SourceName | source name
Public property | TargetDomain | the target server's primary domain
Public property | TargetName | target name
Public property | TestPostFailoverScript | script to run after target is brought online during a test failover (TDV)
Public property | TestPostFailoverScriptArguments | arguments for script to run after target is brought online during a test failover (TDV)
Public property | TestPreFailbackScript | script to run before failing back after a test failover (TDV)
Public property | TestPreFailbackScriptArguments | arguments for script to run before failing back after a test failover (TDV)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ApplicationOptionsModel Constructor

ApplicationOptionsModel Constructor
Initializes a new instance of the ApplicationOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ApplicationOptionsModel()
Public Sub New
public:
ApplicationOptionsModel()
new : unit -> ApplicationOptionsModel
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel Properties

ApplicationOptionsModel Properties

The ApplicationOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AagInstances | aag instances
Public property | DagTargetPublicFolderDataPath | dag target public folder data path
Public property | DnsRecordLocks | the DNS record locks
Public property | ExchangeCredentials | the exchange credentials
Public property | IsAag | is aag
Public property | IsDag | is dag
Public property | MonitorScript | monitor script
Public property | SourceDomain | the source server's primary domain
Public property | SourceName | source name
Public property | TargetDomain | the target server's primary domain
Public property | TargetName | target name
Public property | TestPostFailoverScript | script to run after target is brought online during a test failover (TDV)
Public property | TestPostFailoverScriptArguments | arguments for script to run after target is brought online during a test failover (TDV)
Public property | TestPreFailbackScript | script to run before failing back after a test failover (TDV)
Public property | TestPreFailbackScriptArguments | arguments for script to run before failing back after a test failover (TDV)
Top
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.AagInstances Property

ApplicationOptionsModelAagInstances Property
aag instances

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> AagInstances { get; set; }
Public Property AagInstances As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AagInstances {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member AagInstances : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.DagTargetPublicFolderDataPath Property

ApplicationOptionsModelDagTargetPublicFolderDataPath Property
dag target public folder data path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DagTargetPublicFolderDataPath { get; set; }
Public Property DagTargetPublicFolderDataPath As String
    Get
    Set
public:
property String^ DagTargetPublicFolderDataPath {
    String^ get ();
    void set (String^ value);
}
member DagTargetPublicFolderDataPath : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.DnsRecordLocks Property

ApplicationOptionsModelDnsRecordLocks Property
the DNS record locks

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DnsRecordLockOptionsModel> DnsRecordLocks { get; set; }
Public Property DnsRecordLocks As IEnumerable(Of DnsRecordLockOptionsModel)
    Get
    Set
public:
property IEnumerable<DnsRecordLockOptionsModel^>^ DnsRecordLocks {
    IEnumerable<DnsRecordLockOptionsModel^>^ get ();
    void set (IEnumerable<DnsRecordLockOptionsModel^>^ value);
}
member DnsRecordLocks : IEnumerable<DnsRecordLockOptionsModel> with get, set

Property Value

Type: IEnumerable DnsRecordLockOptionsModel
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.ExchangeCredentials Property

ApplicationOptionsModelExchangeCredentials Property
the exchange credentials

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel ExchangeCredentials { get; set; }
Public Property ExchangeCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ ExchangeCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member ExchangeCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.IsAag Property

ApplicationOptionsModelIsAag Property
is aag

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAag { get; set; }
Public Property IsAag As Boolean
    Get
    Set
public:
property bool IsAag {
    bool get ();
    void set (bool value);
}
member IsAag : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.IsDag Property

ApplicationOptionsModelIsDag Property
is dag

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDag { get; set; }
Public Property IsDag As Boolean
    Get
    Set
public:
property bool IsDag {
    bool get ();
    void set (bool value);
}
member IsDag : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.MonitorScript Property

ApplicationOptionsModelMonitorScript Property
monitor script

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MonitorScript { get; set; }
Public Property MonitorScript As String
    Get
    Set
public:
property String^ MonitorScript {
    String^ get ();
    void set (String^ value);
}
member MonitorScript : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.SourceDomain Property

ApplicationOptionsModelSourceDomain Property
the source server's primary domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceDomain { get; set; }
Public Property SourceDomain As String
    Get
    Set
public:
property String^ SourceDomain {
    String^ get ();
    void set (String^ value);
}
member SourceDomain : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.SourceName Property

ApplicationOptionsModelSourceName Property
source name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
member SourceName : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TargetDomain Property

ApplicationOptionsModelTargetDomain Property
the target server's primary domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetDomain { get; set; }
Public Property TargetDomain As String
    Get
    Set
public:
property String^ TargetDomain {
    String^ get ();
    void set (String^ value);
}
member TargetDomain : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TargetName Property

ApplicationOptionsModelTargetName Property
target name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
member TargetName : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPostFailoverScript Property

ApplicationOptionsModelTestPostFailoverScript Property
script to run after target is brought online during a test failover (TDV)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPostFailoverScript { get; set; }
Public Property TestPostFailoverScript As String
    Get
    Set
public:
property String^ TestPostFailoverScript {
    String^ get ();
    void set (String^ value);
}
member TestPostFailoverScript : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPostFailoverScriptArguments Property

ApplicationOptionsModelTestPostFailoverScriptArguments Property
arguments for script to run after target is brought online during a test failover (TDV)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPostFailoverScriptArguments { get; set; }
Public Property TestPostFailoverScriptArguments As String
    Get
    Set
public:
property String^ TestPostFailoverScriptArguments {
    String^ get ();
    void set (String^ value);
}
member TestPostFailoverScriptArguments : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPreFailbackScript Property

ApplicationOptionsModelTestPreFailbackScript Property
script to run before failing back after a test failover (TDV)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPreFailbackScript { get; set; }
Public Property TestPreFailbackScript As String
    Get
    Set
public:
property String^ TestPreFailbackScript {
    String^ get ();
    void set (String^ value);
}
member TestPreFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPreFailbackScriptArguments Property

ApplicationOptionsModelTestPreFailbackScriptArguments Property
arguments for script to run before failing back after a test failover (TDV)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPreFailbackScriptArguments { get; set; }
Public Property TestPreFailbackScriptArguments As String
    Get
    Set
public:
property String^ TestPreFailbackScriptArguments {
    String^ get ();
    void set (String^ value);
}
member TestPreFailbackScriptArguments : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel Methods

ApplicationOptionsModel Methods

The ApplicationOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ApplicationOptionsModel Class


ArchiveCriteriaModel Class

ArchiveCriteriaModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsArchiveCriteriaModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ArchiveCriteriaModel
Public NotInheritable Class ArchiveCriteriaModel
public ref class ArchiveCriteriaModel sealed
[<SealedAttribute>]
type ArchiveCriteriaModel =  class end

The ArchiveCriteriaModel type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveCriteriaModel | Initializes a new instance of the ArchiveCriteriaModel class
Top
Properties
 | Name | Description
Public property | Age | the age
Public property | DiskUtilizationPercentage | the disk utilization as a percentage
Public property | LogErrors | the log errors
Public property | MinimumFileSize | the minimum file size
Public property | Paths | the paths
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ArchiveCriteriaModel Constructor

ArchiveCriteriaModel Constructor
Initializes a new instance of the ArchiveCriteriaModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveCriteriaModel()
Public Sub New
public:
ArchiveCriteriaModel()
new : unit -> ArchiveCriteriaModel
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel Properties

ArchiveCriteriaModel Properties

The ArchiveCriteriaModel type exposes the following members.

Properties
 | Name | Description
Public property | Age | the age
Public property | DiskUtilizationPercentage | the disk utilization as a percentage
Public property | LogErrors | the log errors
Public property | MinimumFileSize | the minimum file size
Public property | Paths | the paths
Top
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.Age Property

ArchiveCriteriaModelAge Property
the age

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Age { get; set; }
Public Property Age As TimeSpan
    Get
    Set
public:
property TimeSpan Age {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Age : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.DiskUtilizationPercentage Property

ArchiveCriteriaModelDiskUtilizationPercentage Property
the disk utilization as a percentage

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int DiskUtilizationPercentage { get; set; }
Public Property DiskUtilizationPercentage As Integer
    Get
    Set
public:
property int DiskUtilizationPercentage {
    int get ();
    void set (int value);
}
member DiskUtilizationPercentage : int with get, set

Property Value

Type: Int32
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.LogErrors Property

ArchiveCriteriaModelLogErrors Property
the log errors

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LogErrors { get; set; }
Public Property LogErrors As Boolean
    Get
    Set
public:
property bool LogErrors {
    bool get ();
    void set (bool value);
}
member LogErrors : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.MinimumFileSize Property

ArchiveCriteriaModelMinimumFileSize Property
the minimum file size

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MinimumFileSize { get; set; }
Public Property MinimumFileSize As Long
    Get
    Set
public:
property long long MinimumFileSize {
    long long get ();
    void set (long long value);
}
member MinimumFileSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.Paths Property

ArchiveCriteriaModelPaths Property
the paths

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Paths : string[] with get, set

Property Value

Type: String
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel Methods

ArchiveCriteriaModel Methods

The ArchiveCriteriaModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArchiveCriteriaModel Class


ArchiveRestoreOptionEnum Enumeration

ArchiveRestoreOptionEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ArchiveRestoreOptionEnum
Public Enumeration ArchiveRestoreOptionEnum
public enum class ArchiveRestoreOptionEnum
type ArchiveRestoreOptionEnum
Members
Member name | Value | Description
None | 0 |
ArchiveBeforeRestore | 1 |
RecallBeforeRestore | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ArchiveScheduleModel Class

ArchiveScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsArchiveScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ArchiveScheduleModel : ScheduleItemModel
Public NotInheritable Class ArchiveScheduleModel
    Inherits ScheduleItemModel
public ref class ArchiveScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type ArchiveScheduleModel =
    class
        inherit ScheduleItemModel
    end

The ArchiveScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveScheduleModel | Initializes a new instance of the ArchiveScheduleModel class
Top
Properties
 | Name | Description
Public property | Criteria | the archive criteria
Public property | Days | the days to run the archive
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | StartTime | the start time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ArchiveScheduleModel Constructor

ArchiveScheduleModel Constructor
Initializes a new instance of the ArchiveScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveScheduleModel()
Public Sub New
public:
ArchiveScheduleModel()
new : unit -> ArchiveScheduleModel
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel Properties

ArchiveScheduleModel Properties

The ArchiveScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Criteria | the archive criteria
Public property | Days | the days to run the archive
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | StartTime | the start time
Top
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel.Criteria Property

ArchiveScheduleModelCriteria Property
the archive criteria

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveCriteriaModel Criteria { get; set; }
Public Property Criteria As ArchiveCriteriaModel
    Get
    Set
public:
property ArchiveCriteriaModel^ Criteria {
    ArchiveCriteriaModel^ get ();
    void set (ArchiveCriteriaModel^ value);
}
member Criteria : ArchiveCriteriaModel with get, set

Property Value

Type: ArchiveCriteriaModel
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel.Days Property

ArchiveScheduleModelDays Property
the days to run the archive

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WeekdaysEnum Days { get; set; }
Public Property Days As WeekdaysEnum
    Get
    Set
public:
property WeekdaysEnum Days {
    WeekdaysEnum get ();
    void set (WeekdaysEnum value);
}
member Days : WeekdaysEnum with get, set

Property Value

Type: WeekdaysEnum
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel.StartTime Property

ArchiveScheduleModelStartTime Property
the start time

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel Methods

ArchiveScheduleModel Methods

The ArchiveScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArchiveScheduleModel Class


BandwidthEntryModel Class

BandwidthEntryModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthEntryModel
Public NotInheritable Class BandwidthEntryModel
public ref class BandwidthEntryModel sealed
[<SealedAttribute>]
type BandwidthEntryModel =  class end

The BandwidthEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthEntryModel | Initializes a new instance of the BandwidthEntryModel class
Top
Properties
 | Name | Description
Public property | DaysOfWeek | the days of the week to which the entry applies
Public property | EndTime | the end time of the entry
Public property | EntryType | the type of the entry
Public property | IsUnlimited | a value indicating whether or not this entry allows unlimited bandwidth
Public property | Limit | the bandwidth limit for the entry, in bytes per second.
Public property | Name | the name of the bandwidth schedule entry
Public property | StartTime | the start time of the entry
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthEntryModel Constructor

BandwidthEntryModel Constructor
Initializes a new instance of the BandwidthEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthEntryModel()
Public Sub New
public:
BandwidthEntryModel()
new : unit -> BandwidthEntryModel
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel Properties

BandwidthEntryModel Properties

The BandwidthEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | the days of the week to which the entry applies
Public property | EndTime | the end time of the entry
Public property | EntryType | the type of the entry
Public property | IsUnlimited | a value indicating whether or not this entry allows unlimited bandwidth
Public property | Limit | the bandwidth limit for the entry, in bytes per second.
Public property | Name | the name of the bandwidth schedule entry
Public property | StartTime | the start time of the entry
Top
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.DaysOfWeek Property

BandwidthEntryModelDaysOfWeek Property
the days of the week to which the entry applies

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WeekdaysEnum DaysOfWeek { get; set; }
Public Property DaysOfWeek As WeekdaysEnum
    Get
    Set
public:
property WeekdaysEnum DaysOfWeek {
    WeekdaysEnum get ();
    void set (WeekdaysEnum value);
}
member DaysOfWeek : WeekdaysEnum with get, set

Property Value

Type: WeekdaysEnum
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.EndTime Property

BandwidthEntryModelEndTime Property
the end time of the entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}
member EndTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.EntryType Property

BandwidthEntryModelEntryType Property
the type of the entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthEntryTypeEnum EntryType { get; set; }
Public Property EntryType As BandwidthEntryTypeEnum
    Get
    Set
public:
property BandwidthEntryTypeEnum EntryType {
    BandwidthEntryTypeEnum get ();
    void set (BandwidthEntryTypeEnum value);
}
member EntryType : BandwidthEntryTypeEnum with get, set

Property Value

Type: BandwidthEntryTypeEnum
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.IsUnlimited Property

BandwidthEntryModelIsUnlimited Property
a value indicating whether or not this entry allows unlimited bandwidth

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
member IsUnlimited : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.Limit Property

BandwidthEntryModelLimit Property
the bandwidth limit for the entry, in bytes per second.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.Name Property

BandwidthEntryModelName Property
the name of the bandwidth schedule entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.StartTime Property

BandwidthEntryModelStartTime Property
the start time of the entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel Methods

BandwidthEntryModel Methods

The BandwidthEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryTypeEnum Enumeration

BandwidthEntryTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BandwidthEntryTypeEnum
Public Enumeration BandwidthEntryTypeEnum
public enum class BandwidthEntryTypeEnum
type BandwidthEntryTypeEnum
Members
Member name | Value | Description
Daytime | 0 |
Overnight | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthOptionsModel Class

BandwidthOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthOptionsModel
Public NotInheritable Class BandwidthOptionsModel
public ref class BandwidthOptionsModel sealed
[<SealedAttribute>]
type BandwidthOptionsModel =  class end

The BandwidthOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthOptionsModel | Initializes a new instance of the BandwidthOptionsModel class
Top
Properties
 | Name | Description
Public property | Entries | the entries in the bandwidth limiting schedule
Public property | Limit | the bandwidth limit, in bytes per second
Public property | Mode | the mode of the bandwidth schedule
Public property | Specifications | the common bandwidth specifications, such as T1 or ISDN
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthOptionsModel Constructor

BandwidthOptionsModel Constructor
Initializes a new instance of the BandwidthOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthOptionsModel()
Public Sub New
public:
BandwidthOptionsModel()
new : unit -> BandwidthOptionsModel
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel Properties

BandwidthOptionsModel Properties

The BandwidthOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | Entries | the entries in the bandwidth limiting schedule
Public property | Limit | the bandwidth limit, in bytes per second
Public property | Mode | the mode of the bandwidth schedule
Public property | Specifications | the common bandwidth specifications, such as T1 or ISDN
Top
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Entries Property

BandwidthOptionsModelEntries Property
the entries in the bandwidth limiting schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthEntryModel[] Entries { get; set; }
Public Property Entries As BandwidthEntryModel()
    Get
    Set
public:
property array<BandwidthEntryModel^>^ Entries {
    array<BandwidthEntryModel^>^ get ();
    void set (array<BandwidthEntryModel^>^ value);
}
member Entries : BandwidthEntryModel[] with get, set

Property Value

Type: BandwidthEntryModel
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Limit Property

BandwidthOptionsModelLimit Property
the bandwidth limit, in bytes per second

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Mode Property

BandwidthOptionsModelMode Property
the mode of the bandwidth schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleModeEnum Mode { get; set; }
Public Property Mode As BandwidthScheduleModeEnum
    Get
    Set
public:
property BandwidthScheduleModeEnum Mode {
    BandwidthScheduleModeEnum get ();
    void set (BandwidthScheduleModeEnum value);
}
member Mode : BandwidthScheduleModeEnum with get, set

Property Value

Type: BandwidthScheduleModeEnum
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Specifications Property

BandwidthOptionsModelSpecifications Property
the common bandwidth specifications, such as T1 or ISDN

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationModel[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecificationModel()
    Get
    Set
public:
property array<BandwidthSpecificationModel^>^ Specifications {
    array<BandwidthSpecificationModel^>^ get ();
    void set (array<BandwidthSpecificationModel^>^ value);
}
member Specifications : BandwidthSpecificationModel[] with get, set

Property Value

Type: BandwidthSpecificationModel
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel Methods

BandwidthOptionsModel Methods

The BandwidthOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthOptionsModel Class


BandwidthScheduleEntryModel Class

BandwidthScheduleEntryModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthScheduleEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthScheduleEntryModel
Public NotInheritable Class BandwidthScheduleEntryModel
public ref class BandwidthScheduleEntryModel sealed
[<SealedAttribute>]
type BandwidthScheduleEntryModel =  class end

The BandwidthScheduleEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthScheduleEntryModel | Initializes a new instance of the BandwidthScheduleEntryModel class
Top
Properties
 | Name | Description
Public property | DaysOfWeek | indicates the days on which this entry will be active
Public property | IsUnlimited | a value indicating whether or not bandwidth is being limited while this entry is active
Public property | Limit | the network throughput limit in Bps (bytes-per-second)
Public property | Name | the unique name of this entry
Public property | StartTime | indicates time of day at which this entry will be active
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthScheduleEntryModel Constructor

BandwidthScheduleEntryModel Constructor
Initializes a new instance of the BandwidthScheduleEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleEntryModel()
Public Sub New
public:
BandwidthScheduleEntryModel()
new : unit -> BandwidthScheduleEntryModel
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel Properties

BandwidthScheduleEntryModel Properties

The BandwidthScheduleEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | indicates the days on which this entry will be active
Public property | IsUnlimited | a value indicating whether or not bandwidth is being limited while this entry is active
Public property | Limit | the network throughput limit in Bps (bytes-per-second)
Public property | Name | the unique name of this entry
Public property | StartTime | indicates time of day at which this entry will be active
Top
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.DaysOfWeek Property

BandwidthScheduleEntryModelDaysOfWeek Property
indicates the days on which this entry will be active

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WeekdaysEnum DaysOfWeek { get; set; }
Public Property DaysOfWeek As WeekdaysEnum
    Get
    Set
public:
property WeekdaysEnum DaysOfWeek {
    WeekdaysEnum get ();
    void set (WeekdaysEnum value);
}
member DaysOfWeek : WeekdaysEnum with get, set

Property Value

Type: WeekdaysEnum
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.IsUnlimited Property

BandwidthScheduleEntryModelIsUnlimited Property
a value indicating whether or not bandwidth is being limited while this entry is active

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
member IsUnlimited : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.Limit Property

BandwidthScheduleEntryModelLimit Property
the network throughput limit in Bps (bytes-per-second)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.Name Property

BandwidthScheduleEntryModelName Property
the unique name of this entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.StartTime Property

BandwidthScheduleEntryModelStartTime Property
indicates time of day at which this entry will be active

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel Methods

BandwidthScheduleEntryModel Methods

The BandwidthScheduleEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleModeEnum Enumeration

BandwidthScheduleModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BandwidthScheduleModeEnum
Public Enumeration BandwidthScheduleModeEnum
public enum class BandwidthScheduleModeEnum
type BandwidthScheduleModeEnum
Members
Member name | Value | Description
NotLimited | 0 |
Fixed | 1 |
Scheduled | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthScheduleModel Class

BandwidthScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthScheduleModel
Public NotInheritable Class BandwidthScheduleModel
public ref class BandwidthScheduleModel sealed
[<SealedAttribute>]
type BandwidthScheduleModel =  class end

The BandwidthScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthScheduleModel | Initializes a new instance of the BandwidthScheduleModel class
Top
Properties
 | Name | Description
Public property | Current | the active bandwidth schedule entry
Public property | Entries | the bandwidth schedule entries
Public property | Mode | the current bandwidth schedule mode for a connection
Public property | Specifications | the bandwidth specifications
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthScheduleModel Constructor

BandwidthScheduleModel Constructor
Initializes a new instance of the BandwidthScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleModel()
Public Sub New
public:
BandwidthScheduleModel()
new : unit -> BandwidthScheduleModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel Properties

BandwidthScheduleModel Properties

The BandwidthScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Current | the active bandwidth schedule entry
Public property | Entries | the bandwidth schedule entries
Public property | Mode | the current bandwidth schedule mode for a connection
Public property | Specifications | the bandwidth specifications
Top
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Current Property

BandwidthScheduleModelCurrent Property
the active bandwidth schedule entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleEntryModel Current { get; set; }
Public Property Current As BandwidthScheduleEntryModel
    Get
    Set
public:
property BandwidthScheduleEntryModel^ Current {
    BandwidthScheduleEntryModel^ get ();
    void set (BandwidthScheduleEntryModel^ value);
}
member Current : BandwidthScheduleEntryModel with get, set

Property Value

Type: BandwidthScheduleEntryModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Entries Property

BandwidthScheduleModelEntries Property
the bandwidth schedule entries

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleEntryModel[] Entries { get; set; }
Public Property Entries As BandwidthScheduleEntryModel()
    Get
    Set
public:
property array<BandwidthScheduleEntryModel^>^ Entries {
    array<BandwidthScheduleEntryModel^>^ get ();
    void set (array<BandwidthScheduleEntryModel^>^ value);
}
member Entries : BandwidthScheduleEntryModel[] with get, set

Property Value

Type: BandwidthScheduleEntryModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Mode Property

BandwidthScheduleModelMode Property
the current bandwidth schedule mode for a connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleModeEnum Mode { get; set; }
Public Property Mode As BandwidthScheduleModeEnum
    Get
    Set
public:
property BandwidthScheduleModeEnum Mode {
    BandwidthScheduleModeEnum get ();
    void set (BandwidthScheduleModeEnum value);
}
member Mode : BandwidthScheduleModeEnum with get, set

Property Value

Type: BandwidthScheduleModeEnum
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Specifications Property

BandwidthScheduleModelSpecifications Property
the bandwidth specifications

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationModel[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecificationModel()
    Get
    Set
public:
property array<BandwidthSpecificationModel^>^ Specifications {
    array<BandwidthSpecificationModel^>^ get ();
    void set (array<BandwidthSpecificationModel^>^ value);
}
member Specifications : BandwidthSpecificationModel[] with get, set

Property Value

Type: BandwidthSpecificationModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel Methods

BandwidthScheduleModel Methods

The BandwidthScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthScheduleModel Class


BandwidthSpecificationModel Class

BandwidthSpecificationModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthSpecificationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthSpecificationModel
Public NotInheritable Class BandwidthSpecificationModel
public ref class BandwidthSpecificationModel sealed
[<SealedAttribute>]
type BandwidthSpecificationModel =  class end

The BandwidthSpecificationModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthSpecificationModel | Initializes a new instance of the BandwidthSpecificationModel class
Top
Properties
 | Name | Description
Public property | BandwidthType | the type of the bandwidth specification
Public property | Key | the name of the bandwidth specification
Public property | Value | the speed of the bandwidth specification, in bytes per second
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthSpecificationModel Constructor

BandwidthSpecificationModel Constructor
Initializes a new instance of the BandwidthSpecificationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationModel()
Public Sub New
public:
BandwidthSpecificationModel()
new : unit -> BandwidthSpecificationModel
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel Properties

BandwidthSpecificationModel Properties

The BandwidthSpecificationModel type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthType | the type of the bandwidth specification
Public property | Key | the name of the bandwidth specification
Public property | Value | the speed of the bandwidth specification, in bytes per second
Top
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel.BandwidthType Property

BandwidthSpecificationModelBandwidthType Property
the type of the bandwidth specification

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationTypeEnum BandwidthType { get; set; }
Public Property BandwidthType As BandwidthSpecificationTypeEnum
    Get
    Set
public:
property BandwidthSpecificationTypeEnum BandwidthType {
    BandwidthSpecificationTypeEnum get ();
    void set (BandwidthSpecificationTypeEnum value);
}
member BandwidthType : BandwidthSpecificationTypeEnum with get, set

Property Value

Type: BandwidthSpecificationTypeEnum
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel.Key Property

BandwidthSpecificationModelKey Property
the name of the bandwidth specification

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
member Key : string with get, set

Property Value

Type: String
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel.Value Property

BandwidthSpecificationModelValue Property
the speed of the bandwidth specification, in bytes per second

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
member Value : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel Methods

BandwidthSpecificationModel Methods

The BandwidthSpecificationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationTypeEnum Enumeration

BandwidthSpecificationTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum BandwidthSpecificationTypeEnum
Public Enumeration BandwidthSpecificationTypeEnum
public enum class BandwidthSpecificationTypeEnum
type BandwidthSpecificationTypeEnum
Members
Member name | Value | Description
LAN | 0 |
WAN | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


ChangedItemsModel Class

ChangedItemsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsChangedItemsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ChangedItemsModel
Public NotInheritable Class ChangedItemsModel
public ref class ChangedItemsModel sealed
[<SealedAttribute>]
type ChangedItemsModel =  class end

The ChangedItemsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedItemsModel | Initializes a new instance of the ChangedItemsModel class
Top
Properties
 | Name | Description
Public property | LogicalItems | the logical items that changed
Public property | LogicalRules | the new set of logical rules associated with this workload
Public property | PhysicalItems | the physical items that changed
Public property | PhysicalRules | the new set of physical rules associated with this workload
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ChangedItemsModel Constructor

ChangedItemsModel Constructor
Initializes a new instance of the ChangedItemsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ChangedItemsModel()
Public Sub New
public:
ChangedItemsModel()
new : unit -> ChangedItemsModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel Properties

ChangedItemsModel Properties

The ChangedItemsModel type exposes the following members.

Properties
 | Name | Description
Public property | LogicalItems | the logical items that changed
Public property | LogicalRules | the new set of logical rules associated with this workload
Public property | PhysicalItems | the physical items that changed
Public property | PhysicalRules | the new set of physical rules associated with this workload
Top
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.LogicalItems Property

ChangedItemsModelLogicalItems Property
the logical items that changed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalItemModel[] LogicalItems { get; set; }
Public Property LogicalItems As LogicalItemModel()
    Get
    Set
public:
property array<LogicalItemModel^>^ LogicalItems {
    array<LogicalItemModel^>^ get ();
    void set (array<LogicalItemModel^>^ value);
}
member LogicalItems : LogicalItemModel[] with get, set

Property Value

Type: LogicalItemModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.LogicalRules Property

ChangedItemsModelLogicalRules Property
the new set of logical rules associated with this workload

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member LogicalRules : string[] with get, set

Property Value

Type: String
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.PhysicalItems Property

ChangedItemsModelPhysicalItems Property
the physical items that changed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalItemModel[] PhysicalItems { get; set; }
Public Property PhysicalItems As PhysicalItemModel()
    Get
    Set
public:
property array<PhysicalItemModel^>^ PhysicalItems {
    array<PhysicalItemModel^>^ get ();
    void set (array<PhysicalItemModel^>^ value);
}
member PhysicalItems : PhysicalItemModel[] with get, set

Property Value

Type: PhysicalItemModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.PhysicalRules Property

ChangedItemsModelPhysicalRules Property
the new set of physical rules associated with this workload

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel Methods

ChangedItemsModel Methods

The ChangedItemsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChangedItemsModel Class


CloudOptionsModel Class

CloudOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCloudOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CloudOptionsModel
Public NotInheritable Class CloudOptionsModel
public ref class CloudOptionsModel sealed
[<SealedAttribute>]
type CloudOptionsModel =  class end

The CloudOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CloudOptionsModel | Initializes a new instance of the CloudOptionsModel class
Top
Properties
 | Name | Description
Public property | EngineJobType | the engine job type for the connection
Public property | HardLinkLogPath | the path for the hard link processing log/report
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CloudOptionsModel Constructor

CloudOptionsModel Constructor
Initializes a new instance of the CloudOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CloudOptionsModel()
Public Sub New
public:
CloudOptionsModel()
new : unit -> CloudOptionsModel
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel Properties

CloudOptionsModel Properties

The CloudOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | EngineJobType | the engine job type for the connection
Public property | HardLinkLogPath | the path for the hard link processing log/report
Top
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel.EngineJobType Property

CloudOptionsModelEngineJobType Property
the engine job type for the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EngineJobTypeEnum EngineJobType { get; set; }
Public Property EngineJobType As EngineJobTypeEnum
    Get
    Set
public:
property EngineJobTypeEnum EngineJobType {
    EngineJobTypeEnum get ();
    void set (EngineJobTypeEnum value);
}
member EngineJobType : EngineJobTypeEnum with get, set

Property Value

Type: EngineJobTypeEnum
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel.HardLinkLogPath Property

CloudOptionsModelHardLinkLogPath Property
the path for the hard link processing log/report

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HardLinkLogPath { get; set; }
Public Property HardLinkLogPath As String
    Get
    Set
public:
property String^ HardLinkLogPath {
    String^ get ();
    void set (String^ value);
}
member HardLinkLogPath : string with get, set

Property Value

Type: String
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel Methods

CloudOptionsModel Methods

The CloudOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CloudOptionsModel Class


ClusterFilesAndFoldersQualificationResultsModel Class

ClusterFilesAndFoldersQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterFilesAndFoldersQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ClusterFilesAndFoldersQualificationResultsModel
Public NotInheritable Class ClusterFilesAndFoldersQualificationResultsModel
public ref class ClusterFilesAndFoldersQualificationResultsModel sealed
[<SealedAttribute>]
type ClusterFilesAndFoldersQualificationResultsModel =  class end

The ClusterFilesAndFoldersQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterFilesAndFoldersQualificationResultsModel | Initializes a new instance of the ClusterFilesAndFoldersQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | TargetFileServerQualificationResults | the volumes
Public property | TargetGroupDiskOffline | the target group disk offline
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterFilesAndFoldersQualificationResultsModel Constructor

ClusterFilesAndFoldersQualificationResultsModel Constructor
Initializes a new instance of the ClusterFilesAndFoldersQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterFilesAndFoldersQualificationResultsModel()
Public Sub New
public:
ClusterFilesAndFoldersQualificationResultsModel()
new : unit -> ClusterFilesAndFoldersQualificationResultsModel
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel Properties

ClusterFilesAndFoldersQualificationResultsModel Properties

The ClusterFilesAndFoldersQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | TargetFileServerQualificationResults | the volumes
Public property | TargetGroupDiskOffline | the target group disk offline
Top
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel.TargetFileServerQualificationResults Property

ClusterFilesAndFoldersQualificationResultsModelTargetFileServerQualificationResults Property
the volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFileServerQualificationResultsModel[] TargetFileServerQualificationResults { get; set; }
Public Property TargetFileServerQualificationResults As TargetFileServerQualificationResultsModel()
    Get
    Set
public:
property array<TargetFileServerQualificationResultsModel^>^ TargetFileServerQualificationResults {
    array<TargetFileServerQualificationResultsModel^>^ get ();
    void set (array<TargetFileServerQualificationResultsModel^>^ value);
}
member TargetFileServerQualificationResults : TargetFileServerQualificationResultsModel[] with get, set

Property Value

Type: TargetFileServerQualificationResultsModel
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel.TargetGroupDiskOffline Property

ClusterFilesAndFoldersQualificationResultsModelTargetGroupDiskOffline Property
the target group disk offline

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetGroupDiskOffline { get; set; }
Public Property TargetGroupDiskOffline As Boolean
    Get
    Set
public:
property bool TargetGroupDiskOffline {
    bool get ();
    void set (bool value);
}
member TargetGroupDiskOffline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel Methods

ClusterFilesAndFoldersQualificationResultsModel Methods

The ClusterFilesAndFoldersQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterOptionsModel Class

ClusterOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ClusterOptionsModel
Public NotInheritable Class ClusterOptionsModel
public ref class ClusterOptionsModel sealed
[<SealedAttribute>]
type ClusterOptionsModel =  class end

The ClusterOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterOptionsModel | Initializes a new instance of the ClusterOptionsModel class
Top
Properties
 | Name | Description
Public property | DependOnResources | the names of resources to depend on (overrides default storage resource, network name resource dependencies)
Public property | InitializeOnTargetNodeMove | a value indicating whether or not to initialize on target node move
Public property | OriginalSourceClusterId | the original source cluster ID
Public property | SourceClusterName | the name of the source cluster
Public property | SourceGroupName | the name of the source group
Public property | SourceIsCluster | a value indicating whether or not the source is part of a cluster
Public property | TargetClusterName | the name of the target cluster
Public property | TargetClusterResourceNamePrefix | the target cluster resource name prefix
Public property | TargetClusterStoragePath | the target cluster storage location
Public property | TargetGroupName | the name of the target group
Public property | TargetIsCluster | a value indicating whether or not the target is part of a cluster
Public property | TargetVirtualServers | the names of the target virtual servers
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterOptionsModel Constructor

ClusterOptionsModel Constructor
Initializes a new instance of the ClusterOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterOptionsModel()
Public Sub New
public:
ClusterOptionsModel()
new : unit -> ClusterOptionsModel
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel Properties

ClusterOptionsModel Properties

The ClusterOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DependOnResources | the names of resources to depend on (overrides default storage resource, network name resource dependencies)
Public property | InitializeOnTargetNodeMove | a value indicating whether or not to initialize on target node move
Public property | OriginalSourceClusterId | the original source cluster ID
Public property | SourceClusterName | the name of the source cluster
Public property | SourceGroupName | the name of the source group
Public property | SourceIsCluster | a value indicating whether or not the source is part of a cluster
Public property | TargetClusterName | the name of the target cluster
Public property | TargetClusterResourceNamePrefix | the target cluster resource name prefix
Public property | TargetClusterStoragePath | the target cluster storage location
Public property | TargetGroupName | the name of the target group
Public property | TargetIsCluster | a value indicating whether or not the target is part of a cluster
Public property | TargetVirtualServers | the names of the target virtual servers
Top
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.DependOnResources Property

ClusterOptionsModelDependOnResources Property
the names of resources to depend on (overrides default storage resource, network name resource dependencies)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> DependOnResources { get; set; }
Public Property DependOnResources As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ DependOnResources {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member DependOnResources : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.InitializeOnTargetNodeMove Property

ClusterOptionsModelInitializeOnTargetNodeMove Property
a value indicating whether or not to initialize on target node move

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InitializeOnTargetNodeMove { get; set; }
Public Property InitializeOnTargetNodeMove As Boolean
    Get
    Set
public:
property bool InitializeOnTargetNodeMove {
    bool get ();
    void set (bool value);
}
member InitializeOnTargetNodeMove : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.OriginalSourceClusterId Property

ClusterOptionsModelOriginalSourceClusterId Property
the original source cluster ID

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceClusterId { get; set; }
Public Property OriginalSourceClusterId As String
    Get
    Set
public:
property String^ OriginalSourceClusterId {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceClusterId : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.SourceClusterName Property

ClusterOptionsModelSourceClusterName Property
the name of the source cluster

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceClusterName { get; set; }
Public Property SourceClusterName As String
    Get
    Set
public:
property String^ SourceClusterName {
    String^ get ();
    void set (String^ value);
}
member SourceClusterName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.SourceGroupName Property

ClusterOptionsModelSourceGroupName Property
the name of the source group

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceGroupName { get; set; }
Public Property SourceGroupName As String
    Get
    Set
public:
property String^ SourceGroupName {
    String^ get ();
    void set (String^ value);
}
member SourceGroupName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.SourceIsCluster Property

ClusterOptionsModelSourceIsCluster Property
a value indicating whether or not the source is part of a cluster

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceIsCluster { get; set; }
Public Property SourceIsCluster As Boolean
    Get
    Set
public:
property bool SourceIsCluster {
    bool get ();
    void set (bool value);
}
member SourceIsCluster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetClusterName Property

ClusterOptionsModelTargetClusterName Property
the name of the target cluster

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetClusterName { get; set; }
Public Property TargetClusterName As String
    Get
    Set
public:
property String^ TargetClusterName {
    String^ get ();
    void set (String^ value);
}
member TargetClusterName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetClusterResourceNamePrefix Property

ClusterOptionsModelTargetClusterResourceNamePrefix Property
the target cluster resource name prefix

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetClusterResourceNamePrefix { get; set; }
Public Property TargetClusterResourceNamePrefix As String
    Get
    Set
public:
property String^ TargetClusterResourceNamePrefix {
    String^ get ();
    void set (String^ value);
}
member TargetClusterResourceNamePrefix : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetClusterStoragePath Property

ClusterOptionsModelTargetClusterStoragePath Property
the target cluster storage location

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetClusterStoragePath { get; set; }
Public Property TargetClusterStoragePath As String
    Get
    Set
public:
property String^ TargetClusterStoragePath {
    String^ get ();
    void set (String^ value);
}
member TargetClusterStoragePath : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetGroupName Property

ClusterOptionsModelTargetGroupName Property
the name of the target group

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetGroupName { get; set; }
Public Property TargetGroupName As String
    Get
    Set
public:
property String^ TargetGroupName {
    String^ get ();
    void set (String^ value);
}
member TargetGroupName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetIsCluster Property

ClusterOptionsModelTargetIsCluster Property
a value indicating whether or not the target is part of a cluster

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetIsCluster { get; set; }
Public Property TargetIsCluster As Boolean
    Get
    Set
public:
property bool TargetIsCluster {
    bool get ();
    void set (bool value);
}
member TargetIsCluster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetVirtualServers Property

ClusterOptionsModelTargetVirtualServers Property
the names of the target virtual servers

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> TargetVirtualServers { get; set; }
Public Property TargetVirtualServers As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ TargetVirtualServers {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member TargetVirtualServers : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel Methods

ClusterOptionsModel Methods

The ClusterOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterOptionsModel Class


ClusterResourceStateEnum Enumeration

ClusterResourceStateEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ClusterResourceStateEnum
Public Enumeration ClusterResourceStateEnum
public enum class ClusterResourceStateEnum
type ClusterResourceStateEnum
Members
Member name | Value | Description
Uninitialized | 0 |
OfflinePending | 1 |
Offline | 2 |
OnlinePending | 3 |
Online | 4 |
ResourceNotFound | 5 |
Reconnected | 6 |
Connected | 7 |
See Also

Reference

DoubleTake.Web.Models Namespace


CompressionLevelModel Class

CompressionLevelModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCompressionLevelModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CompressionLevelModel
Public NotInheritable Class CompressionLevelModel
public ref class CompressionLevelModel sealed
[<SealedAttribute>]
type CompressionLevelModel =  class end

The CompressionLevelModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompressionLevelModel | Initializes a new instance of the CompressionLevelModel class
Top
Properties
 | Name | Description
Public property | Algorithm | the compression algorithm
Public property | Level | the level of compression
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompressionLevelModel Constructor

CompressionLevelModel Constructor
Initializes a new instance of the CompressionLevelModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel()
Public Sub New
public:
CompressionLevelModel()
new : unit -> CompressionLevelModel
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel Properties

CompressionLevelModel Properties

The CompressionLevelModel type exposes the following members.

Properties
 | Name | Description
Public property | Algorithm | the compression algorithm
Public property | Level | the level of compression
Top
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel.Algorithm Property

CompressionLevelModelAlgorithm Property
the compression algorithm

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Algorithm { get; set; }
Public Property Algorithm As Integer
    Get
    Set
public:
property int Algorithm {
    int get ();
    void set (int value);
}
member Algorithm : int with get, set

Property Value

Type: Int32
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel.Level Property

CompressionLevelModelLevel Property
the level of compression

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
member Level : int with get, set

Property Value

Type: Int32
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel Methods

CompressionLevelModel Methods

The CompressionLevelModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompressionLevelModel Class


ConnectionScheduleModel Class

ConnectionScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionScheduleModel
Public NotInheritable Class ConnectionScheduleModel
public ref class ConnectionScheduleModel sealed
[<SealedAttribute>]
type ConnectionScheduleModel =  class end

The ConnectionScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionScheduleModel | Initializes a new instance of the ConnectionScheduleModel class
Top
Properties
 | Name | Description
Public property | Archive | the archive schedule
Public property | Bandwidth | the bandwidth schedule
Public property | Orphans | the orphans schedule
Public property | Transmission | the transmission schedule
Public property | Verify | the verification schedule
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionScheduleModel Constructor

ConnectionScheduleModel Constructor
Initializes a new instance of the ConnectionScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionScheduleModel()
Public Sub New
public:
ConnectionScheduleModel()
new : unit -> ConnectionScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel Properties

ConnectionScheduleModel Properties

The ConnectionScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Archive | the archive schedule
Public property | Bandwidth | the bandwidth schedule
Public property | Orphans | the orphans schedule
Public property | Transmission | the transmission schedule
Public property | Verify | the verification schedule
Top
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Archive Property

ConnectionScheduleModelArchive Property
the archive schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveScheduleModel Archive { get; set; }
Public Property Archive As ArchiveScheduleModel
    Get
    Set
public:
property ArchiveScheduleModel^ Archive {
    ArchiveScheduleModel^ get ();
    void set (ArchiveScheduleModel^ value);
}
member Archive : ArchiveScheduleModel with get, set

Property Value

Type: ArchiveScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Bandwidth Property

ConnectionScheduleModelBandwidth Property
the bandwidth schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleModel Bandwidth { get; set; }
Public Property Bandwidth As BandwidthScheduleModel
    Get
    Set
public:
property BandwidthScheduleModel^ Bandwidth {
    BandwidthScheduleModel^ get ();
    void set (BandwidthScheduleModel^ value);
}
member Bandwidth : BandwidthScheduleModel with get, set

Property Value

Type: BandwidthScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Orphans Property

ConnectionScheduleModelOrphans Property
the orphans schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrphansScheduleModel Orphans { get; set; }
Public Property Orphans As OrphansScheduleModel
    Get
    Set
public:
property OrphansScheduleModel^ Orphans {
    OrphansScheduleModel^ get ();
    void set (OrphansScheduleModel^ value);
}
member Orphans : OrphansScheduleModel with get, set

Property Value

Type: OrphansScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Transmission Property

ConnectionScheduleModelTransmission Property
the transmission schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionScheduleModel Transmission { get; set; }
Public Property Transmission As TransmissionScheduleModel
    Get
    Set
public:
property TransmissionScheduleModel^ Transmission {
    TransmissionScheduleModel^ get ();
    void set (TransmissionScheduleModel^ value);
}
member Transmission : TransmissionScheduleModel with get, set

Property Value

Type: TransmissionScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Verify Property

ConnectionScheduleModelVerify Property
the verification schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerifyScheduleModel Verify { get; set; }
Public Property Verify As VerifyScheduleModel
    Get
    Set
public:
property VerifyScheduleModel^ Verify {
    VerifyScheduleModel^ get ();
    void set (VerifyScheduleModel^ value);
}
member Verify : VerifyScheduleModel with get, set

Property Value

Type: VerifyScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel Methods

ConnectionScheduleModel Methods

The ConnectionScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionScheduleModel Class


ConnectionStartParametersModel Class

ConnectionStartParametersModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionStartParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionStartParametersModel
Public NotInheritable Class ConnectionStartParametersModel
public ref class ConnectionStartParametersModel sealed
[<SealedAttribute>]
type ConnectionStartParametersModel =  class end

The ConnectionStartParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStartParametersModel | Initializes a new instance of the ConnectionStartParametersModel class
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | the volume on which to store all archived files on the target
Public property | CompressionLevel | the compression to use for data passed over this connection
Public property | IsEncrypted | a value indicating whether or not to encrypt the connection data stream
Public property | IsMirrorEnabled | a value indicating whether or not to start a mirror when the connection is created
Public property | IsPathBlockingEnabled | a value indicating whether or not to block outside access to the destination paths on the target machine
Public property | IsReplicationEnabled | a value indicating whether or not to start replication when the connection is created
Public property | IsRestore | a value indicating whether or not this instance is restore mirror
Public property | MirrorParameters | parameters to be used for the initial connection mirror
Public property | Schedule | the schedule to use for the connection
Public property | ScriptPoints | script points to configure on the connection
Public property | SnapshotSchedule | snapshot schedule configuration
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionStartParametersModel Constructor

ConnectionStartParametersModel Constructor
Initializes a new instance of the ConnectionStartParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel()
Public Sub New
public:
ConnectionStartParametersModel()
new : unit -> ConnectionStartParametersModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel Properties

ConnectionStartParametersModel Properties

The ConnectionStartParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | the volume on which to store all archived files on the target
Public property | CompressionLevel | the compression to use for data passed over this connection
Public property | IsEncrypted | a value indicating whether or not to encrypt the connection data stream
Public property | IsMirrorEnabled | a value indicating whether or not to start a mirror when the connection is created
Public property | IsPathBlockingEnabled | a value indicating whether or not to block outside access to the destination paths on the target machine
Public property | IsReplicationEnabled | a value indicating whether or not to start replication when the connection is created
Public property | IsRestore | a value indicating whether or not this instance is restore mirror
Public property | MirrorParameters | parameters to be used for the initial connection mirror
Public property | Schedule | the schedule to use for the connection
Public property | ScriptPoints | script points to configure on the connection
Public property | SnapshotSchedule | snapshot schedule configuration
Top
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.ArchiveBinLocation Property

ConnectionStartParametersModelArchiveBinLocation Property
the volume on which to store all archived files on the target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
member ArchiveBinLocation : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.CompressionLevel Property

ConnectionStartParametersModelCompressionLevel Property
the compression to use for data passed over this connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevelModel
    Get
    Set
public:
property CompressionLevelModel^ CompressionLevel {
    CompressionLevelModel^ get ();
    void set (CompressionLevelModel^ value);
}
member CompressionLevel : CompressionLevelModel with get, set

Property Value

Type: CompressionLevelModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsEncrypted Property

ConnectionStartParametersModelIsEncrypted Property
a value indicating whether or not to encrypt the connection data stream

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEncrypted { get; set; }
Public Property IsEncrypted As Boolean
    Get
    Set
public:
property bool IsEncrypted {
    bool get ();
    void set (bool value);
}
member IsEncrypted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsMirrorEnabled Property

ConnectionStartParametersModelIsMirrorEnabled Property
a value indicating whether or not to start a mirror when the connection is created

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMirrorEnabled { get; set; }
Public Property IsMirrorEnabled As Boolean
    Get
    Set
public:
property bool IsMirrorEnabled {
    bool get ();
    void set (bool value);
}
member IsMirrorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsPathBlockingEnabled Property

ConnectionStartParametersModelIsPathBlockingEnabled Property
a value indicating whether or not to block outside access to the destination paths on the target machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPathBlockingEnabled { get; set; }
Public Property IsPathBlockingEnabled As Boolean
    Get
    Set
public:
property bool IsPathBlockingEnabled {
    bool get ();
    void set (bool value);
}
member IsPathBlockingEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsReplicationEnabled Property

ConnectionStartParametersModelIsReplicationEnabled Property
a value indicating whether or not to start replication when the connection is created

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
member IsReplicationEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsRestore Property

ConnectionStartParametersModelIsRestore Property
a value indicating whether or not this instance is restore mirror

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRestore { get; set; }
Public Property IsRestore As Boolean
    Get
    Set
public:
property bool IsRestore {
    bool get ();
    void set (bool value);
}
member IsRestore : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.MirrorParameters Property

ConnectionStartParametersModelMirrorParameters Property
parameters to be used for the initial connection mirror

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorParametersModel MirrorParameters { get; set; }
Public Property MirrorParameters As MirrorParametersModel
    Get
    Set
public:
property MirrorParametersModel^ MirrorParameters {
    MirrorParametersModel^ get ();
    void set (MirrorParametersModel^ value);
}
member MirrorParameters : MirrorParametersModel with get, set

Property Value

Type: MirrorParametersModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.Schedule Property

ConnectionStartParametersModelSchedule Property
the schedule to use for the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionScheduleModel Schedule { get; set; }
Public Property Schedule As ConnectionScheduleModel
    Get
    Set
public:
property ConnectionScheduleModel^ Schedule {
    ConnectionScheduleModel^ get ();
    void set (ConnectionScheduleModel^ value);
}
member Schedule : ConnectionScheduleModel with get, set

Property Value

Type: ConnectionScheduleModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.ScriptPoints Property

ConnectionStartParametersModelScriptPoints Property
script points to configure on the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptPointModel[] ScriptPoints { get; set; }
Public Property ScriptPoints As ScriptPointModel()
    Get
    Set
public:
property array<ScriptPointModel^>^ ScriptPoints {
    array<ScriptPointModel^>^ get ();
    void set (array<ScriptPointModel^>^ value);
}
member ScriptPoints : ScriptPointModel[] with get, set

Property Value

Type: ScriptPointModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.SnapshotSchedule Property

ConnectionStartParametersModelSnapshotSchedule Property
snapshot schedule configuration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotScheduleModel SnapshotSchedule { get; set; }
Public Property SnapshotSchedule As SnapshotScheduleModel
    Get
    Set
public:
property SnapshotScheduleModel^ SnapshotSchedule {
    SnapshotScheduleModel^ get ();
    void set (SnapshotScheduleModel^ value);
}
member SnapshotSchedule : SnapshotScheduleModel with get, set

Property Value

Type: SnapshotScheduleModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel Methods

ConnectionStartParametersModel Methods

The ConnectionStartParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionStartParametersModel Class


CoreConnectionDetailsModel Class

CoreConnectionDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreConnectionDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreConnectionDetailsModel
Public NotInheritable Class CoreConnectionDetailsModel
public ref class CoreConnectionDetailsModel sealed
[<SealedAttribute>]
type CoreConnectionDetailsModel =  class end

The CoreConnectionDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionDetailsModel | Initializes a new instance of the CoreConnectionDetailsModel class
Top
Properties
 | Name | Description
Public property | BandwidthCollar | the current bandwidth limit
Public property | CompressionEnabled | a value indicating whether or not transmitted data is compressed
Public property | CompressionLevel | the level of compression configured on the connection
Public property | ConnectionId | a one-based index for each connection established in a Double-Take instance
Public property | DiskQueueBytes | the number of bytes in the disk queue
Public property | Encrypted | a value indicating whether or not the job is currently encrypting network data
Public property | InitialMirrorComplete | a value indicating whether or not the initial mirror for this connection has completed
Public property | ManagedConnectionId | the identity of the connection as applied by the management service
Public property | MirrorBytesRemaining | the number of mirror bytes remaining
Public property | MirrorBytesSent | the number of mirror bytes sent
Public property | MirrorBytesSkipped | the number of mirror bytes skipped
Public property | MirrorBytesTransmitted | the number of mirror bytes transmitted
Public property | MirrorOpsQueued | the number of mirror ops queued
Public property | MirrorPermillage | the mirror permillage
Public property | MirrorState | the operational state of the mirror
Public property | PeerMemoryLow | a value indicating whether or not the peer's memory is low
Public property | ReplicationBytesQueued | the replication bytes queued on the source
Public property | ReplicationBytesSent | the number of replication bytes sent
Public property | ReplicationBytesTransmitted | the number of replication bytes transmitted
Public property | ReplicationOpsQueued | the number of replication ops queued
Public property | ReplicationSetCalcInProgress | the engine's parallel repset calculation feature will start a mirror while the size of the repset is being determined
Public property | ReplicationState | the operational state of replication
Public property | Restoring | a value indicating whether the connection is restoring
Public property | SourceAccessLevel | the source access level
Public property | SourceAvailable | a value indicating whether or not the source server of this connection is available for communication from the server that owns the job
Public property | SourceClusterResourceState | the state of the source cluster resource
Public property | SourceEndpoint | the endpoint on the source server that is the route from the target server back to the source server of the connection
Public property | SourceEngineAvailable | a value indicating whether or not source engine is available
Public property | SourceMachineName | the name of the source server
Public property | SourceUniqueId | the unique identifier of the source server
Public property | StartTime | the time the connection was started
Public property | TargetAccessLevel | the target access level
Public property | TargetAvailable | a value indicating whether or not the target server of this connection is available for communication from the server that owns the job
Public property | TargetEngineAvailable | a value indicating whether target engine is available
Public property | TargetLoaded | a value indicating whether the target module is loaded on the target of the connection
Public property | TargetMachineName | the name of the target server
Public property | TargetQueueBytes | the number of bytes in the target queue
Public property | TargetRoute | the endpoint on the target server that is the route the source server is using for this connection
Public property | TargetState | the known operational states of the connection target
Public property | TargetUniqueId | the unique identifier of the target server
Public property | TotalBytesSent | the total bytes sent
Public property | TotalBytesTransmitted | the total number of bytes transmitted
Public property | TotalOpsQueued | the total number of ops queued
Public property | TransmissionMode | the operational state of replication and mirroring
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreConnectionDetailsModel Constructor

CoreConnectionDetailsModel Constructor
Initializes a new instance of the CoreConnectionDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel()
Public Sub New
public:
CoreConnectionDetailsModel()
new : unit -> CoreConnectionDetailsModel
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel Properties

CoreConnectionDetailsModel Properties

The CoreConnectionDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | the current bandwidth limit
Public property | CompressionEnabled | a value indicating whether or not transmitted data is compressed
Public property | CompressionLevel | the level of compression configured on the connection
Public property | ConnectionId | a one-based index for each connection established in a Double-Take instance
Public property | DiskQueueBytes | the number of bytes in the disk queue
Public property | Encrypted | a value indicating whether or not the job is currently encrypting network data
Public property | InitialMirrorComplete | a value indicating whether or not the initial mirror for this connection has completed
Public property | ManagedConnectionId | the identity of the connection as applied by the management service
Public property | MirrorBytesRemaining | the number of mirror bytes remaining
Public property | MirrorBytesSent | the number of mirror bytes sent
Public property | MirrorBytesSkipped | the number of mirror bytes skipped
Public property | MirrorBytesTransmitted | the number of mirror bytes transmitted
Public property | MirrorOpsQueued | the number of mirror ops queued
Public property | MirrorPermillage | the mirror permillage
Public property | MirrorState | the operational state of the mirror
Public property | PeerMemoryLow | a value indicating whether or not the peer's memory is low
Public property | ReplicationBytesQueued | the replication bytes queued on the source
Public property | ReplicationBytesSent | the number of replication bytes sent
Public property | ReplicationBytesTransmitted | the number of replication bytes transmitted
Public property | ReplicationOpsQueued | the number of replication ops queued
Public property | ReplicationSetCalcInProgress | the engine's parallel repset calculation feature will start a mirror while the size of the repset is being determined
Public property | ReplicationState | the operational state of replication
Public property | Restoring | a value indicating whether the connection is restoring
Public property | SourceAccessLevel | the source access level
Public property | SourceAvailable | a value indicating whether or not the source server of this connection is available for communication from the server that owns the job
Public property | SourceClusterResourceState | the state of the source cluster resource
Public property | SourceEndpoint | the endpoint on the source server that is the route from the target server back to the source server of the connection
Public property | SourceEngineAvailable | a value indicating whether or not source engine is available
Public property | SourceMachineName | the name of the source server
Public property | SourceUniqueId | the unique identifier of the source server
Public property | StartTime | the time the connection was started
Public property | TargetAccessLevel | the target access level
Public property | TargetAvailable | a value indicating whether or not the target server of this connection is available for communication from the server that owns the job
Public property | TargetEngineAvailable | a value indicating whether target engine is available
Public property | TargetLoaded | a value indicating whether the target module is loaded on the target of the connection
Public property | TargetMachineName | the name of the target server
Public property | TargetQueueBytes | the number of bytes in the target queue
Public property | TargetRoute | the endpoint on the target server that is the route the source server is using for this connection
Public property | TargetState | the known operational states of the connection target
Public property | TargetUniqueId | the unique identifier of the target server
Public property | TotalBytesSent | the total bytes sent
Public property | TotalBytesTransmitted | the total number of bytes transmitted
Public property | TotalOpsQueued | the total number of ops queued
Public property | TransmissionMode | the operational state of replication and mirroring
Top
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.BandwidthCollar Property

CoreConnectionDetailsModelBandwidthCollar Property
the current bandwidth limit

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
member BandwidthCollar : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.CompressionEnabled Property

CoreConnectionDetailsModelCompressionEnabled Property
a value indicating whether or not transmitted data is compressed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
member CompressionEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.CompressionLevel Property

CoreConnectionDetailsModelCompressionLevel Property
the level of compression configured on the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
member CompressionLevel : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ConnectionId Property

CoreConnectionDetailsModelConnectionId Property
a one-based index for each connection established in a Double-Take instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
member ConnectionId : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.DiskQueueBytes Property

CoreConnectionDetailsModelDiskQueueBytes Property
the number of bytes in the disk queue

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
member DiskQueueBytes : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.Encrypted Property

CoreConnectionDetailsModelEncrypted Property
a value indicating whether or not the job is currently encrypting network data

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Encrypted { get; set; }
Public Property Encrypted As Boolean
    Get
    Set
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}
member Encrypted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.InitialMirrorComplete Property

CoreConnectionDetailsModelInitialMirrorComplete Property
a value indicating whether or not the initial mirror for this connection has completed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
member InitialMirrorComplete : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ManagedConnectionId Property

CoreConnectionDetailsModelManagedConnectionId Property
the identity of the connection as applied by the management service

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ManagedConnectionId { get; set; }
Public Property ManagedConnectionId As Guid
    Get
    Set
public:
property Guid ManagedConnectionId {
    Guid get ();
    void set (Guid value);
}
member ManagedConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesRemaining Property

CoreConnectionDetailsModelMirrorBytesRemaining Property
the number of mirror bytes remaining

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
member MirrorBytesRemaining : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesSent Property

CoreConnectionDetailsModelMirrorBytesSent Property
the number of mirror bytes sent

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
member MirrorBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesSkipped Property

CoreConnectionDetailsModelMirrorBytesSkipped Property
the number of mirror bytes skipped

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
member MirrorBytesSkipped : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesTransmitted Property

CoreConnectionDetailsModelMirrorBytesTransmitted Property
the number of mirror bytes transmitted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
member MirrorBytesTransmitted : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorOpsQueued Property

CoreConnectionDetailsModelMirrorOpsQueued Property
the number of mirror ops queued

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
member MirrorOpsQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorPermillage Property

CoreConnectionDetailsModelMirrorPermillage Property
the mirror permillage

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
member MirrorPermillage : int16 with get, set

Property Value

Type: Int16
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorState Property

CoreConnectionDetailsModelMirrorState Property
the operational state of the mirror

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorStateEnum MirrorState { get; set; }
Public Property MirrorState As MirrorStateEnum
    Get
    Set
public:
property MirrorStateEnum MirrorState {
    MirrorStateEnum get ();
    void set (MirrorStateEnum value);
}
member MirrorState : MirrorStateEnum with get, set

Property Value

Type: MirrorStateEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.PeerMemoryLow Property

CoreConnectionDetailsModelPeerMemoryLow Property
a value indicating whether or not the peer's memory is low

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
member PeerMemoryLow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationBytesQueued Property

CoreConnectionDetailsModelReplicationBytesQueued Property
the replication bytes queued on the source

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
member ReplicationBytesQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationBytesSent Property

CoreConnectionDetailsModelReplicationBytesSent Property
the number of replication bytes sent

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
member ReplicationBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationBytesTransmitted Property

CoreConnectionDetailsModelReplicationBytesTransmitted Property
the number of replication bytes transmitted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
member ReplicationBytesTransmitted : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationOpsQueued Property

CoreConnectionDetailsModelReplicationOpsQueued Property
the number of replication ops queued

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
member ReplicationOpsQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationSetCalcInProgress Property

CoreConnectionDetailsModelReplicationSetCalcInProgress Property
the engine's parallel repset calculation feature will start a mirror while the size of the repset is being determined

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
member ReplicationSetCalcInProgress : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationState Property

CoreConnectionDetailsModelReplicationState Property
the operational state of replication

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicationStateEnum ReplicationState { get; set; }
Public Property ReplicationState As ReplicationStateEnum
    Get
    Set
public:
property ReplicationStateEnum ReplicationState {
    ReplicationStateEnum get ();
    void set (ReplicationStateEnum value);
}
member ReplicationState : ReplicationStateEnum with get, set

Property Value

Type: ReplicationStateEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.Restoring Property

CoreConnectionDetailsModelRestoring Property
a value indicating whether the connection is restoring

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
member Restoring : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceAccessLevel Property

CoreConnectionDetailsModelSourceAccessLevel Property
the source access level

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<AccessLevelEnum> SourceAccessLevel { get; set; }
Public Property SourceAccessLevel As Nullable(Of AccessLevelEnum)
    Get
    Set
public:
property Nullable<AccessLevelEnum> SourceAccessLevel {
    Nullable<AccessLevelEnum> get ();
    void set (Nullable<AccessLevelEnum> value);
}
member SourceAccessLevel : Nullable<AccessLevelEnum> with get, set

Property Value

Type: Nullable AccessLevelEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceAvailable Property

CoreConnectionDetailsModelSourceAvailable Property
a value indicating whether or not the source server of this connection is available for communication from the server that owns the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceAvailable { get; set; }
Public Property SourceAvailable As Boolean
    Get
    Set
public:
property bool SourceAvailable {
    bool get ();
    void set (bool value);
}
member SourceAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceClusterResourceState Property

CoreConnectionDetailsModelSourceClusterResourceState Property
the state of the source cluster resource

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterResourceStateEnum SourceClusterResourceState { get; set; }
Public Property SourceClusterResourceState As ClusterResourceStateEnum
    Get
    Set
public:
property ClusterResourceStateEnum SourceClusterResourceState {
    ClusterResourceStateEnum get ();
    void set (ClusterResourceStateEnum value);
}
member SourceClusterResourceState : ClusterResourceStateEnum with get, set

Property Value

Type: ClusterResourceStateEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceEndpoint Property

CoreConnectionDetailsModelSourceEndpoint Property
the endpoint on the source server that is the route from the target server back to the source server of the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceEngineAvailable Property

CoreConnectionDetailsModelSourceEngineAvailable Property
a value indicating whether or not source engine is available

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceEngineAvailable { get; set; }
Public Property SourceEngineAvailable As Boolean
    Get
    Set
public:
property bool SourceEngineAvailable {
    bool get ();
    void set (bool value);
}
member SourceEngineAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceMachineName Property

CoreConnectionDetailsModelSourceMachineName Property
the name of the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceUniqueId Property

CoreConnectionDetailsModelSourceUniqueId Property
the unique identifier of the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member SourceUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.StartTime Property

CoreConnectionDetailsModelStartTime Property
the time the connection was started

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetAccessLevel Property

CoreConnectionDetailsModelTargetAccessLevel Property
the target access level

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<AccessLevelEnum> TargetAccessLevel { get; set; }
Public Property TargetAccessLevel As Nullable(Of AccessLevelEnum)
    Get
    Set
public:
property Nullable<AccessLevelEnum> TargetAccessLevel {
    Nullable<AccessLevelEnum> get ();
    void set (Nullable<AccessLevelEnum> value);
}
member TargetAccessLevel : Nullable<AccessLevelEnum> with get, set

Property Value

Type: Nullable AccessLevelEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetAvailable Property

CoreConnectionDetailsModelTargetAvailable Property
a value indicating whether or not the target server of this connection is available for communication from the server that owns the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
member TargetAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetEngineAvailable Property

CoreConnectionDetailsModelTargetEngineAvailable Property
a value indicating whether target engine is available

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetEngineAvailable { get; set; }
Public Property TargetEngineAvailable As Boolean
    Get
    Set
public:
property bool TargetEngineAvailable {
    bool get ();
    void set (bool value);
}
member TargetEngineAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetLoaded Property

CoreConnectionDetailsModelTargetLoaded Property
a value indicating whether the target module is loaded on the target of the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
member TargetLoaded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetMachineName Property

CoreConnectionDetailsModelTargetMachineName Property
the name of the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
member TargetMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetQueueBytes Property

CoreConnectionDetailsModelTargetQueueBytes Property
the number of bytes in the target queue

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TargetQueueBytes { get; set; }
Public Property TargetQueueBytes As Long
    Get
    Set
public:
property long long TargetQueueBytes {
    long long get ();
    void set (long long value);
}
member TargetQueueBytes : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetRoute Property

CoreConnectionDetailsModelTargetRoute Property
the endpoint on the target server that is the route the source server is using for this connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
member TargetRoute : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetState Property

CoreConnectionDetailsModelTargetState Property
the known operational states of the connection target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStatesEnum TargetState { get; set; }
Public Property TargetState As TargetStatesEnum
    Get
    Set
public:
property TargetStatesEnum TargetState {
    TargetStatesEnum get ();
    void set (TargetStatesEnum value);
}
member TargetState : TargetStatesEnum with get, set

Property Value

Type: TargetStatesEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetUniqueId Property

CoreConnectionDetailsModelTargetUniqueId Property
the unique identifier of the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member TargetUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TotalBytesSent Property

CoreConnectionDetailsModelTotalBytesSent Property
the total bytes sent

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
member TotalBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TotalBytesTransmitted Property

CoreConnectionDetailsModelTotalBytesTransmitted Property
the total number of bytes transmitted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
member TotalBytesTransmitted : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TotalOpsQueued Property

CoreConnectionDetailsModelTotalOpsQueued Property
the total number of ops queued

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
member TotalOpsQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TransmissionMode Property

CoreConnectionDetailsModelTransmissionMode Property
the operational state of replication and mirroring

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionModeEnum TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionModeEnum
    Get
    Set
public:
property TransmissionModeEnum TransmissionMode {
    TransmissionModeEnum get ();
    void set (TransmissionModeEnum value);
}
member TransmissionMode : TransmissionModeEnum with get, set

Property Value

Type: TransmissionModeEnum
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel Methods

CoreConnectionDetailsModel Methods

The CoreConnectionDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionOptionsModel Class

CoreConnectionOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreConnectionOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreConnectionOptionsModel
Public NotInheritable Class CoreConnectionOptionsModel
public ref class CoreConnectionOptionsModel sealed
[<SealedAttribute>]
type CoreConnectionOptionsModel =  class end

The CoreConnectionOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionOptionsModel | Initializes a new instance of the CoreConnectionOptionsModel class
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | the parameters used to start the connection between the source and target servers
Public property | PathTransformations | the path transformations
Public property | TargetAddress | the target address.
Public property | TargetEnginePort | the engine port on the target server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreConnectionOptionsModel Constructor

CoreConnectionOptionsModel Constructor
Initializes a new instance of the CoreConnectionOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionOptionsModel()
Public Sub New
public:
CoreConnectionOptionsModel()
new : unit -> CoreConnectionOptionsModel
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel Properties

CoreConnectionOptionsModel Properties

The CoreConnectionOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | the parameters used to start the connection between the source and target servers
Public property | PathTransformations | the path transformations
Public property | TargetAddress | the target address.
Public property | TargetEnginePort | the engine port on the target server
Top
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.ConnectionStartParameters Property

CoreConnectionOptionsModelConnectionStartParameters Property
the parameters used to start the connection between the source and target servers

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ ConnectionStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member ConnectionStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.PathTransformations Property

CoreConnectionOptionsModelPathTransformations Property
the path transformations

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.TargetAddress Property

CoreConnectionOptionsModelTargetAddress Property
the target address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetAddress { get; set; }
Public Property TargetAddress As String
    Get
    Set
public:
property String^ TargetAddress {
    String^ get ();
    void set (String^ value);
}
member TargetAddress : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.TargetEnginePort Property

CoreConnectionOptionsModelTargetEnginePort Property
the engine port on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
member TargetEnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel Methods

CoreConnectionOptionsModel Methods

The CoreConnectionOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreConnectionOptionsModel Class


CoreMonitorDetailsModel Class

CoreMonitorDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreMonitorDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreMonitorDetailsModel
Public NotInheritable Class CoreMonitorDetailsModel
public ref class CoreMonitorDetailsModel sealed
[<SealedAttribute>]
type CoreMonitorDetailsModel =  class end

The CoreMonitorDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorDetailsModel | Initializes a new instance of the CoreMonitorDetailsModel class
Top
Properties
 | Name | Description
Public property | HighAvailabilityState | the high availability state
Public property | MonitoredAddressStatuses | the status of the monitored addresses
Public property | MonitorId | the unique identifier of the monitor
Public property | MonitorName | the name of the monitor
Public property | RestoreStates | the state of the restore operation (if any) on this monitor
Public property | TargetAvailable | a value indicating whether or not the target machine, from which the details are obtained, is available
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreMonitorDetailsModel Constructor

CoreMonitorDetailsModel Constructor
Initializes a new instance of the CoreMonitorDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorDetailsModel()
Public Sub New
public:
CoreMonitorDetailsModel()
new : unit -> CoreMonitorDetailsModel
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel Properties

CoreMonitorDetailsModel Properties

The CoreMonitorDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | HighAvailabilityState | the high availability state
Public property | MonitoredAddressStatuses | the status of the monitored addresses
Public property | MonitorId | the unique identifier of the monitor
Public property | MonitorName | the name of the monitor
Public property | RestoreStates | the state of the restore operation (if any) on this monitor
Public property | TargetAvailable | a value indicating whether or not the target machine, from which the details are obtained, is available
Top
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.HighAvailabilityState Property

CoreMonitorDetailsModelHighAvailabilityState Property
the high availability state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HighAvailabilityStateEnum HighAvailabilityState { get; set; }
Public Property HighAvailabilityState As HighAvailabilityStateEnum
    Get
    Set
public:
property HighAvailabilityStateEnum HighAvailabilityState {
    HighAvailabilityStateEnum get ();
    void set (HighAvailabilityStateEnum value);
}
member HighAvailabilityState : HighAvailabilityStateEnum with get, set

Property Value

Type: HighAvailabilityStateEnum
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.MonitoredAddressStatuses Property

CoreMonitorDetailsModelMonitoredAddressStatuses Property
the status of the monitored addresses

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressStatusModel[] MonitoredAddressStatuses { get; set; }
Public Property MonitoredAddressStatuses As MonitoredAddressStatusModel()
    Get
    Set
public:
property array<MonitoredAddressStatusModel^>^ MonitoredAddressStatuses {
    array<MonitoredAddressStatusModel^>^ get ();
    void set (array<MonitoredAddressStatusModel^>^ value);
}
member MonitoredAddressStatuses : MonitoredAddressStatusModel[] with get, set

Property Value

Type: MonitoredAddressStatusModel
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.MonitorId Property

CoreMonitorDetailsModelMonitorId Property
the unique identifier of the monitor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
member MonitorId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.MonitorName Property

CoreMonitorDetailsModelMonitorName Property
the name of the monitor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MonitorName { get; set; }
Public Property MonitorName As String
    Get
    Set
public:
property String^ MonitorName {
    String^ get ();
    void set (String^ value);
}
member MonitorName : string with get, set

Property Value

Type: String
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.RestoreStates Property

CoreMonitorDetailsModelRestoreStates Property
the state of the restore operation (if any) on this monitor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreStatesEnum RestoreStates { get; set; }
Public Property RestoreStates As RestoreStatesEnum
    Get
    Set
public:
property RestoreStatesEnum RestoreStates {
    RestoreStatesEnum get ();
    void set (RestoreStatesEnum value);
}
member RestoreStates : RestoreStatesEnum with get, set

Property Value

Type: RestoreStatesEnum
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.TargetAvailable Property

CoreMonitorDetailsModelTargetAvailable Property
a value indicating whether or not the target machine, from which the details are obtained, is available

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
member TargetAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel Methods

CoreMonitorDetailsModel Methods

The CoreMonitorDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorOptionsModel Class

CoreMonitorOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreMonitorOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreMonitorOptionsModel
Public NotInheritable Class CoreMonitorOptionsModel
public ref class CoreMonitorOptionsModel sealed
[<SealedAttribute>]
type CoreMonitorOptionsModel =  class end

The CoreMonitorOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorOptionsModel | Initializes a new instance of the CoreMonitorOptionsModel class
Top
Properties
 | Name | Description
Public property | MonitorConfiguration | the monitor configuration
Public property | ShouldPerformLanFailover | a value indicating whether or not LAN (identity) failover should be performed versus WAN (none or DNS) failover
Public property | TotalTimeAllowed | the total time allowed without a successful ping before a failover condition is met
Public property | UseTotalTimeAllowed | a value indicating whether or not to use the totalTimeAllowed
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | SourceDomain | the source domain
Public field | SourceServer | the source server
Public field | TargetDomain | the target domain
Public field | TargetServer | the target server
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreMonitorOptionsModel Constructor

CoreMonitorOptionsModel Constructor
Initializes a new instance of the CoreMonitorOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorOptionsModel()
Public Sub New
public:
CoreMonitorOptionsModel()
new : unit -> CoreMonitorOptionsModel
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel Properties

CoreMonitorOptionsModel Properties

The CoreMonitorOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | MonitorConfiguration | the monitor configuration
Public property | ShouldPerformLanFailover | a value indicating whether or not LAN (identity) failover should be performed versus WAN (none or DNS) failover
Public property | TotalTimeAllowed | the total time allowed without a successful ping before a failover condition is met
Public property | UseTotalTimeAllowed | a value indicating whether or not to use the totalTimeAllowed
Top
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.MonitorConfiguration Property

CoreMonitorOptionsModelMonitorConfiguration Property
the monitor configuration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel MonitorConfiguration { get; set; }
Public Property MonitorConfiguration As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ MonitorConfiguration {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member MonitorConfiguration : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.ShouldPerformLanFailover Property

CoreMonitorOptionsModelShouldPerformLanFailover Property
a value indicating whether or not LAN (identity) failover should be performed versus WAN (none or DNS) failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> ShouldPerformLanFailover { get; set; }
Public Property ShouldPerformLanFailover As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ShouldPerformLanFailover {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member ShouldPerformLanFailover : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.TotalTimeAllowed Property

CoreMonitorOptionsModelTotalTimeAllowed Property
the total time allowed without a successful ping before a failover condition is met

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TotalTimeAllowed { get; set; }
Public Property TotalTimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TotalTimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
member TotalTimeAllowed : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.UseTotalTimeAllowed Property

CoreMonitorOptionsModelUseTotalTimeAllowed Property
a value indicating whether or not to use the totalTimeAllowed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseTotalTimeAllowed { get; set; }
Public Property UseTotalTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTotalTimeAllowed {
    bool get ();
    void set (bool value);
}
member UseTotalTimeAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel Methods

CoreMonitorOptionsModel Methods

The CoreMonitorOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel Fields

CoreMonitorOptionsModel Fields

The CoreMonitorOptionsModel type exposes the following members.

Fields
 | Name | Description
Public field | SourceDomain | the source domain
Public field | SourceServer | the source server
Public field | TargetDomain | the target domain
Public field | TargetServer | the target server
Top
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.SourceDomain Field

CoreMonitorOptionsModelSourceDomain Field
the source domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceDomain
Public SourceDomain As String
public:
String^ SourceDomain
val mutable SourceDomain: string

Field Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.SourceServer Field

CoreMonitorOptionsModelSourceServer Field
the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceServer
Public SourceServer As String
public:
String^ SourceServer
val mutable SourceServer: string

Field Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.TargetDomain Field

CoreMonitorOptionsModelTargetDomain Field
the target domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetDomain
Public TargetDomain As String
public:
String^ TargetDomain
val mutable TargetDomain: string

Field Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.TargetServer Field

CoreMonitorOptionsModelTargetServer Field
the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetServer
Public TargetServer As String
public:
String^ TargetServer
val mutable TargetServer: string

Field Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreQualificationResultsModel Class

CoreQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreQualificationResultsModel
Public NotInheritable Class CoreQualificationResultsModel
public ref class CoreQualificationResultsModel sealed
[<SealedAttribute>]
type CoreQualificationResultsModel =  class end

The CoreQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreQualificationResultsModel | Initializes a new instance of the CoreQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | CompressionLevels | the compression levels
Public property | DefaultAllToOneBasePath | the default base path to use for getting the recommended all-to-one path transformations
Public property | SourceAddresses | the source machine's available IP addresses
Public property | SourceEnginePort | the source engine port
Public property | SourceMachineName | the name of the source machine
Public property | SourceNetworkId | the source network id used to communicate with the source from the target
Public property | SourceNetworkInterfaces | the source network interfaces
Public property | SourceProductInfo | the source product info
Public property | SourceVolumes | the source volumes
Public property | TargetAddresses | the target machine's available IP addresses
Public property | TargetEnginePort | the target engine port
Public property | TargetMachineName | the name of the target machine
Public property | TargetNetworkInterfaces | the target network interfaces
Public property | TargetProductInfo | the target product info
Public property | TargetVolumes | the target volumes
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreQualificationResultsModel Constructor

CoreQualificationResultsModel Constructor
Initializes a new instance of the CoreQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreQualificationResultsModel()
Public Sub New
public:
CoreQualificationResultsModel()
new : unit -> CoreQualificationResultsModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel Properties

CoreQualificationResultsModel Properties

The CoreQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | the compression levels
Public property | DefaultAllToOneBasePath | the default base path to use for getting the recommended all-to-one path transformations
Public property | SourceAddresses | the source machine's available IP addresses
Public property | SourceEnginePort | the source engine port
Public property | SourceMachineName | the name of the source machine
Public property | SourceNetworkId | the source network id used to communicate with the source from the target
Public property | SourceNetworkInterfaces | the source network interfaces
Public property | SourceProductInfo | the source product info
Public property | SourceVolumes | the source volumes
Public property | TargetAddresses | the target machine's available IP addresses
Public property | TargetEnginePort | the target engine port
Public property | TargetMachineName | the name of the target machine
Public property | TargetNetworkInterfaces | the target network interfaces
Public property | TargetProductInfo | the target product info
Public property | TargetVolumes | the target volumes
Top
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.CompressionLevels Property

CoreQualificationResultsModelCompressionLevels Property
the compression levels

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevelModel()
    Get
    Set
public:
property array<CompressionLevelModel^>^ CompressionLevels {
    array<CompressionLevelModel^>^ get ();
    void set (array<CompressionLevelModel^>^ value);
}
member CompressionLevels : CompressionLevelModel[] with get, set

Property Value

Type: CompressionLevelModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.DefaultAllToOneBasePath Property

CoreQualificationResultsModelDefaultAllToOneBasePath Property
the default base path to use for getting the recommended all-to-one path transformations

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultAllToOneBasePath { get; set; }
Public Property DefaultAllToOneBasePath As String
    Get
    Set
public:
property String^ DefaultAllToOneBasePath {
    String^ get ();
    void set (String^ value);
}
member DefaultAllToOneBasePath : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceAddresses Property

CoreQualificationResultsModelSourceAddresses Property
the source machine's available IP addresses

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] SourceAddresses { get; set; }
Public Property SourceAddresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ SourceAddresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member SourceAddresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceEnginePort Property

CoreQualificationResultsModelSourceEnginePort Property
the source engine port

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
member SourceEnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceMachineName Property

CoreQualificationResultsModelSourceMachineName Property
the name of the source machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceNetworkId Property

CoreQualificationResultsModelSourceNetworkId Property
the source network id used to communicate with the source from the target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
member SourceNetworkId : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceNetworkInterfaces Property

CoreQualificationResultsModelSourceNetworkInterfaces Property
the source network interfaces

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel[] SourceNetworkInterfaces { get; set; }
Public Property SourceNetworkInterfaces As NetworkInterfaceInfoModel()
    Get
    Set
public:
property array<NetworkInterfaceInfoModel^>^ SourceNetworkInterfaces {
    array<NetworkInterfaceInfoModel^>^ get ();
    void set (array<NetworkInterfaceInfoModel^>^ value);
}
member SourceNetworkInterfaces : NetworkInterfaceInfoModel[] with get, set

Property Value

Type: NetworkInterfaceInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceProductInfo Property

CoreQualificationResultsModelSourceProductInfo Property
the source product info

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel SourceProductInfo { get; set; }
Public Property SourceProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ SourceProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member SourceProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceVolumes Property

CoreQualificationResultsModelSourceVolumes Property
the source volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel[] SourceVolumes { get; set; }
Public Property SourceVolumes As VolumeModel()
    Get
    Set
public:
property array<VolumeModel^>^ SourceVolumes {
    array<VolumeModel^>^ get ();
    void set (array<VolumeModel^>^ value);
}
member SourceVolumes : VolumeModel[] with get, set

Property Value

Type: VolumeModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetAddresses Property

CoreQualificationResultsModelTargetAddresses Property
the target machine's available IP addresses

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] TargetAddresses { get; set; }
Public Property TargetAddresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ TargetAddresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member TargetAddresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetEnginePort Property

CoreQualificationResultsModelTargetEnginePort Property
the target engine port

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
member TargetEnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetMachineName Property

CoreQualificationResultsModelTargetMachineName Property
the name of the target machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
member TargetMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetNetworkInterfaces Property

CoreQualificationResultsModelTargetNetworkInterfaces Property
the target network interfaces

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel[] TargetNetworkInterfaces { get; set; }
Public Property TargetNetworkInterfaces As NetworkInterfaceInfoModel()
    Get
    Set
public:
property array<NetworkInterfaceInfoModel^>^ TargetNetworkInterfaces {
    array<NetworkInterfaceInfoModel^>^ get ();
    void set (array<NetworkInterfaceInfoModel^>^ value);
}
member TargetNetworkInterfaces : NetworkInterfaceInfoModel[] with get, set

Property Value

Type: NetworkInterfaceInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetProductInfo Property

CoreQualificationResultsModelTargetProductInfo Property
the target product info

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel TargetProductInfo { get; set; }
Public Property TargetProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ TargetProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member TargetProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetVolumes Property

CoreQualificationResultsModelTargetVolumes Property
the target volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel[] TargetVolumes { get; set; }
Public Property TargetVolumes As VolumeModel()
    Get
    Set
public:
property array<VolumeModel^>^ TargetVolumes {
    array<VolumeModel^>^ get ();
    void set (array<VolumeModel^>^ value);
}
member TargetVolumes : VolumeModel[] with get, set

Property Value

Type: VolumeModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel Methods

CoreQualificationResultsModel Methods

The CoreQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreQualificationResultsModel Class


CreateOptionsModel Class

CreateOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateOptionsModel
Public NotInheritable Class CreateOptionsModel
public ref class CreateOptionsModel sealed
[<SealedAttribute>]
type CreateOptionsModel =  class end

The CreateOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateOptionsModel | Initializes a new instance of the CreateOptionsModel class
Top
Properties
 | Name | Description
Public property | JobCredentials | the job credentials
Public property | JobOptions | the job options
Public property | JobType | the type of the job
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateOptionsModel Constructor

CreateOptionsModel Constructor
Initializes a new instance of the CreateOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CreateOptionsModel()
Public Sub New
public:
CreateOptionsModel()
new : unit -> CreateOptionsModel
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel Properties

CreateOptionsModel Properties

The CreateOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials | the job credentials
Public property | JobOptions | the job options
Public property | JobType | the type of the job
Top
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel.JobCredentials Property

CreateOptionsModelJobCredentials Property
the job credentials

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel.JobOptions Property

CreateOptionsModelJobOptions Property
the job options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel.JobType Property

CreateOptionsModelJobType Property
the type of the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel Methods

CreateOptionsModel Methods

The CreateOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateOptionsModel Class


CredentialModel Class

CredentialModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCredentialModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CredentialModel
Public NotInheritable Class CredentialModel
public ref class CredentialModel sealed
[<SealedAttribute>]
type CredentialModel =  class end

The CredentialModel type exposes the following members.

Constructors
 | Name | Description
Public method | CredentialModel | Initializes a new instance of the CredentialModel class
Top
Properties
 | Name | Description
Public property | Domain | the domain
Public property | Password | the password
Public property | UserName | the user name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CredentialModel Constructor

CredentialModel Constructor
Initializes a new instance of the CredentialModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel()
Public Sub New
public:
CredentialModel()
new : unit -> CredentialModel
See Also

Reference

CredentialModel Class


CredentialModel Properties

CredentialModel Properties

The CredentialModel type exposes the following members.

Properties
 | Name | Description
Public property | Domain | the domain
Public property | Password | the password
Public property | UserName | the user name
Top
See Also

Reference

CredentialModel Class


CredentialModel.Domain Property

CredentialModelDomain Property
the domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

CredentialModel Class


CredentialModel.Password Property

CredentialModelPassword Property
the password

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

CredentialModel Class


CredentialModel.UserName Property

CredentialModelUserName Property
the user name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

CredentialModel Class


CredentialModel Methods

CredentialModel Methods

The CredentialModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CredentialModel Class


CutoverDetailsModel Class

CutoverDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCutoverDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CutoverDetailsModel
Public NotInheritable Class CutoverDetailsModel
public ref class CutoverDetailsModel sealed
[<SealedAttribute>]
type CutoverDetailsModel =  class end

The CutoverDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CutoverDetailsModel | Initializes a new instance of the CutoverDetailsModel class
Top
Properties
 | Name | Description
Public property | PercentComplete | the percentage complete of the cutover operation
Public property | State | the state of the cutover operation
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CutoverDetailsModel Constructor

CutoverDetailsModel Constructor
Initializes a new instance of the CutoverDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CutoverDetailsModel()
Public Sub New
public:
CutoverDetailsModel()
new : unit -> CutoverDetailsModel
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel Properties

CutoverDetailsModel Properties

The CutoverDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | PercentComplete | the percentage complete of the cutover operation
Public property | State | the state of the cutover operation
Top
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel.PercentComplete Property

CutoverDetailsModelPercentComplete Property
the percentage complete of the cutover operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
member PercentComplete : int with get, set

Property Value

Type: Int32
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel.State Property

CutoverDetailsModelState Property
the state of the cutover operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
member State : int with get, set

Property Value

Type: Int32
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel Methods

CutoverDetailsModel Methods

The CutoverDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CutoverDetailsModel Class


DeleteJobRequestModel Class

DeleteJobRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDeleteJobRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DeleteJobRequestModel
Public NotInheritable Class DeleteJobRequestModel
public ref class DeleteJobRequestModel sealed
[<SealedAttribute>]
type DeleteJobRequestModel =  class end

The DeleteJobRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteJobRequestModel | Initializes a new instance of the DeleteJobRequestModel class
Top
Properties
 | Name | Description
Public property | DeleteReplica | a value indicating whether or not to delete the replica virtual machine
Public property | DiscardTargetQueue | a value indicating whether or not to discard any replication or mirror operations in the target queue
Public property | ImageOptions | the option for what to do with the image when the job is deleted
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DeleteJobRequestModel Constructor

DeleteJobRequestModel Constructor
Initializes a new instance of the DeleteJobRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DeleteJobRequestModel()
Public Sub New
public:
DeleteJobRequestModel()
new : unit -> DeleteJobRequestModel
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel Properties

DeleteJobRequestModel Properties

The DeleteJobRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteReplica | a value indicating whether or not to delete the replica virtual machine
Public property | DiscardTargetQueue | a value indicating whether or not to discard any replication or mirror operations in the target queue
Public property | ImageOptions | the option for what to do with the image when the job is deleted
Top
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel.DeleteReplica Property

DeleteJobRequestModelDeleteReplica Property
a value indicating whether or not to delete the replica virtual machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteReplica { get; set; }
Public Property DeleteReplica As Boolean
    Get
    Set
public:
property bool DeleteReplica {
    bool get ();
    void set (bool value);
}
member DeleteReplica : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel.DiscardTargetQueue Property

DeleteJobRequestModelDiscardTargetQueue Property
a value indicating whether or not to discard any replication or mirror operations in the target queue

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DiscardTargetQueue { get; set; }
Public Property DiscardTargetQueue As Boolean
    Get
    Set
public:
property bool DiscardTargetQueue {
    bool get ();
    void set (bool value);
}
member DiscardTargetQueue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel.ImageOptions Property

DeleteJobRequestModelImageOptions Property
the option for what to do with the image when the job is deleted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel ImageOptions { get; set; }
Public Property ImageOptions As ImageDeleteInfoModel
    Get
    Set
public:
property ImageDeleteInfoModel^ ImageOptions {
    ImageDeleteInfoModel^ get ();
    void set (ImageDeleteInfoModel^ value);
}
member ImageOptions : ImageDeleteInfoModel with get, set

Property Value

Type: ImageDeleteInfoModel
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel Methods

DeleteJobRequestModel Methods

The DeleteJobRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteJobRequestModel Class


DesktopInteractionModeEnum Enumeration

DesktopInteractionModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum DesktopInteractionModeEnum
Public Enumeration DesktopInteractionModeEnum
public enum class DesktopInteractionModeEnum
type DesktopInteractionModeEnum
Members
Member name | Value | Description
None | 0 |
Interact | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


DirectoryItemModel Class

DirectoryItemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsDirectoryItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectoryItemModel : PhysicalItemModel
Public Class DirectoryItemModel
    Inherits PhysicalItemModel
public ref class DirectoryItemModel : public PhysicalItemModel
type DirectoryItemModel =
    class
        inherit PhysicalItemModel
    end

The DirectoryItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryItemModel | Initializes a new instance of the DirectoryItemModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DirectoryItemModel Constructor

DirectoryItemModel Constructor
Initializes a new instance of the DirectoryItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DirectoryItemModel()
Public Sub New
public:
DirectoryItemModel()
new : unit -> DirectoryItemModel
See Also

Reference

DirectoryItemModel Class


DirectoryItemModel Properties

DirectoryItemModel Properties

The DirectoryItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Top
See Also

Reference

DirectoryItemModel Class


DirectoryItemModel Methods

DirectoryItemModel Methods

The DirectoryItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DirectoryItemModel Class


DnsDomainDetailsModel Class

DnsDomainDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsDomainDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsDomainDetailsModel
Public NotInheritable Class DnsDomainDetailsModel
public ref class DnsDomainDetailsModel sealed
[<SealedAttribute>]
type DnsDomainDetailsModel =  class end

The DnsDomainDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsDomainDetailsModel | Initializes a new instance of the DnsDomainDetailsModel class
Top
Properties
 | Name | Description
Public property | AddressMappings | the list of IP addresses to be updated
Public property | Credentials | the domain credentials
Public property | DnsServers | the list of DNS servers to be updated
Public property | DomainName | the name of the domain
Public property | ShouldUpdateTtl | a value indicating whether or not the time-to-live value should be updated for this record
Public property | TtlValue | the TTL value, in seconds.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsDomainDetailsModel Constructor

DnsDomainDetailsModel Constructor
Initializes a new instance of the DnsDomainDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsDomainDetailsModel()
Public Sub New
public:
DnsDomainDetailsModel()
new : unit -> DnsDomainDetailsModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel Properties

DnsDomainDetailsModel Properties

The DnsDomainDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | AddressMappings | the list of IP addresses to be updated
Public property | Credentials | the domain credentials
Public property | DnsServers | the list of DNS servers to be updated
Public property | DomainName | the name of the domain
Public property | ShouldUpdateTtl | a value indicating whether or not the time-to-live value should be updated for this record
Public property | TtlValue | the TTL value, in seconds.
Top
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.AddressMappings Property

DnsDomainDetailsModelAddressMappings Property
the list of IP addresses to be updated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkAddressMapModel[] AddressMappings { get; set; }
Public Property AddressMappings As NetworkAddressMapModel()
    Get
    Set
public:
property array<NetworkAddressMapModel^>^ AddressMappings {
    array<NetworkAddressMapModel^>^ get ();
    void set (array<NetworkAddressMapModel^>^ value);
}
member AddressMappings : NetworkAddressMapModel[] with get, set

Property Value

Type: NetworkAddressMapModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.Credentials Property

DnsDomainDetailsModelCredentials Property
the domain credentials

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credentials { get; set; }
Public Property Credentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.DnsServers Property

DnsDomainDetailsModelDnsServers Property
the list of DNS servers to be updated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsServerDetailModel[] DnsServers { get; set; }
Public Property DnsServers As DnsServerDetailModel()
    Get
    Set
public:
property array<DnsServerDetailModel^>^ DnsServers {
    array<DnsServerDetailModel^>^ get ();
    void set (array<DnsServerDetailModel^>^ value);
}
member DnsServers : DnsServerDetailModel[] with get, set

Property Value

Type: DnsServerDetailModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.DomainName Property

DnsDomainDetailsModelDomainName Property
the name of the domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DomainName { get; set; }
Public Property DomainName As String
    Get
    Set
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
member DomainName : string with get, set

Property Value

Type: String
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.ShouldUpdateTtl Property

DnsDomainDetailsModelShouldUpdateTtl Property
a value indicating whether or not the time-to-live value should be updated for this record

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
member ShouldUpdateTtl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.TtlValue Property

DnsDomainDetailsModelTtlValue Property
the TTL value, in seconds.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
member TtlValue : int with get, set

Property Value

Type: Int32
The TTL value, in seconds.
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel Methods

DnsDomainDetailsModel Methods

The DnsDomainDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsDomainDetailsModel Class


DnsOptionsModel Class

DnsOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsOptionsModel
Public NotInheritable Class DnsOptionsModel
public ref class DnsOptionsModel sealed
[<SealedAttribute>]
type DnsOptionsModel =  class end

The DnsOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsOptionsModel | Initializes a new instance of the DnsOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalDns | specifies an additional source server DN to lock
Public property | AllIPAddressesNeedMapping | defines if the current environment being protected require all IP addresses to be mapped to an appropriate target IP address
Public property | AlternateTrustees | overrides the default trustees of "NT AUTHORITY/SYSTEM" and the source computer account (for clustered environments)
Public property | Domains | the domains that will be updated during failover
Public property | Enabled | a value indicating whether or not DNS failover is enabled on this job
Public property | SourceServerInWorkgroup | specifies that source server is in a workgroup not a domain
Public property | SourceServerName | the name of the source server
Public property | TargetServerName | the name of the target server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsOptionsModel Constructor

DnsOptionsModel Constructor
Initializes a new instance of the DnsOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsOptionsModel()
Public Sub New
public:
DnsOptionsModel()
new : unit -> DnsOptionsModel
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel Properties

DnsOptionsModel Properties

The DnsOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns | specifies an additional source server DN to lock
Public property | AllIPAddressesNeedMapping | defines if the current environment being protected require all IP addresses to be mapped to an appropriate target IP address
Public property | AlternateTrustees | overrides the default trustees of "NT AUTHORITY/SYSTEM" and the source computer account (for clustered environments)
Public property | Domains | the domains that will be updated during failover
Public property | Enabled | a value indicating whether or not DNS failover is enabled on this job
Public property | SourceServerInWorkgroup | specifies that source server is in a workgroup not a domain
Public property | SourceServerName | the name of the source server
Public property | TargetServerName | the name of the target server
Top
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.AdditionalDns Property

DnsOptionsModelAdditionalDns Property
specifies an additional source server DN to lock

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AdditionalDns { get; set; }
Public Property AdditionalDns As String()
    Get
    Set
public:
property array<String^>^ AdditionalDns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AdditionalDns : string[] with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.AllIPAddressesNeedMapping Property

DnsOptionsModelAllIPAddressesNeedMapping Property
defines if the current environment being protected require all IP addresses to be mapped to an appropriate target IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> AllIPAddressesNeedMapping { get; set; }
Public Property AllIPAddressesNeedMapping As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> AllIPAddressesNeedMapping {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member AllIPAddressesNeedMapping : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.AlternateTrustees Property

DnsOptionsModelAlternateTrustees Property
overrides the default trustees of "NT AUTHORITY/SYSTEM" and the source computer account (for clustered environments)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AlternateTrustees { get; set; }
Public Property AlternateTrustees As String()
    Get
    Set
public:
property array<String^>^ AlternateTrustees {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AlternateTrustees : string[] with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.Domains Property

DnsOptionsModelDomains Property
the domains that will be updated during failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsDomainDetailsModel[] Domains { get; set; }
Public Property Domains As DnsDomainDetailsModel()
    Get
    Set
public:
property array<DnsDomainDetailsModel^>^ Domains {
    array<DnsDomainDetailsModel^>^ get ();
    void set (array<DnsDomainDetailsModel^>^ value);
}
member Domains : DnsDomainDetailsModel[] with get, set

Property Value

Type: DnsDomainDetailsModel
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.Enabled Property

DnsOptionsModelEnabled Property
a value indicating whether or not DNS failover is enabled on this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.SourceServerInWorkgroup Property

DnsOptionsModelSourceServerInWorkgroup Property
specifies that source server is in a workgroup not a domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceServerInWorkgroup { get; set; }
Public Property SourceServerInWorkgroup As Boolean
    Get
    Set
public:
property bool SourceServerInWorkgroup {
    bool get ();
    void set (bool value);
}
member SourceServerInWorkgroup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.SourceServerName Property

DnsOptionsModelSourceServerName Property
the name of the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceServerName { get; set; }
Public Property SourceServerName As String
    Get
    Set
public:
property String^ SourceServerName {
    String^ get ();
    void set (String^ value);
}
member SourceServerName : string with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.TargetServerName Property

DnsOptionsModelTargetServerName Property
the name of the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetServerName { get; set; }
Public Property TargetServerName As String
    Get
    Set
public:
property String^ TargetServerName {
    String^ get ();
    void set (String^ value);
}
member TargetServerName : string with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel Methods

DnsOptionsModel Methods

The DnsOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsOptionsModel Class


DnsRecordLockOptionsModel Class

DnsRecordLockOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsRecordLockOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsRecordLockOptionsModel
Public NotInheritable Class DnsRecordLockOptionsModel
public ref class DnsRecordLockOptionsModel sealed
[<SealedAttribute>]
type DnsRecordLockOptionsModel =  class end

The DnsRecordLockOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsRecordLockOptionsModel | Initializes a new instance of the DnsRecordLockOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalDns | the additional DNS
Public property | DnsServer | the DNS server
Public property | Server | the server
Public property | Trustees | the trustees
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsRecordLockOptionsModel Constructor

DnsRecordLockOptionsModel Constructor
Initializes a new instance of the DnsRecordLockOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsRecordLockOptionsModel()
Public Sub New
public:
DnsRecordLockOptionsModel()
new : unit -> DnsRecordLockOptionsModel
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel Properties

DnsRecordLockOptionsModel Properties

The DnsRecordLockOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns | the additional DNS
Public property | DnsServer | the DNS server
Public property | Server | the server
Public property | Trustees | the trustees
Top
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.AdditionalDns Property

DnsRecordLockOptionsModelAdditionalDns Property
the additional DNS

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> AdditionalDns { get; set; }
Public Property AdditionalDns As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AdditionalDns {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member AdditionalDns : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.DnsServer Property

DnsRecordLockOptionsModelDnsServer Property
the DNS server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DnsServer { get; set; }
Public Property DnsServer As String
    Get
    Set
public:
property String^ DnsServer {
    String^ get ();
    void set (String^ value);
}
member DnsServer : string with get, set

Property Value

Type: String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.Server Property

DnsRecordLockOptionsModelServer Property
the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.Trustees Property

DnsRecordLockOptionsModelTrustees Property
the trustees

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Trustees { get; set; }
Public Property Trustees As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Trustees {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member Trustees : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel Methods

DnsRecordLockOptionsModel Methods

The DnsRecordLockOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsRecordLockOptionsModel Class


DnsServerDetailModel Class

DnsServerDetailModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsServerDetailModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsServerDetailModel
Public NotInheritable Class DnsServerDetailModel
public ref class DnsServerDetailModel sealed
[<SealedAttribute>]
type DnsServerDetailModel =  class end

The DnsServerDetailModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsServerDetailModel | Initializes a new instance of the DnsServerDetailModel class
Top
Properties
 | Name | Description
Public property | Address | the address of the DNS server
Public property | Origin | the origin of the DNS server
Public property | SelectedForUpdate | a value indicating whether or not this DNS server will be updated during DNS failover
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsServerDetailModel Constructor

DnsServerDetailModel Constructor
Initializes a new instance of the DnsServerDetailModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsServerDetailModel()
Public Sub New
public:
DnsServerDetailModel()
new : unit -> DnsServerDetailModel
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel Properties

DnsServerDetailModel Properties

The DnsServerDetailModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | the address of the DNS server
Public property | Origin | the origin of the DNS server
Public property | SelectedForUpdate | a value indicating whether or not this DNS server will be updated during DNS failover
Top
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel.Address Property

DnsServerDetailModelAddress Property
the address of the DNS server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel.Origin Property

DnsServerDetailModelOrigin Property
the origin of the DNS server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Origin { get; set; }
Public Property Origin As String
    Get
    Set
public:
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
member Origin : string with get, set

Property Value

Type: String
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel.SelectedForUpdate Property

DnsServerDetailModelSelectedForUpdate Property
a value indicating whether or not this DNS server will be updated during DNS failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectedForUpdate { get; set; }
Public Property SelectedForUpdate As Boolean
    Get
    Set
public:
property bool SelectedForUpdate {
    bool get ();
    void set (bool value);
}
member SelectedForUpdate : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel Methods

DnsServerDetailModel Methods

The DnsServerDetailModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsServerDetailModel Class


DynamicServiceEndpointModel Class

DynamicServiceEndpointModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDynamicServiceEndpointModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DynamicServiceEndpointModel
Public NotInheritable Class DynamicServiceEndpointModel
public ref class DynamicServiceEndpointModel sealed
[<SealedAttribute>]
type DynamicServiceEndpointModel =  class end

The DynamicServiceEndpointModel type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicServiceEndpointModel | Initializes a new instance of the DynamicServiceEndpointModel class
Top
Properties
 | Name | Description
Public property | Port | port where the service is hosted
Public property | ProtocolTags | attributes and information necessary to connect
Public property | RelativeUri | relative uri where the service is hosted
Public property | ServiceTag | service tag associated with the endpoint
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DynamicServiceEndpointModel Constructor

DynamicServiceEndpointModel Constructor
Initializes a new instance of the DynamicServiceEndpointModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicServiceEndpointModel()
Public Sub New
public:
DynamicServiceEndpointModel()
new : unit -> DynamicServiceEndpointModel
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel Properties

DynamicServiceEndpointModel Properties

The DynamicServiceEndpointModel type exposes the following members.

Properties
 | Name | Description
Public property | Port | port where the service is hosted
Public property | ProtocolTags | attributes and information necessary to connect
Public property | RelativeUri | relative uri where the service is hosted
Public property | ServiceTag | service tag associated with the endpoint
Top
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.Port Property

DynamicServiceEndpointModelPort Property
port where the service is hosted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.ProtocolTags Property

DynamicServiceEndpointModelProtocolTags Property
attributes and information necessary to connect

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ProtocolTags { get; set; }
Public Property ProtocolTags As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ProtocolTags {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ProtocolTags : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
Remarks
This list of protocol tags is intended to be a hint to clients. It may include schemes, authentication models, protocols necessary to connect to the service.
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.RelativeUri Property

DynamicServiceEndpointModelRelativeUri Property
relative uri where the service is hosted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RelativeUri { get; set; }
Public Property RelativeUri As String
    Get
    Set
public:
property String^ RelativeUri {
    String^ get ();
    void set (String^ value);
}
member RelativeUri : string with get, set

Property Value

Type: String
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.ServiceTag Property

DynamicServiceEndpointModelServiceTag Property
service tag associated with the endpoint

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceTag { get; set; }
Public Property ServiceTag As String
    Get
    Set
public:
property String^ ServiceTag {
    String^ get ();
    void set (String^ value);
}
member ServiceTag : string with get, set

Property Value

Type: String
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel Methods

DynamicServiceEndpointModel Methods

The DynamicServiceEndpointModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DynamicServiceEndpointModel Class


EmailOptionsModel Class

EmailOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EmailOptionsModel
Public NotInheritable Class EmailOptionsModel
public ref class EmailOptionsModel sealed
[<SealedAttribute>]
type EmailOptionsModel =  class end

The EmailOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailOptionsModel | Initializes a new instance of the EmailOptionsModel class
Top
Properties
 | Name | Description
Public property | ConnectionSecurity | connection security
Public property | Enabled | value indicating whether or not e-mail notifications are enabled
Public property | EntryIdFilter | entry id filter
Public property | EntryTypeFilter | value that specifies one or more comma-delimited Windows Event Log entry types (Error, Warning, etc.) for which e-mail notifications should be sent
Public property | From | email address that will be placed in the From field of the e-mail message
Public property | IncludeEventDescriptionInSubject | value indicating whether or not to include the event description in the subject of the notification e-mails
Public property | LoginRequired | value indicating whether to login to the SMTP server or not
Public property | SmtpCredentials | the SMTP credentials - missing to use the SMTP server anonymously
Public property | SmtpPort | the SMTP port - missing to use the default SMTP port (25)
Public property | SmtpServer | the SMTP server
Public property | SubjectPrefix | text that will be added to the beginning of the e-mail subject
Public property | To | one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailOptionsModel Constructor

EmailOptionsModel Constructor
Initializes a new instance of the EmailOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmailOptionsModel()
Public Sub New
public:
EmailOptionsModel()
new : unit -> EmailOptionsModel
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel Properties

EmailOptionsModel Properties

The EmailOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionSecurity | connection security
Public property | Enabled | value indicating whether or not e-mail notifications are enabled
Public property | EntryIdFilter | entry id filter
Public property | EntryTypeFilter | value that specifies one or more comma-delimited Windows Event Log entry types (Error, Warning, etc.) for which e-mail notifications should be sent
Public property | From | email address that will be placed in the From field of the e-mail message
Public property | IncludeEventDescriptionInSubject | value indicating whether or not to include the event description in the subject of the notification e-mails
Public property | LoginRequired | value indicating whether to login to the SMTP server or not
Public property | SmtpCredentials | the SMTP credentials - missing to use the SMTP server anonymously
Public property | SmtpPort | the SMTP port - missing to use the default SMTP port (25)
Public property | SmtpServer | the SMTP server
Public property | SubjectPrefix | text that will be added to the beginning of the e-mail subject
Public property | To | one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent
Top
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.ConnectionSecurity Property

EmailOptionsModelConnectionSecurity Property
connection security

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SmtpConnectionSecurityEnum ConnectionSecurity { get; set; }
Public Property ConnectionSecurity As SmtpConnectionSecurityEnum
    Get
    Set
public:
property SmtpConnectionSecurityEnum ConnectionSecurity {
    SmtpConnectionSecurityEnum get ();
    void set (SmtpConnectionSecurityEnum value);
}
member ConnectionSecurity : SmtpConnectionSecurityEnum with get, set

Property Value

Type: SmtpConnectionSecurityEnum
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.Enabled Property

EmailOptionsModelEnabled Property
value indicating whether or not e-mail notifications are enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.EntryIdFilter Property

EmailOptionsModelEntryIdFilter Property
entry id filter

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EntryIdFilter { get; set; }
Public Property EntryIdFilter As String
    Get
    Set
public:
property String^ EntryIdFilter {
    String^ get ();
    void set (String^ value);
}
member EntryIdFilter : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.EntryTypeFilter Property

EmailOptionsModelEntryTypeFilter Property
value that specifies one or more comma-delimited Windows Event Log entry types (Error, Warning, etc.) for which e-mail notifications should be sent

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string EntryTypeFilter { get; set; }
Public Property EntryTypeFilter As String
    Get
    Set
public:
property String^ EntryTypeFilter {
    String^ get ();
    void set (String^ value);
}
member EntryTypeFilter : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.From Property

EmailOptionsModelFrom Property
email address that will be placed in the From field of the e-mail message

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string From { get; set; }
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
member From : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.IncludeEventDescriptionInSubject Property

EmailOptionsModelIncludeEventDescriptionInSubject Property
value indicating whether or not to include the event description in the subject of the notification e-mails

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeEventDescriptionInSubject { get; set; }
Public Property IncludeEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IncludeEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
member IncludeEventDescriptionInSubject : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.LoginRequired Property

EmailOptionsModelLoginRequired Property
value indicating whether to login to the SMTP server or not

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoginRequired { get; set; }
Public Property LoginRequired As Boolean
    Get
    Set
public:
property bool LoginRequired {
    bool get ();
    void set (bool value);
}
member LoginRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SmtpCredentials Property

EmailOptionsModelSmtpCredentials Property
the SMTP credentials - missing to use the SMTP server anonymously

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel SmtpCredentials { get; set; }
Public Property SmtpCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ SmtpCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member SmtpCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SmtpPort Property

EmailOptionsModelSmtpPort Property
the SMTP port - missing to use the default SMTP port (25)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SmtpPort { get; set; }
Public Property SmtpPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SmtpPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SmtpPort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SmtpServer Property

EmailOptionsModelSmtpServer Property
the SMTP server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SmtpServer { get; set; }
Public Property SmtpServer As String
    Get
    Set
public:
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}
member SmtpServer : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SubjectPrefix Property

EmailOptionsModelSubjectPrefix Property
text that will be added to the beginning of the e-mail subject

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
member SubjectPrefix : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.To Property

EmailOptionsModelTo Property
one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
member To : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel Methods

EmailOptionsModel Methods

The EmailOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailOptionsModel Class


EmailTestModel Class

EmailTestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailTestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class EmailTestModel
Public Class EmailTestModel
public ref class EmailTestModel
type EmailTestModel =  class end

The EmailTestModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailTestModel | Initializes a new instance of the EmailTestModel class
Top
Properties
 | Name | Description
Public property | Body | the email body
Public property | Options | the email options
Public property | To | the recipient list
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailTestModel Constructor

EmailTestModel Constructor
Initializes a new instance of the EmailTestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmailTestModel()
Public Sub New
public:
EmailTestModel()
new : unit -> EmailTestModel
See Also

Reference

EmailTestModel Class


EmailTestModel Properties

EmailTestModel Properties

The EmailTestModel type exposes the following members.

Properties
 | Name | Description
Public property | Body | the email body
Public property | Options | the email options
Public property | To | the recipient list
Top
See Also

Reference

EmailTestModel Class


EmailTestModel.Body Property

EmailTestModelBody Property
the email body

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Body { get; set; }
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
member Body : string with get, set

Property Value

Type: String
See Also

Reference

EmailTestModel Class


EmailTestModel.Options Property

EmailTestModelOptions Property
the email options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EmailOptionsModel Options { get; set; }
Public Property Options As EmailOptionsModel
    Get
    Set
public:
property EmailOptionsModel^ Options {
    EmailOptionsModel^ get ();
    void set (EmailOptionsModel^ value);
}
member Options : EmailOptionsModel with get, set

Property Value

Type: EmailOptionsModel
See Also

Reference

EmailTestModel Class


EmailTestModel.To Property

EmailTestModelTo Property
the recipient list

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
member To : string with get, set

Property Value

Type: String
See Also

Reference

EmailTestModel Class


EmailTestModel Methods

EmailTestModel Methods

The EmailTestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailTestModel Class


EngineControlStatusModel Class

EngineControlStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEngineControlStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EngineControlStatusModel
Public NotInheritable Class EngineControlStatusModel
public ref class EngineControlStatusModel sealed
[<SealedAttribute>]
type EngineControlStatusModel =  class end

The EngineControlStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | EngineControlStatusModel | Initializes a new instance of the EngineControlStatusModel class
Top
Properties
 | Name | Description
Public property | CanPauseMirror | a value indicating whether mirroring can be paused on the engine connection represented by this instance
Public property | CanPauseTarget | a value indicating whether the target can be paused for the engine connection represented by this instance
Public property | CanPauseTransmission | a value indicating whether transmission can be paused on the engine connection represented by this instance
Public property | CanProcessOrphans | a value indicating whether orphans can be processed on the engine connection represented by this instance
Public property | CanResumeMirror | a value indicating whether mirroring can be resumed on the engine connection represented by this instance
Public property | CanResumeTarget | a value indicating whether the target can be resumed for the engine connection represented by this instance
Public property | CanResumeTransmission | a value indicating whether transmission can be resumed on the engine connection represented by this instance
Public property | CanSetBandwidth | a value indicating whether the bandwidth limit can be set on the engine connection represented by this instance
Public property | CanStartMirror | a value indicating whether mirroring can be started on the engine connection represented by this instance
Public property | CanStartTransmission | a value indicating whether transmission can be started on the engine connection represented by this instance
Public property | CanStopMirror | a value indicating whether mirroring can be stopped on the engine connection represented by this instance
Public property | CanTakeSnapshot | a value indicating whether a snapshot can be taken for the engine connection represented by this instance
Public property | CanUpdateShares | a value indicating whether shares can be updated
Public property | CanVerify | a value indicating whether verification can be performed on the engine connection represented by this instance
Public property | ConnectionId | the connection id
Public property | Role | the role of the engine connection in the job
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EngineControlStatusModel Constructor

EngineControlStatusModel Constructor
Initializes a new instance of the EngineControlStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EngineControlStatusModel()
Public Sub New
public:
EngineControlStatusModel()
new : unit -> EngineControlStatusModel
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel Properties

EngineControlStatusModel Properties

The EngineControlStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | CanPauseMirror | a value indicating whether mirroring can be paused on the engine connection represented by this instance
Public property | CanPauseTarget | a value indicating whether the target can be paused for the engine connection represented by this instance
Public property | CanPauseTransmission | a value indicating whether transmission can be paused on the engine connection represented by this instance
Public property | CanProcessOrphans | a value indicating whether orphans can be processed on the engine connection represented by this instance
Public property | CanResumeMirror | a value indicating whether mirroring can be resumed on the engine connection represented by this instance
Public property | CanResumeTarget | a value indicating whether the target can be resumed for the engine connection represented by this instance
Public property | CanResumeTransmission | a value indicating whether transmission can be resumed on the engine connection represented by this instance
Public property | CanSetBandwidth | a value indicating whether the bandwidth limit can be set on the engine connection represented by this instance
Public property | CanStartMirror | a value indicating whether mirroring can be started on the engine connection represented by this instance
Public property | CanStartTransmission | a value indicating whether transmission can be started on the engine connection represented by this instance
Public property | CanStopMirror | a value indicating whether mirroring can be stopped on the engine connection represented by this instance
Public property | CanTakeSnapshot | a value indicating whether a snapshot can be taken for the engine connection represented by this instance
Public property | CanUpdateShares | a value indicating whether shares can be updated
Public property | CanVerify | a value indicating whether verification can be performed on the engine connection represented by this instance
Public property | ConnectionId | the connection id
Public property | Role | the role of the engine connection in the job
Top
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanPauseMirror Property

EngineControlStatusModelCanPauseMirror Property
a value indicating whether mirroring can be paused on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseMirror { get; set; }
Public Property CanPauseMirror As Boolean
    Get
    Set
public:
property bool CanPauseMirror {
    bool get ();
    void set (bool value);
}
member CanPauseMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanPauseTarget Property

EngineControlStatusModelCanPauseTarget Property
a value indicating whether the target can be paused for the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
member CanPauseTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanPauseTransmission Property

EngineControlStatusModelCanPauseTransmission Property
a value indicating whether transmission can be paused on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseTransmission { get; set; }
Public Property CanPauseTransmission As Boolean
    Get
    Set
public:
property bool CanPauseTransmission {
    bool get ();
    void set (bool value);
}
member CanPauseTransmission : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanProcessOrphans Property

EngineControlStatusModelCanProcessOrphans Property
a value indicating whether orphans can be processed on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanProcessOrphans { get; set; }
Public Property CanProcessOrphans As Boolean
    Get
    Set
public:
property bool CanProcessOrphans {
    bool get ();
    void set (bool value);
}
member CanProcessOrphans : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanResumeMirror Property

EngineControlStatusModelCanResumeMirror Property
a value indicating whether mirroring can be resumed on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeMirror { get; set; }
Public Property CanResumeMirror As Boolean
    Get
    Set
public:
property bool CanResumeMirror {
    bool get ();
    void set (bool value);
}
member CanResumeMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanResumeTarget Property

EngineControlStatusModelCanResumeTarget Property
a value indicating whether the target can be resumed for the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
member CanResumeTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanResumeTransmission Property

EngineControlStatusModelCanResumeTransmission Property
a value indicating whether transmission can be resumed on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeTransmission { get; set; }
Public Property CanResumeTransmission As Boolean
    Get
    Set
public:
property bool CanResumeTransmission {
    bool get ();
    void set (bool value);
}
member CanResumeTransmission : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanSetBandwidth Property

EngineControlStatusModelCanSetBandwidth Property
a value indicating whether the bandwidth limit can be set on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSetBandwidth { get; set; }
Public Property CanSetBandwidth As Boolean
    Get
    Set
public:
property bool CanSetBandwidth {
    bool get ();
    void set (bool value);
}
member CanSetBandwidth : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanStartMirror Property

EngineControlStatusModelCanStartMirror Property
a value indicating whether mirroring can be started on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStartMirror { get; set; }
Public Property CanStartMirror As Boolean
    Get
    Set
public:
property bool CanStartMirror {
    bool get ();
    void set (bool value);
}
member CanStartMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanStartTransmission Property

EngineControlStatusModelCanStartTransmission Property
a value indicating whether transmission can be started on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStartTransmission { get; set; }
Public Property CanStartTransmission As Boolean
    Get
    Set
public:
property bool CanStartTransmission {
    bool get ();
    void set (bool value);
}
member CanStartTransmission : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanStopMirror Property

EngineControlStatusModelCanStopMirror Property
a value indicating whether mirroring can be stopped on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStopMirror { get; set; }
Public Property CanStopMirror As Boolean
    Get
    Set
public:
property bool CanStopMirror {
    bool get ();
    void set (bool value);
}
member CanStopMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanTakeSnapshot Property

EngineControlStatusModelCanTakeSnapshot Property
a value indicating whether a snapshot can be taken for the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanTakeSnapshot { get; set; }
Public Property CanTakeSnapshot As Boolean
    Get
    Set
public:
property bool CanTakeSnapshot {
    bool get ();
    void set (bool value);
}
member CanTakeSnapshot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanUpdateShares Property

EngineControlStatusModelCanUpdateShares Property
a value indicating whether shares can be updated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUpdateShares { get; set; }
Public Property CanUpdateShares As Boolean
    Get
    Set
public:
property bool CanUpdateShares {
    bool get ();
    void set (bool value);
}
member CanUpdateShares : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanVerify Property

EngineControlStatusModelCanVerify Property
a value indicating whether verification can be performed on the engine connection represented by this instance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanVerify { get; set; }
Public Property CanVerify As Boolean
    Get
    Set
public:
property bool CanVerify {
    bool get ();
    void set (bool value);
}
member CanVerify : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.ConnectionId Property

EngineControlStatusModelConnectionId Property
the connection id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
member ConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.Role Property

EngineControlStatusModelRole Property
the role of the engine connection in the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}
member Role : string with get, set

Property Value

Type: String
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel Methods

EngineControlStatusModel Methods

The EngineControlStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EngineControlStatusModel Class


EngineJobTypeEnum Enumeration

EngineJobTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum EngineJobTypeEnum
<FlagsAttribute>
Public Enumeration EngineJobTypeEnum
[FlagsAttribute]
public enum class EngineJobTypeEnum
[<FlagsAttribute>]
type EngineJobTypeEnum
Members
Member name | Value | Description
NormalJob | 0 |
ImageJob | 1 |
RecoveryJob | 2 |
FullServerJob | 4 |
GeoClusterJob | 8 |
MigrationJob | 16 |
FullServerRevertJob | 32 |
VraRecoveryJob | 64 |
VraMigrationJob | 128 |
DataOnlyOption | 256 |
VraJob | 512 |
HyperVJob | 1024 |
Win32MirrorOption | 2048 |
SourceConnectionResourceJob | 4096 |
FullServerBackupJob | 8192 |
UvraJob | 16384 |
NonClientAccessibleSnapshot | 32768 |
FFO | 65536 |
LVRA_JOB | 131072 |
Invalid | 65535 |
See Also

Reference

DoubleTake.Web.Models Namespace


EventLogModel Class

EventLogModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEventLogModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EventLogModel
Public NotInheritable Class EventLogModel
public ref class EventLogModel sealed
[<SealedAttribute>]
type EventLogModel =  class end

The EventLogModel type exposes the following members.

Constructors
 | Name | Description
Public method | EventLogModel | Initializes a new instance of the EventLogModel class
Top
Properties
 | Name | Description
Public property | Category | the text associated with the categoryNumber for this entry
Public property | CategoryNumber | the category number of the event log entry
Public property | EntryType | the event type of this entry
Public property | Id | the id of this entry in the event log
Public property | InstanceId | the resource identifier that designates the message text of the event entry
Public property | MachineName | the name of the computer on which this entry was generated
Public property | Message | the localized message associated with this event entry
Public property | ReplacementStrings | the replacement strings associated with the event log entry
Public property | Source | the name of the application that generated this event
Public property | TimeGenerated | the local time at which this event was generated
Public property | TimeWritten | the local time at which this event was written to the log
Public property | UserName | the name of the user who is responsible for this event
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EventLogModel Constructor

EventLogModel Constructor
Initializes a new instance of the EventLogModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventLogModel()
Public Sub New
public:
EventLogModel()
new : unit -> EventLogModel
See Also

Reference

EventLogModel Class


EventLogModel Properties

EventLogModel Properties

The EventLogModel type exposes the following members.

Properties
 | Name | Description
Public property | Category | the text associated with the categoryNumber for this entry
Public property | CategoryNumber | the category number of the event log entry
Public property | EntryType | the event type of this entry
Public property | Id | the id of this entry in the event log
Public property | InstanceId | the resource identifier that designates the message text of the event entry
Public property | MachineName | the name of the computer on which this entry was generated
Public property | Message | the localized message associated with this event entry
Public property | ReplacementStrings | the replacement strings associated with the event log entry
Public property | Source | the name of the application that generated this event
Public property | TimeGenerated | the local time at which this event was generated
Public property | TimeWritten | the local time at which this event was written to the log
Public property | UserName | the name of the user who is responsible for this event
Top
See Also

Reference

EventLogModel Class


EventLogModel.Category Property

EventLogModelCategory Property
the text associated with the categoryNumber for this entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.CategoryNumber Property

EventLogModelCategoryNumber Property
the category number of the event log entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short CategoryNumber { get; set; }
Public Property CategoryNumber As Short
    Get
    Set
public:
property short CategoryNumber {
    short get ();
    void set (short value);
}
member CategoryNumber : int16 with get, set

Property Value

Type: Int16
See Also

Reference

EventLogModel Class


EventLogModel.EntryType Property

EventLogModelEntryType Property
the event type of this entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EventLogEntryType EntryType { get; set; }
Public Property EntryType As EventLogEntryType
    Get
    Set
public:
property EventLogEntryType EntryType {
    EventLogEntryType get ();
    void set (EventLogEntryType value);
}
member EntryType : EventLogEntryType with get, set

Property Value

Type: EventLogEntryType
See Also

Reference

EventLogModel Class


EventLogModel.Id Property

EventLogModelId Property
the id of this entry in the event log

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

EventLogModel Class


EventLogModel.InstanceId Property

EventLogModelInstanceId Property
the resource identifier that designates the message text of the event entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long InstanceId { get; set; }
Public Property InstanceId As Long
    Get
    Set
public:
property long long InstanceId {
    long long get ();
    void set (long long value);
}
member InstanceId : int64 with get, set

Property Value

Type: Int64
See Also

Reference

EventLogModel Class


EventLogModel.MachineName Property

EventLogModelMachineName Property
the name of the computer on which this entry was generated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
member MachineName : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.Message Property

EventLogModelMessage Property
the localized message associated with this event entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.ReplacementStrings Property

EventLogModelReplacementStrings Property
the replacement strings associated with the event log entry

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ReplacementStrings { get; set; }
Public Property ReplacementStrings As String()
    Get
    Set
public:
property array<String^>^ ReplacementStrings {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ReplacementStrings : string[] with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.Source Property

EventLogModelSource Property
the name of the application that generated this event

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
member Source : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.TimeGenerated Property

EventLogModelTimeGenerated Property
the local time at which this event was generated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimeGenerated { get; set; }
Public Property TimeGenerated As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeGenerated {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimeGenerated : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

EventLogModel Class


EventLogModel.TimeWritten Property

EventLogModelTimeWritten Property
the local time at which this event was written to the log

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimeWritten { get; set; }
Public Property TimeWritten As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeWritten {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimeWritten : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

EventLogModel Class


EventLogModel.UserName Property

EventLogModelUserName Property
the name of the user who is responsible for this event

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel Methods

EventLogModel Methods

The EventLogModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventLogModel Class


ExtendedLowLevelStateModel Class

ExtendedLowLevelStateModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsExtendedLowLevelStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ExtendedLowLevelStateModel
Public NotInheritable Class ExtendedLowLevelStateModel
public ref class ExtendedLowLevelStateModel sealed
[<SealedAttribute>]
type ExtendedLowLevelStateModel =  class end

The ExtendedLowLevelStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedLowLevelStateModel | Initializes a new instance of the ExtendedLowLevelStateModel class
Top
Properties
 | Name | Description
Public property | Health | the health of the low level state
Public property | MessageId | a value representing a message identifier for this low level state
Public property | MessageIdFormatParameters | the message format parameters for this low level state
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ExtendedLowLevelStateModel Constructor

ExtendedLowLevelStateModel Constructor
Initializes a new instance of the ExtendedLowLevelStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel()
Public Sub New
public:
ExtendedLowLevelStateModel()
new : unit -> ExtendedLowLevelStateModel
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel Properties

ExtendedLowLevelStateModel Properties

The ExtendedLowLevelStateModel type exposes the following members.

Properties
 | Name | Description
Public property | Health | the health of the low level state
Public property | MessageId | a value representing a message identifier for this low level state
Public property | MessageIdFormatParameters | the message format parameters for this low level state
Top
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel.Health Property

ExtendedLowLevelStateModelHealth Property
the health of the low level state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HealthEnum Health { get; set; }
Public Property Health As HealthEnum
    Get
    Set
public:
property HealthEnum Health {
    HealthEnum get ();
    void set (HealthEnum value);
}
member Health : HealthEnum with get, set

Property Value

Type: HealthEnum
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel.MessageId Property

ExtendedLowLevelStateModelMessageId Property
a value representing a message identifier for this low level state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
member MessageId : string with get, set

Property Value

Type: String
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel.MessageIdFormatParameters Property

ExtendedLowLevelStateModelMessageIdFormatParameters Property
the message format parameters for this low level state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageIdFormatParameters { get; set; }
Public Property MessageIdFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageIdFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageIdFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel Methods

ExtendedLowLevelStateModel Methods

The ExtendedLowLevelStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedLowLevelStateModel Class


FailbackOptionsModel Class

FailbackOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailbackOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailbackOptionsModel
Public NotInheritable Class FailbackOptionsModel
public ref class FailbackOptionsModel sealed
[<SealedAttribute>]
type FailbackOptionsModel =  class end

The FailbackOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailbackOptionsModel | Initializes a new instance of the FailbackOptionsModel class
Top
Properties
 | Name | Description
Public property | NewMonitorOptions | the monitor options for the new source server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailbackOptionsModel Constructor

FailbackOptionsModel Constructor
Initializes a new instance of the FailbackOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailbackOptionsModel()
Public Sub New
public:
FailbackOptionsModel()
new : unit -> FailbackOptionsModel
See Also

Reference

FailbackOptionsModel Class


FailbackOptionsModel Properties

FailbackOptionsModel Properties

The FailbackOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | NewMonitorOptions | the monitor options for the new source server
Top
See Also

Reference

FailbackOptionsModel Class


FailbackOptionsModel.NewMonitorOptions Property

FailbackOptionsModelNewMonitorOptions Property
the monitor options for the new source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorOptionsModel NewMonitorOptions { get; set; }
Public Property NewMonitorOptions As CoreMonitorOptionsModel
    Get
    Set
public:
property CoreMonitorOptionsModel^ NewMonitorOptions {
    CoreMonitorOptionsModel^ get ();
    void set (CoreMonitorOptionsModel^ value);
}
member NewMonitorOptions : CoreMonitorOptionsModel with get, set

Property Value

Type: CoreMonitorOptionsModel
See Also

Reference

FailbackOptionsModel Class


FailbackOptionsModel Methods

FailbackOptionsModel Methods

The FailbackOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailbackOptionsModel Class


FailoverAddressesOptionEnum Enumeration

FailoverAddressesOptionEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverAddressesOptionEnum
Public Enumeration FailoverAddressesOptionEnum
public enum class FailoverAddressesOptionEnum
type FailoverAddressesOptionEnum
Members
Member name | Value | Description
Monitored | 0 |
All | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverDataActionEnum Enumeration

FailoverDataActionEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverDataActionEnum
Public Enumeration FailoverDataActionEnum
public enum class FailoverDataActionEnum
type FailoverDataActionEnum
Members
Member name | Value | Description
Apply | 0 |
Flush | 1 |
Revert | 2 |
Unknown | 3 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverItemsEnum Enumeration

FailoverItemsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FailoverItemsEnum
<FlagsAttribute>
Public Enumeration FailoverItemsEnum
[FlagsAttribute]
public enum class FailoverItemsEnum
[<FlagsAttribute>]
type FailoverItemsEnum
Members
Member name | Value | Description
None | 0 |
IPAddresses | 1 |
Name | 2 |
Shares | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverModeEnum Enumeration

FailoverModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverModeEnum
Public Enumeration FailoverModeEnum
public enum class FailoverModeEnum
type FailoverModeEnum
Members
Member name | Value | Description
Live | 0 |
Test | 1 |
Snapshot | 2 |
SetRestoreRequiredOnly | 3 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverOptionsModel Class

FailoverOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverOptionsModel
Public NotInheritable Class FailoverOptionsModel
public ref class FailoverOptionsModel sealed
[<SealedAttribute>]
type FailoverOptionsModel =  class end

The FailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverOptionsModel | Initializes a new instance of the FailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | FailoverDataAction | the failover data action
Public property | FailoverMode | the failover mode
Public property | FailoverType | the failover type
Public property | SnapshotId | the snapshot id to apply to the target server during failover
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverOptionsModel Constructor

FailoverOptionsModel Constructor
Initializes a new instance of the FailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel()
Public Sub New
public:
FailoverOptionsModel()
new : unit -> FailoverOptionsModel
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel Properties

FailoverOptionsModel Properties

The FailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverDataAction | the failover data action
Public property | FailoverMode | the failover mode
Public property | FailoverType | the failover type
Public property | SnapshotId | the snapshot id to apply to the target server during failover
Top
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.FailoverDataAction Property

FailoverOptionsModelFailoverDataAction Property
the failover data action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverDataActionEnum FailoverDataAction { get; set; }
Public Property FailoverDataAction As FailoverDataActionEnum
    Get
    Set
public:
property FailoverDataActionEnum FailoverDataAction {
    FailoverDataActionEnum get ();
    void set (FailoverDataActionEnum value);
}
member FailoverDataAction : FailoverDataActionEnum with get, set

Property Value

Type: FailoverDataActionEnum
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.FailoverMode Property

FailoverOptionsModelFailoverMode Property
the failover mode

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverModeEnum FailoverMode { get; set; }
Public Property FailoverMode As FailoverModeEnum
    Get
    Set
public:
property FailoverModeEnum FailoverMode {
    FailoverModeEnum get ();
    void set (FailoverModeEnum value);
}
member FailoverMode : FailoverModeEnum with get, set

Property Value

Type: FailoverModeEnum
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.FailoverType Property

FailoverOptionsModelFailoverType Property
the failover type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverTypeEnum FailoverType { get; set; }
Public Property FailoverType As FailoverTypeEnum
    Get
    Set
public:
property FailoverTypeEnum FailoverType {
    FailoverTypeEnum get ();
    void set (FailoverTypeEnum value);
}
member FailoverType : FailoverTypeEnum with get, set

Property Value

Type: FailoverTypeEnum
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.SnapshotId Property

FailoverOptionsModelSnapshotId Property
the snapshot id to apply to the target server during failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid SnapshotId { get; set; }
Public Property SnapshotId As Guid
    Get
    Set
public:
property Guid SnapshotId {
    Guid get ();
    void set (Guid value);
}
member SnapshotId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel Methods

FailoverOptionsModel Methods

The FailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverOptionsModel Class


FailoverProcessingOptionsEnum Enumeration

FailoverProcessingOptionsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FailoverProcessingOptionsEnum
<FlagsAttribute>
Public Enumeration FailoverProcessingOptionsEnum
[FlagsAttribute]
public enum class FailoverProcessingOptionsEnum
[<FlagsAttribute>]
type FailoverProcessingOptionsEnum
Members
Member name | Value | Description
None | 0 |
UserInterventionRequired | 1 |
UseShareFile | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReplaceActionsEnum Enumeration

FailoverReplaceActionsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FailoverReplaceActionsEnum
<FlagsAttribute>
Public Enumeration FailoverReplaceActionsEnum
[FlagsAttribute]
public enum class FailoverReplaceActionsEnum
[<FlagsAttribute>]
type FailoverReplaceActionsEnum
Members
Member name | Value | Description
Address | 2 |
Name | 1 |
None | 0 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverScriptConfigurationModel Class

FailoverScriptConfigurationModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverScriptConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FailoverScriptConfigurationModel
Public Class FailoverScriptConfigurationModel
public ref class FailoverScriptConfigurationModel
type FailoverScriptConfigurationModel =  class end

The FailoverScriptConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverScriptConfigurationModel | Initializes a new instance of the FailoverScriptConfigurationModel class
Top
Properties
 | Name | Description
Public property | PostFailbackScript | script to be run after the failback operation completes
Public property | PostFailbackScriptArgs | arguments to be used when running the post-failback script
Public property | PostFailoverScript | script to be run after the failover operation completes
Public property | PostFailoverScriptArgs | arguments to be used when running the post-failover script
Public property | PreFailbackScript | script to be run before the failback operation is started
Public property | PreFailbackScriptArgs | arguments to be used when running the pre-failback script
Public property | PreFailbackWait | a value that indicates whether or not to wait for the pre-failback script to complete before continuing with the failback operation
Public property | PreFailoverScript | script to be run before the failover operation is started
Public property | PreFailoverScriptArgs | arguments to be used when running the pre-failover script
Public property | PreFailoverWait | a value that indicates whether or not to wait for the pre-failover script to complete before continuing with the failover operation
Public property | SourcePostFailbackScript | script to be run after the failback operation completes
Public property | SourcePostFailbackScriptArgs | arguments to be used when running the source post-failback script
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverScriptConfigurationModel Constructor

FailoverScriptConfigurationModel Constructor
Initializes a new instance of the FailoverScriptConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverScriptConfigurationModel()
Public Sub New
public:
FailoverScriptConfigurationModel()
new : unit -> FailoverScriptConfigurationModel
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel Properties

FailoverScriptConfigurationModel Properties

The FailoverScriptConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | PostFailbackScript | script to be run after the failback operation completes
Public property | PostFailbackScriptArgs | arguments to be used when running the post-failback script
Public property | PostFailoverScript | script to be run after the failover operation completes
Public property | PostFailoverScriptArgs | arguments to be used when running the post-failover script
Public property | PreFailbackScript | script to be run before the failback operation is started
Public property | PreFailbackScriptArgs | arguments to be used when running the pre-failback script
Public property | PreFailbackWait | a value that indicates whether or not to wait for the pre-failback script to complete before continuing with the failback operation
Public property | PreFailoverScript | script to be run before the failover operation is started
Public property | PreFailoverScriptArgs | arguments to be used when running the pre-failover script
Public property | PreFailoverWait | a value that indicates whether or not to wait for the pre-failover script to complete before continuing with the failover operation
Public property | SourcePostFailbackScript | script to be run after the failback operation completes
Public property | SourcePostFailbackScriptArgs | arguments to be used when running the source post-failback script
Top
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailbackScript Property

FailoverScriptConfigurationModelPostFailbackScript Property
script to be run after the failback operation completes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailbackScript { get; set; }
Public Property PostFailbackScript As String
    Get
    Set
public:
property String^ PostFailbackScript {
    String^ get ();
    void set (String^ value);
}
member PostFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailbackScriptArgs Property

FailoverScriptConfigurationModelPostFailbackScriptArgs Property
arguments to be used when running the post-failback script

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailbackScriptArgs { get; set; }
Public Property PostFailbackScriptArgs As String
    Get
    Set
public:
property String^ PostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PostFailbackScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailoverScript Property

FailoverScriptConfigurationModelPostFailoverScript Property
script to be run after the failover operation completes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailoverScript { get; set; }
Public Property PostFailoverScript As String
    Get
    Set
public:
property String^ PostFailoverScript {
    String^ get ();
    void set (String^ value);
}
member PostFailoverScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailoverScriptArgs Property

FailoverScriptConfigurationModelPostFailoverScriptArgs Property
arguments to be used when running the post-failover script

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailoverScriptArgs { get; set; }
Public Property PostFailoverScriptArgs As String
    Get
    Set
public:
property String^ PostFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PostFailoverScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailbackScript Property

FailoverScriptConfigurationModelPreFailbackScript Property
script to be run before the failback operation is started

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailbackScript { get; set; }
Public Property PreFailbackScript As String
    Get
    Set
public:
property String^ PreFailbackScript {
    String^ get ();
    void set (String^ value);
}
member PreFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailbackScriptArgs Property

FailoverScriptConfigurationModelPreFailbackScriptArgs Property
arguments to be used when running the pre-failback script

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailbackScriptArgs { get; set; }
Public Property PreFailbackScriptArgs As String
    Get
    Set
public:
property String^ PreFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PreFailbackScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailbackWait Property

FailoverScriptConfigurationModelPreFailbackWait Property
a value that indicates whether or not to wait for the pre-failback script to complete before continuing with the failback operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreFailbackWait { get; set; }
Public Property PreFailbackWait As Boolean
    Get
    Set
public:
property bool PreFailbackWait {
    bool get ();
    void set (bool value);
}
member PreFailbackWait : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailoverScript Property

FailoverScriptConfigurationModelPreFailoverScript Property
script to be run before the failover operation is started

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailoverScript { get; set; }
Public Property PreFailoverScript As String
    Get
    Set
public:
property String^ PreFailoverScript {
    String^ get ();
    void set (String^ value);
}
member PreFailoverScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailoverScriptArgs Property

FailoverScriptConfigurationModelPreFailoverScriptArgs Property
arguments to be used when running the pre-failover script

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailoverScriptArgs { get; set; }
Public Property PreFailoverScriptArgs As String
    Get
    Set
public:
property String^ PreFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PreFailoverScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailoverWait Property

FailoverScriptConfigurationModelPreFailoverWait Property
a value that indicates whether or not to wait for the pre-failover script to complete before continuing with the failover operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreFailoverWait { get; set; }
Public Property PreFailoverWait As Boolean
    Get
    Set
public:
property bool PreFailoverWait {
    bool get ();
    void set (bool value);
}
member PreFailoverWait : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.SourcePostFailbackScript Property

FailoverScriptConfigurationModelSourcePostFailbackScript Property
script to be run after the failback operation completes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourcePostFailbackScript { get; set; }
Public Property SourcePostFailbackScript As String
    Get
    Set
public:
property String^ SourcePostFailbackScript {
    String^ get ();
    void set (String^ value);
}
member SourcePostFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.SourcePostFailbackScriptArgs Property

FailoverScriptConfigurationModelSourcePostFailbackScriptArgs Property
arguments to be used when running the source post-failback script

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourcePostFailbackScriptArgs { get; set; }
Public Property SourcePostFailbackScriptArgs As String
    Get
    Set
public:
property String^ SourcePostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
member SourcePostFailbackScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel Methods

FailoverScriptConfigurationModel Methods

The FailoverScriptConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverTriggerEnum Enumeration

FailoverTriggerEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverTriggerEnum
Public Enumeration FailoverTriggerEnum
public enum class FailoverTriggerEnum
type FailoverTriggerEnum
Members
Member name | Value | Description
OneAddressFails | 0 |
AllAddressesFail | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverTypeEnum Enumeration

FailoverTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverTypeEnum
Public Enumeration FailoverTypeEnum
public enum class FailoverTypeEnum
type FailoverTypeEnum
Members
Member name | Value | Description
FullServer | 1 |
Normal | 0 |
See Also

Reference

DoubleTake.Web.Models Namespace


FeatureModel Class

FeatureModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFeatureModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FeatureModel
Public NotInheritable Class FeatureModel
public ref class FeatureModel sealed
[<SealedAttribute>]
type FeatureModel =  class end

The FeatureModel type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureModel | Initializes a new instance of the FeatureModel class
Top
Properties
 | Name | Description
Public property | Endpoint | the endpoint that identifies the location of this service
Public property | Tag | a tag that identifies the role of this service
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FeatureModel Constructor

FeatureModel Constructor
Initializes a new instance of the FeatureModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FeatureModel()
Public Sub New
public:
FeatureModel()
new : unit -> FeatureModel
See Also

Reference

FeatureModel Class


FeatureModel Properties

FeatureModel Properties

The FeatureModel type exposes the following members.

Properties
 | Name | Description
Public property | Endpoint | the endpoint that identifies the location of this service
Public property | Tag | a tag that identifies the role of this service
Top
See Also

Reference

FeatureModel Class


FeatureModel.Endpoint Property

FeatureModelEndpoint Property
the endpoint that identifies the location of this service

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Uri Endpoint { get; set; }
Public Property Endpoint As Uri
    Get
    Set
public:
property Uri^ Endpoint {
    Uri^ get ();
    void set (Uri^ value);
}
member Endpoint : Uri with get, set

Property Value

Type: Uri
See Also

Reference

FeatureModel Class


FeatureModel.Tag Property

FeatureModelTag Property
a tag that identifies the role of this service

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}
member Tag : string with get, set

Property Value

Type: String
See Also

Reference

FeatureModel Class


FeatureModel Methods

FeatureModel Methods

The FeatureModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FeatureModel Class


FileItemModel Class

FileItemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsFileItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FileItemModel : PhysicalItemModel
Public NotInheritable Class FileItemModel
    Inherits PhysicalItemModel
public ref class FileItemModel sealed : public PhysicalItemModel
[<SealedAttribute>]
type FileItemModel =
    class
        inherit PhysicalItemModel
    end

The FileItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | FileItemModel | Initializes a new instance of the FileItemModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FileItemModel Constructor

FileItemModel Constructor
Initializes a new instance of the FileItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FileItemModel()
Public Sub New
public:
FileItemModel()
new : unit -> FileItemModel
See Also

Reference

FileItemModel Class


FileItemModel Properties

FileItemModel Properties

The FileItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Top
See Also

Reference

FileItemModel Class


FileItemModel Methods

FileItemModel Methods

The FileItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileItemModel Class


FileSystemAttributesEnum Enumeration

FileSystemAttributesEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FileSystemAttributesEnum
<FlagsAttribute>
Public Enumeration FileSystemAttributesEnum
[FlagsAttribute]
public enum class FileSystemAttributesEnum
[<FlagsAttribute>]
type FileSystemAttributesEnum
Members
Member name | Value | Description
ReadOnly | 1 |
Hidden | 2 |
System | 4 |
Directory | 16 |
Archive | 32 |
Normal | 128 |
Temporary | 256 |
SparseFile | 512 |
ReparsePoint | 1024 |
Compressed | 2048 |
Offline | 4096 |
NotContentIndexed | 8192 |
Encrypted | 16384 |
See Also

Reference

DoubleTake.Web.Models Namespace


FixJobOptionsRequestModel Class

FixJobOptionsRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFixJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FixJobOptionsRequestModel
Public NotInheritable Class FixJobOptionsRequestModel
public ref class FixJobOptionsRequestModel sealed
[<SealedAttribute>]
type FixJobOptionsRequestModel =  class end

The FixJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | FixJobOptionsRequestModel | Initializes a new instance of the FixJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | JobOptions |
Public property | StepsToFix |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FixJobOptionsRequestModel Constructor

FixJobOptionsRequestModel Constructor
Initializes a new instance of the FixJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FixJobOptionsRequestModel()
Public Sub New
public:
FixJobOptionsRequestModel()
new : unit -> FixJobOptionsRequestModel
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel Properties

FixJobOptionsRequestModel Properties

The FixJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | JobOptions |
Public property | StepsToFix |
Top
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel.JobOptions Property

FixJobOptionsRequestModelJobOptions Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel.StepsToFix Property

FixJobOptionsRequestModelStepsToFix Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStepModel[] StepsToFix { get; set; }
Public Property StepsToFix As VerificationStepModel()
    Get
    Set
public:
property array<VerificationStepModel^>^ StepsToFix {
    array<VerificationStepModel^>^ get ();
    void set (array<VerificationStepModel^>^ value);
}
member StepsToFix : VerificationStepModel[] with get, set

Property Value

Type: VerificationStepModel
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel Methods

FixJobOptionsRequestModel Methods

The FixJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsStatusModel Class

FixJobOptionsStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityStatusModel
DoubleTake.Web.ModelsFixJobOptionsStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FixJobOptionsStatusModel : ActivityStatusModel
Public NotInheritable Class FixJobOptionsStatusModel
    Inherits ActivityStatusModel
public ref class FixJobOptionsStatusModel sealed : public ActivityStatusModel
[<SealedAttribute>]
type FixJobOptionsStatusModel =
    class
        inherit ActivityStatusModel
    end

The FixJobOptionsStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | FixJobOptionsStatusModel | Initializes a new instance of the FixJobOptionsStatusModel class
Top
Properties
 | Name | Description
Public property | Duration | a value the duration of the activity at the time this status was yielded (Inherited from ActivityStatusModel.)
Public property | JobOptions | the new job options after the fixing is complete
Public property | MessageFormatParameters | the message format parameters (Inherited from ActivityStatusModel.)
Public property | MessageId | a value representing a message identifier (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | the user that initiated the activity (Inherited from ActivityStatusModel.)
Public property | Status | the current status of the activity (Inherited from ActivityStatusModel.)
Public property | StatusUri | the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted' (Inherited from ActivityStatusModel.)
Public property | TimeStamp | the server time when the activity yielded this status (Inherited from ActivityStatusModel.)
Public property | Token | a token that identifies the request that initiated the activity (Inherited from ActivityStatusModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FixJobOptionsStatusModel Constructor

FixJobOptionsStatusModel Constructor
Initializes a new instance of the FixJobOptionsStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FixJobOptionsStatusModel()
Public Sub New
public:
FixJobOptionsStatusModel()
new : unit -> FixJobOptionsStatusModel
See Also

Reference

FixJobOptionsStatusModel Class


FixJobOptionsStatusModel Properties

FixJobOptionsStatusModel Properties

The FixJobOptionsStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | a value the duration of the activity at the time this status was yielded (Inherited from ActivityStatusModel.)
Public property | JobOptions | the new job options after the fixing is complete
Public property | MessageFormatParameters | the message format parameters (Inherited from ActivityStatusModel.)
Public property | MessageId | a value representing a message identifier (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | the user that initiated the activity (Inherited from ActivityStatusModel.)
Public property | Status | the current status of the activity (Inherited from ActivityStatusModel.)
Public property | StatusUri | the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted' (Inherited from ActivityStatusModel.)
Public property | TimeStamp | the server time when the activity yielded this status (Inherited from ActivityStatusModel.)
Public property | Token | a token that identifies the request that initiated the activity (Inherited from ActivityStatusModel.)
Top
See Also

Reference

FixJobOptionsStatusModel Class


FixJobOptionsStatusModel.JobOptions Property

FixJobOptionsStatusModelJobOptions Property
the new job options after the fixing is complete

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

FixJobOptionsStatusModel Class


FixJobOptionsStatusModel Methods

FixJobOptionsStatusModel Methods

The FixJobOptionsStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FixJobOptionsStatusModel Class


FixRecommendedJobOptionsRequestModel Class

FixRecommendedJobOptionsRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFixRecommendedJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class FixRecommendedJobOptionsRequestModel
Public Class FixRecommendedJobOptionsRequestModel
public ref class FixRecommendedJobOptionsRequestModel
type FixRecommendedJobOptionsRequestModel =  class end

The FixRecommendedJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | FixRecommendedJobOptionsRequestModel | Initializes a new instance of the FixRecommendedJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | JobCredentials |
Public property | JobOptions |
Public property | JobType |
Public property | StepsToFix |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FixRecommendedJobOptionsRequestModel Constructor

FixRecommendedJobOptionsRequestModel Constructor
Initializes a new instance of the FixRecommendedJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FixRecommendedJobOptionsRequestModel()
Public Sub New
public:
FixRecommendedJobOptionsRequestModel()
new : unit -> FixRecommendedJobOptionsRequestModel
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel Properties

FixRecommendedJobOptionsRequestModel Properties

The FixRecommendedJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials |
Public property | JobOptions |
Public property | JobType |
Public property | StepsToFix |
Top
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.JobCredentials Property

FixRecommendedJobOptionsRequestModelJobCredentials Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.JobOptions Property

FixRecommendedJobOptionsRequestModelJobOptions Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.JobType Property

FixRecommendedJobOptionsRequestModelJobType Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.StepsToFix Property

FixRecommendedJobOptionsRequestModelStepsToFix Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStepModel[] StepsToFix { get; set; }
Public Property StepsToFix As VerificationStepModel()
    Get
    Set
public:
property array<VerificationStepModel^>^ StepsToFix {
    array<VerificationStepModel^>^ get ();
    void set (array<VerificationStepModel^>^ value);
}
member StepsToFix : VerificationStepModel[] with get, set

Property Value

Type: VerificationStepModel
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel Methods

FixRecommendedJobOptionsRequestModel Methods

The FixRecommendedJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FullServerFailoverOptionsModel Class

FullServerFailoverOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerFailoverOptionsModel
Public NotInheritable Class FullServerFailoverOptionsModel
public ref class FullServerFailoverOptionsModel sealed
[<SealedAttribute>]
type FullServerFailoverOptionsModel =  class end

The FullServerFailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerFailoverOptionsModel | Initializes a new instance of the FullServerFailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | the additional folders that should be staged on the target server
Public property | CreateBackupConnection | a value indicating whether or not the job should create a backup connection to put the target server's system on the source server
Public property | RemoveOrphans | a value indicating whether or not orphans should be removed
Public property | ReverseRoute | the reverse route
Public property | ReverseRouteEnginePort | the engine port on the reverse route
Public property | ShutdownSourceServer | a value indicating whether or not to shut down the source server during cutover
Public property | SourceChecksumAll | a value indicating whether or not a checksum should be used for all files when comparing them
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerFailoverOptionsModel Constructor

FullServerFailoverOptionsModel Constructor
Initializes a new instance of the FullServerFailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerFailoverOptionsModel()
Public Sub New
public:
FullServerFailoverOptionsModel()
new : unit -> FullServerFailoverOptionsModel
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel Properties

FullServerFailoverOptionsModel Properties

The FullServerFailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | the additional folders that should be staged on the target server
Public property | CreateBackupConnection | a value indicating whether or not the job should create a backup connection to put the target server's system on the source server
Public property | RemoveOrphans | a value indicating whether or not orphans should be removed
Public property | ReverseRoute | the reverse route
Public property | ReverseRouteEnginePort | the engine port on the reverse route
Public property | ShutdownSourceServer | a value indicating whether or not to shut down the source server during cutover
Public property | SourceChecksumAll | a value indicating whether or not a checksum should be used for all files when comparing them
Top
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.AdditionalStagingFolders Property

FullServerFailoverOptionsModelAdditionalStagingFolders Property
the additional folders that should be staged on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AdditionalStagingFolders : string[] with get, set

Property Value

Type: String
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.CreateBackupConnection Property

FullServerFailoverOptionsModelCreateBackupConnection Property
a value indicating whether or not the job should create a backup connection to put the target server's system on the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CreateBackupConnection { get; set; }
Public Property CreateBackupConnection As Boolean
    Get
    Set
public:
property bool CreateBackupConnection {
    bool get ();
    void set (bool value);
}
member CreateBackupConnection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.RemoveOrphans Property

FullServerFailoverOptionsModelRemoveOrphans Property
a value indicating whether or not orphans should be removed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveOrphans { get; set; }
Public Property RemoveOrphans As Boolean
    Get
    Set
public:
property bool RemoveOrphans {
    bool get ();
    void set (bool value);
}
member RemoveOrphans : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.ReverseRoute Property

FullServerFailoverOptionsModelReverseRoute Property
the reverse route

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
member ReverseRoute : string with get, set

Property Value

Type: String
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.ReverseRouteEnginePort Property

FullServerFailoverOptionsModelReverseRouteEnginePort Property
the engine port on the reverse route

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ReverseRouteEnginePort { get; set; }
Public Property ReverseRouteEnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ReverseRouteEnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ReverseRouteEnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.ShutdownSourceServer Property

FullServerFailoverOptionsModelShutdownSourceServer Property
a value indicating whether or not to shut down the source server during cutover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
member ShutdownSourceServer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.SourceChecksumAll Property

FullServerFailoverOptionsModelSourceChecksumAll Property
a value indicating whether or not a checksum should be used for all files when comparing them

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceChecksumAll { get; set; }
Public Property SourceChecksumAll As Boolean
    Get
    Set
public:
property bool SourceChecksumAll {
    bool get ();
    void set (bool value);
}
member SourceChecksumAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel Methods

FullServerFailoverOptionsModel Methods

The FullServerFailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerJobDetailsModel Class

FullServerJobDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerJobDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerJobDetailsModel
Public NotInheritable Class FullServerJobDetailsModel
public ref class FullServerJobDetailsModel sealed
[<SealedAttribute>]
type FullServerJobDetailsModel =  class end

The FullServerJobDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerJobDetailsModel | Initializes a new instance of the FullServerJobDetailsModel class
Top
Properties
 | Name | Description
Public property | BackupConnectionDetails | the details of the backup connection
Public property | CutoverDetails | the details of the cutover operation
Public property | ProtectionConnectionDetails | the details of the protection connection
Public property | RecoveryConnectionDetails | the details of the recovery connection
Public property | SystemVolumeRevertConnectionDetails | the details of the system volume revert connection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerJobDetailsModel Constructor

FullServerJobDetailsModel Constructor
Initializes a new instance of the FullServerJobDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerJobDetailsModel()
Public Sub New
public:
FullServerJobDetailsModel()
new : unit -> FullServerJobDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel Properties

FullServerJobDetailsModel Properties

The FullServerJobDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnectionDetails | the details of the backup connection
Public property | CutoverDetails | the details of the cutover operation
Public property | ProtectionConnectionDetails | the details of the protection connection
Public property | RecoveryConnectionDetails | the details of the recovery connection
Public property | SystemVolumeRevertConnectionDetails | the details of the system volume revert connection
Top
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.BackupConnectionDetails Property

FullServerJobDetailsModelBackupConnectionDetails Property
the details of the backup connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel BackupConnectionDetails { get; set; }
Public Property BackupConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ BackupConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member BackupConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.CutoverDetails Property

FullServerJobDetailsModelCutoverDetails Property
the details of the cutover operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CutoverDetailsModel CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetailsModel
    Get
    Set
public:
property CutoverDetailsModel^ CutoverDetails {
    CutoverDetailsModel^ get ();
    void set (CutoverDetailsModel^ value);
}
member CutoverDetails : CutoverDetailsModel with get, set

Property Value

Type: CutoverDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.ProtectionConnectionDetails Property

FullServerJobDetailsModelProtectionConnectionDetails Property
the details of the protection connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ ProtectionConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member ProtectionConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.RecoveryConnectionDetails Property

FullServerJobDetailsModelRecoveryConnectionDetails Property
the details of the recovery connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ RecoveryConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member RecoveryConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.SystemVolumeRevertConnectionDetails Property

FullServerJobDetailsModelSystemVolumeRevertConnectionDetails Property
the details of the system volume revert connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel SystemVolumeRevertConnectionDetails { get; set; }
Public Property SystemVolumeRevertConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ SystemVolumeRevertConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member SystemVolumeRevertConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel Methods

FullServerJobDetailsModel Methods

The FullServerJobDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerJobDetailsModel Class


FullServerNicMappingsModel Class

FullServerNicMappingsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerNicMappingsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerNicMappingsModel
Public NotInheritable Class FullServerNicMappingsModel
public ref class FullServerNicMappingsModel sealed
[<SealedAttribute>]
type FullServerNicMappingsModel =  class end

The FullServerNicMappingsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerNicMappingsModel | Initializes a new instance of the FullServerNicMappingsModel class
Top
Properties
 | Name | Description
Public property | SourceNic | the network interface on the source server
Public property | TargetNic | the network interface on the target server
Public property | TargetNicList | the list of network interfaces on the target server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerNicMappingsModel Constructor

FullServerNicMappingsModel Constructor
Initializes a new instance of the FullServerNicMappingsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel()
Public Sub New
public:
FullServerNicMappingsModel()
new : unit -> FullServerNicMappingsModel
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel Properties

FullServerNicMappingsModel Properties

The FullServerNicMappingsModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceNic | the network interface on the source server
Public property | TargetNic | the network interface on the target server
Public property | TargetNicList | the list of network interfaces on the target server
Top
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.SourceNic Property

FullServerNicMappingsModelSourceNic Property
the network interface on the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceNic { get; set; }
Public Property SourceNic As String
    Get
    Set
public:
property String^ SourceNic {
    String^ get ();
    void set (String^ value);
}
member SourceNic : string with get, set

Property Value

Type: String
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.TargetNic Property

FullServerNicMappingsModelTargetNic Property
the network interface on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetNic { get; set; }
Public Property TargetNic As String
    Get
    Set
public:
property String^ TargetNic {
    String^ get ();
    void set (String^ value);
}
member TargetNic : string with get, set

Property Value

Type: String
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.TargetNicList Property

FullServerNicMappingsModelTargetNicList Property
the list of network interfaces on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TargetNicList { get; set; }
Public Property TargetNicList As String()
    Get
    Set
public:
property array<String^>^ TargetNicList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TargetNicList : string[] with get, set

Property Value

Type: String
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel Methods

FullServerNicMappingsModel Methods

The FullServerNicMappingsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerNicMappingsModel Class


HealthEnum Enumeration

HealthEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HealthEnum
Public Enumeration HealthEnum
public enum class HealthEnum
type HealthEnum
Members
Member name | Value | Description
Unknown | 0 |
Ok | 1 |
Warning | 2 |
Error | 3 |
See Also

Reference

DoubleTake.Web.Models Namespace


HighAvailabilityStateEnum Enumeration

HighAvailabilityStateEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HighAvailabilityStateEnum
Public Enumeration HighAvailabilityStateEnum
public enum class HighAvailabilityStateEnum
type HighAvailabilityStateEnum
Members
Member name | Value | Description
FailbackOccurring | 80 |
FailbackRemonitor | 96 |
FailbackRequired | 64 |
FailoverMonitoring | 16 |
FailoverOccurring | 48 |
FailoverRequired | 32 |
Illegal | -1 |
None | 0 |
See Also

Reference

DoubleTake.Web.Models Namespace


HighLevelStateEnum Enumeration

HighLevelStateEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum HighLevelStateEnum
Public Enumeration HighLevelStateEnum
public enum class HighLevelStateEnum
type HighLevelStateEnum
Members
Member name | Value | Description
Unknown | 0 |
Created | 1 |
Deleting | 2 |
FailedBack | 3 |
FailedOver | 4 |
FailingBack | 5 |
FailingOver | 6 |
FailoverFailed | 7 |
FailoverPending | 8 |
Mirroring | 9 |
MirrorRequired | 10 |
Paused | 11 |
Pausing | 12 |
Protecting | 13 |
Provisioning | 14 |
Restored | 15 |
RestoreFailed | 16 |
RestorePaused | 17 |
RestoreRequired | 18 |
Restoring | 19 |
Resuming | 20 |
Reversing | 21 |
Reverting | 22 |
Starting | 23 |
Stopped | 24 |
Stopping | 25 |
Undoing | 26 |
RevertingSnapshot | 27 |
UpdatingTargetImage | 28 |
CredentialsRequired | 29 |
ActivationCodeWarning | 30 |
ActivationCodeError | 31 |
EngineConnectionWarning | 32 |
EngineConnectionError | 33 |
EngineServiceWarning | 34 |
EngineServiceError | 35 |
ServerCommunicationWarning | 36 |
ServerCommunicationError | 37 |
TargetInfoNotAvailable | 38 |
See Also

Reference

DoubleTake.Web.Models Namespace


ImageDeleteInfoModel Class

ImageDeleteInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageDeleteInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageDeleteInfoModel
Public NotInheritable Class ImageDeleteInfoModel
public ref class ImageDeleteInfoModel sealed
[<SealedAttribute>]
type ImageDeleteInfoModel =  class end

The ImageDeleteInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageDeleteInfoModel | Initializes a new instance of the ImageDeleteInfoModel class
Top
Properties
 | Name | Description
Public property | DeleteImage |
Public property | ImageId |
Public property | VhdDeleteAction |
Public property | VhdsToDelete |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageDeleteInfoModel Constructor

ImageDeleteInfoModel Constructor
Initializes a new instance of the ImageDeleteInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel()
Public Sub New
public:
ImageDeleteInfoModel()
new : unit -> ImageDeleteInfoModel
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel Properties

ImageDeleteInfoModel Properties

The ImageDeleteInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteImage |
Public property | ImageId |
Public property | VhdDeleteAction |
Public property | VhdsToDelete |
Top
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.DeleteImage Property

ImageDeleteInfoModelDeleteImage Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteImage { get; set; }
Public Property DeleteImage As Boolean
    Get
    Set
public:
property bool DeleteImage {
    bool get ();
    void set (bool value);
}
member DeleteImage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.ImageId Property

ImageDeleteInfoModelImageId Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
member ImageId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.VhdDeleteAction Property

ImageDeleteInfoModelVhdDeleteAction Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VhdDeleteActionTypeEnum VhdDeleteAction { get; set; }
Public Property VhdDeleteAction As VhdDeleteActionTypeEnum
    Get
    Set
public:
property VhdDeleteActionTypeEnum VhdDeleteAction {
    VhdDeleteActionTypeEnum get ();
    void set (VhdDeleteActionTypeEnum value);
}
member VhdDeleteAction : VhdDeleteActionTypeEnum with get, set

Property Value

Type: VhdDeleteActionTypeEnum
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.VhdsToDelete Property

ImageDeleteInfoModelVhdsToDelete Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> VhdsToDelete { get; set; }
Public Property VhdsToDelete As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDelete {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member VhdsToDelete : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel Methods

ImageDeleteInfoModel Methods

The ImageDeleteInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageDeleteInfoModel Class


ImageInfoModel Class

ImageInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageInfoModel
Public NotInheritable Class ImageInfoModel
public ref class ImageInfoModel sealed
[<SealedAttribute>]
type ImageInfoModel =  class end

The ImageInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageInfoModel | Initializes a new instance of the ImageInfoModel class
Top
Properties
 | Name | Description
Public property | CreationTimestamp | the date and time when the image was created
Public property | Description | the description of the image
Public property | Id | the image unique ID
Public property | ImageName | the name of the image
Public property | ImageType | the type of image
Public property | ProtectionConnectionId | the connection ID, if there is a protection job using the image
Public property | ProtectionJobName | the job name, if there is a protection job using the image
Public property | Snapshots | the current list of snapshots for the connection
Public property | SourceImageMountLocation | the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter
Public property | SourceName | the name of the source that contained the original the image data
Public property | State | the state of the target
Public property | VhdFiles | information about a virtual hard disk used to store an image
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageInfoModel Constructor

ImageInfoModel Constructor
Initializes a new instance of the ImageInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageInfoModel()
Public Sub New
public:
ImageInfoModel()
new : unit -> ImageInfoModel
See Also

Reference

ImageInfoModel Class


ImageInfoModel Properties

ImageInfoModel Properties

The ImageInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | CreationTimestamp | the date and time when the image was created
Public property | Description | the description of the image
Public property | Id | the image unique ID
Public property | ImageName | the name of the image
Public property | ImageType | the type of image
Public property | ProtectionConnectionId | the connection ID, if there is a protection job using the image
Public property | ProtectionJobName | the job name, if there is a protection job using the image
Public property | Snapshots | the current list of snapshots for the connection
Public property | SourceImageMountLocation | the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter
Public property | SourceName | the name of the source that contained the original the image data
Public property | State | the state of the target
Public property | VhdFiles | information about a virtual hard disk used to store an image
Top
See Also

Reference

ImageInfoModel Class


ImageInfoModel.CreationTimestamp Property

ImageInfoModelCreationTimestamp Property
the date and time when the image was created

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime CreationTimestamp { get; set; }
Public Property CreationTimestamp As DateTime
    Get
    Set
public:
property DateTime CreationTimestamp {
    DateTime get ();
    void set (DateTime value);
}
member CreationTimestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ImageInfoModel Class


ImageInfoModel.Description Property

ImageInfoModelDescription Property
the description of the image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.Id Property

ImageInfoModelId Property
the image unique ID

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ImageName Property

ImageInfoModelImageName Property
the name of the image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
member ImageName : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ImageType Property

ImageInfoModelImageType Property
the type of image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageTypeEnum ImageType { get; set; }
Public Property ImageType As ImageTypeEnum
    Get
    Set
public:
property ImageTypeEnum ImageType {
    ImageTypeEnum get ();
    void set (ImageTypeEnum value);
}
member ImageType : ImageTypeEnum with get, set

Property Value

Type: ImageTypeEnum
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ProtectionConnectionId Property

ImageInfoModelProtectionConnectionId Property
the connection ID, if there is a protection job using the image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProtectionConnectionId { get; set; }
Public Property ProtectionConnectionId As String
    Get
    Set
public:
property String^ ProtectionConnectionId {
    String^ get ();
    void set (String^ value);
}
member ProtectionConnectionId : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ProtectionJobName Property

ImageInfoModelProtectionJobName Property
the job name, if there is a protection job using the image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProtectionJobName { get; set; }
Public Property ProtectionJobName As String
    Get
    Set
public:
property String^ ProtectionJobName {
    String^ get ();
    void set (String^ value);
}
member ProtectionJobName : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.Snapshots Property

ImageInfoModelSnapshots Property
the current list of snapshots for the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntryModel()
    Get
    Set
public:
property array<SnapshotEntryModel^>^ Snapshots {
    array<SnapshotEntryModel^>^ get ();
    void set (array<SnapshotEntryModel^>^ value);
}
member Snapshots : SnapshotEntryModel[] with get, set

Property Value

Type: SnapshotEntryModel
See Also

Reference

ImageInfoModel Class


ImageInfoModel.SourceImageMountLocation Property

ImageInfoModelSourceImageMountLocation Property
the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceImageMountLocation { get; set; }
Public Property SourceImageMountLocation As String
    Get
    Set
public:
property String^ SourceImageMountLocation {
    String^ get ();
    void set (String^ value);
}
member SourceImageMountLocation : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.SourceName Property

ImageInfoModelSourceName Property
the name of the source that contained the original the image data

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
member SourceName : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.State Property

ImageInfoModelState Property
the state of the target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStatesEnum State { get; set; }
Public Property State As TargetStatesEnum
    Get
    Set
public:
property TargetStatesEnum State {
    TargetStatesEnum get ();
    void set (TargetStatesEnum value);
}
member State : TargetStatesEnum with get, set

Property Value

Type: TargetStatesEnum
See Also

Reference

ImageInfoModel Class


ImageInfoModel.VhdFiles Property

ImageInfoModelVhdFiles Property
information about a virtual hard disk used to store an image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageVhdInfoModel[] VhdFiles { get; set; }
Public Property VhdFiles As ImageVhdInfoModel()
    Get
    Set
public:
property array<ImageVhdInfoModel^>^ VhdFiles {
    array<ImageVhdInfoModel^>^ get ();
    void set (array<ImageVhdInfoModel^>^ value);
}
member VhdFiles : ImageVhdInfoModel[] with get, set

Property Value

Type: ImageVhdInfoModel
See Also

Reference

ImageInfoModel Class


ImageInfoModel Methods

ImageInfoModel Methods

The ImageInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageInfoModel Class


ImageProtectionJobDetailsModel Class

ImageProtectionJobDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageProtectionJobDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageProtectionJobDetailsModel
Public NotInheritable Class ImageProtectionJobDetailsModel
public ref class ImageProtectionJobDetailsModel sealed
[<SealedAttribute>]
type ImageProtectionJobDetailsModel =  class end

The ImageProtectionJobDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionJobDetailsModel | Initializes a new instance of the ImageProtectionJobDetailsModel class
Top
Properties
 | Name | Description
Public property | ProtectionConnectionDetails | the details of the protection connection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageProtectionJobDetailsModel Constructor

ImageProtectionJobDetailsModel Constructor
Initializes a new instance of the ImageProtectionJobDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionJobDetailsModel()
Public Sub New
public:
ImageProtectionJobDetailsModel()
new : unit -> ImageProtectionJobDetailsModel
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionJobDetailsModel Properties

ImageProtectionJobDetailsModel Properties

The ImageProtectionJobDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | ProtectionConnectionDetails | the details of the protection connection
Top
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionJobDetailsModel.ProtectionConnectionDetails Property

ImageProtectionJobDetailsModelProtectionConnectionDetails Property
the details of the protection connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ ProtectionConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member ProtectionConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionJobDetailsModel Methods

ImageProtectionJobDetailsModel Methods

The ImageProtectionJobDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionOptionsModel Class

ImageProtectionOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageProtectionOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageProtectionOptionsModel
Public NotInheritable Class ImageProtectionOptionsModel
public ref class ImageProtectionOptionsModel sealed
[<SealedAttribute>]
type ImageProtectionOptionsModel =  class end

The ImageProtectionOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionOptionsModel | Initializes a new instance of the ImageProtectionOptionsModel class
Top
Properties
 | Name | Description
Public property | ImageId | the value used to uniquely identify the image in the image store
Public property | ImageName | the name of the image.
Public property | VhdInfo | the information on the VHDs of the image.
Public property | VhdsToDeleteOnRemove | the list of VHD files to delete (specified by volume letter) from disk when the corresponding protected volume has been removed from the image
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageProtectionOptionsModel Constructor

ImageProtectionOptionsModel Constructor
Initializes a new instance of the ImageProtectionOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionOptionsModel()
Public Sub New
public:
ImageProtectionOptionsModel()
new : unit -> ImageProtectionOptionsModel
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel Properties

ImageProtectionOptionsModel Properties

The ImageProtectionOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ImageId | the value used to uniquely identify the image in the image store
Public property | ImageName | the name of the image.
Public property | VhdInfo | the information on the VHDs of the image.
Public property | VhdsToDeleteOnRemove | the list of VHD files to delete (specified by volume letter) from disk when the corresponding protected volume has been removed from the image
Top
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.ImageId Property

ImageProtectionOptionsModelImageId Property
the value used to uniquely identify the image in the image store

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
member ImageId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.ImageName Property

ImageProtectionOptionsModelImageName Property
the name of the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
member ImageName : string with get, set

Property Value

Type: String
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.VhdInfo Property

ImageProtectionOptionsModelVhdInfo Property
the information on the VHDs of the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageVhdInfoModel[] VhdInfo { get; set; }
Public Property VhdInfo As ImageVhdInfoModel()
    Get
    Set
public:
property array<ImageVhdInfoModel^>^ VhdInfo {
    array<ImageVhdInfoModel^>^ get ();
    void set (array<ImageVhdInfoModel^>^ value);
}
member VhdInfo : ImageVhdInfoModel[] with get, set

Property Value

Type: ImageVhdInfoModel
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.VhdsToDeleteOnRemove Property

ImageProtectionOptionsModelVhdsToDeleteOnRemove Property
the list of VHD files to delete (specified by volume letter) from disk when the corresponding protected volume has been removed from the image

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> VhdsToDeleteOnRemove { get; set; }
Public Property VhdsToDeleteOnRemove As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDeleteOnRemove {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member VhdsToDeleteOnRemove : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel Methods

ImageProtectionOptionsModel Methods

The ImageProtectionOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageProtectionOptionsModel Class


ImageRecoveryJobDetailsModel Class

ImageRecoveryJobDetailsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageRecoveryJobDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageRecoveryJobDetailsModel
Public NotInheritable Class ImageRecoveryJobDetailsModel
public ref class ImageRecoveryJobDetailsModel sealed
[<SealedAttribute>]
type ImageRecoveryJobDetailsModel =  class end

The ImageRecoveryJobDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryJobDetailsModel | Initializes a new instance of the ImageRecoveryJobDetailsModel class
Top
Properties
 | Name | Description
Public property | CutoverDetails | the details of the cutover operation
Public property | RecoveryConnectionDetails | the details of the recovery connection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageRecoveryJobDetailsModel Constructor

ImageRecoveryJobDetailsModel Constructor
Initializes a new instance of the ImageRecoveryJobDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryJobDetailsModel()
Public Sub New
public:
ImageRecoveryJobDetailsModel()
new : unit -> ImageRecoveryJobDetailsModel
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel Properties

ImageRecoveryJobDetailsModel Properties

The ImageRecoveryJobDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | CutoverDetails | the details of the cutover operation
Public property | RecoveryConnectionDetails | the details of the recovery connection
Top
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel.CutoverDetails Property

ImageRecoveryJobDetailsModelCutoverDetails Property
the details of the cutover operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CutoverDetailsModel CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetailsModel
    Get
    Set
public:
property CutoverDetailsModel^ CutoverDetails {
    CutoverDetailsModel^ get ();
    void set (CutoverDetailsModel^ value);
}
member CutoverDetails : CutoverDetailsModel with get, set

Property Value

Type: CutoverDetailsModel
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel.RecoveryConnectionDetails Property

ImageRecoveryJobDetailsModelRecoveryConnectionDetails Property
the details of the recovery connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ RecoveryConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member RecoveryConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel Methods

ImageRecoveryJobDetailsModel Methods

The ImageRecoveryJobDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryOptionsModel Class

ImageRecoveryOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageRecoveryOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageRecoveryOptionsModel
Public NotInheritable Class ImageRecoveryOptionsModel
public ref class ImageRecoveryOptionsModel sealed
[<SealedAttribute>]
type ImageRecoveryOptionsModel =  class end

The ImageRecoveryOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryOptionsModel | Initializes a new instance of the ImageRecoveryOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | the additional folders that should be staged on the target server
Public property | ImageId | the unique identifier of the image which will be recovered
Public property | ImageRecoveryDataLocation | the location of the original source's image data during an image recovery job
Public property | ShutdownSourceServer | a value indicating whether or not to shut down the source server during cutover
Public property | SnapshotSetId | the unique identifier of the snapshot set which will be recovered
Public property | UserInitiatedCutover | a value indicating whether or not the user initiates cutover
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageRecoveryOptionsModel Constructor

ImageRecoveryOptionsModel Constructor
Initializes a new instance of the ImageRecoveryOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryOptionsModel()
Public Sub New
public:
ImageRecoveryOptionsModel()
new : unit -> ImageRecoveryOptionsModel
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel Properties

ImageRecoveryOptionsModel Properties

The ImageRecoveryOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | the additional folders that should be staged on the target server
Public property | ImageId | the unique identifier of the image which will be recovered
Public property | ImageRecoveryDataLocation | the location of the original source's image data during an image recovery job
Public property | ShutdownSourceServer | a value indicating whether or not to shut down the source server during cutover
Public property | SnapshotSetId | the unique identifier of the snapshot set which will be recovered
Public property | UserInitiatedCutover | a value indicating whether or not the user initiates cutover
Top
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.AdditionalStagingFolders Property

ImageRecoveryOptionsModelAdditionalStagingFolders Property
the additional folders that should be staged on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AdditionalStagingFolders : string[] with get, set

Property Value

Type: String
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.ImageId Property

ImageRecoveryOptionsModelImageId Property
the unique identifier of the image which will be recovered

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
member ImageId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.ImageRecoveryDataLocation Property

ImageRecoveryOptionsModelImageRecoveryDataLocation Property
the location of the original source's image data during an image recovery job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageRecoveryDataLocation { get; set; }
Public Property ImageRecoveryDataLocation As String
    Get
    Set
public:
property String^ ImageRecoveryDataLocation {
    String^ get ();
    void set (String^ value);
}
member ImageRecoveryDataLocation : string with get, set

Property Value

Type: String
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.ShutdownSourceServer Property

ImageRecoveryOptionsModelShutdownSourceServer Property
a value indicating whether or not to shut down the source server during cutover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
member ShutdownSourceServer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.SnapshotSetId Property

ImageRecoveryOptionsModelSnapshotSetId Property
the unique identifier of the snapshot set which will be recovered

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid SnapshotSetId { get; set; }
Public Property SnapshotSetId As Guid
    Get
    Set
public:
property Guid SnapshotSetId {
    Guid get ();
    void set (Guid value);
}
member SnapshotSetId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.UserInitiatedCutover Property

ImageRecoveryOptionsModelUserInitiatedCutover Property
a value indicating whether or not the user initiates cutover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserInitiatedCutover { get; set; }
Public Property UserInitiatedCutover As Boolean
    Get
    Set
public:
property bool UserInitiatedCutover {
    bool get ();
    void set (bool value);
}
member UserInitiatedCutover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel Methods

ImageRecoveryOptionsModel Methods

The ImageRecoveryOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRecoveryOptionsModel Class


ImageTypeEnum Enumeration

ImageTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImageTypeEnum
Public Enumeration ImageTypeEnum
public enum class ImageTypeEnum
type ImageTypeEnum
Members
Member name | Value | Description
DataOnly | 0 |
FullServer | 1 |
Unknown | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ImageVhdInfoModel Class

ImageVhdInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageVhdInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageVhdInfoModel
Public NotInheritable Class ImageVhdInfoModel
public ref class ImageVhdInfoModel sealed
[<SealedAttribute>]
type ImageVhdInfoModel =  class end

The ImageVhdInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageVhdInfoModel | Initializes a new instance of the ImageVhdInfoModel class
Top
Properties
 | Name | Description
Public property | FilePath | full path to the VHD file
Public property | FormatType | the format type of the VHD file
Public property | SizeInMB | size of the VHD file in Megabytes
Public property | UseExistingVhd | a value indicating whether or not existing VHD file should be used
Public property | VolumeLetter | volume letter of the original volume this VHD is storing
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageVhdInfoModel Constructor

ImageVhdInfoModel Constructor
Initializes a new instance of the ImageVhdInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageVhdInfoModel()
Public Sub New
public:
ImageVhdInfoModel()
new : unit -> ImageVhdInfoModel
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel Properties

ImageVhdInfoModel Properties

The ImageVhdInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | full path to the VHD file
Public property | FormatType | the format type of the VHD file
Public property | SizeInMB | size of the VHD file in Megabytes
Public property | UseExistingVhd | a value indicating whether or not existing VHD file should be used
Public property | VolumeLetter | volume letter of the original volume this VHD is storing
Top
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.FilePath Property

ImageVhdInfoModelFilePath Property
full path to the VHD file

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
member FilePath : string with get, set

Property Value

Type: String
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.FormatType Property

ImageVhdInfoModelFormatType Property
the format type of the VHD file

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FormatType { get; set; }
Public Property FormatType As String
    Get
    Set
public:
property String^ FormatType {
    String^ get ();
    void set (String^ value);
}
member FormatType : string with get, set

Property Value

Type: String
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.SizeInMB Property

ImageVhdInfoModelSizeInMB Property
size of the VHD file in Megabytes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long SizeInMB { get; set; }
Public Property SizeInMB As Long
    Get
    Set
public:
property long long SizeInMB {
    long long get ();
    void set (long long value);
}
member SizeInMB : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.UseExistingVhd Property

ImageVhdInfoModelUseExistingVhd Property
a value indicating whether or not existing VHD file should be used

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseExistingVhd { get; set; }
Public Property UseExistingVhd As Boolean
    Get
    Set
public:
property bool UseExistingVhd {
    bool get ();
    void set (bool value);
}
member UseExistingVhd : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.VolumeLetter Property

ImageVhdInfoModelVolumeLetter Property
volume letter of the original volume this VHD is storing

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VolumeLetter { get; set; }
Public Property VolumeLetter As String
    Get
    Set
public:
property String^ VolumeLetter {
    String^ get ();
    void set (String^ value);
}
member VolumeLetter : string with get, set

Property Value

Type: String
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel Methods

ImageVhdInfoModel Methods

The ImageVhdInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageVhdInfoModel Class


InclusionModeEnum Enumeration

InclusionModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum InclusionModeEnum
Public Enumeration InclusionModeEnum
public enum class InclusionModeEnum
type InclusionModeEnum
Members
Member name | Value | Description
Include | 0 |
Exclude | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


JobActionModel Class

JobActionModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobActionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobActionModel
Public NotInheritable Class JobActionModel
public ref class JobActionModel sealed
[<SealedAttribute>]
type JobActionModel =  class end

The JobActionModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobActionModel | Initializes a new instance of the JobActionModel class
Top
Properties
 | Name | Description
Public property | Duration | the duration of this action
Public property | ErrorCode | the error code associated with this action
Public property | ExceptionMessage | the message from the underlying exception
Public property | Id | a unique identifier for this action
Public property | MessageFormatParameters | the message format parameters for this action
Public property | MessageId | the message identifier for this action
Public property | RequestingUserName | the name of the user that requested this action
Public property | Status | the status of this action.
Public property | Timestamp | the timestamp when this action occurred
Public property | TitleFormatParameters | the title format parameters for this action
Public property | TitleId | the title identifier for this action
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobActionModel Constructor

JobActionModel Constructor
Initializes a new instance of the JobActionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobActionModel()
Public Sub New
public:
JobActionModel()
new : unit -> JobActionModel
See Also

Reference

JobActionModel Class


JobActionModel Properties

JobActionModel Properties

The JobActionModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | the duration of this action
Public property | ErrorCode | the error code associated with this action
Public property | ExceptionMessage | the message from the underlying exception
Public property | Id | a unique identifier for this action
Public property | MessageFormatParameters | the message format parameters for this action
Public property | MessageId | the message identifier for this action
Public property | RequestingUserName | the name of the user that requested this action
Public property | Status | the status of this action.
Public property | Timestamp | the timestamp when this action occurred
Public property | TitleFormatParameters | the title format parameters for this action
Public property | TitleId | the title identifier for this action
Top
See Also

Reference

JobActionModel Class


JobActionModel.Duration Property

JobActionModelDuration Property
the duration of this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Duration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

JobActionModel Class


JobActionModel.ErrorCode Property

JobActionModelErrorCode Property
the error code associated with this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
member ErrorCode : int with get, set

Property Value

Type: Int32
See Also

Reference

JobActionModel Class


JobActionModel.ExceptionMessage Property

JobActionModelExceptionMessage Property
the message from the underlying exception

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ExceptionMessage { get; set; }
Public Property ExceptionMessage As String
    Get
    Set
public:
property String^ ExceptionMessage {
    String^ get ();
    void set (String^ value);
}
member ExceptionMessage : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.Id Property

JobActionModelId Property
a unique identifier for this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobActionModel Class


JobActionModel.MessageFormatParameters Property

JobActionModelMessageFormatParameters Property
the message format parameters for this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.MessageId Property

JobActionModelMessageId Property
the message identifier for this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
member MessageId : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.RequestingUserName Property

JobActionModelRequestingUserName Property
the name of the user that requested this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RequestingUserName { get; set; }
Public Property RequestingUserName As String
    Get
    Set
public:
property String^ RequestingUserName {
    String^ get ();
    void set (String^ value);
}
member RequestingUserName : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.Status Property

JobActionModelStatus Property
the status of this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActionStatusEnum Status { get; set; }
Public Property Status As ActionStatusEnum
    Get
    Set
public:
property ActionStatusEnum Status {
    ActionStatusEnum get ();
    void set (ActionStatusEnum value);
}
member Status : ActionStatusEnum with get, set

Property Value

Type: ActionStatusEnum
See Also

Reference

JobActionModel Class


JobActionModel.Timestamp Property

JobActionModelTimestamp Property
the timestamp when this action occurred

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member Timestamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

JobActionModel Class


JobActionModel.TitleFormatParameters Property

JobActionModelTitleFormatParameters Property
the title format parameters for this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TitleFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.TitleId Property

JobActionModelTitleId Property
the title identifier for this action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TitleId { get; set; }
Public Property TitleId As String
    Get
    Set
public:
property String^ TitleId {
    String^ get ();
    void set (String^ value);
}
member TitleId : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel Methods

JobActionModel Methods

The JobActionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobActionModel Class


JobCredentialsModel Class

JobCredentialsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobCredentialsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class JobCredentialsModel
Public Class JobCredentialsModel
public ref class JobCredentialsModel
type JobCredentialsModel =  class end

The JobCredentialsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobCredentialsModel | Initializes a new instance of the JobCredentialsModel class
Top
Properties
 | Name | Description
Public property | OtherServers | the connection information for other servers
Public property | SourceServer | the source server connection information
Public property | TargetServer | the target server connection information
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobCredentialsModel Constructor

JobCredentialsModel Constructor
Initializes a new instance of the JobCredentialsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel()
Public Sub New
public:
JobCredentialsModel()
new : unit -> JobCredentialsModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel Properties

JobCredentialsModel Properties

The JobCredentialsModel type exposes the following members.

Properties
 | Name | Description
Public property | OtherServers | the connection information for other servers
Public property | SourceServer | the source server connection information
Public property | TargetServer | the target server connection information
Top
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel.OtherServers Property

JobCredentialsModelOtherServers Property
the connection information for other servers

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, ServiceConnectionModel> OtherServers { get; set; }
Public Property OtherServers As IDictionary(Of String, ServiceConnectionModel)
    Get
    Set
public:
property IDictionary<String^, ServiceConnectionModel^>^ OtherServers {
    IDictionary<String^, ServiceConnectionModel^>^ get ();
    void set (IDictionary<String^, ServiceConnectionModel^>^ value);
}
member OtherServers : IDictionary<string, ServiceConnectionModel> with get, set

Property Value

Type: IDictionary String, ServiceConnectionModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel.SourceServer Property

JobCredentialsModelSourceServer Property
the source server connection information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel SourceServer { get; set; }
Public Property SourceServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ SourceServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member SourceServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel.TargetServer Property

JobCredentialsModelTargetServer Property
the target server connection information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel TargetServer { get; set; }
Public Property TargetServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ TargetServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member TargetServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel Methods

JobCredentialsModel Methods

The JobCredentialsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobCredentialsModel Class


JobInfoModel Class

JobInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobInfoModel
Public NotInheritable Class JobInfoModel
public ref class JobInfoModel sealed
[<SealedAttribute>]
type JobInfoModel =  class end

The JobInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfoModel | Initializes a new instance of the JobInfoModel class
Top
Properties
 | Name | Description
Public property | CreatorUserName | the name of the user who created this job
Public property | Features | the additional features supported by this job
Public property | Id | the unique identifier of this job
Public property | JobType | the type of this job
Public property | LoadedFromDisk | a value indicating whether this job was loaded from persistence
Public property | Managed | a value indicating whether or not this job is managed by the unified job manager
Public property | Options | the current options for this job
Public property | OtherServers | the server connection information for other servers involved in the job
Public property | SourceServer | the source server connection information
Public property | SourceUniqueId | the unique identifier of the source server
Public property | Statistics | the current statistics of this job
Public property | Status | the current status of this job
Public property | TargetServer | the target server connection information
Public property | TargetUniqueId | the unique identifier of the target server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobInfoModel Constructor

JobInfoModel Constructor
Initializes a new instance of the JobInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobInfoModel()
Public Sub New
public:
JobInfoModel()
new : unit -> JobInfoModel
See Also

Reference

JobInfoModel Class


JobInfoModel Properties

JobInfoModel Properties

The JobInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | CreatorUserName | the name of the user who created this job
Public property | Features | the additional features supported by this job
Public property | Id | the unique identifier of this job
Public property | JobType | the type of this job
Public property | LoadedFromDisk | a value indicating whether this job was loaded from persistence
Public property | Managed | a value indicating whether or not this job is managed by the unified job manager
Public property | Options | the current options for this job
Public property | OtherServers | the server connection information for other servers involved in the job
Public property | SourceServer | the source server connection information
Public property | SourceUniqueId | the unique identifier of the source server
Public property | Statistics | the current statistics of this job
Public property | Status | the current status of this job
Public property | TargetServer | the target server connection information
Public property | TargetUniqueId | the unique identifier of the target server
Top
See Also

Reference

JobInfoModel Class


JobInfoModel.CreatorUserName Property

JobInfoModelCreatorUserName Property
the name of the user who created this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CreatorUserName { get; set; }
Public Property CreatorUserName As String
    Get
    Set
public:
property String^ CreatorUserName {
    String^ get ();
    void set (String^ value);
}
member CreatorUserName : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel.Features Property

JobInfoModelFeatures Property
the additional features supported by this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FeatureModel[] Features { get; set; }
Public Property Features As FeatureModel()
    Get
    Set
public:
property array<FeatureModel^>^ Features {
    array<FeatureModel^>^ get ();
    void set (array<FeatureModel^>^ value);
}
member Features : FeatureModel[] with get, set

Property Value

Type: FeatureModel
See Also

Reference

JobInfoModel Class


JobInfoModel.Id Property

JobInfoModelId Property
the unique identifier of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobInfoModel Class


JobInfoModel.JobType Property

JobInfoModelJobType Property
the type of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel.LoadedFromDisk Property

JobInfoModelLoadedFromDisk Property
a value indicating whether this job was loaded from persistence

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
member LoadedFromDisk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobInfoModel Class


JobInfoModel.Managed Property

JobInfoModelManaged Property
a value indicating whether or not this job is managed by the unified job manager

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Managed { get; set; }
Public Property Managed As Boolean
    Get
    Set
public:
property bool Managed {
    bool get ();
    void set (bool value);
}
member Managed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobInfoModel Class


JobInfoModel.Options Property

JobInfoModelOptions Property
the current options for this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel Options { get; set; }
Public Property Options As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ Options {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member Options : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

JobInfoModel Class


JobInfoModel.OtherServers Property

JobInfoModelOtherServers Property
the server connection information for other servers involved in the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, ServiceConnectionModel> OtherServers { get; set; }
Public Property OtherServers As IDictionary(Of String, ServiceConnectionModel)
    Get
    Set
public:
property IDictionary<String^, ServiceConnectionModel^>^ OtherServers {
    IDictionary<String^, ServiceConnectionModel^>^ get ();
    void set (IDictionary<String^, ServiceConnectionModel^>^ value);
}
member OtherServers : IDictionary<string, ServiceConnectionModel> with get, set

Property Value

Type: IDictionary String, ServiceConnectionModel
See Also

Reference

JobInfoModel Class


JobInfoModel.SourceServer Property

JobInfoModelSourceServer Property
the source server connection information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel SourceServer { get; set; }
Public Property SourceServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ SourceServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member SourceServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobInfoModel Class


JobInfoModel.SourceUniqueId Property

JobInfoModelSourceUniqueId Property
the unique identifier of the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member SourceUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel.Statistics Property

JobInfoModelStatistics Property
the current statistics of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatisticsModel Statistics { get; set; }
Public Property Statistics As JobStatisticsModel
    Get
    Set
public:
property JobStatisticsModel^ Statistics {
    JobStatisticsModel^ get ();
    void set (JobStatisticsModel^ value);
}
member Statistics : JobStatisticsModel with get, set

Property Value

Type: JobStatisticsModel
See Also

Reference

JobInfoModel Class


JobInfoModel.Status Property

JobInfoModelStatus Property
the current status of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatusModel Status { get; set; }
Public Property Status As JobStatusModel
    Get
    Set
public:
property JobStatusModel^ Status {
    JobStatusModel^ get ();
    void set (JobStatusModel^ value);
}
member Status : JobStatusModel with get, set

Property Value

Type: JobStatusModel
See Also

Reference

JobInfoModel Class


JobInfoModel.TargetServer Property

JobInfoModelTargetServer Property
the target server connection information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel TargetServer { get; set; }
Public Property TargetServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ TargetServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member TargetServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobInfoModel Class


JobInfoModel.TargetUniqueId Property

JobInfoModelTargetUniqueId Property
the unique identifier of the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member TargetUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel Methods

JobInfoModel Methods

The JobInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobInfoModel Class


JobOptionsModel Class

JobOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobOptionsModel
Public NotInheritable Class JobOptionsModel
public ref class JobOptionsModel sealed
[<SealedAttribute>]
type JobOptionsModel =  class end

The JobOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobOptionsModel | Initializes a new instance of the JobOptionsModel class
Top
Properties
 | Name | Description
Public property | ApplicationOptions | the options for application-specific protection jobs
Public property | BandwidthOptions | the options for bandwidth limiting
Public property | CloudOptions | the options for cloud jobs
Public property | ClusterOptions | the cluster options
Public property | CoreConnectionOptions | the core connection options
Public property | CoreMonitorOptions | the core monitor options
Public property | DnsOptions | the DNS options
Public property | FailoverMonitoringEnabled | a value indicating whether or not failover monitoring is enabled
Public property | FullServerFailoverOptions | the options for full server failover jobs
Public property | ImageProtectionOptions | the options for image protection jobs
Public property | ImageRecoveryOptions | the options for image recovery jobs
Public property | ManagementServiceTargetPort | the port used by ManagementService
Public property | MonitoringOptions | the monitoring options
Public property | Name | the name of this job
Public property | SimpleFailoverMonitorOptions | the options for failover monitoring without using IP address
Public property | SystemStateOptions | the system state options
Public property | TargetServicesOptions | target service options
Public property | UnmanagedConnectionOptions | the options for jobs that use an unmanaged connection
Public property | VcdVappOptions | new DTAV (Linux)
Public property | VraOptions | the options for jobs that use Virtual Recovery Assistant
Public property | Workload | the workload to be protected by this job
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobOptionsModel Constructor

JobOptionsModel Constructor
Initializes a new instance of the JobOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel()
Public Sub New
public:
JobOptionsModel()
new : unit -> JobOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel Properties

JobOptionsModel Properties

The JobOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationOptions | the options for application-specific protection jobs
Public property | BandwidthOptions | the options for bandwidth limiting
Public property | CloudOptions | the options for cloud jobs
Public property | ClusterOptions | the cluster options
Public property | CoreConnectionOptions | the core connection options
Public property | CoreMonitorOptions | the core monitor options
Public property | DnsOptions | the DNS options
Public property | FailoverMonitoringEnabled | a value indicating whether or not failover monitoring is enabled
Public property | FullServerFailoverOptions | the options for full server failover jobs
Public property | ImageProtectionOptions | the options for image protection jobs
Public property | ImageRecoveryOptions | the options for image recovery jobs
Public property | ManagementServiceTargetPort | the port used by ManagementService
Public property | MonitoringOptions | the monitoring options
Public property | Name | the name of this job
Public property | SimpleFailoverMonitorOptions | the options for failover monitoring without using IP address
Public property | SystemStateOptions | the system state options
Public property | TargetServicesOptions | target service options
Public property | UnmanagedConnectionOptions | the options for jobs that use an unmanaged connection
Public property | VcdVappOptions | new DTAV (Linux)
Public property | VraOptions | the options for jobs that use Virtual Recovery Assistant
Public property | Workload | the workload to be protected by this job
Top
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ApplicationOptions Property

JobOptionsModelApplicationOptions Property
the options for application-specific protection jobs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ApplicationOptionsModel ApplicationOptions { get; set; }
Public Property ApplicationOptions As ApplicationOptionsModel
    Get
    Set
public:
property ApplicationOptionsModel^ ApplicationOptions {
    ApplicationOptionsModel^ get ();
    void set (ApplicationOptionsModel^ value);
}
member ApplicationOptions : ApplicationOptionsModel with get, set

Property Value

Type: ApplicationOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.BandwidthOptions Property

JobOptionsModelBandwidthOptions Property
the options for bandwidth limiting

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthOptionsModel BandwidthOptions { get; set; }
Public Property BandwidthOptions As BandwidthOptionsModel
    Get
    Set
public:
property BandwidthOptionsModel^ BandwidthOptions {
    BandwidthOptionsModel^ get ();
    void set (BandwidthOptionsModel^ value);
}
member BandwidthOptions : BandwidthOptionsModel with get, set

Property Value

Type: BandwidthOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.CloudOptions Property

JobOptionsModelCloudOptions Property
the options for cloud jobs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CloudOptionsModel CloudOptions { get; set; }
Public Property CloudOptions As CloudOptionsModel
    Get
    Set
public:
property CloudOptionsModel^ CloudOptions {
    CloudOptionsModel^ get ();
    void set (CloudOptionsModel^ value);
}
member CloudOptions : CloudOptionsModel with get, set

Property Value

Type: CloudOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ClusterOptions Property

JobOptionsModelClusterOptions Property
the cluster options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterOptionsModel ClusterOptions { get; set; }
Public Property ClusterOptions As ClusterOptionsModel
    Get
    Set
public:
property ClusterOptionsModel^ ClusterOptions {
    ClusterOptionsModel^ get ();
    void set (ClusterOptionsModel^ value);
}
member ClusterOptions : ClusterOptionsModel with get, set

Property Value

Type: ClusterOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.CoreConnectionOptions Property

JobOptionsModelCoreConnectionOptions Property
the core connection options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionOptionsModel CoreConnectionOptions { get; set; }
Public Property CoreConnectionOptions As CoreConnectionOptionsModel
    Get
    Set
public:
property CoreConnectionOptionsModel^ CoreConnectionOptions {
    CoreConnectionOptionsModel^ get ();
    void set (CoreConnectionOptionsModel^ value);
}
member CoreConnectionOptions : CoreConnectionOptionsModel with get, set

Property Value

Type: CoreConnectionOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.CoreMonitorOptions Property

JobOptionsModelCoreMonitorOptions Property
the core monitor options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorOptionsModel CoreMonitorOptions { get; set; }
Public Property CoreMonitorOptions As CoreMonitorOptionsModel
    Get
    Set
public:
property CoreMonitorOptionsModel^ CoreMonitorOptions {
    CoreMonitorOptionsModel^ get ();
    void set (CoreMonitorOptionsModel^ value);
}
member CoreMonitorOptions : CoreMonitorOptionsModel with get, set

Property Value

Type: CoreMonitorOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.DnsOptions Property

JobOptionsModelDnsOptions Property
the DNS options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DnsOptionsModel DnsOptions { get; set; }
Public Property DnsOptions As DnsOptionsModel
    Get
    Set
public:
property DnsOptionsModel^ DnsOptions {
    DnsOptionsModel^ get ();
    void set (DnsOptionsModel^ value);
}
member DnsOptions : DnsOptionsModel with get, set

Property Value

Type: DnsOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.FailoverMonitoringEnabled Property

JobOptionsModelFailoverMonitoringEnabled Property
a value indicating whether or not failover monitoring is enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> FailoverMonitoringEnabled { get; set; }
Public Property FailoverMonitoringEnabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> FailoverMonitoringEnabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member FailoverMonitoringEnabled : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

JobOptionsModel Class


JobOptionsModel.FullServerFailoverOptions Property

JobOptionsModelFullServerFailoverOptions Property
the options for full server failover jobs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerFailoverOptionsModel FullServerFailoverOptions { get; set; }
Public Property FullServerFailoverOptions As FullServerFailoverOptionsModel
    Get
    Set
public:
property FullServerFailoverOptionsModel^ FullServerFailoverOptions {
    FullServerFailoverOptionsModel^ get ();
    void set (FullServerFailoverOptionsModel^ value);
}
member FullServerFailoverOptions : FullServerFailoverOptionsModel with get, set

Property Value

Type: FullServerFailoverOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ImageProtectionOptions Property

JobOptionsModelImageProtectionOptions Property
the options for image protection jobs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionOptionsModel ImageProtectionOptions { get; set; }
Public Property ImageProtectionOptions As ImageProtectionOptionsModel
    Get
    Set
public:
property ImageProtectionOptionsModel^ ImageProtectionOptions {
    ImageProtectionOptionsModel^ get ();
    void set (ImageProtectionOptionsModel^ value);
}
member ImageProtectionOptions : ImageProtectionOptionsModel with get, set

Property Value

Type: ImageProtectionOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ImageRecoveryOptions Property

JobOptionsModelImageRecoveryOptions Property
the options for image recovery jobs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryOptionsModel ImageRecoveryOptions { get; set; }
Public Property ImageRecoveryOptions As ImageRecoveryOptionsModel
    Get
    Set
public:
property ImageRecoveryOptionsModel^ ImageRecoveryOptions {
    ImageRecoveryOptionsModel^ get ();
    void set (ImageRecoveryOptionsModel^ value);
}
member ImageRecoveryOptions : ImageRecoveryOptionsModel with get, set

Property Value

Type: ImageRecoveryOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ManagementServiceTargetPort Property

JobOptionsModelManagementServiceTargetPort Property
the port used by ManagementService

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ManagementServiceTargetPort { get; set; }
Public Property ManagementServiceTargetPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ManagementServiceTargetPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ManagementServiceTargetPort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

JobOptionsModel Class


JobOptionsModel.MonitoringOptions Property

JobOptionsModelMonitoringOptions Property
the monitoring options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoringOptionsModel MonitoringOptions { get; set; }
Public Property MonitoringOptions As MonitoringOptionsModel
    Get
    Set
public:
property MonitoringOptionsModel^ MonitoringOptions {
    MonitoringOptionsModel^ get ();
    void set (MonitoringOptionsModel^ value);
}
member MonitoringOptions : MonitoringOptionsModel with get, set

Property Value

Type: MonitoringOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.Name Property

JobOptionsModelName Property
the name of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

JobOptionsModel Class


JobOptionsModel.SimpleFailoverMonitorOptions Property

JobOptionsModelSimpleFailoverMonitorOptions Property
the options for failover monitoring without using IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleFailoverMonitorOptionsModel SimpleFailoverMonitorOptions { get; set; }
Public Property SimpleFailoverMonitorOptions As SimpleFailoverMonitorOptionsModel
    Get
    Set
public:
property SimpleFailoverMonitorOptionsModel^ SimpleFailoverMonitorOptions {
    SimpleFailoverMonitorOptionsModel^ get ();
    void set (SimpleFailoverMonitorOptionsModel^ value);
}
member SimpleFailoverMonitorOptions : SimpleFailoverMonitorOptionsModel with get, set

Property Value

Type: SimpleFailoverMonitorOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.SystemStateOptions Property

JobOptionsModelSystemStateOptions Property
the system state options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SystemStateOptionsModel SystemStateOptions { get; set; }
Public Property SystemStateOptions As SystemStateOptionsModel
    Get
    Set
public:
property SystemStateOptionsModel^ SystemStateOptions {
    SystemStateOptionsModel^ get ();
    void set (SystemStateOptionsModel^ value);
}
member SystemStateOptions : SystemStateOptionsModel with get, set

Property Value

Type: SystemStateOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.TargetServicesOptions Property

JobOptionsModelTargetServicesOptions Property
target service options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesOptionsModel TargetServicesOptions { get; set; }
Public Property TargetServicesOptions As TargetServicesOptionsModel
    Get
    Set
public:
property TargetServicesOptionsModel^ TargetServicesOptions {
    TargetServicesOptionsModel^ get ();
    void set (TargetServicesOptionsModel^ value);
}
member TargetServicesOptions : TargetServicesOptionsModel with get, set

Property Value

Type: TargetServicesOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.UnmanagedConnectionOptions Property

JobOptionsModelUnmanagedConnectionOptions Property
the options for jobs that use an unmanaged connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnmanagedConnectionOptionsModel UnmanagedConnectionOptions { get; set; }
Public Property UnmanagedConnectionOptions As UnmanagedConnectionOptionsModel
    Get
    Set
public:
property UnmanagedConnectionOptionsModel^ UnmanagedConnectionOptions {
    UnmanagedConnectionOptionsModel^ get ();
    void set (UnmanagedConnectionOptionsModel^ value);
}
member UnmanagedConnectionOptions : UnmanagedConnectionOptionsModel with get, set

Property Value

Type: UnmanagedConnectionOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.VcdVappOptions Property

JobOptionsModelVcdVappOptions Property
new DTAV (Linux)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VcdVappOptionsModel VcdVappOptions { get; set; }
Public Property VcdVappOptions As VcdVappOptionsModel
    Get
    Set
public:
property VcdVappOptionsModel^ VcdVappOptions {
    VcdVappOptionsModel^ get ();
    void set (VcdVappOptionsModel^ value);
}
member VcdVappOptions : VcdVappOptionsModel with get, set

Property Value

Type: VcdVappOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.VraOptions Property

JobOptionsModelVraOptions Property
the options for jobs that use Virtual Recovery Assistant

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VraOptionsModel VraOptions { get; set; }
Public Property VraOptions As VraOptionsModel
    Get
    Set
public:
property VraOptionsModel^ VraOptions {
    VraOptionsModel^ get ();
    void set (VraOptionsModel^ value);
}
member VraOptions : VraOptionsModel with get, set

Property Value

Type: VraOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.Workload Property

JobOptionsModelWorkload Property
the workload to be protected by this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel Methods

JobOptionsModel Methods

The JobOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobOptionsModel Class


JobQualificationResultsModel Class

JobQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobQualificationResultsModel
Public NotInheritable Class JobQualificationResultsModel
public ref class JobQualificationResultsModel sealed
[<SealedAttribute>]
type JobQualificationResultsModel =  class end

The JobQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobQualificationResultsModel | Initializes a new instance of the JobQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | the cluster files and folders qualification results
Public property | CoreQualificationResults | the possible options that apply to engine connection and monitor
Public property | SourceBehindNat | a value indicating whether the source is behind a NAT firewall
Public property | SourceHostUri | the source host URI
Public property | SupportsFrameworkMonitoring | a value indicating whether the machine supports framework monitoring
Public property | SuppressFailoverMonitorOptions | a value indicating whether to suppress failover monitor options
Public property | VcdVappQualificationResults | the possible options that apply to new DTVI job
Public property | VraQualificationResults | the possible options that apply to VRA job
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobQualificationResultsModel Constructor

JobQualificationResultsModel Constructor
Initializes a new instance of the JobQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobQualificationResultsModel()
Public Sub New
public:
JobQualificationResultsModel()
new : unit -> JobQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel Properties

JobQualificationResultsModel Properties

The JobQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | the cluster files and folders qualification results
Public property | CoreQualificationResults | the possible options that apply to engine connection and monitor
Public property | SourceBehindNat | a value indicating whether the source is behind a NAT firewall
Public property | SourceHostUri | the source host URI
Public property | SupportsFrameworkMonitoring | a value indicating whether the machine supports framework monitoring
Public property | SuppressFailoverMonitorOptions | a value indicating whether to suppress failover monitor options
Public property | VcdVappQualificationResults | the possible options that apply to new DTVI job
Public property | VraQualificationResults | the possible options that apply to VRA job
Top
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.ClusterFilesAndFoldersQualificationResults Property

JobQualificationResultsModelClusterFilesAndFoldersQualificationResults Property
the cluster files and folders qualification results

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterFilesAndFoldersQualificationResultsModel ClusterFilesAndFoldersQualificationResults { get; set; }
Public Property ClusterFilesAndFoldersQualificationResults As ClusterFilesAndFoldersQualificationResultsModel
    Get
    Set
public:
property ClusterFilesAndFoldersQualificationResultsModel^ ClusterFilesAndFoldersQualificationResults {
    ClusterFilesAndFoldersQualificationResultsModel^ get ();
    void set (ClusterFilesAndFoldersQualificationResultsModel^ value);
}
member ClusterFilesAndFoldersQualificationResults : ClusterFilesAndFoldersQualificationResultsModel with get, set

Property Value

Type: ClusterFilesAndFoldersQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.CoreQualificationResults Property

JobQualificationResultsModelCoreQualificationResults Property
the possible options that apply to engine connection and monitor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreQualificationResultsModel CoreQualificationResults { get; set; }
Public Property CoreQualificationResults As CoreQualificationResultsModel
    Get
    Set
public:
property CoreQualificationResultsModel^ CoreQualificationResults {
    CoreQualificationResultsModel^ get ();
    void set (CoreQualificationResultsModel^ value);
}
member CoreQualificationResults : CoreQualificationResultsModel with get, set

Property Value

Type: CoreQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SourceBehindNat Property

JobQualificationResultsModelSourceBehindNat Property
a value indicating whether the source is behind a NAT firewall

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceBehindNat { get; set; }
Public Property SourceBehindNat As Boolean
    Get
    Set
public:
property bool SourceBehindNat {
    bool get ();
    void set (bool value);
}
member SourceBehindNat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SourceHostUri Property

JobQualificationResultsModelSourceHostUri Property
the source host URI

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member SourceHostUri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SupportsFrameworkMonitoring Property

JobQualificationResultsModelSupportsFrameworkMonitoring Property
a value indicating whether the machine supports framework monitoring

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsFrameworkMonitoring { get; set; }
Public Property SupportsFrameworkMonitoring As Boolean
    Get
    Set
public:
property bool SupportsFrameworkMonitoring {
    bool get ();
    void set (bool value);
}
member SupportsFrameworkMonitoring : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SuppressFailoverMonitorOptions Property

JobQualificationResultsModelSuppressFailoverMonitorOptions Property
a value indicating whether to suppress failover monitor options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressFailoverMonitorOptions { get; set; }
Public Property SuppressFailoverMonitorOptions As Boolean
    Get
    Set
public:
property bool SuppressFailoverMonitorOptions {
    bool get ();
    void set (bool value);
}
member SuppressFailoverMonitorOptions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.VcdVappQualificationResults Property

JobQualificationResultsModelVcdVappQualificationResults Property
the possible options that apply to new DTVI job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VcdVappOptionsModel VcdVappQualificationResults { get; set; }
Public Property VcdVappQualificationResults As VcdVappOptionsModel
    Get
    Set
public:
property VcdVappOptionsModel^ VcdVappQualificationResults {
    VcdVappOptionsModel^ get ();
    void set (VcdVappOptionsModel^ value);
}
member VcdVappQualificationResults : VcdVappOptionsModel with get, set

Property Value

Type: VcdVappOptionsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.VraQualificationResults Property

JobQualificationResultsModelVraQualificationResults Property
the possible options that apply to VRA job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VraQualificationResultsModel VraQualificationResults { get; set; }
Public Property VraQualificationResults As VraQualificationResultsModel
    Get
    Set
public:
property VraQualificationResultsModel^ VraQualificationResults {
    VraQualificationResultsModel^ get ();
    void set (VraQualificationResultsModel^ value);
}
member VraQualificationResults : VraQualificationResultsModel with get, set

Property Value

Type: VraQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel Methods

JobQualificationResultsModel Methods

The JobQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobQualificationResultsModel Class


JobStatisticsModel Class

JobStatisticsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobStatisticsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobStatisticsModel
Public NotInheritable Class JobStatisticsModel
public ref class JobStatisticsModel sealed
[<SealedAttribute>]
type JobStatisticsModel =  class end

The JobStatisticsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatisticsModel | Initializes a new instance of the JobStatisticsModel class
Top
Properties
 | Name | Description
Public property | CoreConnectionDetails | the core connection details
Public property | CoreMonitorDetails | the core monitor details
Public property | FullServerJobDetails | the full server job details
Public property | ImageProtectionJobDetails | the image protection job details
Public property | ImageRecoveryJobDetails | the image recovery job details
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobStatisticsModel Constructor

JobStatisticsModel Constructor
Initializes a new instance of the JobStatisticsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatisticsModel()
Public Sub New
public:
JobStatisticsModel()
new : unit -> JobStatisticsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel Properties

JobStatisticsModel Properties

The JobStatisticsModel type exposes the following members.

Properties
 | Name | Description
Public property | CoreConnectionDetails | the core connection details
Public property | CoreMonitorDetails | the core monitor details
Public property | FullServerJobDetails | the full server job details
Public property | ImageProtectionJobDetails | the image protection job details
Public property | ImageRecoveryJobDetails | the image recovery job details
Top
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.CoreConnectionDetails Property

JobStatisticsModelCoreConnectionDetails Property
the core connection details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel CoreConnectionDetails { get; set; }
Public Property CoreConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ CoreConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member CoreConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.CoreMonitorDetails Property

JobStatisticsModelCoreMonitorDetails Property
the core monitor details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorDetailsModel CoreMonitorDetails { get; set; }
Public Property CoreMonitorDetails As CoreMonitorDetailsModel
    Get
    Set
public:
property CoreMonitorDetailsModel^ CoreMonitorDetails {
    CoreMonitorDetailsModel^ get ();
    void set (CoreMonitorDetailsModel^ value);
}
member CoreMonitorDetails : CoreMonitorDetailsModel with get, set

Property Value

Type: CoreMonitorDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.FullServerJobDetails Property

JobStatisticsModelFullServerJobDetails Property
the full server job details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerJobDetailsModel FullServerJobDetails { get; set; }
Public Property FullServerJobDetails As FullServerJobDetailsModel
    Get
    Set
public:
property FullServerJobDetailsModel^ FullServerJobDetails {
    FullServerJobDetailsModel^ get ();
    void set (FullServerJobDetailsModel^ value);
}
member FullServerJobDetails : FullServerJobDetailsModel with get, set

Property Value

Type: FullServerJobDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.ImageProtectionJobDetails Property

JobStatisticsModelImageProtectionJobDetails Property
the image protection job details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionJobDetailsModel ImageProtectionJobDetails { get; set; }
Public Property ImageProtectionJobDetails As ImageProtectionJobDetailsModel
    Get
    Set
public:
property ImageProtectionJobDetailsModel^ ImageProtectionJobDetails {
    ImageProtectionJobDetailsModel^ get ();
    void set (ImageProtectionJobDetailsModel^ value);
}
member ImageProtectionJobDetails : ImageProtectionJobDetailsModel with get, set

Property Value

Type: ImageProtectionJobDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.ImageRecoveryJobDetails Property

JobStatisticsModelImageRecoveryJobDetails Property
the image recovery job details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryJobDetailsModel ImageRecoveryJobDetails { get; set; }
Public Property ImageRecoveryJobDetails As ImageRecoveryJobDetailsModel
    Get
    Set
public:
property ImageRecoveryJobDetailsModel^ ImageRecoveryJobDetails {
    ImageRecoveryJobDetailsModel^ get ();
    void set (ImageRecoveryJobDetailsModel^ value);
}
member ImageRecoveryJobDetails : ImageRecoveryJobDetailsModel with get, set

Property Value

Type: ImageRecoveryJobDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel Methods

JobStatisticsModel Methods

The JobStatisticsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobStatisticsModel Class


JobStatusModel Class

JobStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobStatusModel
Public NotInheritable Class JobStatusModel
public ref class JobStatusModel sealed
[<SealedAttribute>]
type JobStatusModel =  class end

The JobStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatusModel | Initializes a new instance of the JobStatusModel class
Top
Properties
 | Name | Description
Public property | Actions | a list of actions recently associated with this job
Public property | CanCreateImageRecovery | a value indicating whether an image protection job is in a viable state to create an image recovery job off of
Public property | CanDelete | a value indicating whether this job can currently be deleted
Public property | CanEdit | a value indicating whether this job can currently be edited
Public property | CanFailback | a value indicating whether this job can currently be failed back
Public property | CanFailover | a value indicating whether this job can currently be failed over
Public property | CanPause | a value indicating whether this job can currently be paused
Public property | CanRestore | a value indicating whether this job can currently be restored
Public property | CanReverse | a value indicating whether this job can currently be reversed
Public property | CanStart | a value indicating whether this job can currently be started
Public property | CanStop | a value indicating whether this job can currently be stopped
Public property | CanUndoFailover | a value indicating whether the failover of this job can be currently undone
Public property | EngineControlStatuses | the engine control statuses
Public property | ExtendedLowLevelStates | the extended low level states of this job
Public property | Health | the health of this job
Public property | HighLevelState | the high level state of this job
Public property | IsInError | a value indicating whether this job is in an error state
Public property | LowLevelState | the low level state of this job
Public property | PermillageComplete | the permillage complete of the current activity of this job
Public property | TargetState | the state of the data on the target server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobStatusModel Constructor

JobStatusModel Constructor
Initializes a new instance of the JobStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatusModel()
Public Sub New
public:
JobStatusModel()
new : unit -> JobStatusModel
See Also

Reference

JobStatusModel Class


JobStatusModel Properties

JobStatusModel Properties

The JobStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Actions | a list of actions recently associated with this job
Public property | CanCreateImageRecovery | a value indicating whether an image protection job is in a viable state to create an image recovery job off of
Public property | CanDelete | a value indicating whether this job can currently be deleted
Public property | CanEdit | a value indicating whether this job can currently be edited
Public property | CanFailback | a value indicating whether this job can currently be failed back
Public property | CanFailover | a value indicating whether this job can currently be failed over
Public property | CanPause | a value indicating whether this job can currently be paused
Public property | CanRestore | a value indicating whether this job can currently be restored
Public property | CanReverse | a value indicating whether this job can currently be reversed
Public property | CanStart | a value indicating whether this job can currently be started
Public property | CanStop | a value indicating whether this job can currently be stopped
Public property | CanUndoFailover | a value indicating whether the failover of this job can be currently undone
Public property | EngineControlStatuses | the engine control statuses
Public property | ExtendedLowLevelStates | the extended low level states of this job
Public property | Health | the health of this job
Public property | HighLevelState | the high level state of this job
Public property | IsInError | a value indicating whether this job is in an error state
Public property | LowLevelState | the low level state of this job
Public property | PermillageComplete | the permillage complete of the current activity of this job
Public property | TargetState | the state of the data on the target server
Top
See Also

Reference

JobStatusModel Class


JobStatusModel.Actions Property

JobStatusModelActions Property
a list of actions recently associated with this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobActionModel[] Actions { get; set; }
Public Property Actions As JobActionModel()
    Get
    Set
public:
property array<JobActionModel^>^ Actions {
    array<JobActionModel^>^ get ();
    void set (array<JobActionModel^>^ value);
}
member Actions : JobActionModel[] with get, set

Property Value

Type: JobActionModel
See Also

Reference

JobStatusModel Class


JobStatusModel.CanCreateImageRecovery Property

JobStatusModelCanCreateImageRecovery Property
a value indicating whether an image protection job is in a viable state to create an image recovery job off of

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCreateImageRecovery { get; set; }
Public Property CanCreateImageRecovery As Boolean
    Get
    Set
public:
property bool CanCreateImageRecovery {
    bool get ();
    void set (bool value);
}
member CanCreateImageRecovery : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanDelete Property

JobStatusModelCanDelete Property
a value indicating whether this job can currently be deleted

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDelete { get; set; }
Public Property CanDelete As Boolean
    Get
    Set
public:
property bool CanDelete {
    bool get ();
    void set (bool value);
}
member CanDelete : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanEdit Property

JobStatusModelCanEdit Property
a value indicating whether this job can currently be edited

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanEdit { get; set; }
Public Property CanEdit As Boolean
    Get
    Set
public:
property bool CanEdit {
    bool get ();
    void set (bool value);
}
member CanEdit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanFailback Property

JobStatusModelCanFailback Property
a value indicating whether this job can currently be failed back

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFailback { get; set; }
Public Property CanFailback As Boolean
    Get
    Set
public:
property bool CanFailback {
    bool get ();
    void set (bool value);
}
member CanFailback : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanFailover Property

JobStatusModelCanFailover Property
a value indicating whether this job can currently be failed over

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFailover { get; set; }
Public Property CanFailover As Boolean
    Get
    Set
public:
property bool CanFailover {
    bool get ();
    void set (bool value);
}
member CanFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanPause Property

JobStatusModelCanPause Property
a value indicating whether this job can currently be paused

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPause { get; set; }
Public Property CanPause As Boolean
    Get
    Set
public:
property bool CanPause {
    bool get ();
    void set (bool value);
}
member CanPause : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanRestore Property

JobStatusModelCanRestore Property
a value indicating whether this job can currently be restored

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRestore { get; set; }
Public Property CanRestore As Boolean
    Get
    Set
public:
property bool CanRestore {
    bool get ();
    void set (bool value);
}
member CanRestore : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanReverse Property

JobStatusModelCanReverse Property
a value indicating whether this job can currently be reversed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanReverse { get; set; }
Public Property CanReverse As Boolean
    Get
    Set
public:
property bool CanReverse {
    bool get ();
    void set (bool value);
}
member CanReverse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanStart Property

JobStatusModelCanStart Property
a value indicating whether this job can currently be started

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStart { get; set; }
Public Property CanStart As Boolean
    Get
    Set
public:
property bool CanStart {
    bool get ();
    void set (bool value);
}
member CanStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanStop Property

JobStatusModelCanStop Property
a value indicating whether this job can currently be stopped

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStop { get; set; }
Public Property CanStop As Boolean
    Get
    Set
public:
property bool CanStop {
    bool get ();
    void set (bool value);
}
member CanStop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanUndoFailover Property

JobStatusModelCanUndoFailover Property
a value indicating whether the failover of this job can be currently undone

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndoFailover { get; set; }
Public Property CanUndoFailover As Boolean
    Get
    Set
public:
property bool CanUndoFailover {
    bool get ();
    void set (bool value);
}
member CanUndoFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.EngineControlStatuses Property

JobStatusModelEngineControlStatuses Property
the engine control statuses

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EngineControlStatusModel[] EngineControlStatuses { get; set; }
Public Property EngineControlStatuses As EngineControlStatusModel()
    Get
    Set
public:
property array<EngineControlStatusModel^>^ EngineControlStatuses {
    array<EngineControlStatusModel^>^ get ();
    void set (array<EngineControlStatusModel^>^ value);
}
member EngineControlStatuses : EngineControlStatusModel[] with get, set

Property Value

Type: EngineControlStatusModel
See Also

Reference

JobStatusModel Class


JobStatusModel.ExtendedLowLevelStates Property

JobStatusModelExtendedLowLevelStates Property
the extended low level states of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel[] ExtendedLowLevelStates { get; set; }
Public Property ExtendedLowLevelStates As ExtendedLowLevelStateModel()
    Get
    Set
public:
property array<ExtendedLowLevelStateModel^>^ ExtendedLowLevelStates {
    array<ExtendedLowLevelStateModel^>^ get ();
    void set (array<ExtendedLowLevelStateModel^>^ value);
}
member ExtendedLowLevelStates : ExtendedLowLevelStateModel[] with get, set

Property Value

Type: ExtendedLowLevelStateModel
See Also

Reference

JobStatusModel Class


JobStatusModel.Health Property

JobStatusModelHealth Property
the health of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HealthEnum Health { get; set; }
Public Property Health As HealthEnum
    Get
    Set
public:
property HealthEnum Health {
    HealthEnum get ();
    void set (HealthEnum value);
}
member Health : HealthEnum with get, set

Property Value

Type: HealthEnum
See Also

Reference

JobStatusModel Class


JobStatusModel.HighLevelState Property

JobStatusModelHighLevelState Property
the high level state of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public HighLevelStateEnum HighLevelState { get; set; }
Public Property HighLevelState As HighLevelStateEnum
    Get
    Set
public:
property HighLevelStateEnum HighLevelState {
    HighLevelStateEnum get ();
    void set (HighLevelStateEnum value);
}
member HighLevelState : HighLevelStateEnum with get, set

Property Value

Type: HighLevelStateEnum
See Also

Reference

JobStatusModel Class


JobStatusModel.IsInError Property

JobStatusModelIsInError Property
a value indicating whether this job is in an error state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInError { get; set; }
Public Property IsInError As Boolean
    Get
    Set
public:
property bool IsInError {
    bool get ();
    void set (bool value);
}
member IsInError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.LowLevelState Property

JobStatusModelLowLevelState Property
the low level state of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LowLevelState { get; set; }
Public Property LowLevelState As String
    Get
    Set
public:
property String^ LowLevelState {
    String^ get ();
    void set (String^ value);
}
member LowLevelState : string with get, set

Property Value

Type: String
See Also

Reference

JobStatusModel Class


JobStatusModel.PermillageComplete Property

JobStatusModelPermillageComplete Property
the permillage complete of the current activity of this job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int PermillageComplete { get; set; }
Public Property PermillageComplete As Integer
    Get
    Set
public:
property int PermillageComplete {
    int get ();
    void set (int value);
}
member PermillageComplete : int with get, set

Property Value

Type: Int32
See Also

Reference

JobStatusModel Class


JobStatusModel.TargetState Property

JobStatusModelTargetState Property
the state of the data on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetState { get; set; }
Public Property TargetState As String
    Get
    Set
public:
property String^ TargetState {
    String^ get ();
    void set (String^ value);
}
member TargetState : string with get, set

Property Value

Type: String
See Also

Reference

JobStatusModel Class


JobStatusModel Methods

JobStatusModel Methods

The JobStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobStatusModel Class


LicenseTypeEnum Enumeration

LicenseTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum LicenseTypeEnum
Public Enumeration LicenseTypeEnum
public enum class LicenseTypeEnum
type LicenseTypeEnum
Members
Member name | Value | Description
NotApplicable | 0 |
Limited | 1 |
Single | 2 |
Site | 3 |
NodeLockedKey | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


LogicalItemModel Class

LogicalItemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsLogicalItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class LogicalItemModel : ProtectableItemModel
Public NotInheritable Class LogicalItemModel
    Inherits ProtectableItemModel
public ref class LogicalItemModel sealed : public ProtectableItemModel
[<SealedAttribute>]
type LogicalItemModel =
    class
        inherit ProtectableItemModel
    end

The LogicalItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalItemModel | Initializes a new instance of the LogicalItemModel class
Top
Properties
 | Name | Description
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogicalItemModel Constructor

LogicalItemModel Constructor
Initializes a new instance of the LogicalItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalItemModel()
Public Sub New
public:
LogicalItemModel()
new : unit -> LogicalItemModel
See Also

Reference

LogicalItemModel Class


LogicalItemModel Properties

LogicalItemModel Properties

The LogicalItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Top
See Also

Reference

LogicalItemModel Class


LogicalItemModel Methods

LogicalItemModel Methods

The LogicalItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogicalItemModel Class


LogicalVolumeModel Class

LogicalVolumeModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsLogicalVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class LogicalVolumeModel : VolumeOptionsModel
Public Class LogicalVolumeModel
    Inherits VolumeOptionsModel
public ref class LogicalVolumeModel : public VolumeOptionsModel
type LogicalVolumeModel =
    class
        inherit VolumeOptionsModel
    end

The LogicalVolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalVolumeModel | Initializes a new instance of the LogicalVolumeModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume (Inherited from VolumeModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DesiredSize | the size that the user wants the drive to be (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | the type of the disk controller (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | the type of the disk provisioning (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | the format of the drive (Inherited from VolumeModel.)
Public property | DriveType | the type of the drive (Inherited from VolumeModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive (Inherited from VolumeModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label (Inherited from VolumeModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | LogicalVolumeName | the logical volume name
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | the path of preexisting disk (Inherited from VolumeOptionsModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume (Inherited from VolumeModel.)
Public property | VirtualDiskPath | the path on the host where the volume should be stored (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | the volume signature (Inherited from VolumeOptionsModel.)
Public property | VolumeType | the volume type (Inherited from VolumeModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogicalVolumeModel Constructor

LogicalVolumeModel Constructor
Initializes a new instance of the LogicalVolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalVolumeModel()
Public Sub New
public:
LogicalVolumeModel()
new : unit -> LogicalVolumeModel
See Also

Reference

LogicalVolumeModel Class


LogicalVolumeModel Properties

LogicalVolumeModel Properties

The LogicalVolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume (Inherited from VolumeModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DesiredSize | the size that the user wants the drive to be (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | the type of the disk controller (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | the type of the disk provisioning (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | the format of the drive (Inherited from VolumeModel.)
Public property | DriveType | the type of the drive (Inherited from VolumeModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive (Inherited from VolumeModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label (Inherited from VolumeModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | LogicalVolumeName | the logical volume name
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | the path of preexisting disk (Inherited from VolumeOptionsModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume (Inherited from VolumeModel.)
Public property | VirtualDiskPath | the path on the host where the volume should be stored (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | the volume signature (Inherited from VolumeOptionsModel.)
Public property | VolumeType | the volume type (Inherited from VolumeModel.)
Top
See Also

Reference

LogicalVolumeModel Class


LogicalVolumeModel.LogicalVolumeName Property

LogicalVolumeModelLogicalVolumeName Property
the logical volume name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string LogicalVolumeName { get; set; }
Public Property LogicalVolumeName As String
    Get
    Set
public:
property String^ LogicalVolumeName {
    String^ get ();
    void set (String^ value);
}
member LogicalVolumeName : string with get, set

Property Value

Type: String
See Also

Reference

LogicalVolumeModel Class


LogicalVolumeModel Methods

LogicalVolumeModel Methods

The LogicalVolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogicalVolumeModel Class


LogMessageModel Class

LogMessageModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLogMessageModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class LogMessageModel
Public NotInheritable Class LogMessageModel
public ref class LogMessageModel sealed
[<SealedAttribute>]
type LogMessageModel =  class end

The LogMessageModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogMessageModel | Initializes a new instance of the LogMessageModel class
Top
Properties
 | Name | Description
Public property | Hash | the message hash used to differentiate messages written with the same Timestamp
Public property | Id | the message id
Public property | MessageType | the message type
Public property | ProcessId | the process id of the process that generated this message
Public property | Sequence | the message's sequence number within the log file
Public property | Source | the log file source
Public property | Text | the descriptive portion of the message
Public property | ThreadId | the thread id of the thread that generated this message
Public property | Timestamp | the local time when this message was generated
Public property | TimestampOffset | the time when this message was generated, relative to UTC
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogMessageModel Constructor

LogMessageModel Constructor
Initializes a new instance of the LogMessageModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogMessageModel()
Public Sub New
public:
LogMessageModel()
new : unit -> LogMessageModel
See Also

Reference

LogMessageModel Class


LogMessageModel Properties

LogMessageModel Properties

The LogMessageModel type exposes the following members.

Properties
 | Name | Description
Public property | Hash | the message hash used to differentiate messages written with the same Timestamp
Public property | Id | the message id
Public property | MessageType | the message type
Public property | ProcessId | the process id of the process that generated this message
Public property | Sequence | the message's sequence number within the log file
Public property | Source | the log file source
Public property | Text | the descriptive portion of the message
Public property | ThreadId | the thread id of the thread that generated this message
Public property | Timestamp | the local time when this message was generated
Public property | TimestampOffset | the time when this message was generated, relative to UTC
Top
See Also

Reference

LogMessageModel Class


LogMessageModel.Hash Property

LogMessageModelHash Property
the message hash used to differentiate messages written with the same Timestamp

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Hash { get; set; }
Public Property Hash As Integer
    Get
    Set
public:
property int Hash {
    int get ();
    void set (int value);
}
member Hash : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Id Property

LogMessageModelId Property
the message id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.MessageType Property

LogMessageModelMessageType Property
the message type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MessageType { get; set; }
Public Property MessageType As Integer
    Get
    Set
public:
property int MessageType {
    int get ();
    void set (int value);
}
member MessageType : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.ProcessId Property

LogMessageModelProcessId Property
the process id of the process that generated this message

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProcessId { get; set; }
Public Property ProcessId As Integer
    Get
    Set
public:
property int ProcessId {
    int get ();
    void set (int value);
}
member ProcessId : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Sequence Property

LogMessageModelSequence Property
the message's sequence number within the log file

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Sequence { get; set; }
Public Property Sequence As Integer
    Get
    Set
public:
property int Sequence {
    int get ();
    void set (int value);
}
member Sequence : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Source Property

LogMessageModelSource Property
the log file source

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
member Source : string with get, set

Property Value

Type: String
See Also

Reference

LogMessageModel Class


LogMessageModel.Text Property

LogMessageModelText Property
the descriptive portion of the message

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

LogMessageModel Class


LogMessageModel.ThreadId Property

LogMessageModelThreadId Property
the thread id of the thread that generated this message

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ThreadId { get; set; }
Public Property ThreadId As Integer
    Get
    Set
public:
property int ThreadId {
    int get ();
    void set (int value);
}
member ThreadId : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Timestamp Property

LogMessageModelTimestamp Property
the local time when this message was generated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
member Timestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

LogMessageModel Class


LogMessageModel.TimestampOffset Property

LogMessageModelTimestampOffset Property
the time when this message was generated, relative to UTC

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimestampOffset { get; set; }
Public Property TimestampOffset As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimestampOffset {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimestampOffset : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

LogMessageModel Class


LogMessageModel Methods

LogMessageModel Methods

The LogMessageModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogMessageModel Class


LvmOptionsModel Class

LvmOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLvmOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class LvmOptionsModel
Public NotInheritable Class LvmOptionsModel
public ref class LvmOptionsModel sealed
[<SealedAttribute>]
type LvmOptionsModel =  class end

The LvmOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | LvmOptionsModel | Initializes a new instance of the LvmOptionsModel class
Top
Properties
 | Name | Description
Public property | VolumeGroups | the volume groups
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LvmOptionsModel Constructor

LvmOptionsModel Constructor
Initializes a new instance of the LvmOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LvmOptionsModel()
Public Sub New
public:
LvmOptionsModel()
new : unit -> LvmOptionsModel
See Also

Reference

LvmOptionsModel Class


LvmOptionsModel Properties

LvmOptionsModel Properties

The LvmOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | VolumeGroups | the volume groups
Top
See Also

Reference

LvmOptionsModel Class


LvmOptionsModel.VolumeGroups Property

LvmOptionsModelVolumeGroups Property
the volume groups

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeGroupModel[] VolumeGroups { get; set; }
Public Property VolumeGroups As VolumeGroupModel()
    Get
    Set
public:
property array<VolumeGroupModel^>^ VolumeGroups {
    array<VolumeGroupModel^>^ get ();
    void set (array<VolumeGroupModel^>^ value);
}
member VolumeGroups : VolumeGroupModel[] with get, set

Property Value

Type: VolumeGroupModel
See Also

Reference

LvmOptionsModel Class


LvmOptionsModel Methods

LvmOptionsModel Methods

The LvmOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LvmOptionsModel Class


MirrorComparisonCriteriaEnum Enumeration

MirrorComparisonCriteriaEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MirrorComparisonCriteriaEnum
Public Enumeration MirrorComparisonCriteriaEnum
public enum class MirrorComparisonCriteriaEnum
type MirrorComparisonCriteriaEnum
Members
Member name | Value | Description
None | 0 |
Newer | 1 |
Checksum | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


MirrorOperationOptionsEnum Enumeration

MirrorOperationOptionsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MirrorOperationOptionsEnum
Public Enumeration MirrorOperationOptionsEnum
public enum class MirrorOperationOptionsEnum
type MirrorOperationOptionsEnum
Members
Member name | Value | Description
None | 0 |
Synchronize | 1 |
Report | 2 |
CalculateDifferences | 4 |
CalculateSize | 8 |
ProcessOrphans | 16 |
See Also

Reference

DoubleTake.Web.Models Namespace


MirrorParametersModel Class

MirrorParametersModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMirrorParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MirrorParametersModel
Public NotInheritable Class MirrorParametersModel
public ref class MirrorParametersModel sealed
[<SealedAttribute>]
type MirrorParametersModel =  class end

The MirrorParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | MirrorParametersModel | Initializes a new instance of the MirrorParametersModel class
Top
Properties
 | Name | Description
Public property | ComparisonCriteria | specifies how to compare the workload items on the source with the replica on the target
Public property | Options | mirror operation options
Public property | OverrideJobOrphansProcessing | a value indicating whether or not to override the job's orphan processing setting
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MirrorParametersModel Constructor

MirrorParametersModel Constructor
Initializes a new instance of the MirrorParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorParametersModel()
Public Sub New
public:
MirrorParametersModel()
new : unit -> MirrorParametersModel
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel Properties

MirrorParametersModel Properties

The MirrorParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonCriteria | specifies how to compare the workload items on the source with the replica on the target
Public property | Options | mirror operation options
Public property | OverrideJobOrphansProcessing | a value indicating whether or not to override the job's orphan processing setting
Top
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel.ComparisonCriteria Property

MirrorParametersModelComparisonCriteria Property
specifies how to compare the workload items on the source with the replica on the target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorComparisonCriteriaEnum ComparisonCriteria { get; set; }
Public Property ComparisonCriteria As MirrorComparisonCriteriaEnum
    Get
    Set
public:
property MirrorComparisonCriteriaEnum ComparisonCriteria {
    MirrorComparisonCriteriaEnum get ();
    void set (MirrorComparisonCriteriaEnum value);
}
member ComparisonCriteria : MirrorComparisonCriteriaEnum with get, set

Property Value

Type: MirrorComparisonCriteriaEnum
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel.Options Property

MirrorParametersModelOptions Property
mirror operation options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorOperationOptionsEnum Options { get; set; }
Public Property Options As MirrorOperationOptionsEnum
    Get
    Set
public:
property MirrorOperationOptionsEnum Options {
    MirrorOperationOptionsEnum get ();
    void set (MirrorOperationOptionsEnum value);
}
member Options : MirrorOperationOptionsEnum with get, set

Property Value

Type: MirrorOperationOptionsEnum
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel.OverrideJobOrphansProcessing Property

MirrorParametersModelOverrideJobOrphansProcessing Property
a value indicating whether or not to override the job's orphan processing setting

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool OverrideJobOrphansProcessing { get; set; }
Public Property OverrideJobOrphansProcessing As Boolean
    Get
    Set
public:
property bool OverrideJobOrphansProcessing {
    bool get ();
    void set (bool value);
}
member OverrideJobOrphansProcessing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel Methods

MirrorParametersModel Methods

The MirrorParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MirrorParametersModel Class


MirrorStateEnum Enumeration

MirrorStateEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum MirrorStateEnum
Public Enumeration MirrorStateEnum
public enum class MirrorStateEnum
type MirrorStateEnum
Members
Member name | Value | Description
Calculating | 0 |
Idle | 1 |
Mirror | 2 |
Pause | 3 |
RemoveOrphans | 4 |
RepsetVerify | 5 |
Restore | 6 |
Stopped | 7 |
Waiting | 8 |
Unknown | 9 |
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorConfigurationModel Class

MonitorConfigurationModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitorConfigurationModel
Public NotInheritable Class MonitorConfigurationModel
public ref class MonitorConfigurationModel sealed
[<SealedAttribute>]
type MonitorConfigurationModel =  class end

The MonitorConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorConfigurationModel | Initializes a new instance of the MonitorConfigurationModel class
Top
Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | the active directory credentials
Public property | ActiveDirectoryOptions | the active directory options
Public property | Addresses | the array of monitor address configurations specifying the IP addresses to be monitored
Public property | DataAction | the failover data action
Public property | FailoverAddressesOption | the failover IP addresses option
Public property | FailoverType | the failover type
Public property | ItemsToFailover | the failover items
Public property | MaxScriptFailures | the number of times the monitoring script can fail before giving up the script monitoring
Public property | Name | the name of the failover monitor
Public property | ProcessingOptions | the processing options
Public property | ReplaceActions | the replace actions
Public property | ScriptMonitorEngine | the script monitor engine
Public property | ScriptMonitorName | the name of the script monitor
Public property | Scripts | the failover script configuration
Public property | SourceEndpoint | the source IP endpoint to be used to communicate with Double-Take on the source
Public property | SSMLogPath | the SSM log path
Public property | SSMManualReboot | a value indicating whether or not SSM manual reboot
Public property | SSMRecoveryType | the type of the SSM recovery
Public property | SSMSourceNicGuids | the SSM source NIC GUIDs
Public property | SSMStagingPath | the SSM staging path
Public property | SSMTargetNicGuids | the SSM target NIC GUIDs
Public property | Trigger | the failover trigger
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorConfigurationModel Constructor

MonitorConfigurationModel Constructor
Initializes a new instance of the MonitorConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel()
Public Sub New
public:
MonitorConfigurationModel()
new : unit -> MonitorConfigurationModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel Properties

MonitorConfigurationModel Properties

The MonitorConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | the active directory credentials
Public property | ActiveDirectoryOptions | the active directory options
Public property | Addresses | the array of monitor address configurations specifying the IP addresses to be monitored
Public property | DataAction | the failover data action
Public property | FailoverAddressesOption | the failover IP addresses option
Public property | FailoverType | the failover type
Public property | ItemsToFailover | the failover items
Public property | MaxScriptFailures | the number of times the monitoring script can fail before giving up the script monitoring
Public property | Name | the name of the failover monitor
Public property | ProcessingOptions | the processing options
Public property | ReplaceActions | the replace actions
Public property | ScriptMonitorEngine | the script monitor engine
Public property | ScriptMonitorName | the name of the script monitor
Public property | Scripts | the failover script configuration
Public property | SourceEndpoint | the source IP endpoint to be used to communicate with Double-Take on the source
Public property | SSMLogPath | the SSM log path
Public property | SSMManualReboot | a value indicating whether or not SSM manual reboot
Public property | SSMRecoveryType | the type of the SSM recovery
Public property | SSMSourceNicGuids | the SSM source NIC GUIDs
Public property | SSMStagingPath | the SSM staging path
Public property | SSMTargetNicGuids | the SSM target NIC GUIDs
Public property | Trigger | the failover trigger
Top
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ActiveDirectoryCredentials Property

MonitorConfigurationModelActiveDirectoryCredentials Property
the active directory credentials

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel ActiveDirectoryCredentials { get; set; }
Public Property ActiveDirectoryCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ ActiveDirectoryCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member ActiveDirectoryCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ActiveDirectoryOptions Property

MonitorConfigurationModelActiveDirectoryOptions Property
the active directory options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActiveDirectoryFailoverOptionsEnum ActiveDirectoryOptions { get; set; }
Public Property ActiveDirectoryOptions As ActiveDirectoryFailoverOptionsEnum
    Get
    Set
public:
property ActiveDirectoryFailoverOptionsEnum ActiveDirectoryOptions {
    ActiveDirectoryFailoverOptionsEnum get ();
    void set (ActiveDirectoryFailoverOptionsEnum value);
}
member ActiveDirectoryOptions : ActiveDirectoryFailoverOptionsEnum with get, set

Property Value

Type: ActiveDirectoryFailoverOptionsEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Addresses Property

MonitorConfigurationModelAddresses Property
the array of monitor address configurations specifying the IP addresses to be monitored

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressConfigurationModel[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressConfigurationModel()
    Get
    Set
public:
property array<MonitoredAddressConfigurationModel^>^ Addresses {
    array<MonitoredAddressConfigurationModel^>^ get ();
    void set (array<MonitoredAddressConfigurationModel^>^ value);
}
member Addresses : MonitoredAddressConfigurationModel[] with get, set

Property Value

Type: MonitoredAddressConfigurationModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.DataAction Property

MonitorConfigurationModelDataAction Property
the failover data action

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverDataActionEnum DataAction { get; set; }
Public Property DataAction As FailoverDataActionEnum
    Get
    Set
public:
property FailoverDataActionEnum DataAction {
    FailoverDataActionEnum get ();
    void set (FailoverDataActionEnum value);
}
member DataAction : FailoverDataActionEnum with get, set

Property Value

Type: FailoverDataActionEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.FailoverAddressesOption Property

MonitorConfigurationModelFailoverAddressesOption Property
the failover IP addresses option

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverAddressesOptionEnum FailoverAddressesOption { get; set; }
Public Property FailoverAddressesOption As FailoverAddressesOptionEnum
    Get
    Set
public:
property FailoverAddressesOptionEnum FailoverAddressesOption {
    FailoverAddressesOptionEnum get ();
    void set (FailoverAddressesOptionEnum value);
}
member FailoverAddressesOption : FailoverAddressesOptionEnum with get, set

Property Value

Type: FailoverAddressesOptionEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.FailoverType Property

MonitorConfigurationModelFailoverType Property
the failover type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverTypeEnum FailoverType { get; set; }
Public Property FailoverType As FailoverTypeEnum
    Get
    Set
public:
property FailoverTypeEnum FailoverType {
    FailoverTypeEnum get ();
    void set (FailoverTypeEnum value);
}
member FailoverType : FailoverTypeEnum with get, set

Property Value

Type: FailoverTypeEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ItemsToFailover Property

MonitorConfigurationModelItemsToFailover Property
the failover items

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverItemsEnum ItemsToFailover { get; set; }
Public Property ItemsToFailover As FailoverItemsEnum
    Get
    Set
public:
property FailoverItemsEnum ItemsToFailover {
    FailoverItemsEnum get ();
    void set (FailoverItemsEnum value);
}
member ItemsToFailover : FailoverItemsEnum with get, set

Property Value

Type: FailoverItemsEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.MaxScriptFailures Property

MonitorConfigurationModelMaxScriptFailures Property
the number of times the monitoring script can fail before giving up the script monitoring

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaxScriptFailures { get; set; }
Public Property MaxScriptFailures As Integer
    Get
    Set
public:
property int MaxScriptFailures {
    int get ();
    void set (int value);
}
member MaxScriptFailures : int with get, set

Property Value

Type: Int32
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Name Property

MonitorConfigurationModelName Property
the name of the failover monitor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ProcessingOptions Property

MonitorConfigurationModelProcessingOptions Property
the processing options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverProcessingOptionsEnum ProcessingOptions { get; set; }
Public Property ProcessingOptions As FailoverProcessingOptionsEnum
    Get
    Set
public:
property FailoverProcessingOptionsEnum ProcessingOptions {
    FailoverProcessingOptionsEnum get ();
    void set (FailoverProcessingOptionsEnum value);
}
member ProcessingOptions : FailoverProcessingOptionsEnum with get, set

Property Value

Type: FailoverProcessingOptionsEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ReplaceActions Property

MonitorConfigurationModelReplaceActions Property
the replace actions

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverReplaceActionsEnum ReplaceActions { get; set; }
Public Property ReplaceActions As FailoverReplaceActionsEnum
    Get
    Set
public:
property FailoverReplaceActionsEnum ReplaceActions {
    FailoverReplaceActionsEnum get ();
    void set (FailoverReplaceActionsEnum value);
}
member ReplaceActions : FailoverReplaceActionsEnum with get, set

Property Value

Type: FailoverReplaceActionsEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ScriptMonitorEngine Property

MonitorConfigurationModelScriptMonitorEngine Property
the script monitor engine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptMonitorEngine { get; set; }
Public Property ScriptMonitorEngine As String
    Get
    Set
public:
property String^ ScriptMonitorEngine {
    String^ get ();
    void set (String^ value);
}
member ScriptMonitorEngine : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ScriptMonitorName Property

MonitorConfigurationModelScriptMonitorName Property
the name of the script monitor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptMonitorName { get; set; }
Public Property ScriptMonitorName As String
    Get
    Set
public:
property String^ ScriptMonitorName {
    String^ get ();
    void set (String^ value);
}
member ScriptMonitorName : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Scripts Property

MonitorConfigurationModelScripts Property
the failover script configuration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverScriptConfigurationModel Scripts { get; set; }
Public Property Scripts As FailoverScriptConfigurationModel
    Get
    Set
public:
property FailoverScriptConfigurationModel^ Scripts {
    FailoverScriptConfigurationModel^ get ();
    void set (FailoverScriptConfigurationModel^ value);
}
member Scripts : FailoverScriptConfigurationModel with get, set

Property Value

Type: FailoverScriptConfigurationModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SourceEndpoint Property

MonitorConfigurationModelSourceEndpoint Property
the source IP endpoint to be used to communicate with Double-Take on the source

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMLogPath Property

MonitorConfigurationModelSSMLogPath Property
the SSM log path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMLogPath { get; set; }
Public Property SSMLogPath As String
    Get
    Set
public:
property String^ SSMLogPath {
    String^ get ();
    void set (String^ value);
}
member SSMLogPath : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMManualReboot Property

MonitorConfigurationModelSSMManualReboot Property
a value indicating whether or not SSM manual reboot

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SSMManualReboot { get; set; }
Public Property SSMManualReboot As Boolean
    Get
    Set
public:
property bool SSMManualReboot {
    bool get ();
    void set (bool value);
}
member SSMManualReboot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMRecoveryType Property

MonitorConfigurationModelSSMRecoveryType Property
the type of the SSM recovery

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SsmRecoveryTypeEnum SSMRecoveryType { get; set; }
Public Property SSMRecoveryType As SsmRecoveryTypeEnum
    Get
    Set
public:
property SsmRecoveryTypeEnum SSMRecoveryType {
    SsmRecoveryTypeEnum get ();
    void set (SsmRecoveryTypeEnum value);
}
member SSMRecoveryType : SsmRecoveryTypeEnum with get, set

Property Value

Type: SsmRecoveryTypeEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMSourceNicGuids Property

MonitorConfigurationModelSSMSourceNicGuids Property
the SSM source NIC GUIDs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMSourceNicGuids { get; set; }
Public Property SSMSourceNicGuids As String
    Get
    Set
public:
property String^ SSMSourceNicGuids {
    String^ get ();
    void set (String^ value);
}
member SSMSourceNicGuids : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMStagingPath Property

MonitorConfigurationModelSSMStagingPath Property
the SSM staging path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMStagingPath { get; set; }
Public Property SSMStagingPath As String
    Get
    Set
public:
property String^ SSMStagingPath {
    String^ get ();
    void set (String^ value);
}
member SSMStagingPath : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMTargetNicGuids Property

MonitorConfigurationModelSSMTargetNicGuids Property
the SSM target NIC GUIDs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMTargetNicGuids { get; set; }
Public Property SSMTargetNicGuids As String
    Get
    Set
public:
property String^ SSMTargetNicGuids {
    String^ get ();
    void set (String^ value);
}
member SSMTargetNicGuids : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Trigger Property

MonitorConfigurationModelTrigger Property
the failover trigger

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverTriggerEnum Trigger { get; set; }
Public Property Trigger As FailoverTriggerEnum
    Get
    Set
public:
property FailoverTriggerEnum Trigger {
    FailoverTriggerEnum get ();
    void set (FailoverTriggerEnum value);
}
member Trigger : FailoverTriggerEnum with get, set

Property Value

Type: FailoverTriggerEnum
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel Methods

MonitorConfigurationModel Methods

The MonitorConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorConfigurationModel Class


MonitoredAddressConfigurationModel Class

MonitoredAddressConfigurationModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitoredAddressConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitoredAddressConfigurationModel
Public NotInheritable Class MonitoredAddressConfigurationModel
public ref class MonitoredAddressConfigurationModel sealed
[<SealedAttribute>]
type MonitoredAddressConfigurationModel =  class end

The MonitoredAddressConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressConfigurationModel | Initializes a new instance of the MonitoredAddressConfigurationModel class
Top
Properties
 | Name | Description
Public property | Address | the IP address
Public property | EnginePort | the engine port
Public property | MacAddress | the MAC address of the source NIC on which this address resides
Public property | MaxPingAttempts | the maximum number of ping attempts before the IP address is considered to be failed
Public property | NicName | the name of the target NIC to use to monitor this IP address
Public property | PingInterval | the interval at which the source address is pinged to determine a failure condition
Public property | PingMethods | The ping methods to be used to ping the IP address
Public property | SubnetMask | the subnet mask
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitoredAddressConfigurationModel Constructor

MonitoredAddressConfigurationModel Constructor
Initializes a new instance of the MonitoredAddressConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressConfigurationModel()
Public Sub New
public:
MonitoredAddressConfigurationModel()
new : unit -> MonitoredAddressConfigurationModel
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel Properties

MonitoredAddressConfigurationModel Properties

The MonitoredAddressConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | the IP address
Public property | EnginePort | the engine port
Public property | MacAddress | the MAC address of the source NIC on which this address resides
Public property | MaxPingAttempts | the maximum number of ping attempts before the IP address is considered to be failed
Public property | NicName | the name of the target NIC to use to monitor this IP address
Public property | PingInterval | the interval at which the source address is pinged to determine a failure condition
Public property | PingMethods | The ping methods to be used to ping the IP address
Public property | SubnetMask | the subnet mask
Top
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.Address Property

MonitoredAddressConfigurationModelAddress Property
the IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.EnginePort Property

MonitoredAddressConfigurationModelEnginePort Property
the engine port

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.MacAddress Property

MonitoredAddressConfigurationModelMacAddress Property
the MAC address of the source NIC on which this address resides

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.MaxPingAttempts Property

MonitoredAddressConfigurationModelMaxPingAttempts Property
the maximum number of ping attempts before the IP address is considered to be failed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
member MaxPingAttempts : int16 with get, set

Property Value

Type: Int16
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.NicName Property

MonitoredAddressConfigurationModelNicName Property
the name of the target NIC to use to monitor this IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NicName { get; set; }
Public Property NicName As String
    Get
    Set
public:
property String^ NicName {
    String^ get ();
    void set (String^ value);
}
member NicName : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.PingInterval Property

MonitoredAddressConfigurationModelPingInterval Property
the interval at which the source address is pinged to determine a failure condition

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member PingInterval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.PingMethods Property

MonitoredAddressConfigurationModelPingMethods Property
The ping methods to be used to ping the IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PingMethodsEnum PingMethods { get; set; }
Public Property PingMethods As PingMethodsEnum
    Get
    Set
public:
property PingMethodsEnum PingMethods {
    PingMethodsEnum get ();
    void set (PingMethodsEnum value);
}
member PingMethods : PingMethodsEnum with get, set

Property Value

Type: PingMethodsEnum
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.SubnetMask Property

MonitoredAddressConfigurationModelSubnetMask Property
the subnet mask

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SubnetMask { get; set; }
Public Property SubnetMask As String
    Get
    Set
public:
property String^ SubnetMask {
    String^ get ();
    void set (String^ value);
}
member SubnetMask : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel Methods

MonitoredAddressConfigurationModel Methods

The MonitoredAddressConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressStatusModel Class

MonitoredAddressStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitoredAddressStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitoredAddressStatusModel
Public NotInheritable Class MonitoredAddressStatusModel
public ref class MonitoredAddressStatusModel sealed
[<SealedAttribute>]
type MonitoredAddressStatusModel =  class end

The MonitoredAddressStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressStatusModel | Initializes a new instance of the MonitoredAddressStatusModel class
Top
Properties
 | Name | Description
Public property | Address | the IP address that is being monitored
Public property | Alive | a value indicating whether the IP address is responding to ping attempts
Public property | FailoverConditionMet | a value indicating whether the IP addresses is considered failed
Public property | RemainingTime | the time remaining before the IP address is considered failed
Public property | WarningConditionMet | a value indicating whether the IP address is considered in a warning condition
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitoredAddressStatusModel Constructor

MonitoredAddressStatusModel Constructor
Initializes a new instance of the MonitoredAddressStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressStatusModel()
Public Sub New
public:
MonitoredAddressStatusModel()
new : unit -> MonitoredAddressStatusModel
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel Properties

MonitoredAddressStatusModel Properties

The MonitoredAddressStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | the IP address that is being monitored
Public property | Alive | a value indicating whether the IP address is responding to ping attempts
Public property | FailoverConditionMet | a value indicating whether the IP addresses is considered failed
Public property | RemainingTime | the time remaining before the IP address is considered failed
Public property | WarningConditionMet | a value indicating whether the IP address is considered in a warning condition
Top
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.Address Property

MonitoredAddressStatusModelAddress Property
the IP address that is being monitored

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.Alive Property

MonitoredAddressStatusModelAlive Property
a value indicating whether the IP address is responding to ping attempts

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
member Alive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.FailoverConditionMet Property

MonitoredAddressStatusModelFailoverConditionMet Property
a value indicating whether the IP addresses is considered failed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool FailoverConditionMet { get; set; }
Public Property FailoverConditionMet As Boolean
    Get
    Set
public:
property bool FailoverConditionMet {
    bool get ();
    void set (bool value);
}
member FailoverConditionMet : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.RemainingTime Property

MonitoredAddressStatusModelRemainingTime Property
the time remaining before the IP address is considered failed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan RemainingTime { get; set; }
Public Property RemainingTime As TimeSpan
    Get
    Set
public:
property TimeSpan RemainingTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
member RemainingTime : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.WarningConditionMet Property

MonitoredAddressStatusModelWarningConditionMet Property
a value indicating whether the IP address is considered in a warning condition

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WarningConditionMet { get; set; }
Public Property WarningConditionMet As Boolean
    Get
    Set
public:
property bool WarningConditionMet {
    bool get ();
    void set (bool value);
}
member WarningConditionMet : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel Methods

MonitoredAddressStatusModel Methods

The MonitoredAddressStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitoredAddressStatusModel Class


MonitoringOptionsModel Class

MonitoringOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitoringOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitoringOptionsModel
Public NotInheritable Class MonitoringOptionsModel
public ref class MonitoringOptionsModel sealed
[<SealedAttribute>]
type MonitoringOptionsModel =  class end

The MonitoringOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoringOptionsModel | Initializes a new instance of the MonitoringOptionsModel class
Top
Properties
 | Name | Description
Public property | ServiceMonitoringEnabled | a value indicating whether service monitoring is enabled
Public property | ServiceMonitoringOptions | the service monitoring options
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitoringOptionsModel Constructor

MonitoringOptionsModel Constructor
Initializes a new instance of the MonitoringOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoringOptionsModel()
Public Sub New
public:
MonitoringOptionsModel()
new : unit -> MonitoringOptionsModel
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel Properties

MonitoringOptionsModel Properties

The MonitoringOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ServiceMonitoringEnabled | a value indicating whether service monitoring is enabled
Public property | ServiceMonitoringOptions | the service monitoring options
Top
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel.ServiceMonitoringEnabled Property

MonitoringOptionsModelServiceMonitoringEnabled Property
a value indicating whether service monitoring is enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ServiceMonitoringEnabled { get; set; }
Public Property ServiceMonitoringEnabled As Boolean
    Get
    Set
public:
property bool ServiceMonitoringEnabled {
    bool get ();
    void set (bool value);
}
member ServiceMonitoringEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel.ServiceMonitoringOptions Property

MonitoringOptionsModelServiceMonitoringOptions Property
the service monitoring options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceMonitoringOptionsModel ServiceMonitoringOptions { get; set; }
Public Property ServiceMonitoringOptions As ServiceMonitoringOptionsModel
    Get
    Set
public:
property ServiceMonitoringOptionsModel^ ServiceMonitoringOptions {
    ServiceMonitoringOptionsModel^ get ();
    void set (ServiceMonitoringOptionsModel^ value);
}
member ServiceMonitoringOptions : ServiceMonitoringOptionsModel with get, set

Property Value

Type: ServiceMonitoringOptionsModel
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel Methods

MonitoringOptionsModel Methods

The MonitoringOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitoringOptionsModel Class


NetworkAddressMapModel Class

NetworkAddressMapModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkAddressMapModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class NetworkAddressMapModel
Public NotInheritable Class NetworkAddressMapModel
public ref class NetworkAddressMapModel sealed
[<SealedAttribute>]
type NetworkAddressMapModel =  class end

The NetworkAddressMapModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkAddressMapModel | Initializes a new instance of the NetworkAddressMapModel class
Top
Properties
 | Name | Description
Public property | ShouldUpdateTtl | a value indicating whether the time-to-live value should be updated for this record
Public property | SourceIP | the IP address on the source server
Public property | TargetIP | the IP address on the target server
Public property | TtlValue | the TTL value, in seconds
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NetworkAddressMapModel Constructor

NetworkAddressMapModel Constructor
Initializes a new instance of the NetworkAddressMapModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkAddressMapModel()
Public Sub New
public:
NetworkAddressMapModel()
new : unit -> NetworkAddressMapModel
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel Properties

NetworkAddressMapModel Properties

The NetworkAddressMapModel type exposes the following members.

Properties
 | Name | Description
Public property | ShouldUpdateTtl | a value indicating whether the time-to-live value should be updated for this record
Public property | SourceIP | the IP address on the source server
Public property | TargetIP | the IP address on the target server
Public property | TtlValue | the TTL value, in seconds
Top
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.ShouldUpdateTtl Property

NetworkAddressMapModelShouldUpdateTtl Property
a value indicating whether the time-to-live value should be updated for this record

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
member ShouldUpdateTtl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.SourceIP Property

NetworkAddressMapModelSourceIP Property
the IP address on the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceIP { get; set; }
Public Property SourceIP As String
    Get
    Set
public:
property String^ SourceIP {
    String^ get ();
    void set (String^ value);
}
member SourceIP : string with get, set

Property Value

Type: String
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.TargetIP Property

NetworkAddressMapModelTargetIP Property
the IP address on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetIP { get; set; }
Public Property TargetIP As String
    Get
    Set
public:
property String^ TargetIP {
    String^ get ();
    void set (String^ value);
}
member TargetIP : string with get, set

Property Value

Type: String
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.TtlValue Property

NetworkAddressMapModelTtlValue Property
the TTL value, in seconds

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
member TtlValue : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel Methods

NetworkAddressMapModel Methods

The NetworkAddressMapModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkAddressMapModel Class


NetworkInterfaceInfoModel Class

NetworkInterfaceInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class NetworkInterfaceInfoModel
Public NotInheritable Class NetworkInterfaceInfoModel
public ref class NetworkInterfaceInfoModel sealed
[<SealedAttribute>]
type NetworkInterfaceInfoModel =  class end

The NetworkInterfaceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceInfoModel | Initializes a new instance of the NetworkInterfaceInfoModel class
Top
Properties
 | Name | Description
Public property | Addresses | a value that represents the IP addresses on the network interface
Public property | Description | the description of the network interface
Public property | DnsDomain | the DNS Domain
Public property | DnsServers | the DNS servers
Public property | Gateways | the gateways
Public property | Guid | a value that represents the unique identifier of the network interface
Public property | Index | the index of the network interface
Public property | InterfaceIndex | the index of the network interface
Public property | MacAddress | the MAC address
Public property | Name | a value that represents the friendly name of the network interface
Public property | PnpInstanceId | the PNP instance id
Public property | ServiceName | the service name of the network interface
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NetworkInterfaceInfoModel Constructor

NetworkInterfaceInfoModel Constructor
Initializes a new instance of the NetworkInterfaceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel()
Public Sub New
public:
NetworkInterfaceInfoModel()
new : unit -> NetworkInterfaceInfoModel
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel Properties

NetworkInterfaceInfoModel Properties

The NetworkInterfaceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | a value that represents the IP addresses on the network interface
Public property | Description | the description of the network interface
Public property | DnsDomain | the DNS Domain
Public property | DnsServers | the DNS servers
Public property | Gateways | the gateways
Public property | Guid | a value that represents the unique identifier of the network interface
Public property | Index | the index of the network interface
Public property | InterfaceIndex | the index of the network interface
Public property | MacAddress | the MAC address
Public property | Name | a value that represents the friendly name of the network interface
Public property | PnpInstanceId | the PNP instance id
Public property | ServiceName | the service name of the network interface
Top
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Addresses Property

NetworkInterfaceInfoModelAddresses Property
a value that represents the IP addresses on the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] Addresses { get; set; }
Public Property Addresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ Addresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member Addresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Description Property

NetworkInterfaceInfoModelDescription Property
the description of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.DnsDomain Property

NetworkInterfaceInfoModelDnsDomain Property
the DNS Domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DnsDomain { get; set; }
Public Property DnsDomain As String
    Get
    Set
public:
property String^ DnsDomain {
    String^ get ();
    void set (String^ value);
}
member DnsDomain : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.DnsServers Property

NetworkInterfaceInfoModelDnsServers Property
the DNS servers

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DnsServers : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Gateways Property

NetworkInterfaceInfoModelGateways Property
the gateways

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Gateways { get; set; }
Public Property Gateways As String()
    Get
    Set
public:
property array<String^>^ Gateways {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Gateways : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Guid Property

NetworkInterfaceInfoModelGuid Property
a value that represents the unique identifier of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
member Guid : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Index Property

NetworkInterfaceInfoModelIndex Property
the index of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.InterfaceIndex Property

NetworkInterfaceInfoModelInterfaceIndex Property
the index of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InterfaceIndex { get; set; }
Public Property InterfaceIndex As Integer
    Get
    Set
public:
property int InterfaceIndex {
    int get ();
    void set (int value);
}
member InterfaceIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.MacAddress Property

NetworkInterfaceInfoModelMacAddress Property
the MAC address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Name Property

NetworkInterfaceInfoModelName Property
a value that represents the friendly name of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.PnpInstanceId Property

NetworkInterfaceInfoModelPnpInstanceId Property
the PNP instance id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PnpInstanceId { get; set; }
Public Property PnpInstanceId As String
    Get
    Set
public:
property String^ PnpInstanceId {
    String^ get ();
    void set (String^ value);
}
member PnpInstanceId : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.ServiceName Property

NetworkInterfaceInfoModelServiceName Property
the service name of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel Methods

NetworkInterfaceInfoModel Methods

The NetworkInterfaceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceModel Class

NetworkInterfaceModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceModel
DoubleTake.Web.ModelsVirtualNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class NetworkInterfaceModel
Public Class NetworkInterfaceModel
public ref class NetworkInterfaceModel
type NetworkInterfaceModel =  class end

The NetworkInterfaceModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceModel | Initializes a new instance of the NetworkInterfaceModel class
Top
Properties
 | Name | Description
Public property | Description | the description of the network interface
Public property | DnsDomain | the DNS Domain
Public property | DnsServers | the DNS servers
Public property | Gateways | the gateways
Public property | Id | the unique identifier of the network interface
Public property | Index | the index of the network interface
Public property | InterfaceIndex | the index of the network interface
Public property | IPAddresses | the IP addresses on the network interface
Public property | MacAddress | the MAC address
Public property | Name | the friendly name of the network interface
Public property | PnpInstanceId | the PNP instance id
Public property | ServiceName | the service name of the network interface
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NetworkInterfaceModel Constructor

NetworkInterfaceModel Constructor
Initializes a new instance of the NetworkInterfaceModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceModel()
Public Sub New
public:
NetworkInterfaceModel()
new : unit -> NetworkInterfaceModel
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel Properties

NetworkInterfaceModel Properties

The NetworkInterfaceModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | the description of the network interface
Public property | DnsDomain | the DNS Domain
Public property | DnsServers | the DNS servers
Public property | Gateways | the gateways
Public property | Id | the unique identifier of the network interface
Public property | Index | the index of the network interface
Public property | InterfaceIndex | the index of the network interface
Public property | IPAddresses | the IP addresses on the network interface
Public property | MacAddress | the MAC address
Public property | Name | the friendly name of the network interface
Public property | PnpInstanceId | the PNP instance id
Public property | ServiceName | the service name of the network interface
Top
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Description Property

NetworkInterfaceModelDescription Property
the description of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.DnsDomain Property

NetworkInterfaceModelDnsDomain Property
the DNS Domain

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DnsDomain { get; set; }
Public Property DnsDomain As String
    Get
    Set
public:
property String^ DnsDomain {
    String^ get ();
    void set (String^ value);
}
member DnsDomain : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.DnsServers Property

NetworkInterfaceModelDnsServers Property
the DNS servers

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DnsServers : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Gateways Property

NetworkInterfaceModelGateways Property
the gateways

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Gateways { get; set; }
Public Property Gateways As String()
    Get
    Set
public:
property array<String^>^ Gateways {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Gateways : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Id Property

NetworkInterfaceModelId Property
the unique identifier of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Index Property

NetworkInterfaceModelIndex Property
the index of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.InterfaceIndex Property

NetworkInterfaceModelInterfaceIndex Property
the index of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int InterfaceIndex { get; set; }
Public Property InterfaceIndex As Integer
    Get
    Set
public:
property int InterfaceIndex {
    int get ();
    void set (int value);
}
member InterfaceIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.IPAddresses Property

NetworkInterfaceModelIPAddresses Property
the IP addresses on the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel[] IPAddresses { get; set; }
Public Property IPAddresses As UnicastIPAddressModel()
    Get
    Set
public:
property array<UnicastIPAddressModel^>^ IPAddresses {
    array<UnicastIPAddressModel^>^ get ();
    void set (array<UnicastIPAddressModel^>^ value);
}
member IPAddresses : UnicastIPAddressModel[] with get, set

Property Value

Type: UnicastIPAddressModel
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.MacAddress Property

NetworkInterfaceModelMacAddress Property
the MAC address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Name Property

NetworkInterfaceModelName Property
the friendly name of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.PnpInstanceId Property

NetworkInterfaceModelPnpInstanceId Property
the PNP instance id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PnpInstanceId { get; set; }
Public Property PnpInstanceId As String
    Get
    Set
public:
property String^ PnpInstanceId {
    String^ get ();
    void set (String^ value);
}
member PnpInstanceId : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.ServiceName Property

NetworkInterfaceModelServiceName Property
the service name of the network interface

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel Methods

NetworkInterfaceModel Methods

The NetworkInterfaceModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkInterfaceModel Class


OperatingSystemArchitectureEnum Enumeration

OperatingSystemArchitectureEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OperatingSystemArchitectureEnum
Public Enumeration OperatingSystemArchitectureEnum
public enum class OperatingSystemArchitectureEnum
type OperatingSystemArchitectureEnum
Members
Member name | Value | Description
x86 | 0 |
x64 | 9 |
ia64 | 6 |
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemModel Class

OperatingSystemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOperatingSystemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OperatingSystemModel
Public Class OperatingSystemModel
public ref class OperatingSystemModel
type OperatingSystemModel =  class end

The OperatingSystemModel type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemModel | Initializes a new instance of the OperatingSystemModel class
Top
Properties
 | Name | Description
Public property | Architecture | the architecture of the operating system
Public property | CsdVersion | the service pack number
Public property | ProductSuite | a bit mask that identifies the product suites available on the system
Public property | ProductType | the product type of the operating system
Public property | ServicePack | the service pack number of the operating system
Public property | Version | the version of the operating system
Public property | VersionString | the version of the operating system
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemModel Constructor

OperatingSystemModel Constructor
Initializes a new instance of the OperatingSystemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemModel()
Public Sub New
public:
OperatingSystemModel()
new : unit -> OperatingSystemModel
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel Properties

OperatingSystemModel Properties

The OperatingSystemModel type exposes the following members.

Properties
 | Name | Description
Public property | Architecture | the architecture of the operating system
Public property | CsdVersion | the service pack number
Public property | ProductSuite | a bit mask that identifies the product suites available on the system
Public property | ProductType | the product type of the operating system
Public property | ServicePack | the service pack number of the operating system
Public property | Version | the version of the operating system
Public property | VersionString | the version of the operating system
Top
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.Architecture Property

OperatingSystemModelArchitecture Property
the architecture of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemArchitectureEnum Architecture { get; set; }
Public Property Architecture As OperatingSystemArchitectureEnum
    Get
    Set
public:
property OperatingSystemArchitectureEnum Architecture {
    OperatingSystemArchitectureEnum get ();
    void set (OperatingSystemArchitectureEnum value);
}
member Architecture : OperatingSystemArchitectureEnum with get, set

Property Value

Type: OperatingSystemArchitectureEnum
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.CsdVersion Property

OperatingSystemModelCsdVersion Property
the service pack number

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int CsdVersion { get; set; }
Public Property CsdVersion As Integer
    Get
    Set
public:
property int CsdVersion {
    int get ();
    void set (int value);
}
member CsdVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.ProductSuite Property

OperatingSystemModelProductSuite Property
a bit mask that identifies the product suites available on the system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductSuite { get; set; }
Public Property ProductSuite As Integer
    Get
    Set
public:
property int ProductSuite {
    int get ();
    void set (int value);
}
member ProductSuite : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.ProductType Property

OperatingSystemModelProductType Property
the product type of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemProductTypeEnum ProductType { get; set; }
Public Property ProductType As OperatingSystemProductTypeEnum
    Get
    Set
public:
property OperatingSystemProductTypeEnum ProductType {
    OperatingSystemProductTypeEnum get ();
    void set (OperatingSystemProductTypeEnum value);
}
member ProductType : OperatingSystemProductTypeEnum with get, set

Property Value

Type: OperatingSystemProductTypeEnum
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.ServicePack Property

OperatingSystemModelServicePack Property
the service pack number of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServicePack { get; set; }
Public Property ServicePack As String
    Get
    Set
public:
property String^ ServicePack {
    String^ get ();
    void set (String^ value);
}
member ServicePack : string with get, set

Property Value

Type: String
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.Version Property

OperatingSystemModelVersion Property
the version of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemVersionModel Version { get; set; }
Public Property Version As OperatingSystemVersionModel
    Get
    Set
public:
property OperatingSystemVersionModel^ Version {
    OperatingSystemVersionModel^ get ();
    void set (OperatingSystemVersionModel^ value);
}
member Version : OperatingSystemVersionModel with get, set

Property Value

Type: OperatingSystemVersionModel
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.VersionString Property

OperatingSystemModelVersionString Property
the version of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionString { get; set; }
Public Property VersionString As String
    Get
    Set
public:
property String^ VersionString {
    String^ get ();
    void set (String^ value);
}
member VersionString : string with get, set

Property Value

Type: String
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel Methods

OperatingSystemModel Methods

The OperatingSystemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OperatingSystemModel Class


OperatingSystemProductTypeEnum Enumeration

OperatingSystemProductTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum OperatingSystemProductTypeEnum
Public Enumeration OperatingSystemProductTypeEnum
public enum class OperatingSystemProductTypeEnum
type OperatingSystemProductTypeEnum
Members
Member name | Value | Description
None | 0 |
Workstation | 1 |
DomainController | 2 |
Server | 3 |
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemVersionModel Class

OperatingSystemVersionModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOperatingSystemVersionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class OperatingSystemVersionModel
Public Class OperatingSystemVersionModel
public ref class OperatingSystemVersionModel
type OperatingSystemVersionModel =  class end

The OperatingSystemVersionModel type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemVersionModel | Initializes a new instance of the OperatingSystemVersionModel class
Top
Properties
 | Name | Description
Public property | Build | the build number of the operating system
Public property | Major | the major version of the operating system
Public property | Minor | the minor version of the operating system
Public property | Revision | the revision number of the operating system
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemVersionModel Constructor

OperatingSystemVersionModel Constructor
Initializes a new instance of the OperatingSystemVersionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemVersionModel()
Public Sub New
public:
OperatingSystemVersionModel()
new : unit -> OperatingSystemVersionModel
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel Properties

OperatingSystemVersionModel Properties

The OperatingSystemVersionModel type exposes the following members.

Properties
 | Name | Description
Public property | Build | the build number of the operating system
Public property | Major | the major version of the operating system
Public property | Minor | the minor version of the operating system
Public property | Revision | the revision number of the operating system
Top
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Build Property

OperatingSystemVersionModelBuild Property
the build number of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
member Build : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Major Property

OperatingSystemVersionModelMajor Property
the major version of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
member Major : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Minor Property

OperatingSystemVersionModelMinor Property
the minor version of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
member Minor : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Revision Property

OperatingSystemVersionModelRevision Property
the revision number of the operating system

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
member Revision : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel Methods

OperatingSystemVersionModel Methods

The OperatingSystemVersionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OperatingSystemVersionModel Class


OptionModel Class

OptionModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOptionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionModel
Public NotInheritable Class OptionModel
public ref class OptionModel sealed
[<SealedAttribute>]
type OptionModel =  class end

The OptionModel type exposes the following members.

Constructors
 | Name | Description
Public method | OptionModel | Initializes a new instance of the OptionModel class
Top
Properties
 | Name | Description
Public property | Name | the name
Public property | Value | the value
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OptionModel Constructor

OptionModel Constructor
Initializes a new instance of the OptionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OptionModel()
Public Sub New
public:
OptionModel()
new : unit -> OptionModel
See Also

Reference

OptionModel Class


OptionModel Properties

OptionModel Properties

The OptionModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | the name
Public property | Value | the value
Top
See Also

Reference

OptionModel Class


OptionModel.Name Property

OptionModelName Property
the name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

OptionModel Class


OptionModel.Value Property

OptionModelValue Property
the value

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

OptionModel Class


OptionModel Methods

OptionModel Methods

The OptionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionModel Class


OrphansScheduleModel Class

OrphansScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsOrphansScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class OrphansScheduleModel : ScheduleItemModel
Public NotInheritable Class OrphansScheduleModel
    Inherits ScheduleItemModel
public ref class OrphansScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type OrphansScheduleModel =
    class
        inherit ScheduleItemModel
    end

The OrphansScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | OrphansScheduleModel | Initializes a new instance of the OrphansScheduleModel class
Top
Properties
 | Name | Description
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OrphansScheduleModel Constructor

OrphansScheduleModel Constructor
Initializes a new instance of the OrphansScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OrphansScheduleModel()
Public Sub New
public:
OrphansScheduleModel()
new : unit -> OrphansScheduleModel
See Also

Reference

OrphansScheduleModel Class


OrphansScheduleModel Properties

OrphansScheduleModel Properties

The OrphansScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Top
See Also

Reference

OrphansScheduleModel Class


OrphansScheduleModel Methods

OrphansScheduleModel Methods

The OrphansScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrphansScheduleModel Class


PathTransformationModel Class

PathTransformationModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPathTransformationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class PathTransformationModel
Public NotInheritable Class PathTransformationModel
public ref class PathTransformationModel sealed
[<SealedAttribute>]
type PathTransformationModel =  class end

The PathTransformationModel type exposes the following members.

Constructors
 | Name | Description
Public method | PathTransformationModel | Initializes a new instance of the PathTransformationModel class
Top
Properties
 | Name | Description
Public property | SourcePath | the path expression used to qualify files for this rule
Public property | TargetPath | the path expression used to transform file paths for the all-to-one transformations on the target
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PathTransformationModel Constructor

PathTransformationModel Constructor
Initializes a new instance of the PathTransformationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel()
Public Sub New
public:
PathTransformationModel()
new : unit -> PathTransformationModel
See Also

Reference

PathTransformationModel Class


PathTransformationModel Properties

PathTransformationModel Properties

The PathTransformationModel type exposes the following members.

Properties
 | Name | Description
Public property | SourcePath | the path expression used to qualify files for this rule
Public property | TargetPath | the path expression used to transform file paths for the all-to-one transformations on the target
Top
See Also

Reference

PathTransformationModel Class


PathTransformationModel.SourcePath Property

PathTransformationModelSourcePath Property
the path expression used to qualify files for this rule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourcePath { get; set; }
Public Property SourcePath As String
    Get
    Set
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}
member SourcePath : string with get, set

Property Value

Type: String
See Also

Reference

PathTransformationModel Class


PathTransformationModel.TargetPath Property

PathTransformationModelTargetPath Property
the path expression used to transform file paths for the all-to-one transformations on the target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
member TargetPath : string with get, set

Property Value

Type: String
See Also

Reference

PathTransformationModel Class


PathTransformationModel Methods

PathTransformationModel Methods

The PathTransformationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathTransformationModel Class


PhysicalItemModel Class

PhysicalItemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsDirectoryItemModel
DoubleTake.Web.ModelsFileItemModel
DoubleTake.Web.ModelsVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class PhysicalItemModel : ProtectableItemModel
Public Class PhysicalItemModel
    Inherits ProtectableItemModel
public ref class PhysicalItemModel : public ProtectableItemModel
type PhysicalItemModel =
    class
        inherit ProtectableItemModel
    end

The PhysicalItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalItemModel | Initializes a new instance of the PhysicalItemModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item
Public property | CreationTime | a value specifying the time this item was created
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed
Public property | LastWriteTime | a value specifying the time this item was last written to
Public property | Metadata | a value specifying additional meta data for this item
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalItemModel Constructor

PhysicalItemModel Constructor
Initializes a new instance of the PhysicalItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalItemModel()
Public Sub New
public:
PhysicalItemModel()
new : unit -> PhysicalItemModel
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel Properties

PhysicalItemModel Properties

The PhysicalItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item
Public property | CreationTime | a value specifying the time this item was created
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed
Public property | LastWriteTime | a value specifying the time this item was last written to
Public property | Metadata | a value specifying additional meta data for this item
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item
Top
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Attributes Property

PhysicalItemModelAttributes Property
a value specifying the file system attributes of this item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<FileSystemAttributesEnum> Attributes { get; set; }
Public Property Attributes As Nullable(Of FileSystemAttributesEnum)
    Get
    Set
public:
property Nullable<FileSystemAttributesEnum> Attributes {
    Nullable<FileSystemAttributesEnum> get ();
    void set (Nullable<FileSystemAttributesEnum> value);
}
member Attributes : Nullable<FileSystemAttributesEnum> with get, set

Property Value

Type: Nullable FileSystemAttributesEnum
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.CreationTime Property

PhysicalItemModelCreationTime Property
a value specifying the time this item was created

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> CreationTime { get; set; }
Public Property CreationTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreationTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CreationTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.LastAccessTime Property

PhysicalItemModelLastAccessTime Property
a value specifying the time this item was last accessed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LastAccessTime { get; set; }
Public Property LastAccessTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastAccessTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastAccessTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.LastWriteTime Property

PhysicalItemModelLastWriteTime Property
a value specifying the time this item was last written to

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LastWriteTime { get; set; }
Public Property LastWriteTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastWriteTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastWriteTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Metadata Property

PhysicalItemModelMetadata Property
a value specifying additional meta data for this item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
member Metadata : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Size Property

PhysicalItemModelSize Property
a value indicating the physical size of the item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> Size { get; set; }
Public Property Size As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> Size {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member Size : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel Methods

PhysicalItemModel Methods

The PhysicalItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalItemModel Class


PhysicalRuleModel Class

PhysicalRuleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPhysicalRuleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class PhysicalRuleModel
Public NotInheritable Class PhysicalRuleModel
public ref class PhysicalRuleModel sealed
[<SealedAttribute>]
type PhysicalRuleModel =  class end

The PhysicalRuleModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalRuleModel | Initializes a new instance of the PhysicalRuleModel class
Top
Properties
 | Name | Description
Public property | Inclusion | a value indicating whether the path will be included or excluded from replication
Public property | IsReadOnly | a value indicating whether or not this rule is read only
Public property | Metadata | the metadata for this rule
Public property | Path | the path of the data to be replicated
Public property | Recursion | a value indicating whether the rule will apply to this path only, or to all children of this path as well
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalRuleModel Constructor

PhysicalRuleModel Constructor
Initializes a new instance of the PhysicalRuleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel()
Public Sub New
public:
PhysicalRuleModel()
new : unit -> PhysicalRuleModel
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel Properties

PhysicalRuleModel Properties

The PhysicalRuleModel type exposes the following members.

Properties
 | Name | Description
Public property | Inclusion | a value indicating whether the path will be included or excluded from replication
Public property | IsReadOnly | a value indicating whether or not this rule is read only
Public property | Metadata | the metadata for this rule
Public property | Path | the path of the data to be replicated
Public property | Recursion | a value indicating whether the rule will apply to this path only, or to all children of this path as well
Top
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Inclusion Property

PhysicalRuleModelInclusion Property
a value indicating whether the path will be included or excluded from replication

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public InclusionModeEnum Inclusion { get; set; }
Public Property Inclusion As InclusionModeEnum
    Get
    Set
public:
property InclusionModeEnum Inclusion {
    InclusionModeEnum get ();
    void set (InclusionModeEnum value);
}
member Inclusion : InclusionModeEnum with get, set

Property Value

Type: InclusionModeEnum
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.IsReadOnly Property

PhysicalRuleModelIsReadOnly Property
a value indicating whether or not this rule is read only

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Metadata Property

PhysicalRuleModelMetadata Property
the metadata for this rule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
member Metadata : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Path Property

PhysicalRuleModelPath Property
the path of the data to be replicated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Recursion Property

PhysicalRuleModelRecursion Property
a value indicating whether the rule will apply to this path only, or to all children of this path as well

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RecursionModeEnum Recursion { get; set; }
Public Property Recursion As RecursionModeEnum
    Get
    Set
public:
property RecursionModeEnum Recursion {
    RecursionModeEnum get ();
    void set (RecursionModeEnum value);
}
member Recursion : RecursionModeEnum with get, set

Property Value

Type: RecursionModeEnum
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel Methods

PhysicalRuleModel Methods

The PhysicalRuleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalRuleModel Class


PhysicalVolumeModel Class

PhysicalVolumeModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsPhysicalVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class PhysicalVolumeModel : VolumeOptionsModel
Public NotInheritable Class PhysicalVolumeModel
    Inherits VolumeOptionsModel
public ref class PhysicalVolumeModel sealed : public VolumeOptionsModel
[<SealedAttribute>]
type PhysicalVolumeModel =
    class
        inherit VolumeOptionsModel
    end

The PhysicalVolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalVolumeModel | Initializes a new instance of the PhysicalVolumeModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume (Inherited from VolumeModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DesiredSize | the size that the user wants the drive to be (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | the type of the disk controller (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | the type of the disk provisioning (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | the format of the drive (Inherited from VolumeModel.)
Public property | DriveType | the type of the drive (Inherited from VolumeModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive (Inherited from VolumeModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label (Inherited from VolumeModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | the path of preexisting disk (Inherited from VolumeOptionsModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume (Inherited from VolumeModel.)
Public property | VirtualDiskPath | the path on the host where the volume should be stored (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | the volume signature (Inherited from VolumeOptionsModel.)
Public property | VolumeType | the volume type (Inherited from VolumeModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalVolumeModel Constructor

PhysicalVolumeModel Constructor
Initializes a new instance of the PhysicalVolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalVolumeModel()
Public Sub New
public:
PhysicalVolumeModel()
new : unit -> PhysicalVolumeModel
See Also

Reference

PhysicalVolumeModel Class


PhysicalVolumeModel Properties

PhysicalVolumeModel Properties

The PhysicalVolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume (Inherited from VolumeModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DesiredSize | the size that the user wants the drive to be (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | the type of the disk controller (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | the type of the disk provisioning (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | the format of the drive (Inherited from VolumeModel.)
Public property | DriveType | the type of the drive (Inherited from VolumeModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive (Inherited from VolumeModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label (Inherited from VolumeModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | the path of preexisting disk (Inherited from VolumeOptionsModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume (Inherited from VolumeModel.)
Public property | VirtualDiskPath | the path on the host where the volume should be stored (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | the volume signature (Inherited from VolumeOptionsModel.)
Public property | VolumeType | the volume type (Inherited from VolumeModel.)
Top
See Also

Reference

PhysicalVolumeModel Class


PhysicalVolumeModel Methods

PhysicalVolumeModel Methods

The PhysicalVolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalVolumeModel Class


PingMethodsEnum Enumeration

PingMethodsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum PingMethodsEnum
<FlagsAttribute>
Public Enumeration PingMethodsEnum
[FlagsAttribute]
public enum class PingMethodsEnum
[<FlagsAttribute>]
type PingMethodsEnum
Members
Member name | Value | Description
ForceUpdate | 256 |
Manual | 4 |
Network | 1 |
None | 0 |
Script | 8 |
Service | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ProductInfoModel Class

ProductInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProductInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ProductInfoModel
Public NotInheritable Class ProductInfoModel
public ref class ProductInfoModel sealed
[<SealedAttribute>]
type ProductInfoModel =  class end

The ProductInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ProductInfoModel | Initializes a new instance of the ProductInfoModel class
Top
Properties
 | Name | Description
Public property | ActivationStatus | the activation status of the server
Public property | CanPauseTarget | a value indicating whether or not target operations can be paused
Public property | CanResumeTarget | a value indicating whether or not target operations can be resumed
Public property | EnginePort | the port on which the engine is listening
Public property | InstallationPath | the installation path
Public property | LocalEndpoints | the local endpoints
Public property | MachineName | the name of the machine
Public property | ManagementServiceVersion | the version of the management service on the server
Public property | Name | the name of the product on the server
Public property | NatEndpoints | the NAT end points
Public property | ReservedAddress | the reserved IP address for the server
Public property | UniqueId | the unique id of the server
Public property | Version | the version of the product on the server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ProductInfoModel Constructor

ProductInfoModel Constructor
Initializes a new instance of the ProductInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel()
Public Sub New
public:
ProductInfoModel()
new : unit -> ProductInfoModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel Properties

ProductInfoModel Properties

The ProductInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationStatus | the activation status of the server
Public property | CanPauseTarget | a value indicating whether or not target operations can be paused
Public property | CanResumeTarget | a value indicating whether or not target operations can be resumed
Public property | EnginePort | the port on which the engine is listening
Public property | InstallationPath | the installation path
Public property | LocalEndpoints | the local endpoints
Public property | MachineName | the name of the machine
Public property | ManagementServiceVersion | the version of the management service on the server
Public property | Name | the name of the product on the server
Public property | NatEndpoints | the NAT end points
Public property | ReservedAddress | the reserved IP address for the server
Public property | UniqueId | the unique id of the server
Public property | Version | the version of the product on the server
Top
See Also

Reference

ProductInfoModel Class


ProductInfoModel.ActivationStatus Property

ProductInfoModelActivationStatus Property
the activation status of the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusModel ActivationStatus { get; set; }
Public Property ActivationStatus As ActivationStatusModel
    Get
    Set
public:
property ActivationStatusModel^ ActivationStatus {
    ActivationStatusModel^ get ();
    void set (ActivationStatusModel^ value);
}
member ActivationStatus : ActivationStatusModel with get, set

Property Value

Type: ActivationStatusModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel.CanPauseTarget Property

ProductInfoModelCanPauseTarget Property
a value indicating whether or not target operations can be paused

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
member CanPauseTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProductInfoModel Class


ProductInfoModel.CanResumeTarget Property

ProductInfoModelCanResumeTarget Property
a value indicating whether or not target operations can be resumed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
member CanResumeTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProductInfoModel Class


ProductInfoModel.EnginePort Property

ProductInfoModelEnginePort Property
the port on which the engine is listening

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
member EnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductInfoModel Class


ProductInfoModel.InstallationPath Property

ProductInfoModelInstallationPath Property
the installation path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string InstallationPath { get; set; }
Public Property InstallationPath As String
    Get
    Set
public:
property String^ InstallationPath {
    String^ get ();
    void set (String^ value);
}
member InstallationPath : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.LocalEndpoints Property

ProductInfoModelLocalEndpoints Property
the local endpoints

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> LocalEndpoints { get; set; }
Public Property LocalEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ LocalEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member LocalEndpoints : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.MachineName Property

ProductInfoModelMachineName Property
the name of the machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
member MachineName : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.ManagementServiceVersion Property

ProductInfoModelManagementServiceVersion Property
the version of the management service on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel ManagementServiceVersion { get; set; }
Public Property ManagementServiceVersion As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ ManagementServiceVersion {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member ManagementServiceVersion : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel.Name Property

ProductInfoModelName Property
the name of the product on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.NatEndpoints Property

ProductInfoModelNatEndpoints Property
the NAT end points

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> NatEndpoints { get; set; }
Public Property NatEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ NatEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member NatEndpoints : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.ReservedAddress Property

ProductInfoModelReservedAddress Property
the reserved IP address for the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReservedAddress { get; set; }
Public Property ReservedAddress As String
    Get
    Set
public:
property String^ ReservedAddress {
    String^ get ();
    void set (String^ value);
}
member ReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.UniqueId Property

ProductInfoModelUniqueId Property
the unique id of the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
member UniqueId : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.Version Property

ProductInfoModelVersion Property
the version of the product on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel Version { get; set; }
Public Property Version As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ Version {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member Version : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel Methods

ProductInfoModel Methods

The ProductInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductInfoModel Class


ProductVersionModel Class

ProductVersionModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProductVersionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ProductVersionModel
Public NotInheritable Class ProductVersionModel
public ref class ProductVersionModel sealed
[<SealedAttribute>]
type ProductVersionModel =  class end

The ProductVersionModel type exposes the following members.

Constructors
 | Name | Description
Public method | ProductVersionModel | Initializes a new instance of the ProductVersionModel class
Top
Properties
 | Name | Description
Public property | Build | the build (sequence) number
Public property | Hotfix | the hot fix number.
Public property | Major | the major version number
Public property | Minor | the minor version number
Public property | ServicePack | the service pack number
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ProductVersionModel Constructor

ProductVersionModel Constructor
Initializes a new instance of the ProductVersionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel()
Public Sub New
public:
ProductVersionModel()
new : unit -> ProductVersionModel
See Also

Reference

ProductVersionModel Class


ProductVersionModel Properties

ProductVersionModel Properties

The ProductVersionModel type exposes the following members.

Properties
 | Name | Description
Public property | Build | the build (sequence) number
Public property | Hotfix | the hot fix number.
Public property | Major | the major version number
Public property | Minor | the minor version number
Public property | ServicePack | the service pack number
Top
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Build Property

ProductVersionModelBuild Property
the build (sequence) number

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
member Build : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Hotfix Property

ProductVersionModelHotfix Property
the hot fix number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Hotfix { get; set; }
Public Property Hotfix As Integer
    Get
    Set
public:
property int Hotfix {
    int get ();
    void set (int value);
}
member Hotfix : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Major Property

ProductVersionModelMajor Property
the major version number

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
member Major : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Minor Property

ProductVersionModelMinor Property
the minor version number

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
member Minor : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.ServicePack Property

ProductVersionModelServicePack Property
the service pack number

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ServicePack { get; set; }
Public Property ServicePack As Integer
    Get
    Set
public:
property int ServicePack {
    int get ();
    void set (int value);
}
member ServicePack : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel Methods

ProductVersionModel Methods

The ProductVersionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductVersionModel Class


ProtectableItemModel Class

ProtectableItemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsLogicalItemModel
DoubleTake.Web.ModelsPhysicalItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ProtectableItemModel
Public MustInherit Class ProtectableItemModel
public ref class ProtectableItemModel abstract
[<AbstractClassAttribute>]
type ProtectableItemModel =  class end

The ProtectableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ProtectableItemModel | Initializes a new instance of the ProtectableItemModel class
Top
Properties
 | Name | Description
Public property | Id | the item identifier
Public property | IsContainer | a value indicating whether or not this item is a container of other items
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed
Public property | ItemType | the type of this item
Public property | Name | the name of this item
Public property | Path | the path that uniquely identifies this item
Public property | Saturation | the saturation level of this item
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ProtectableItemModel Constructor

ProtectableItemModel Constructor
Initializes a new instance of the ProtectableItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ProtectableItemModel()
Protected Sub New
protected:
ProtectableItemModel()
new : unit -> ProtectableItemModel
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel Properties

ProtectableItemModel Properties

The ProtectableItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | the item identifier
Public property | IsContainer | a value indicating whether or not this item is a container of other items
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed
Public property | ItemType | the type of this item
Public property | Name | the name of this item
Public property | Path | the path that uniquely identifies this item
Public property | Saturation | the saturation level of this item
Top
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Id Property

ProtectableItemModelId Property
the item identifier

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.IsContainer Property

ProtectableItemModelIsContainer Property
a value indicating whether or not this item is a container of other items

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
property bool IsContainer {
    bool get ();
    void set (bool value);
}
member IsContainer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.IsReadOnly Property

ProtectableItemModelIsReadOnly Property
a value indicating whether or not this item is read only; that is, its Saturation cannot be changed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.ItemType Property

ProtectableItemModelItemType Property
the type of this item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
property String^ ItemType {
    String^ get ();
    void set (String^ value);
}
member ItemType : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Name Property

ProtectableItemModelName Property
the name of this item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Path Property

ProtectableItemModelPath Property
the path that uniquely identifies this item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Saturation Property

ProtectableItemModelSaturation Property
the saturation level of this item

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SaturationLevelEnum Saturation { get; set; }
Public Property Saturation As SaturationLevelEnum
    Get
    Set
public:
property SaturationLevelEnum Saturation {
    SaturationLevelEnum get ();
    void set (SaturationLevelEnum value);
}
member Saturation : SaturationLevelEnum with get, set

Property Value

Type: SaturationLevelEnum
The saturation level.
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel Methods

ProtectableItemModel Methods

The ProtectableItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProtectableItemModel Class


RecommendedFailbackOptionsModel Class

RecommendedFailbackOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedFailbackOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedFailbackOptionsModel
Public NotInheritable Class RecommendedFailbackOptionsModel
public ref class RecommendedFailbackOptionsModel sealed
[<SealedAttribute>]
type RecommendedFailbackOptionsModel =  class end

The RecommendedFailbackOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailbackOptionsModel | Initializes a new instance of the RecommendedFailbackOptionsModel class
Top
Properties
 | Name | Description
Public property | FailbackOptions | the failback options
Public property | IsSourceNew | a value indicating whether the data was restored, or is being restored, to a new source
Public property | RestoreStatus | the status of the restore operation
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedFailbackOptionsModel Constructor

RecommendedFailbackOptionsModel Constructor
Initializes a new instance of the RecommendedFailbackOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedFailbackOptionsModel()
Public Sub New
public:
RecommendedFailbackOptionsModel()
new : unit -> RecommendedFailbackOptionsModel
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel Properties

RecommendedFailbackOptionsModel Properties

The RecommendedFailbackOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailbackOptions | the failback options
Public property | IsSourceNew | a value indicating whether the data was restored, or is being restored, to a new source
Public property | RestoreStatus | the status of the restore operation
Top
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel.FailbackOptions Property

RecommendedFailbackOptionsModelFailbackOptions Property
the failback options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailbackOptionsModel FailbackOptions { get; set; }
Public Property FailbackOptions As FailbackOptionsModel
    Get
    Set
public:
property FailbackOptionsModel^ FailbackOptions {
    FailbackOptionsModel^ get ();
    void set (FailbackOptionsModel^ value);
}
member FailbackOptions : FailbackOptionsModel with get, set

Property Value

Type: FailbackOptionsModel
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel.IsSourceNew Property

RecommendedFailbackOptionsModelIsSourceNew Property
a value indicating whether the data was restored, or is being restored, to a new source

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSourceNew { get; set; }
Public Property IsSourceNew As Boolean
    Get
    Set
public:
property bool IsSourceNew {
    bool get ();
    void set (bool value);
}
member IsSourceNew : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel.RestoreStatus Property

RecommendedFailbackOptionsModelRestoreStatus Property
the status of the restore operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreStatusEnum RestoreStatus { get; set; }
Public Property RestoreStatus As RestoreStatusEnum
    Get
    Set
public:
property RestoreStatusEnum RestoreStatus {
    RestoreStatusEnum get ();
    void set (RestoreStatusEnum value);
}
member RestoreStatus : RestoreStatusEnum with get, set

Property Value

Type: RestoreStatusEnum
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel Methods

RecommendedFailbackOptionsModel Methods

The RecommendedFailbackOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailoverOptionsModel Class

RecommendedFailoverOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedFailoverOptionsModel
Public NotInheritable Class RecommendedFailoverOptionsModel
public ref class RecommendedFailoverOptionsModel sealed
[<SealedAttribute>]
type RecommendedFailoverOptionsModel =  class end

The RecommendedFailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailoverOptionsModel | Initializes a new instance of the RecommendedFailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | FailoverOptions | the recommended failover options
Public property | IsTestFailoverSupported | a value indicating whether test failover is supported
Public property | Snapshots | the list of snapshots on the target server
Public property | WarningTextTestFailover | warning text to display if Test Failover is selected
Public property | WarnUserOfInconsistentProtectionData | a value indicating whether to warn that the data on the target server may be in an inconsistent state
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedFailoverOptionsModel Constructor

RecommendedFailoverOptionsModel Constructor
Initializes a new instance of the RecommendedFailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedFailoverOptionsModel()
Public Sub New
public:
RecommendedFailoverOptionsModel()
new : unit -> RecommendedFailoverOptionsModel
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel Properties

RecommendedFailoverOptionsModel Properties

The RecommendedFailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverOptions | the recommended failover options
Public property | IsTestFailoverSupported | a value indicating whether test failover is supported
Public property | Snapshots | the list of snapshots on the target server
Public property | WarningTextTestFailover | warning text to display if Test Failover is selected
Public property | WarnUserOfInconsistentProtectionData | a value indicating whether to warn that the data on the target server may be in an inconsistent state
Top
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.FailoverOptions Property

RecommendedFailoverOptionsModelFailoverOptions Property
the recommended failover options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.IsTestFailoverSupported Property

RecommendedFailoverOptionsModelIsTestFailoverSupported Property
a value indicating whether test failover is supported

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTestFailoverSupported { get; set; }
Public Property IsTestFailoverSupported As Boolean
    Get
    Set
public:
property bool IsTestFailoverSupported {
    bool get ();
    void set (bool value);
}
member IsTestFailoverSupported : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.Snapshots Property

RecommendedFailoverOptionsModelSnapshots Property
the list of snapshots on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntryModel()
    Get
    Set
public:
property array<SnapshotEntryModel^>^ Snapshots {
    array<SnapshotEntryModel^>^ get ();
    void set (array<SnapshotEntryModel^>^ value);
}
member Snapshots : SnapshotEntryModel[] with get, set

Property Value

Type: SnapshotEntryModel
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.WarningTextTestFailover Property

RecommendedFailoverOptionsModelWarningTextTestFailover Property
warning text to display if Test Failover is selected

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WarningTextTestFailover { get; set; }
Public Property WarningTextTestFailover As Boolean
    Get
    Set
public:
property bool WarningTextTestFailover {
    bool get ();
    void set (bool value);
}
member WarningTextTestFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.WarnUserOfInconsistentProtectionData Property

RecommendedFailoverOptionsModelWarnUserOfInconsistentProtectionData Property
a value indicating whether to warn that the data on the target server may be in an inconsistent state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool WarnUserOfInconsistentProtectionData { get; set; }
Public Property WarnUserOfInconsistentProtectionData As Boolean
    Get
    Set
public:
property bool WarnUserOfInconsistentProtectionData {
    bool get ();
    void set (bool value);
}
member WarnUserOfInconsistentProtectionData : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel Methods

RecommendedFailoverOptionsModel Methods

The RecommendedFailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedJobOptionsModel Class

RecommendedJobOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedJobOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedJobOptionsModel
Public NotInheritable Class RecommendedJobOptionsModel
public ref class RecommendedJobOptionsModel sealed
[<SealedAttribute>]
type RecommendedJobOptionsModel =  class end

The RecommendedJobOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedJobOptionsModel | Initializes a new instance of the RecommendedJobOptionsModel class
Top
Properties
 | Name | Description
Public property | JobOptions | the recommended job options
Public property | JobQualificationResults | the job qualification results
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedJobOptionsModel Constructor

RecommendedJobOptionsModel Constructor
Initializes a new instance of the RecommendedJobOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedJobOptionsModel()
Public Sub New
public:
RecommendedJobOptionsModel()
new : unit -> RecommendedJobOptionsModel
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel Properties

RecommendedJobOptionsModel Properties

The RecommendedJobOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | JobOptions | the recommended job options
Public property | JobQualificationResults | the job qualification results
Top
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel.JobOptions Property

RecommendedJobOptionsModelJobOptions Property
the recommended job options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel.JobQualificationResults Property

RecommendedJobOptionsModelJobQualificationResults Property
the job qualification results

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobQualificationResultsModel JobQualificationResults { get; set; }
Public Property JobQualificationResults As JobQualificationResultsModel
    Get
    Set
public:
property JobQualificationResultsModel^ JobQualificationResults {
    JobQualificationResultsModel^ get ();
    void set (JobQualificationResultsModel^ value);
}
member JobQualificationResults : JobQualificationResultsModel with get, set

Property Value

Type: JobQualificationResultsModel
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel Methods

RecommendedJobOptionsModel Methods

The RecommendedJobOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsRequestModel Class

RecommendedJobOptionsRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedJobOptionsRequestModel
Public NotInheritable Class RecommendedJobOptionsRequestModel
public ref class RecommendedJobOptionsRequestModel sealed
[<SealedAttribute>]
type RecommendedJobOptionsRequestModel =  class end

The RecommendedJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedJobOptionsRequestModel | Initializes a new instance of the RecommendedJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | Credentials | the job credentials
Public property | JobType | the job type
Public property | Workload | the workload
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedJobOptionsRequestModel Constructor

RecommendedJobOptionsRequestModel Constructor
Initializes a new instance of the RecommendedJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedJobOptionsRequestModel()
Public Sub New
public:
RecommendedJobOptionsRequestModel()
new : unit -> RecommendedJobOptionsRequestModel
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel Properties

RecommendedJobOptionsRequestModel Properties

The RecommendedJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | the job credentials
Public property | JobType | the job type
Public property | Workload | the workload
Top
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel.Credentials Property

RecommendedJobOptionsRequestModelCredentials Property
the job credentials

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel Credentials { get; set; }
Public Property Credentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ Credentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member Credentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel.JobType Property

RecommendedJobOptionsRequestModelJobType Property
the job type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel.Workload Property

RecommendedJobOptionsRequestModelWorkload Property
the workload

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel Methods

RecommendedJobOptionsRequestModel Methods

The RecommendedJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedRestoreOptionsModel Class

RecommendedRestoreOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedRestoreOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedRestoreOptionsModel
Public NotInheritable Class RecommendedRestoreOptionsModel
public ref class RecommendedRestoreOptionsModel sealed
[<SealedAttribute>]
type RecommendedRestoreOptionsModel =  class end

The RecommendedRestoreOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedRestoreOptionsModel | Initializes a new instance of the RecommendedRestoreOptionsModel class
Top
Properties
 | Name | Description
Public property | CanClearRestoreRequired | a value indicating whether the restore required state can be cleared
Public property | IsNat |
Public property | PossibleSourceAddresses | the possible source addresses
Public property | RestoreOptions | the restore options
Public property | SameSourceOnly | a value indicating whether the job only allows restoring to the same source
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedRestoreOptionsModel Constructor

RecommendedRestoreOptionsModel Constructor
Initializes a new instance of the RecommendedRestoreOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedRestoreOptionsModel()
Public Sub New
public:
RecommendedRestoreOptionsModel()
new : unit -> RecommendedRestoreOptionsModel
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel Properties

RecommendedRestoreOptionsModel Properties

The RecommendedRestoreOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | CanClearRestoreRequired | a value indicating whether the restore required state can be cleared
Public property | IsNat |
Public property | PossibleSourceAddresses | the possible source addresses
Public property | RestoreOptions | the restore options
Public property | SameSourceOnly | a value indicating whether the job only allows restoring to the same source
Top
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.CanClearRestoreRequired Property

RecommendedRestoreOptionsModelCanClearRestoreRequired Property
a value indicating whether the restore required state can be cleared

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanClearRestoreRequired { get; set; }
Public Property CanClearRestoreRequired As Boolean
    Get
    Set
public:
property bool CanClearRestoreRequired {
    bool get ();
    void set (bool value);
}
member CanClearRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.IsNat Property

RecommendedRestoreOptionsModelIsNat Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
member IsNat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.PossibleSourceAddresses Property

RecommendedRestoreOptionsModelPossibleSourceAddresses Property
the possible source addresses

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] PossibleSourceAddresses { get; set; }
Public Property PossibleSourceAddresses As String()
    Get
    Set
public:
property array<String^>^ PossibleSourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PossibleSourceAddresses : string[] with get, set

Property Value

Type: String
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.RestoreOptions Property

RecommendedRestoreOptionsModelRestoreOptions Property
the restore options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptionsModel RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptionsModel
    Get
    Set
public:
property RestoreOptionsModel^ RestoreOptions {
    RestoreOptionsModel^ get ();
    void set (RestoreOptionsModel^ value);
}
member RestoreOptions : RestoreOptionsModel with get, set

Property Value

Type: RestoreOptionsModel
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.SameSourceOnly Property

RecommendedRestoreOptionsModelSameSourceOnly Property
a value indicating whether the job only allows restoring to the same source

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool SameSourceOnly { get; set; }
Public Property SameSourceOnly As Boolean
    Get
    Set
public:
property bool SameSourceOnly {
    bool get ();
    void set (bool value);
}
member SameSourceOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel Methods

RecommendedRestoreOptionsModel Methods

The RecommendedRestoreOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedRestoreOptionsModel Class


RecursionModeEnum Enumeration

RecursionModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RecursionModeEnum
Public Enumeration RecursionModeEnum
public enum class RecursionModeEnum
type RecursionModeEnum
Members
Member name | Value | Description
Recursive | 0 |
NonRecursive | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationSetUsageTypeEnum Enumeration

ReplicationSetUsageTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReplicationSetUsageTypeEnum
Public Enumeration ReplicationSetUsageTypeEnum
public enum class ReplicationSetUsageTypeEnum
type ReplicationSetUsageTypeEnum
Members
Member name | Value | Description
Invalid | -1 |
Normal | 0 |
SystemState | 1 |
GeoCluster | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationStateEnum Enumeration

ReplicationStateEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReplicationStateEnum
Public Enumeration ReplicationStateEnum
public enum class ReplicationStateEnum
type ReplicationStateEnum
Members
Member name | Value | Description
NotReplicating | 0 |
OutOfMemory | 1 |
Pending | 2 |
Replicating | 3 |
Unknown | 4 |
Watchdog | 5 |
Ready | 6 |
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicaVmInfoModel Class

ReplicaVmInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmInfoModel
DoubleTake.Web.ModelsReplicaVmInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ReplicaVmInfoModel : VmInfoModel
Public NotInheritable Class ReplicaVmInfoModel
    Inherits VmInfoModel
public ref class ReplicaVmInfoModel sealed : public VmInfoModel
[<SealedAttribute>]
type ReplicaVmInfoModel =
    class
        inherit VmInfoModel
    end

The ReplicaVmInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicaVmInfoModel | Initializes a new instance of the ReplicaVmInfoModel class
Top
Properties
 | Name | Description
Public property | Address | the virtual machine guest DNS name/IP Address (Inherited from VmInfoModel.)
Public property | BiosGuid | the virtual machine BIOS Guid (Inherited from VmInfoModel.)
Public property | BootVolumeSignature | the VM boot volume signature (Inherited from VmInfoModel.)
Public property | Cpus | the number of CPUs for the replica Vm
Public property | DisplayName | the virtual machine display name (Inherited from VmInfoModel.)
Public property | GuestOS | the virtual machine guest OS (Inherited from VmInfoModel.)
Public property | GuestUri | the guest URI (Inherited from VmInfoModel.)
Public property | Id | the virtual machine Guid (Inherited from VmInfoModel.)
Public property | Memory | the amount of RAM in bytes the Vm should have
Public property | OperatingSystem | the ESX operating system name
Public property | Path | the virtual machine location (Inherited from VmInfoModel.)
Public property | PathTransformations | the path transformations (Inherited from VmInfoModel.)
Public property | PrestageFolder | the prestage folder.
Public property | ReplicaVmVersion | the version of the Vm hardware
Public property | RunOnceAtStartup | a command to run when the replica vm is first powered on
Public property | SnapshotDataPath | the virtual machine snapshot location (Inherited from VmInfoModel.)
Public property | SnapshotFileNames | the VM snapshot FileNames (Inherited from VmInfoModel.)
Public property | SystemDirectory | the VM system directory (Inherited from VmInfoModel.)
Public property | VirtualHardDiskPath | the virtual hard disk path (Inherited from VmInfoModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicaVmInfoModel Constructor

ReplicaVmInfoModel Constructor
Initializes a new instance of the ReplicaVmInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicaVmInfoModel()
Public Sub New
public:
ReplicaVmInfoModel()
new : unit -> ReplicaVmInfoModel
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel Properties

ReplicaVmInfoModel Properties

The ReplicaVmInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | the virtual machine guest DNS name/IP Address (Inherited from VmInfoModel.)
Public property | BiosGuid | the virtual machine BIOS Guid (Inherited from VmInfoModel.)
Public property | BootVolumeSignature | the VM boot volume signature (Inherited from VmInfoModel.)
Public property | Cpus | the number of CPUs for the replica Vm
Public property | DisplayName | the virtual machine display name (Inherited from VmInfoModel.)
Public property | GuestOS | the virtual machine guest OS (Inherited from VmInfoModel.)
Public property | GuestUri | the guest URI (Inherited from VmInfoModel.)
Public property | Id | the virtual machine Guid (Inherited from VmInfoModel.)
Public property | Memory | the amount of RAM in bytes the Vm should have
Public property | OperatingSystem | the ESX operating system name
Public property | Path | the virtual machine location (Inherited from VmInfoModel.)
Public property | PathTransformations | the path transformations (Inherited from VmInfoModel.)
Public property | PrestageFolder | the prestage folder.
Public property | ReplicaVmVersion | the version of the Vm hardware
Public property | RunOnceAtStartup | a command to run when the replica vm is first powered on
Public property | SnapshotDataPath | the virtual machine snapshot location (Inherited from VmInfoModel.)
Public property | SnapshotFileNames | the VM snapshot FileNames (Inherited from VmInfoModel.)
Public property | SystemDirectory | the VM system directory (Inherited from VmInfoModel.)
Public property | VirtualHardDiskPath | the virtual hard disk path (Inherited from VmInfoModel.)
Top
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.Cpus Property

ReplicaVmInfoModelCpus Property
the number of CPUs for the replica Vm

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
member Cpus : int with get, set

Property Value

Type: Int32
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.Memory Property

ReplicaVmInfoModelMemory Property
the amount of RAM in bytes the Vm should have

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
member Memory : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.OperatingSystem Property

ReplicaVmInfoModelOperatingSystem Property
the ESX operating system name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatingSystem { get; set; }
Public Property OperatingSystem As String
    Get
    Set
public:
property String^ OperatingSystem {
    String^ get ();
    void set (String^ value);
}
member OperatingSystem : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.PrestageFolder Property

ReplicaVmInfoModelPrestageFolder Property
the prestage folder.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PrestageFolder { get; set; }
Public Property PrestageFolder As String
    Get
    Set
public:
property String^ PrestageFolder {
    String^ get ();
    void set (String^ value);
}
member PrestageFolder : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.ReplicaVmVersion Property

ReplicaVmInfoModelReplicaVmVersion Property
the version of the Vm hardware

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicaVmVersion { get; set; }
Public Property ReplicaVmVersion As String
    Get
    Set
public:
property String^ ReplicaVmVersion {
    String^ get ();
    void set (String^ value);
}
member ReplicaVmVersion : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.RunOnceAtStartup Property

ReplicaVmInfoModelRunOnceAtStartup Property
a command to run when the replica vm is first powered on

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RunOnceAtStartup { get; set; }
Public Property RunOnceAtStartup As String
    Get
    Set
public:
property String^ RunOnceAtStartup {
    String^ get ();
    void set (String^ value);
}
member RunOnceAtStartup : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel Methods

ReplicaVmInfoModel Methods

The ReplicaVmInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReplicaVmInfoModel Class


RestoreOptionsEnum Enumeration

RestoreOptionsEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum RestoreOptionsEnum
<FlagsAttribute>
Public Enumeration RestoreOptionsEnum
[FlagsAttribute]
public enum class RestoreOptionsEnum
[<FlagsAttribute>]
type RestoreOptionsEnum
Members
Member name | Value | Description
None | 0 |
UseTargetWorkload | 1 |
RestoreWorkloadToSource | 2 |
OverwriteExistingFiles | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreOptionsModel Class

RestoreOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRestoreOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RestoreOptionsModel
Public NotInheritable Class RestoreOptionsModel
public ref class RestoreOptionsModel sealed
[<SealedAttribute>]
type RestoreOptionsModel =  class end

The RestoreOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreOptionsModel | Initializes a new instance of the RestoreOptionsModel class
Top
Properties
 | Name | Description
Public property | ClearRestoreRequired | a value indicating whether to simply clear the "Restore required" state without restoring
Public property | EnginePort | the engine port
Public property | RestoreParameters | the parameters for the restore operation
Public property | RestoreTargetHostUri | the restore target host URI
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreOptionsModel Constructor

RestoreOptionsModel Constructor
Initializes a new instance of the RestoreOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptionsModel()
Public Sub New
public:
RestoreOptionsModel()
new : unit -> RestoreOptionsModel
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel Properties

RestoreOptionsModel Properties

The RestoreOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClearRestoreRequired | a value indicating whether to simply clear the "Restore required" state without restoring
Public property | EnginePort | the engine port
Public property | RestoreParameters | the parameters for the restore operation
Public property | RestoreTargetHostUri | the restore target host URI
Top
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.ClearRestoreRequired Property

RestoreOptionsModelClearRestoreRequired Property
a value indicating whether to simply clear the "Restore required" state without restoring

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearRestoreRequired { get; set; }
Public Property ClearRestoreRequired As Boolean
    Get
    Set
public:
property bool ClearRestoreRequired {
    bool get ();
    void set (bool value);
}
member ClearRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.EnginePort Property

RestoreOptionsModelEnginePort Property
the engine port

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.RestoreParameters Property

RestoreOptionsModelRestoreParameters Property
the parameters for the restore operation

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreParametersModel RestoreParameters { get; set; }
Public Property RestoreParameters As RestoreParametersModel
    Get
    Set
public:
property RestoreParametersModel^ RestoreParameters {
    RestoreParametersModel^ get ();
    void set (RestoreParametersModel^ value);
}
member RestoreParameters : RestoreParametersModel with get, set

Property Value

Type: RestoreParametersModel
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.RestoreTargetHostUri Property

RestoreOptionsModelRestoreTargetHostUri Property
the restore target host URI

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Uri RestoreTargetHostUri { get; set; }
Public Property RestoreTargetHostUri As Uri
    Get
    Set
public:
property Uri^ RestoreTargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RestoreTargetHostUri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel Methods

RestoreOptionsModel Methods

The RestoreOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestoreOptionsModel Class


RestoreParametersModel Class

RestoreParametersModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRestoreParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RestoreParametersModel
Public NotInheritable Class RestoreParametersModel
public ref class RestoreParametersModel sealed
[<SealedAttribute>]
type RestoreParametersModel =  class end

The RestoreParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreParametersModel | Initializes a new instance of the RestoreParametersModel class
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | the archive bin location
Public property | ArchiveOption | the archive option
Public property | CompressionLevel | the compression level
Public property | MirrorComparisonCriteria | the comparison criteria
Public property | OriginalSourceName | the name of the original source
Public property | OriginalTargetRoute | the original target route
Public property | PathTransformations | the path transformations
Public property | ProcessOrphans | a value indicating whether to process orphans
Public property | ReplicationSetName | the name of the replication set
Public property | RestoreOptions | the options
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreParametersModel Constructor

RestoreParametersModel Constructor
Initializes a new instance of the RestoreParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreParametersModel()
Public Sub New
public:
RestoreParametersModel()
new : unit -> RestoreParametersModel
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel Properties

RestoreParametersModel Properties

The RestoreParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | the archive bin location
Public property | ArchiveOption | the archive option
Public property | CompressionLevel | the compression level
Public property | MirrorComparisonCriteria | the comparison criteria
Public property | OriginalSourceName | the name of the original source
Public property | OriginalTargetRoute | the original target route
Public property | PathTransformations | the path transformations
Public property | ProcessOrphans | a value indicating whether to process orphans
Public property | ReplicationSetName | the name of the replication set
Public property | RestoreOptions | the options
Top
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ArchiveBinLocation Property

RestoreParametersModelArchiveBinLocation Property
the archive bin location

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
member ArchiveBinLocation : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ArchiveOption Property

RestoreParametersModelArchiveOption Property
the archive option

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveRestoreOptionEnum ArchiveOption { get; set; }
Public Property ArchiveOption As ArchiveRestoreOptionEnum
    Get
    Set
public:
property ArchiveRestoreOptionEnum ArchiveOption {
    ArchiveRestoreOptionEnum get ();
    void set (ArchiveRestoreOptionEnum value);
}
member ArchiveOption : ArchiveRestoreOptionEnum with get, set

Property Value

Type: ArchiveRestoreOptionEnum
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.CompressionLevel Property

RestoreParametersModelCompressionLevel Property
the compression level

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevelModel
    Get
    Set
public:
property CompressionLevelModel^ CompressionLevel {
    CompressionLevelModel^ get ();
    void set (CompressionLevelModel^ value);
}
member CompressionLevel : CompressionLevelModel with get, set

Property Value

Type: CompressionLevelModel
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.MirrorComparisonCriteria Property

RestoreParametersModelMirrorComparisonCriteria Property
the comparison criteria

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorComparisonCriteriaEnum MirrorComparisonCriteria { get; set; }
Public Property MirrorComparisonCriteria As MirrorComparisonCriteriaEnum
    Get
    Set
public:
property MirrorComparisonCriteriaEnum MirrorComparisonCriteria {
    MirrorComparisonCriteriaEnum get ();
    void set (MirrorComparisonCriteriaEnum value);
}
member MirrorComparisonCriteria : MirrorComparisonCriteriaEnum with get, set

Property Value

Type: MirrorComparisonCriteriaEnum
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.OriginalSourceName Property

RestoreParametersModelOriginalSourceName Property
the name of the original source

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceName { get; set; }
Public Property OriginalSourceName As String
    Get
    Set
public:
property String^ OriginalSourceName {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceName : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.OriginalTargetRoute Property

RestoreParametersModelOriginalTargetRoute Property
the original target route

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalTargetRoute { get; set; }
Public Property OriginalTargetRoute As String
    Get
    Set
public:
property String^ OriginalTargetRoute {
    String^ get ();
    void set (String^ value);
}
member OriginalTargetRoute : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.PathTransformations Property

RestoreParametersModelPathTransformations Property
the path transformations

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ProcessOrphans Property

RestoreParametersModelProcessOrphans Property
a value indicating whether to process orphans

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProcessOrphans { get; set; }
Public Property ProcessOrphans As Boolean
    Get
    Set
public:
property bool ProcessOrphans {
    bool get ();
    void set (bool value);
}
member ProcessOrphans : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ReplicationSetName Property

RestoreParametersModelReplicationSetName Property
the name of the replication set

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.RestoreOptions Property

RestoreParametersModelRestoreOptions Property
the options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptionsEnum RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptionsEnum
    Get
    Set
public:
property RestoreOptionsEnum RestoreOptions {
    RestoreOptionsEnum get ();
    void set (RestoreOptionsEnum value);
}
member RestoreOptions : RestoreOptionsEnum with get, set

Property Value

Type: RestoreOptionsEnum
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel Methods

RestoreParametersModel Methods

The RestoreParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestoreParametersModel Class


RestoreStatesEnum Enumeration

RestoreStatesEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum RestoreStatesEnum
<FlagsAttribute>
Public Enumeration RestoreStatesEnum
[FlagsAttribute]
public enum class RestoreStatesEnum
[<FlagsAttribute>]
type RestoreStatesEnum
Members
Member name | Value | Description
Connected | 4 |
Mirroring | 16 |
MirrorStopped | 32 |
MultiConnect | 8 |
None | 0 |
OldServer | 1 |
OpDropped | 64 |
OpRetrying | 128 |
Required | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreStatusEnum Enumeration

RestoreStatusEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum RestoreStatusEnum
Public Enumeration RestoreStatusEnum
public enum class RestoreStatusEnum
type RestoreStatusEnum
Members
Member name | Value | Description
NotStarted | 0 |
Restoring | 1 |
Restored | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


RunScriptRequestModel Class

RunScriptRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRunScriptRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RunScriptRequestModel
Public NotInheritable Class RunScriptRequestModel
public ref class RunScriptRequestModel sealed
[<SealedAttribute>]
type RunScriptRequestModel =  class end

The RunScriptRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | RunScriptRequestModel | Initializes a new instance of the RunScriptRequestModel class
Top
Properties
 | Name | Description
Public property | Arguments |
Public property | Credential |
Public property | ScriptPath |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RunScriptRequestModel Constructor

RunScriptRequestModel Constructor
Initializes a new instance of the RunScriptRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public RunScriptRequestModel()
Public Sub New
public:
RunScriptRequestModel()
new : unit -> RunScriptRequestModel
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel Properties

RunScriptRequestModel Properties

The RunScriptRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments |
Public property | Credential |
Public property | ScriptPath |
Top
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel.Arguments Property

RunScriptRequestModelArguments Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel.Credential Property

RunScriptRequestModelCredential Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credential { get; set; }
Public Property Credential As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credential {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credential : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel.ScriptPath Property

RunScriptRequestModelScriptPath Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptPath { get; set; }
Public Property ScriptPath As String
    Get
    Set
public:
property String^ ScriptPath {
    String^ get ();
    void set (String^ value);
}
member ScriptPath : string with get, set

Property Value

Type: String
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel Methods

RunScriptRequestModel Methods

The RunScriptRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunScriptRequestModel Class


SaturationLevelEnum Enumeration

SaturationLevelEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SaturationLevelEnum
Public Enumeration SaturationLevelEnum
public enum class SaturationLevelEnum
type SaturationLevelEnum
Members
Member name | Value | Description
Unknown | 0 |
None | 1 |
Partial | 2 |
Full | 3 |
Error | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


ScheduleItemModel Class

ScheduleItemModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsArchiveScheduleModel
DoubleTake.Web.ModelsOrphansScheduleModel
DoubleTake.Web.ModelsSnapshotScheduleModel
DoubleTake.Web.ModelsTransmissionScheduleModel
DoubleTake.Web.ModelsVerifyScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScheduleItemModel
Public MustInherit Class ScheduleItemModel
public ref class ScheduleItemModel abstract
[<AbstractClassAttribute>]
type ScheduleItemModel =  class end

The ScheduleItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ScheduleItemModel | Initializes a new instance of the ScheduleItemModel class
Top
Properties
 | Name | Description
Public property | IsEnabled | a value indicating whether or not the item is enabled
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ScheduleItemModel Constructor

ScheduleItemModel Constructor
Initializes a new instance of the ScheduleItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
protected ScheduleItemModel()
Protected Sub New
protected:
ScheduleItemModel()
new : unit -> ScheduleItemModel
See Also

Reference

ScheduleItemModel Class


ScheduleItemModel Properties

ScheduleItemModel Properties

The ScheduleItemModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | a value indicating whether or not the item is enabled
Top
See Also

Reference

ScheduleItemModel Class


ScheduleItemModel.IsEnabled Property

ScheduleItemModelIsEnabled Property
a value indicating whether or not the item is enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
member IsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScheduleItemModel Class


ScheduleItemModel Methods

ScheduleItemModel Methods

The ScheduleItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScheduleItemModel Class


ScriptExecutionModeEnum Enumeration

ScriptExecutionModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptExecutionModeEnum
Public Enumeration ScriptExecutionModeEnum
public enum class ScriptExecutionModeEnum
type ScriptExecutionModeEnum
Members
Member name | Value | Description
Synchronous | 0 |
Asynchronous | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptPointModel Class

ScriptPointModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScriptPointModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ScriptPointModel
Public NotInheritable Class ScriptPointModel
public ref class ScriptPointModel sealed
[<SealedAttribute>]
type ScriptPointModel =  class end

The ScriptPointModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptPointModel | Initializes a new instance of the ScriptPointModel class
Top
Properties
 | Name | Description
Public property | Arguments | the arguments
Public property | ExecutionMode | the execution mode
Public property | InteractionMode | the interaction mode
Public property | Path | the path
Public property | ScriptType | the script point type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptPointModel Constructor

ScriptPointModel Constructor
Initializes a new instance of the ScriptPointModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptPointModel()
Public Sub New
public:
ScriptPointModel()
new : unit -> ScriptPointModel
See Also

Reference

ScriptPointModel Class


ScriptPointModel Properties

ScriptPointModel Properties

The ScriptPointModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | the arguments
Public property | ExecutionMode | the execution mode
Public property | InteractionMode | the interaction mode
Public property | Path | the path
Public property | ScriptType | the script point type
Top
See Also

Reference

ScriptPointModel Class


ScriptPointModel.Arguments Property

ScriptPointModelArguments Property
the arguments

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
See Also

Reference

ScriptPointModel Class


ScriptPointModel.ExecutionMode Property

ScriptPointModelExecutionMode Property
the execution mode

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptExecutionModeEnum ExecutionMode { get; set; }
Public Property ExecutionMode As ScriptExecutionModeEnum
    Get
    Set
public:
property ScriptExecutionModeEnum ExecutionMode {
    ScriptExecutionModeEnum get ();
    void set (ScriptExecutionModeEnum value);
}
member ExecutionMode : ScriptExecutionModeEnum with get, set

Property Value

Type: ScriptExecutionModeEnum
See Also

Reference

ScriptPointModel Class


ScriptPointModel.InteractionMode Property

ScriptPointModelInteractionMode Property
the interaction mode

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesktopInteractionModeEnum InteractionMode { get; set; }
Public Property InteractionMode As DesktopInteractionModeEnum
    Get
    Set
public:
property DesktopInteractionModeEnum InteractionMode {
    DesktopInteractionModeEnum get ();
    void set (DesktopInteractionModeEnum value);
}
member InteractionMode : DesktopInteractionModeEnum with get, set

Property Value

Type: DesktopInteractionModeEnum
See Also

Reference

ScriptPointModel Class


ScriptPointModel.Path Property

ScriptPointModelPath Property
the path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

ScriptPointModel Class


ScriptPointModel.ScriptType Property

ScriptPointModelScriptType Property
the script point type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptPointTypeEnum ScriptType { get; set; }
Public Property ScriptType As ScriptPointTypeEnum
    Get
    Set
public:
property ScriptPointTypeEnum ScriptType {
    ScriptPointTypeEnum get ();
    void set (ScriptPointTypeEnum value);
}
member ScriptType : ScriptPointTypeEnum with get, set

Property Value

Type: ScriptPointTypeEnum
See Also

Reference

ScriptPointModel Class


ScriptPointModel Methods

ScriptPointModel Methods

The ScriptPointModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptPointModel Class


ScriptPointTypeEnum Enumeration

ScriptPointTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptPointTypeEnum
Public Enumeration ScriptPointTypeEnum
public enum class ScriptPointTypeEnum
type ScriptPointTypeEnum
Members
Member name | Value | Description
MirrorStart | 0 |
MirrorComplete | 1 |
MirrorStop | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


ServerInfoModel Class

ServerInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServerInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServerInfoModel
Public NotInheritable Class ServerInfoModel
public ref class ServerInfoModel sealed
[<SealedAttribute>]
type ServerInfoModel =  class end

The ServerInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServerInfoModel | Initializes a new instance of the ServerInfoModel class
Top
Properties
 | Name | Description
Public property | BiosGuid | the BIOS GUID
Public property | BootVolume | the boot volume
Public property | Domain | the domain the server is a member of
Public property | FullyQualifiedDomain | the fully qualified domain name of the server
Public property | HalInternalName | the internal name of the hardware abstraction layer (HAL)
Public property | HalVersion | the version of the hardware abstraction layer (HAL)
Public property | IsClustered | a value indicating whether the server is part of a cluster
Public property | IsHostedByHyperV | a value indicating whether or not the server is hosted by Hyper-V
Public property | IsHostedByVMware | a value indicating whether or not the server is hosted by VMware
Public property | IsHostedByXen | a value indicating whether or not the server is hosted by Xen
Public property | IsHyperVHost | a value indicating whether or not the server is a Hyper-V host
Public property | IsReplicationEnabled | a value indicating whether or not replication is enabled
Public property | IsSbs | a value indicating whether or not the server is running Microsoft Windows Small Business Server
Public property | IsSse | a value indicating whether or not the server is running Microsoft Windows Storage Server
Public property | LvmOptions | LVM information for volumes
Public property | ManagementPort | the port where the management service is listening
Public property | MemorySize | the amount of memory on the server
Public property | Name | the name of the server
Public property | NetworkInterfaces | the network interfaces on the server
Public property | NodeLockedServerInfo | the node locked server information
Public property | OperatingSystem | the operating system on the server
Public property | ProcessorCount | the processor count of the server
Public property | ProgramFilesPath | the program files path
Public property | SystemPath | the system path
Public property | SystemRoot | the system root path
Public property | SystemVolume | the system volume
Public property | Volumes | the volumes on the server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServerInfoModel Constructor

ServerInfoModel Constructor
Initializes a new instance of the ServerInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerInfoModel()
Public Sub New
public:
ServerInfoModel()
new : unit -> ServerInfoModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel Properties

ServerInfoModel Properties

The ServerInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | BiosGuid | the BIOS GUID
Public property | BootVolume | the boot volume
Public property | Domain | the domain the server is a member of
Public property | FullyQualifiedDomain | the fully qualified domain name of the server
Public property | HalInternalName | the internal name of the hardware abstraction layer (HAL)
Public property | HalVersion | the version of the hardware abstraction layer (HAL)
Public property | IsClustered | a value indicating whether the server is part of a cluster
Public property | IsHostedByHyperV | a value indicating whether or not the server is hosted by Hyper-V
Public property | IsHostedByVMware | a value indicating whether or not the server is hosted by VMware
Public property | IsHostedByXen | a value indicating whether or not the server is hosted by Xen
Public property | IsHyperVHost | a value indicating whether or not the server is a Hyper-V host
Public property | IsReplicationEnabled | a value indicating whether or not replication is enabled
Public property | IsSbs | a value indicating whether or not the server is running Microsoft Windows Small Business Server
Public property | IsSse | a value indicating whether or not the server is running Microsoft Windows Storage Server
Public property | LvmOptions | LVM information for volumes
Public property | ManagementPort | the port where the management service is listening
Public property | MemorySize | the amount of memory on the server
Public property | Name | the name of the server
Public property | NetworkInterfaces | the network interfaces on the server
Public property | NodeLockedServerInfo | the node locked server information
Public property | OperatingSystem | the operating system on the server
Public property | ProcessorCount | the processor count of the server
Public property | ProgramFilesPath | the program files path
Public property | SystemPath | the system path
Public property | SystemRoot | the system root path
Public property | SystemVolume | the system volume
Public property | Volumes | the volumes on the server
Top
See Also

Reference

ServerInfoModel Class


ServerInfoModel.BiosGuid Property

ServerInfoModelBiosGuid Property
the BIOS GUID

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
member BiosGuid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ServerInfoModel Class


ServerInfoModel.BootVolume Property

ServerInfoModelBootVolume Property
the boot volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string BootVolume { get; set; }
Public Property BootVolume As String
    Get
    Set
public:
property String^ BootVolume {
    String^ get ();
    void set (String^ value);
}
member BootVolume : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Domain Property

ServerInfoModelDomain Property
the domain the server is a member of

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.FullyQualifiedDomain Property

ServerInfoModelFullyQualifiedDomain Property
the fully qualified domain name of the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string FullyQualifiedDomain { get; set; }
Public Property FullyQualifiedDomain As String
    Get
    Set
public:
property String^ FullyQualifiedDomain {
    String^ get ();
    void set (String^ value);
}
member FullyQualifiedDomain : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.HalInternalName Property

ServerInfoModelHalInternalName Property
the internal name of the hardware abstraction layer (HAL)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HalInternalName { get; set; }
Public Property HalInternalName As String
    Get
    Set
public:
property String^ HalInternalName {
    String^ get ();
    void set (String^ value);
}
member HalInternalName : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.HalVersion Property

ServerInfoModelHalVersion Property
the version of the hardware abstraction layer (HAL)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string HalVersion { get; set; }
Public Property HalVersion As String
    Get
    Set
public:
property String^ HalVersion {
    String^ get ();
    void set (String^ value);
}
member HalVersion : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsClustered Property

ServerInfoModelIsClustered Property
a value indicating whether the server is part of a cluster

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClustered { get; set; }
Public Property IsClustered As Boolean
    Get
    Set
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
member IsClustered : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHostedByHyperV Property

ServerInfoModelIsHostedByHyperV Property
a value indicating whether or not the server is hosted by Hyper-V

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHostedByHyperV { get; set; }
Public Property IsHostedByHyperV As Boolean
    Get
    Set
public:
property bool IsHostedByHyperV {
    bool get ();
    void set (bool value);
}
member IsHostedByHyperV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHostedByVMware Property

ServerInfoModelIsHostedByVMware Property
a value indicating whether or not the server is hosted by VMware

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHostedByVMware { get; set; }
Public Property IsHostedByVMware As Boolean
    Get
    Set
public:
property bool IsHostedByVMware {
    bool get ();
    void set (bool value);
}
member IsHostedByVMware : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHostedByXen Property

ServerInfoModelIsHostedByXen Property
a value indicating whether or not the server is hosted by Xen

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHostedByXen { get; set; }
Public Property IsHostedByXen As Boolean
    Get
    Set
public:
property bool IsHostedByXen {
    bool get ();
    void set (bool value);
}
member IsHostedByXen : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHyperVHost Property

ServerInfoModelIsHyperVHost Property
a value indicating whether or not the server is a Hyper-V host

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHyperVHost { get; set; }
Public Property IsHyperVHost As Boolean
    Get
    Set
public:
property bool IsHyperVHost {
    bool get ();
    void set (bool value);
}
member IsHyperVHost : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsReplicationEnabled Property

ServerInfoModelIsReplicationEnabled Property
a value indicating whether or not replication is enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
member IsReplicationEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsSbs Property

ServerInfoModelIsSbs Property
a value indicating whether or not the server is running Microsoft Windows Small Business Server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSbs { get; set; }
Public Property IsSbs As Boolean
    Get
    Set
public:
property bool IsSbs {
    bool get ();
    void set (bool value);
}
member IsSbs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsSse Property

ServerInfoModelIsSse Property
a value indicating whether or not the server is running Microsoft Windows Storage Server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSse { get; set; }
Public Property IsSse As Boolean
    Get
    Set
public:
property bool IsSse {
    bool get ();
    void set (bool value);
}
member IsSse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.LvmOptions Property

ServerInfoModelLvmOptions Property
LVM information for volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LvmOptionsModel LvmOptions { get; set; }
Public Property LvmOptions As LvmOptionsModel
    Get
    Set
public:
property LvmOptionsModel^ LvmOptions {
    LvmOptionsModel^ get ();
    void set (LvmOptionsModel^ value);
}
member LvmOptions : LvmOptionsModel with get, set

Property Value

Type: LvmOptionsModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.ManagementPort Property

ServerInfoModelManagementPort Property
the port where the management service is listening

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ManagementPort { get; set; }
Public Property ManagementPort As Integer
    Get
    Set
public:
property int ManagementPort {
    int get ();
    void set (int value);
}
member ManagementPort : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerInfoModel Class


ServerInfoModel.MemorySize Property

ServerInfoModelMemorySize Property
the amount of memory on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MemorySize { get; set; }
Public Property MemorySize As Long
    Get
    Set
public:
property long long MemorySize {
    long long get ();
    void set (long long value);
}
member MemorySize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Name Property

ServerInfoModelName Property
the name of the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.NetworkInterfaces Property

ServerInfoModelNetworkInterfaces Property
the network interfaces on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceModel[] NetworkInterfaces { get; set; }
Public Property NetworkInterfaces As NetworkInterfaceModel()
    Get
    Set
public:
property array<NetworkInterfaceModel^>^ NetworkInterfaces {
    array<NetworkInterfaceModel^>^ get ();
    void set (array<NetworkInterfaceModel^>^ value);
}
member NetworkInterfaces : NetworkInterfaceModel[] with get, set

Property Value

Type: NetworkInterfaceModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.NodeLockedServerInfo Property

ServerInfoModelNodeLockedServerInfo Property
the node locked server information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string NodeLockedServerInfo { get; set; }
Public Property NodeLockedServerInfo As String
    Get
    Set
public:
property String^ NodeLockedServerInfo {
    String^ get ();
    void set (String^ value);
}
member NodeLockedServerInfo : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.OperatingSystem Property

ServerInfoModelOperatingSystem Property
the operating system on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemModel OperatingSystem { get; set; }
Public Property OperatingSystem As OperatingSystemModel
    Get
    Set
public:
property OperatingSystemModel^ OperatingSystem {
    OperatingSystemModel^ get ();
    void set (OperatingSystemModel^ value);
}
member OperatingSystem : OperatingSystemModel with get, set

Property Value

Type: OperatingSystemModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.ProcessorCount Property

ServerInfoModelProcessorCount Property
the processor count of the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ProcessorCount { get; set; }
Public Property ProcessorCount As Integer
    Get
    Set
public:
property int ProcessorCount {
    int get ();
    void set (int value);
}
member ProcessorCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerInfoModel Class


ServerInfoModel.ProgramFilesPath Property

ServerInfoModelProgramFilesPath Property
the program files path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProgramFilesPath { get; set; }
Public Property ProgramFilesPath As String
    Get
    Set
public:
property String^ ProgramFilesPath {
    String^ get ();
    void set (String^ value);
}
member ProgramFilesPath : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.SystemPath Property

ServerInfoModelSystemPath Property
the system path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemPath { get; set; }
Public Property SystemPath As String
    Get
    Set
public:
property String^ SystemPath {
    String^ get ();
    void set (String^ value);
}
member SystemPath : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.SystemRoot Property

ServerInfoModelSystemRoot Property
the system root path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemRoot { get; set; }
Public Property SystemRoot As String
    Get
    Set
public:
property String^ SystemRoot {
    String^ get ();
    void set (String^ value);
}
member SystemRoot : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.SystemVolume Property

ServerInfoModelSystemVolume Property
the system volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemVolume { get; set; }
Public Property SystemVolume As String
    Get
    Set
public:
property String^ SystemVolume {
    String^ get ();
    void set (String^ value);
}
member SystemVolume : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Volumes Property

ServerInfoModelVolumes Property
the volumes on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel[] Volumes { get; set; }
Public Property Volumes As VolumeModel()
    Get
    Set
public:
property array<VolumeModel^>^ Volumes {
    array<VolumeModel^>^ get ();
    void set (array<VolumeModel^>^ value);
}
member Volumes : VolumeModel[] with get, set

Property Value

Type: VolumeModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel Methods

ServerInfoModel Methods

The ServerInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerInfoModel Class


ServerQualificationResultsModel Class

ServerQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServerQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServerQualificationResultsModel
Public NotInheritable Class ServerQualificationResultsModel
public ref class ServerQualificationResultsModel sealed
[<SealedAttribute>]
type ServerQualificationResultsModel =  class end

The ServerQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServerQualificationResultsModel | Initializes a new instance of the ServerQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | Cpus | the number of CPUs
Public property | Memory | the amount of RAM in bytes
Public property | Version | the version
Public property | VirtualSwitches | the virtual switches
Public property | Volumes | the volumes
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServerQualificationResultsModel Constructor

ServerQualificationResultsModel Constructor
Initializes a new instance of the ServerQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerQualificationResultsModel()
Public Sub New
public:
ServerQualificationResultsModel()
new : unit -> ServerQualificationResultsModel
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel Properties

ServerQualificationResultsModel Properties

The ServerQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | Cpus | the number of CPUs
Public property | Memory | the amount of RAM in bytes
Public property | Version | the version
Public property | VirtualSwitches | the virtual switches
Public property | Volumes | the volumes
Top
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Cpus Property

ServerQualificationResultsModelCpus Property
the number of CPUs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
member Cpus : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Memory Property

ServerQualificationResultsModelMemory Property
the amount of RAM in bytes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
member Memory : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Version Property

ServerQualificationResultsModelVersion Property
the version

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.VirtualSwitches Property

ServerQualificationResultsModelVirtualSwitches Property
the virtual switches

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitches { get; set; }
Public Property VirtualSwitches As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitches {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitches : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Volumes Property

ServerQualificationResultsModelVolumes Property
the volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeQualificationResultsModel[] Volumes { get; set; }
Public Property Volumes As VolumeQualificationResultsModel()
    Get
    Set
public:
property array<VolumeQualificationResultsModel^>^ Volumes {
    array<VolumeQualificationResultsModel^>^ get ();
    void set (array<VolumeQualificationResultsModel^>^ value);
}
member Volumes : VolumeQualificationResultsModel[] with get, set

Property Value

Type: VolumeQualificationResultsModel
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel Methods

ServerQualificationResultsModel Methods

The ServerQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerQualificationResultsModel Class


ServiceConnectionModel Class

ServiceConnectionModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceConnectionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceConnectionModel
Public NotInheritable Class ServiceConnectionModel
public ref class ServiceConnectionModel sealed
[<SealedAttribute>]
type ServiceConnectionModel =  class end

The ServiceConnectionModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceConnectionModel | Initializes a new instance of the ServiceConnectionModel class
Public method | ServiceConnectionModel(Uri) | Initializes a new instance of the ServiceConnectionModel class
Top
Properties
 | Name | Description
Public property | Credential |
Public property | Host |
Public property | Port |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceConnectionModel Constructor

ServiceConnectionModel Constructor
Overload List
 | Name | Description
Public method | ServiceConnectionModel | Initializes a new instance of the ServiceConnectionModel class
Public method | ServiceConnectionModel(Uri) | Initializes a new instance of the ServiceConnectionModel class
Top
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel Constructor

ServiceConnectionModel Constructor
Initializes a new instance of the ServiceConnectionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel()
Public Sub New
public:
ServiceConnectionModel()
new : unit -> ServiceConnectionModel
See Also

Reference

ServiceConnectionModel Class
ServiceConnectionModel Overload


ServiceConnectionModel Constructor (Uri)

ServiceConnectionModel Constructor (Uri)
Initializes a new instance of the ServiceConnectionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel(
    Uri serviceUri
)
Public Sub New (
    serviceUri As Uri
)
public:
ServiceConnectionModel(
    Uri^ serviceUri
)
new :
        serviceUri : Uri -> ServiceConnectionModel

Parameters

serviceUri
Type: SystemUri
See Also

Reference

ServiceConnectionModel Class
ServiceConnectionModel Overload


ServiceConnectionModel Properties

ServiceConnectionModel Properties

The ServiceConnectionModel type exposes the following members.

Properties
 | Name | Description
Public property | Credential |
Public property | Host |
Public property | Port |
Top
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel.Credential Property

ServiceConnectionModelCredential Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credential { get; set; }
Public Property Credential As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credential {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credential : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel.Host Property

ServiceConnectionModelHost Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Host { get; set; }
Public Property Host As String
    Get
    Set
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}
member Host : string with get, set

Property Value

Type: String
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel.Port Property

ServiceConnectionModelPort Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Port { get; set; }
Public Property Port As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Port : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel Methods

ServiceConnectionModel Methods

The ServiceConnectionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceConnectionModel Class


ServiceInformationModel Class

ServiceInformationModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceInformationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceInformationModel
Public NotInheritable Class ServiceInformationModel
public ref class ServiceInformationModel sealed
[<SealedAttribute>]
type ServiceInformationModel =  class end

The ServiceInformationModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInformationModel | Initializes a new instance of the ServiceInformationModel class
Top
Properties
 | Name | Description
Public property | DisplayName | the display name
Public property | Name | the name
Public property | Selected | a value indicating whether or not this is selected
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceInformationModel Constructor

ServiceInformationModel Constructor
Initializes a new instance of the ServiceInformationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceInformationModel()
Public Sub New
public:
ServiceInformationModel()
new : unit -> ServiceInformationModel
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel Properties

ServiceInformationModel Properties

The ServiceInformationModel type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | the display name
Public property | Name | the name
Public property | Selected | a value indicating whether or not this is selected
Top
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel.DisplayName Property

ServiceInformationModelDisplayName Property
the display name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel.Name Property

ServiceInformationModelName Property
the name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel.Selected Property

ServiceInformationModelSelected Property
a value indicating whether or not this is selected

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
member Selected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel Methods

ServiceInformationModel Methods

The ServiceInformationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceInformationModel Class


ServiceMetadataModel Class

ServiceMetadataModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceMetadataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceMetadataModel
Public NotInheritable Class ServiceMetadataModel
public ref class ServiceMetadataModel sealed
[<SealedAttribute>]
type ServiceMetadataModel =  class end

The ServiceMetadataModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMetadataModel | Initializes a new instance of the ServiceMetadataModel class
Top
Properties
 | Name | Description
Public property | MachineId |
Public property | ProductVersion |
Public property | ServerName |
Public property | ServiceTags |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceMetadataModel Constructor

ServiceMetadataModel Constructor
Initializes a new instance of the ServiceMetadataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceMetadataModel()
Public Sub New
public:
ServiceMetadataModel()
new : unit -> ServiceMetadataModel
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel Properties

ServiceMetadataModel Properties

The ServiceMetadataModel type exposes the following members.

Properties
 | Name | Description
Public property | MachineId |
Public property | ProductVersion |
Public property | ServerName |
Public property | ServiceTags |
Top
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.MachineId Property

ServiceMetadataModelMachineId Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid MachineId { get; set; }
Public Property MachineId As Guid
    Get
    Set
public:
property Guid MachineId {
    Guid get ();
    void set (Guid value);
}
member MachineId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ProductVersion Property

ServiceMetadataModelProductVersion Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}
member ProductVersion : string with get, set

Property Value

Type: String
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ServerName Property

ServiceMetadataModelServerName Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

Type: String
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ServiceTags Property

ServiceMetadataModelServiceTags Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ServiceTags { get; set; }
Public Property ServiceTags As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ServiceTags {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ServiceTags : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel Methods

ServiceMetadataModel Methods

The ServiceMetadataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceMetadataModel Class


ServiceMonitoringOptionsModel Class

ServiceMonitoringOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceMonitoringOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceMonitoringOptionsModel
Public NotInheritable Class ServiceMonitoringOptionsModel
public ref class ServiceMonitoringOptionsModel sealed
[<SealedAttribute>]
type ServiceMonitoringOptionsModel =  class end

The ServiceMonitoringOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMonitoringOptionsModel | Initializes a new instance of the ServiceMonitoringOptionsModel class
Top
Properties
 | Name | Description
Public property | RepeatCount | the number of times to repeat the call to retrieve the service status
Public property | Services | the services to be monitored
Public property | StartService | a value indicating whether or not to start a monitored service if it is stopped
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceMonitoringOptionsModel Constructor

ServiceMonitoringOptionsModel Constructor
Initializes a new instance of the ServiceMonitoringOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceMonitoringOptionsModel()
Public Sub New
public:
ServiceMonitoringOptionsModel()
new : unit -> ServiceMonitoringOptionsModel
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel Properties

ServiceMonitoringOptionsModel Properties

The ServiceMonitoringOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | RepeatCount | the number of times to repeat the call to retrieve the service status
Public property | Services | the services to be monitored
Public property | StartService | a value indicating whether or not to start a monitored service if it is stopped
Top
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel.RepeatCount Property

ServiceMonitoringOptionsModelRepeatCount Property
the number of times to repeat the call to retrieve the service status

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int RepeatCount { get; set; }
Public Property RepeatCount As Integer
    Get
    Set
public:
property int RepeatCount {
    int get ();
    void set (int value);
}
member RepeatCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel.Services Property

ServiceMonitoringOptionsModelServices Property
the services to be monitored

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceInformationModel[] Services { get; set; }
Public Property Services As ServiceInformationModel()
    Get
    Set
public:
property array<ServiceInformationModel^>^ Services {
    array<ServiceInformationModel^>^ get ();
    void set (array<ServiceInformationModel^>^ value);
}
member Services : ServiceInformationModel[] with get, set

Property Value

Type: ServiceInformationModel
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel.StartService Property

ServiceMonitoringOptionsModelStartService Property
a value indicating whether or not to start a monitored service if it is stopped

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StartService { get; set; }
Public Property StartService As Boolean
    Get
    Set
public:
property bool StartService {
    bool get ();
    void set (bool value);
}
member StartService : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel Methods

ServiceMonitoringOptionsModel Methods

The ServiceMonitoringOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceMonitoringOptionsModel Class


ShareModel Class

ShareModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsShareModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ShareModel
Public NotInheritable Class ShareModel
public ref class ShareModel sealed
[<SealedAttribute>]
type ShareModel =  class end

The ShareModel type exposes the following members.

Constructors
 | Name | Description
Public method | ShareModel | Initializes a new instance of the ShareModel class
Top
Properties
 | Name | Description
Public property | Aces |
Public property | MaxUsers |
Public property | Name |
Public property | Path |
Public property | Type |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ShareModel Constructor

ShareModel Constructor
Initializes a new instance of the ShareModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ShareModel()
Public Sub New
public:
ShareModel()
new : unit -> ShareModel
See Also

Reference

ShareModel Class


ShareModel Properties

ShareModel Properties

The ShareModel type exposes the following members.

Properties
 | Name | Description
Public property | Aces |
Public property | MaxUsers |
Public property | Name |
Public property | Path |
Public property | Type |
Top
See Also

Reference

ShareModel Class


ShareModel.Aces Property

ShareModelAces Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<AceModel> Aces { get; set; }
Public Property Aces As IEnumerable(Of AceModel)
    Get
    Set
public:
property IEnumerable<AceModel^>^ Aces {
    IEnumerable<AceModel^>^ get ();
    void set (IEnumerable<AceModel^>^ value);
}
member Aces : IEnumerable<AceModel> with get, set

Property Value

Type: IEnumerable AceModel
See Also

Reference

ShareModel Class


ShareModel.MaxUsers Property

ShareModelMaxUsers Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> MaxUsers { get; set; }
Public Property MaxUsers As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> MaxUsers {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member MaxUsers : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ShareModel Class


ShareModel.Name Property

ShareModelName Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ShareModel Class


ShareModel.Path Property

ShareModelPath Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

ShareModel Class


ShareModel.Type Property

ShareModelType Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
See Also

Reference

ShareModel Class


ShareModel Methods

ShareModel Methods

The ShareModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShareModel Class


SimpleFailoverMonitorOptionsModel Class

SimpleFailoverMonitorOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSimpleFailoverMonitorOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SimpleFailoverMonitorOptionsModel
Public NotInheritable Class SimpleFailoverMonitorOptionsModel
public ref class SimpleFailoverMonitorOptionsModel sealed
[<SealedAttribute>]
type SimpleFailoverMonitorOptionsModel =  class end

The SimpleFailoverMonitorOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleFailoverMonitorOptionsModel | Initializes a new instance of the SimpleFailoverMonitorOptionsModel class
Top
Properties
 | Name | Description
Public property | IsUserInterventionRequired | a value indicating whether or not user intervention is required before triggering a failover
Public property | MaxPingAttempts | the maximum number of ping attempts before the IP address is considered to be failed
Public property | PingInterval | the interval at which the source address is pinged to determine a failure condition
Public property | TimeAllowed | the total time to failover
Public property | UseTimeAllowed | a value indicating whether or not to use the timeAllowed property
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SimpleFailoverMonitorOptionsModel Constructor

SimpleFailoverMonitorOptionsModel Constructor
Initializes a new instance of the SimpleFailoverMonitorOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleFailoverMonitorOptionsModel()
Public Sub New
public:
SimpleFailoverMonitorOptionsModel()
new : unit -> SimpleFailoverMonitorOptionsModel
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel Properties

SimpleFailoverMonitorOptionsModel Properties

The SimpleFailoverMonitorOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | IsUserInterventionRequired | a value indicating whether or not user intervention is required before triggering a failover
Public property | MaxPingAttempts | the maximum number of ping attempts before the IP address is considered to be failed
Public property | PingInterval | the interval at which the source address is pinged to determine a failure condition
Public property | TimeAllowed | the total time to failover
Public property | UseTimeAllowed | a value indicating whether or not to use the timeAllowed property
Top
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.IsUserInterventionRequired Property

SimpleFailoverMonitorOptionsModelIsUserInterventionRequired Property
a value indicating whether or not user intervention is required before triggering a failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUserInterventionRequired { get; set; }
Public Property IsUserInterventionRequired As Boolean
    Get
    Set
public:
property bool IsUserInterventionRequired {
    bool get ();
    void set (bool value);
}
member IsUserInterventionRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.MaxPingAttempts Property

SimpleFailoverMonitorOptionsModelMaxPingAttempts Property
the maximum number of ping attempts before the IP address is considered to be failed

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
member MaxPingAttempts : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.PingInterval Property

SimpleFailoverMonitorOptionsModelPingInterval Property
the interval at which the source address is pinged to determine a failure condition

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member PingInterval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.TimeAllowed Property

SimpleFailoverMonitorOptionsModelTimeAllowed Property
the total time to failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TimeAllowed { get; set; }
Public Property TimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
member TimeAllowed : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.UseTimeAllowed Property

SimpleFailoverMonitorOptionsModelUseTimeAllowed Property
a value indicating whether or not to use the timeAllowed property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseTimeAllowed { get; set; }
Public Property UseTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTimeAllowed {
    bool get ();
    void set (bool value);
}
member UseTimeAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel Methods

SimpleFailoverMonitorOptionsModel Methods

The SimpleFailoverMonitorOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SmtpConnectionSecurityEnum Enumeration

SmtpConnectionSecurityEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SmtpConnectionSecurityEnum
Public Enumeration SmtpConnectionSecurityEnum
public enum class SmtpConnectionSecurityEnum
type SmtpConnectionSecurityEnum
Members
Member name | Value | Description
Plain | 0 |
Ssl | 1 |
Tls | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotCreationReasonEnum Enumeration

SnapshotCreationReasonEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SnapshotCreationReasonEnum
Public Enumeration SnapshotCreationReasonEnum
public enum class SnapshotCreationReasonEnum
type SnapshotCreationReasonEnum
Members
Member name | Value | Description
Manual | 0 |
Automatic | 1 |
Scheduled | 2 |
Deferred | 3 |
DataTest | 4 |
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotEntryModel Class

SnapshotEntryModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSnapshotEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SnapshotEntryModel
Public NotInheritable Class SnapshotEntryModel
public ref class SnapshotEntryModel sealed
[<SealedAttribute>]
type SnapshotEntryModel =  class end

The SnapshotEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotEntryModel | Initializes a new instance of the SnapshotEntryModel class
Top
Properties
 | Name | Description
Public property | Comment | the comment associated with this snapshot
Public property | Id | the unqiue identifier of this snapshot
Public property | Reason | the reason for taking this snapshot
Public property | States | the state of the target server associated with this snapshot
Public property | Timestamp | the when this snapshot was taken
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotEntryModel Constructor

SnapshotEntryModel Constructor
Initializes a new instance of the SnapshotEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel()
Public Sub New
public:
SnapshotEntryModel()
new : unit -> SnapshotEntryModel
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel Properties

SnapshotEntryModel Properties

The SnapshotEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | Comment | the comment associated with this snapshot
Public property | Id | the unqiue identifier of this snapshot
Public property | Reason | the reason for taking this snapshot
Public property | States | the state of the target server associated with this snapshot
Public property | Timestamp | the when this snapshot was taken
Top
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Comment Property

SnapshotEntryModelComment Property
the comment associated with this snapshot

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Id Property

SnapshotEntryModelId Property
the unqiue identifier of this snapshot

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Reason Property

SnapshotEntryModelReason Property
the reason for taking this snapshot

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotCreationReasonEnum Reason { get; set; }
Public Property Reason As SnapshotCreationReasonEnum
    Get
    Set
public:
property SnapshotCreationReasonEnum Reason {
    SnapshotCreationReasonEnum get ();
    void set (SnapshotCreationReasonEnum value);
}
member Reason : SnapshotCreationReasonEnum with get, set

Property Value

Type: SnapshotCreationReasonEnum
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.States Property

SnapshotEntryModelStates Property
the state of the target server associated with this snapshot

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStatesEnum States { get; set; }
Public Property States As TargetStatesEnum
    Get
    Set
public:
property TargetStatesEnum States {
    TargetStatesEnum get ();
    void set (TargetStatesEnum value);
}
member States : TargetStatesEnum with get, set

Property Value

Type: TargetStatesEnum
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Timestamp Property

SnapshotEntryModelTimestamp Property
the when this snapshot was taken

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member Timestamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel Methods

SnapshotEntryModel Methods

The SnapshotEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SnapshotEntryModel Class


SnapshotScheduleModel Class

SnapshotScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsSnapshotScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SnapshotScheduleModel : ScheduleItemModel
Public NotInheritable Class SnapshotScheduleModel
    Inherits ScheduleItemModel
public ref class SnapshotScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type SnapshotScheduleModel =
    class
        inherit ScheduleItemModel
    end

The SnapshotScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotScheduleModel | Initializes a new instance of the SnapshotScheduleModel class
Top
Properties
 | Name | Description
Public property | Interval | the interval
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | MaxNumberOfSnapshots | the maximum number of snapshots
Public property | StartTime | the start time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotScheduleModel Constructor

SnapshotScheduleModel Constructor
Initializes a new instance of the SnapshotScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotScheduleModel()
Public Sub New
public:
SnapshotScheduleModel()
new : unit -> SnapshotScheduleModel
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel Properties

SnapshotScheduleModel Properties

The SnapshotScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Interval | the interval
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | MaxNumberOfSnapshots | the maximum number of snapshots
Public property | StartTime | the start time
Top
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel.Interval Property

SnapshotScheduleModelInterval Property
the interval

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Interval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel.MaxNumberOfSnapshots Property

SnapshotScheduleModelMaxNumberOfSnapshots Property
the maximum number of snapshots

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int MaxNumberOfSnapshots { get; set; }
Public Property MaxNumberOfSnapshots As Integer
    Get
    Set
public:
property int MaxNumberOfSnapshots {
    int get ();
    void set (int value);
}
member MaxNumberOfSnapshots : int with get, set

Property Value

Type: Int32
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel.StartTime Property

SnapshotScheduleModelStartTime Property
the start time

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel Methods

SnapshotScheduleModel Methods

The SnapshotScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SnapshotScheduleModel Class


SsmRecoveryTypeEnum Enumeration

SsmRecoveryTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum SsmRecoveryTypeEnum
Public Enumeration SsmRecoveryTypeEnum
public enum class SsmRecoveryTypeEnum
type SsmRecoveryTypeEnum
Members
Member name | Value | Description
LAN | 0 |
WAN | 1 |
See Also

Reference

DoubleTake.Web.Models Namespace


SwitchPortInfoModel Class

SwitchPortInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSwitchPortInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SwitchPortInfoModel
Public NotInheritable Class SwitchPortInfoModel
public ref class SwitchPortInfoModel sealed
[<SealedAttribute>]
type SwitchPortInfoModel =  class end

The SwitchPortInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchPortInfoModel | Initializes a new instance of the SwitchPortInfoModel class
Top
Properties
 | Name | Description
Public property | AccessVLanId | the VLan Id
Public property | Guid | the switch port Guid.
Public property | Name | the switch port label
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SwitchPortInfoModel Constructor

SwitchPortInfoModel Constructor
Initializes a new instance of the SwitchPortInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SwitchPortInfoModel()
Public Sub New
public:
SwitchPortInfoModel()
new : unit -> SwitchPortInfoModel
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel Properties

SwitchPortInfoModel Properties

The SwitchPortInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessVLanId | the VLan Id
Public property | Guid | the switch port Guid.
Public property | Name | the switch port label
Top
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.AccessVLanId Property

SwitchPortInfoModelAccessVLanId Property
the VLan Id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int AccessVLanId { get; set; }
Public Property AccessVLanId As Integer
    Get
    Set
public:
property int AccessVLanId {
    int get ();
    void set (int value);
}
member AccessVLanId : int with get, set

Property Value

Type: Int32
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.Guid Property

SwitchPortInfoModelGuid Property
the switch port Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
member Guid : string with get, set

Property Value

Type: String
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.Name Property

SwitchPortInfoModelName Property
the switch port label

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel Methods

SwitchPortInfoModel Methods

The SwitchPortInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SwitchPortInfoModel Class


SystemStateOptionsModel Class

SystemStateOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStateOptionsModel
Public NotInheritable Class SystemStateOptionsModel
public ref class SystemStateOptionsModel sealed
[<SealedAttribute>]
type SystemStateOptionsModel =  class end

The SystemStateOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateOptionsModel | Initializes a new instance of the SystemStateOptionsModel class
Top
Properties
 | Name | Description
Public property | AlternateVolumeMapping | the alternate volume used for staging
Public property | AlternateVolumeStaging | a value indicating whether or not the system volume staging will be done on an alternate volume
Public property | ApplyPorts | a value indicating whether source engine and management service ports should be copied to the target
Public property | ClearMonitor | a value indicating whether or not the failover monitor should be removed at cutover.
Public property | IsWanFailover | a value indicating whether or not this job uses WAN failover
Public property | KeepTargetActivationCode | a value indicating whether or not the target activation code should be kept after failover
Public property | NicMappings | the network interface mappings
Public property | ServicesToStopOptions | the services on the target server to stop during protection
Public property | ShouldApplyDiskSignatures | a value indicating whether or not disk signatures should be applied at cutover
Public property | SourceReservedAddress | the reserved IP address on the source server
Public property | StagingFolder | the folder where operating system files will be staged
Public property | TargetReservedAddress | the reserved IP address on the target server
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateOptionsModel Constructor

SystemStateOptionsModel Constructor
Initializes a new instance of the SystemStateOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SystemStateOptionsModel()
Public Sub New
public:
SystemStateOptionsModel()
new : unit -> SystemStateOptionsModel
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel Properties

SystemStateOptionsModel Properties

The SystemStateOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AlternateVolumeMapping | the alternate volume used for staging
Public property | AlternateVolumeStaging | a value indicating whether or not the system volume staging will be done on an alternate volume
Public property | ApplyPorts | a value indicating whether source engine and management service ports should be copied to the target
Public property | ClearMonitor | a value indicating whether or not the failover monitor should be removed at cutover.
Public property | IsWanFailover | a value indicating whether or not this job uses WAN failover
Public property | KeepTargetActivationCode | a value indicating whether or not the target activation code should be kept after failover
Public property | NicMappings | the network interface mappings
Public property | ServicesToStopOptions | the services on the target server to stop during protection
Public property | ShouldApplyDiskSignatures | a value indicating whether or not disk signatures should be applied at cutover
Public property | SourceReservedAddress | the reserved IP address on the source server
Public property | StagingFolder | the folder where operating system files will be staged
Public property | TargetReservedAddress | the reserved IP address on the target server
Top
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.AlternateVolumeMapping Property

SystemStateOptionsModelAlternateVolumeMapping Property
the alternate volume used for staging

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string AlternateVolumeMapping { get; set; }
Public Property AlternateVolumeMapping As String
    Get
    Set
public:
property String^ AlternateVolumeMapping {
    String^ get ();
    void set (String^ value);
}
member AlternateVolumeMapping : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.AlternateVolumeStaging Property

SystemStateOptionsModelAlternateVolumeStaging Property
a value indicating whether or not the system volume staging will be done on an alternate volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlternateVolumeStaging { get; set; }
Public Property AlternateVolumeStaging As Boolean
    Get
    Set
public:
property bool AlternateVolumeStaging {
    bool get ();
    void set (bool value);
}
member AlternateVolumeStaging : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ApplyPorts Property

SystemStateOptionsModelApplyPorts Property
a value indicating whether source engine and management service ports should be copied to the target

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> ApplyPorts { get; set; }
Public Property ApplyPorts As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ApplyPorts {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member ApplyPorts : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ClearMonitor Property

SystemStateOptionsModelClearMonitor Property
a value indicating whether or not the failover monitor should be removed at cutover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearMonitor { get; set; }
Public Property ClearMonitor As Boolean
    Get
    Set
public:
property bool ClearMonitor {
    bool get ();
    void set (bool value);
}
member ClearMonitor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.IsWanFailover Property

SystemStateOptionsModelIsWanFailover Property
a value indicating whether or not this job uses WAN failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWanFailover { get; set; }
Public Property IsWanFailover As Boolean
    Get
    Set
public:
property bool IsWanFailover {
    bool get ();
    void set (bool value);
}
member IsWanFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.KeepTargetActivationCode Property

SystemStateOptionsModelKeepTargetActivationCode Property
a value indicating whether or not the target activation code should be kept after failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool KeepTargetActivationCode { get; set; }
Public Property KeepTargetActivationCode As Boolean
    Get
    Set
public:
property bool KeepTargetActivationCode {
    bool get ();
    void set (bool value);
}
member KeepTargetActivationCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.NicMappings Property

SystemStateOptionsModelNicMappings Property
the network interface mappings

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel[] NicMappings { get; set; }
Public Property NicMappings As FullServerNicMappingsModel()
    Get
    Set
public:
property array<FullServerNicMappingsModel^>^ NicMappings {
    array<FullServerNicMappingsModel^>^ get ();
    void set (array<FullServerNicMappingsModel^>^ value);
}
member NicMappings : FullServerNicMappingsModel[] with get, set

Property Value

Type: FullServerNicMappingsModel
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ServicesToStopOptions Property

SystemStateOptionsModelServicesToStopOptions Property
the services on the target server to stop during protection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesToStopModel[] ServicesToStopOptions { get; set; }
Public Property ServicesToStopOptions As TargetServicesToStopModel()
    Get
    Set
public:
property array<TargetServicesToStopModel^>^ ServicesToStopOptions {
    array<TargetServicesToStopModel^>^ get ();
    void set (array<TargetServicesToStopModel^>^ value);
}
member ServicesToStopOptions : TargetServicesToStopModel[] with get, set

Property Value

Type: TargetServicesToStopModel
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ShouldApplyDiskSignatures Property

SystemStateOptionsModelShouldApplyDiskSignatures Property
a value indicating whether or not disk signatures should be applied at cutover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldApplyDiskSignatures { get; set; }
Public Property ShouldApplyDiskSignatures As Boolean
    Get
    Set
public:
property bool ShouldApplyDiskSignatures {
    bool get ();
    void set (bool value);
}
member ShouldApplyDiskSignatures : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.SourceReservedAddress Property

SystemStateOptionsModelSourceReservedAddress Property
the reserved IP address on the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceReservedAddress { get; set; }
Public Property SourceReservedAddress As String
    Get
    Set
public:
property String^ SourceReservedAddress {
    String^ get ();
    void set (String^ value);
}
member SourceReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.StagingFolder Property

SystemStateOptionsModelStagingFolder Property
the folder where operating system files will be staged

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string StagingFolder { get; set; }
Public Property StagingFolder As String
    Get
    Set
public:
property String^ StagingFolder {
    String^ get ();
    void set (String^ value);
}
member StagingFolder : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.TargetReservedAddress Property

SystemStateOptionsModelTargetReservedAddress Property
the reserved IP address on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetReservedAddress { get; set; }
Public Property TargetReservedAddress As String
    Get
    Set
public:
property String^ TargetReservedAddress {
    String^ get ();
    void set (String^ value);
}
member TargetReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel Methods

SystemStateOptionsModel Methods

The SystemStateOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateOptionsModel Class


TargetFileServerQualificationResultsModel Class

TargetFileServerQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetFileServerQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetFileServerQualificationResultsModel
Public NotInheritable Class TargetFileServerQualificationResultsModel
public ref class TargetFileServerQualificationResultsModel sealed
[<SealedAttribute>]
type TargetFileServerQualificationResultsModel =  class end

The TargetFileServerQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetFileServerQualificationResultsModel | Initializes a new instance of the TargetFileServerQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupAddresses | the cluster resource group IP addresses
Public property | ClusterResourceGroupName | the name of the group that contains the resource
Public property | CurrentOwnerNodeName | the name of the resource's current owner node
Public property | DiskSize | the volume total disk size
Public property | DriveLetter | the volume drive letter
Public property | FreeSpace | the volume available free space
Public property | IsVolumeCSV | the value if it is a cluster shared volume
Public property | RecommendedGroup | the recommended group
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetFileServerQualificationResultsModel Constructor

TargetFileServerQualificationResultsModel Constructor
Initializes a new instance of the TargetFileServerQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFileServerQualificationResultsModel()
Public Sub New
public:
TargetFileServerQualificationResultsModel()
new : unit -> TargetFileServerQualificationResultsModel
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel Properties

TargetFileServerQualificationResultsModel Properties

The TargetFileServerQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupAddresses | the cluster resource group IP addresses
Public property | ClusterResourceGroupName | the name of the group that contains the resource
Public property | CurrentOwnerNodeName | the name of the resource's current owner node
Public property | DiskSize | the volume total disk size
Public property | DriveLetter | the volume drive letter
Public property | FreeSpace | the volume available free space
Public property | IsVolumeCSV | the value if it is a cluster shared volume
Public property | RecommendedGroup | the recommended group
Top
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.ClusterResourceGroupAddresses Property

TargetFileServerQualificationResultsModelClusterResourceGroupAddresses Property
the cluster resource group IP addresses

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] ClusterResourceGroupAddresses { get; set; }
Public Property ClusterResourceGroupAddresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ ClusterResourceGroupAddresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member ClusterResourceGroupAddresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.ClusterResourceGroupName Property

TargetFileServerQualificationResultsModelClusterResourceGroupName Property
the name of the group that contains the resource

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
member ClusterResourceGroupName : string with get, set

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.CurrentOwnerNodeName Property

TargetFileServerQualificationResultsModelCurrentOwnerNodeName Property
the name of the resource's current owner node

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
member CurrentOwnerNodeName : string with get, set

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.DiskSize Property

TargetFileServerQualificationResultsModelDiskSize Property
the volume total disk size

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
member DiskSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.DriveLetter Property

TargetFileServerQualificationResultsModelDriveLetter Property
the volume drive letter

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
member DriveLetter : string with get, set

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.FreeSpace Property

TargetFileServerQualificationResultsModelFreeSpace Property
the volume available free space

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
member FreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.IsVolumeCSV Property

TargetFileServerQualificationResultsModelIsVolumeCSV Property
the value if it is a cluster shared volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
member IsVolumeCSV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.RecommendedGroup Property

TargetFileServerQualificationResultsModelRecommendedGroup Property
the recommended group

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool RecommendedGroup { get; set; }
Public Property RecommendedGroup As Boolean
    Get
    Set
public:
property bool RecommendedGroup {
    bool get ();
    void set (bool value);
}
member RecommendedGroup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel Methods

TargetFileServerQualificationResultsModel Methods

The TargetFileServerQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetServicesOptionsModel Class

TargetServicesOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetServicesOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetServicesOptionsModel
Public NotInheritable Class TargetServicesOptionsModel
public ref class TargetServicesOptionsModel sealed
[<SealedAttribute>]
type TargetServicesOptionsModel =  class end

The TargetServicesOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesOptionsModel | Initializes a new instance of the TargetServicesOptionsModel class
Top
Properties
 | Name | Description
Public property | FailoverServices | the failover services
Public property | StartAndStopServices | a value indicating whether or not to start and stop services
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetServicesOptionsModel Constructor

TargetServicesOptionsModel Constructor
Initializes a new instance of the TargetServicesOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesOptionsModel()
Public Sub New
public:
TargetServicesOptionsModel()
new : unit -> TargetServicesOptionsModel
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel Properties

TargetServicesOptionsModel Properties

The TargetServicesOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverServices | the failover services
Public property | StartAndStopServices | a value indicating whether or not to start and stop services
Top
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel.FailoverServices Property

TargetServicesOptionsModelFailoverServices Property
the failover services

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceInformationModel[] FailoverServices { get; set; }
Public Property FailoverServices As ServiceInformationModel()
    Get
    Set
public:
property array<ServiceInformationModel^>^ FailoverServices {
    array<ServiceInformationModel^>^ get ();
    void set (array<ServiceInformationModel^>^ value);
}
member FailoverServices : ServiceInformationModel[] with get, set

Property Value

Type: ServiceInformationModel
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel.StartAndStopServices Property

TargetServicesOptionsModelStartAndStopServices Property
a value indicating whether or not to start and stop services

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool StartAndStopServices { get; set; }
Public Property StartAndStopServices As Boolean
    Get
    Set
public:
property bool StartAndStopServices {
    bool get ();
    void set (bool value);
}
member StartAndStopServices : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel Methods

TargetServicesOptionsModel Methods

The TargetServicesOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetServicesOptionsModel Class


TargetServiceStatusEnum Enumeration

TargetServiceStatusEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TargetServiceStatusEnum
Public Enumeration TargetServiceStatusEnum
public enum class TargetServiceStatusEnum
type TargetServiceStatusEnum
Members
Member name | Value | Description
Stopped | 0 |
Started | 1 |
StopPending | 2 |
StartPending | 3 |
ResumePending | 4 |
PausePending | 5 |
Paused | 6 |
Unknown | 7 |
See Also

Reference

DoubleTake.Web.Models Namespace


TargetServicesToStopModel Class

TargetServicesToStopModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetServicesToStopModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetServicesToStopModel
Public NotInheritable Class TargetServicesToStopModel
public ref class TargetServicesToStopModel sealed
[<SealedAttribute>]
type TargetServicesToStopModel =  class end

The TargetServicesToStopModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesToStopModel | Initializes a new instance of the TargetServicesToStopModel class
Top
Properties
 | Name | Description
Public property | Failover | a value indicating whether to start this service after failover
Public property | IsCritical | a value indicating whether this service is critical
Public property | KeepRunningNonCritical | a value indicating whether to keep running this non-critical service
Public property | ServiceDescription | the service description
Public property | ServiceName | the name of the service
Public property | State | the state of this service
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetServicesToStopModel Constructor

TargetServicesToStopModel Constructor
Initializes a new instance of the TargetServicesToStopModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesToStopModel()
Public Sub New
public:
TargetServicesToStopModel()
new : unit -> TargetServicesToStopModel
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel Properties

TargetServicesToStopModel Properties

The TargetServicesToStopModel type exposes the following members.

Properties
 | Name | Description
Public property | Failover | a value indicating whether to start this service after failover
Public property | IsCritical | a value indicating whether this service is critical
Public property | KeepRunningNonCritical | a value indicating whether to keep running this non-critical service
Public property | ServiceDescription | the service description
Public property | ServiceName | the name of the service
Public property | State | the state of this service
Top
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.Failover Property

TargetServicesToStopModelFailover Property
a value indicating whether to start this service after failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool Failover { get; set; }
Public Property Failover As Boolean
    Get
    Set
public:
property bool Failover {
    bool get ();
    void set (bool value);
}
member Failover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.IsCritical Property

TargetServicesToStopModelIsCritical Property
a value indicating whether this service is critical

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCritical { get; set; }
Public Property IsCritical As Boolean
    Get
    Set
public:
property bool IsCritical {
    bool get ();
    void set (bool value);
}
member IsCritical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.KeepRunningNonCritical Property

TargetServicesToStopModelKeepRunningNonCritical Property
a value indicating whether to keep running this non-critical service

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool KeepRunningNonCritical { get; set; }
Public Property KeepRunningNonCritical As Boolean
    Get
    Set
public:
property bool KeepRunningNonCritical {
    bool get ();
    void set (bool value);
}
member KeepRunningNonCritical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.ServiceDescription Property

TargetServicesToStopModelServiceDescription Property
the service description

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceDescription { get; set; }
Public Property ServiceDescription As String
    Get
    Set
public:
property String^ ServiceDescription {
    String^ get ();
    void set (String^ value);
}
member ServiceDescription : string with get, set

Property Value

Type: String
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.ServiceName Property

TargetServicesToStopModelServiceName Property
the name of the service

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.State Property

TargetServicesToStopModelState Property
the state of this service

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServiceStatusEnum State { get; set; }
Public Property State As TargetServiceStatusEnum
    Get
    Set
public:
property TargetServiceStatusEnum State {
    TargetServiceStatusEnum get ();
    void set (TargetServiceStatusEnum value);
}
member State : TargetServiceStatusEnum with get, set

Property Value

Type: TargetServiceStatusEnum
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel Methods

TargetServicesToStopModel Methods

The TargetServicesToStopModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetServicesToStopModel Class


TargetStateInfoModel Class

TargetStateInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetStateInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetStateInfoModel
Public NotInheritable Class TargetStateInfoModel
public ref class TargetStateInfoModel sealed
[<SealedAttribute>]
type TargetStateInfoModel =  class end

The TargetStateInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateInfoModel | Initializes a new instance of the TargetStateInfoModel class
Top
Properties
 | Name | Description
Public property | ConnectionId | the unique identifier of the connection
Public property | ConnectTime | the time this connection was created
Public property | EngineConnectionId | the engine connection id
Public property | EngineJobType | the engine job type of the connection
Public property | HasSnapshotSchedule | a value indicating whether this connection has a snapshot schedule
Public property | LastUpdateTime | the last time this target connection information was updated
Public property | NextScheduledSnapshot | the time of the next scheduled snapshot
Public property | Paths | the paths used on the target server
Public property | QueueBytes | the target queue bytes
Public property | ReplicationSetName | the name of the replication set
Public property | ReplicationSetUsageType | the usage type of the replication set that is connected
Public property | ScheduledSnapshotInterval | the scheduled snapshot interval
Public property | Snapshots | the current list of snapshots taken for this connection
Public property | SourceEndpoint | the source endpoint
Public property | SourceEndpointFromSource | the default address for the source server as provided by the source server
Public property | SourceMachineName | the name of the source machine
Public property | SourceVersion | the product version of the source machine
Public property | TargetEndpoint | the destination endpoint of the socket connection
Public property | TargetStates | the target states
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetStateInfoModel Constructor

TargetStateInfoModel Constructor
Initializes a new instance of the TargetStateInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateInfoModel()
Public Sub New
public:
TargetStateInfoModel()
new : unit -> TargetStateInfoModel
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel Properties

TargetStateInfoModel Properties

The TargetStateInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionId | the unique identifier of the connection
Public property | ConnectTime | the time this connection was created
Public property | EngineConnectionId | the engine connection id
Public property | EngineJobType | the engine job type of the connection
Public property | HasSnapshotSchedule | a value indicating whether this connection has a snapshot schedule
Public property | LastUpdateTime | the last time this target connection information was updated
Public property | NextScheduledSnapshot | the time of the next scheduled snapshot
Public property | Paths | the paths used on the target server
Public property | QueueBytes | the target queue bytes
Public property | ReplicationSetName | the name of the replication set
Public property | ReplicationSetUsageType | the usage type of the replication set that is connected
Public property | ScheduledSnapshotInterval | the scheduled snapshot interval
Public property | Snapshots | the current list of snapshots taken for this connection
Public property | SourceEndpoint | the source endpoint
Public property | SourceEndpointFromSource | the default address for the source server as provided by the source server
Public property | SourceMachineName | the name of the source machine
Public property | SourceVersion | the product version of the source machine
Public property | TargetEndpoint | the destination endpoint of the socket connection
Public property | TargetStates | the target states
Top
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ConnectionId Property

TargetStateInfoModelConnectionId Property
the unique identifier of the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
member ConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ConnectTime Property

TargetStateInfoModelConnectTime Property
the time this connection was created

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset ConnectTime { get; set; }
Public Property ConnectTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset ConnectTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member ConnectTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.EngineConnectionId Property

TargetStateInfoModelEngineConnectionId Property
the engine connection id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int EngineConnectionId { get; set; }
Public Property EngineConnectionId As Integer
    Get
    Set
public:
property int EngineConnectionId {
    int get ();
    void set (int value);
}
member EngineConnectionId : int with get, set

Property Value

Type: Int32
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.EngineJobType Property

TargetStateInfoModelEngineJobType Property
the engine job type of the connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public EngineJobTypeEnum EngineJobType { get; set; }
Public Property EngineJobType As EngineJobTypeEnum
    Get
    Set
public:
property EngineJobTypeEnum EngineJobType {
    EngineJobTypeEnum get ();
    void set (EngineJobTypeEnum value);
}
member EngineJobType : EngineJobTypeEnum with get, set

Property Value

Type: EngineJobTypeEnum
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.HasSnapshotSchedule Property

TargetStateInfoModelHasSnapshotSchedule Property
a value indicating whether this connection has a snapshot schedule

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSnapshotSchedule { get; set; }
Public Property HasSnapshotSchedule As Boolean
    Get
    Set
public:
property bool HasSnapshotSchedule {
    bool get ();
    void set (bool value);
}
member HasSnapshotSchedule : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.LastUpdateTime Property

TargetStateInfoModelLastUpdateTime Property
the last time this target connection information was updated

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastUpdateTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member LastUpdateTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.NextScheduledSnapshot Property

TargetStateInfoModelNextScheduledSnapshot Property
the time of the next scheduled snapshot

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset NextScheduledSnapshot { get; set; }
Public Property NextScheduledSnapshot As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextScheduledSnapshot {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member NextScheduledSnapshot : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.Paths Property

TargetStateInfoModelPaths Property
the paths used on the target server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Paths : string[] with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.QueueBytes Property

TargetStateInfoModelQueueBytes Property
the target queue bytes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long QueueBytes { get; set; }
Public Property QueueBytes As Long
    Get
    Set
public:
property long long QueueBytes {
    long long get ();
    void set (long long value);
}
member QueueBytes : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ReplicationSetName Property

TargetStateInfoModelReplicationSetName Property
the name of the replication set

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ReplicationSetUsageType Property

TargetStateInfoModelReplicationSetUsageType Property
the usage type of the replication set that is connected

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicationSetUsageTypeEnum ReplicationSetUsageType { get; set; }
Public Property ReplicationSetUsageType As ReplicationSetUsageTypeEnum
    Get
    Set
public:
property ReplicationSetUsageTypeEnum ReplicationSetUsageType {
    ReplicationSetUsageTypeEnum get ();
    void set (ReplicationSetUsageTypeEnum value);
}
member ReplicationSetUsageType : ReplicationSetUsageTypeEnum with get, set

Property Value

Type: ReplicationSetUsageTypeEnum
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ScheduledSnapshotInterval Property

TargetStateInfoModelScheduledSnapshotInterval Property
the scheduled snapshot interval

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan ScheduledSnapshotInterval { get; set; }
Public Property ScheduledSnapshotInterval As TimeSpan
    Get
    Set
public:
property TimeSpan ScheduledSnapshotInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member ScheduledSnapshotInterval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.Snapshots Property

TargetStateInfoModelSnapshots Property
the current list of snapshots taken for this connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntryModel()
    Get
    Set
public:
property array<SnapshotEntryModel^>^ Snapshots {
    array<SnapshotEntryModel^>^ get ();
    void set (array<SnapshotEntryModel^>^ value);
}
member Snapshots : SnapshotEntryModel[] with get, set

Property Value

Type: SnapshotEntryModel
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceEndpoint Property

TargetStateInfoModelSourceEndpoint Property
the source endpoint

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceEndpointFromSource Property

TargetStateInfoModelSourceEndpointFromSource Property
the default address for the source server as provided by the source server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpointFromSource { get; set; }
Public Property SourceEndpointFromSource As String
    Get
    Set
public:
property String^ SourceEndpointFromSource {
    String^ get ();
    void set (String^ value);
}
member SourceEndpointFromSource : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceMachineName Property

TargetStateInfoModelSourceMachineName Property
the name of the source machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceVersion Property

TargetStateInfoModelSourceVersion Property
the product version of the source machine

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel SourceVersion { get; set; }
Public Property SourceVersion As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ SourceVersion {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member SourceVersion : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.TargetEndpoint Property

TargetStateInfoModelTargetEndpoint Property
the destination endpoint of the socket connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetEndpoint { get; set; }
Public Property TargetEndpoint As String
    Get
    Set
public:
property String^ TargetEndpoint {
    String^ get ();
    void set (String^ value);
}
member TargetEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.TargetStates Property

TargetStateInfoModelTargetStates Property
the target states

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStatesEnum TargetStates { get; set; }
Public Property TargetStates As TargetStatesEnum
    Get
    Set
public:
property TargetStatesEnum TargetStates {
    TargetStatesEnum get ();
    void set (TargetStatesEnum value);
}
member TargetStates : TargetStatesEnum with get, set

Property Value

Type: TargetStatesEnum
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel Methods

TargetStateInfoModel Methods

The TargetStateInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetStateInfoModel Class


TargetStatesEnum Enumeration

TargetStatesEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum TargetStatesEnum
<FlagsAttribute>
Public Enumeration TargetStatesEnum
[FlagsAttribute]
public enum class TargetStatesEnum
[<FlagsAttribute>]
type TargetStatesEnum
Members
Member name | Value | Description
Good | 0 |
Mirroring | 1 |
MirrorStopped | 2 |
OpDropped | 4 |
Retrying | 8 |
Paused | 16 |
PausePending | 32 |
RestoreRequired | 64 |
ReplicationPending | 128 |
SnapshotReverted | 256 |
FailoverUnblocked | 512 |
Disconnected | 1024 |
SroImage | 2048 |
FailoverMonitoring | 4096 |
TransactionsPending | 8192 |
GCReplicationComplete | 16384 |
MarkedForDeletion | 32768 |
JobNotReadyOnTarget | 65536 |
TargetPathBlocked | 2147483648 |
Unknown | -4294967296 |
See Also

Reference

DoubleTake.Web.Models Namespace


TestScriptRequestModel Class

TestScriptRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTestScriptRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TestScriptRequestModel
Public NotInheritable Class TestScriptRequestModel
public ref class TestScriptRequestModel sealed
[<SealedAttribute>]
type TestScriptRequestModel =  class end

The TestScriptRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | TestScriptRequestModel | Initializes a new instance of the TestScriptRequestModel class
Top
Properties
 | Name | Description
Public property | Arguments |
Public property | InteractionMode |
Public property | ScriptPath |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TestScriptRequestModel Constructor

TestScriptRequestModel Constructor
Initializes a new instance of the TestScriptRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TestScriptRequestModel()
Public Sub New
public:
TestScriptRequestModel()
new : unit -> TestScriptRequestModel
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel Properties

TestScriptRequestModel Properties

The TestScriptRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments |
Public property | InteractionMode |
Public property | ScriptPath |
Top
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel.Arguments Property

TestScriptRequestModelArguments Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel.InteractionMode Property

TestScriptRequestModelInteractionMode Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DesktopInteractionModeEnum InteractionMode { get; set; }
Public Property InteractionMode As DesktopInteractionModeEnum
    Get
    Set
public:
property DesktopInteractionModeEnum InteractionMode {
    DesktopInteractionModeEnum get ();
    void set (DesktopInteractionModeEnum value);
}
member InteractionMode : DesktopInteractionModeEnum with get, set

Property Value

Type: DesktopInteractionModeEnum
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel.ScriptPath Property

TestScriptRequestModelScriptPath Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptPath { get; set; }
Public Property ScriptPath As String
    Get
    Set
public:
property String^ ScriptPath {
    String^ get ();
    void set (String^ value);
}
member ScriptPath : string with get, set

Property Value

Type: String
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel Methods

TestScriptRequestModel Methods

The TestScriptRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TestScriptRequestModel Class


TimeWindowModel Class

TimeWindowModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTimeWindowModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TimeWindowModel
Public NotInheritable Class TimeWindowModel
public ref class TimeWindowModel sealed
[<SealedAttribute>]
type TimeWindowModel =  class end

The TimeWindowModel type exposes the following members.

Constructors
 | Name | Description
Public method | TimeWindowModel | Initializes a new instance of the TimeWindowModel class
Top
Properties
 | Name | Description
Public property | Duration | the duration
Public property | Start | the start time
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TimeWindowModel Constructor

TimeWindowModel Constructor
Initializes a new instance of the TimeWindowModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeWindowModel()
Public Sub New
public:
TimeWindowModel()
new : unit -> TimeWindowModel
See Also

Reference

TimeWindowModel Class


TimeWindowModel Properties

TimeWindowModel Properties

The TimeWindowModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | the duration
Public property | Start | the start time
Top
See Also

Reference

TimeWindowModel Class


TimeWindowModel.Duration Property

TimeWindowModelDuration Property
the duration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Duration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

TimeWindowModel Class


TimeWindowModel.Start Property

TimeWindowModelStart Property
the start time

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime Start { get; set; }
Public Property Start As DateTime
    Get
    Set
public:
property DateTime Start {
    DateTime get ();
    void set (DateTime value);
}
member Start : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

TimeWindowModel Class


TimeWindowModel Methods

TimeWindowModel Methods

The TimeWindowModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TimeWindowModel Class


TransmissionModeEnum Enumeration

TransmissionModeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum TransmissionModeEnum
Public Enumeration TransmissionModeEnum
public enum class TransmissionModeEnum
type TransmissionModeEnum
Members
Member name | Value | Description
Error | 0 |
Paused | 1 |
Started | 2 |
Scheduled | 3 |
Stopped | 4 |
Unknown | 5 |
See Also

Reference

DoubleTake.Web.Models Namespace


TransmissionScheduleModel Class

TransmissionScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsTransmissionScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TransmissionScheduleModel : ScheduleItemModel
Public NotInheritable Class TransmissionScheduleModel
    Inherits ScheduleItemModel
public ref class TransmissionScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type TransmissionScheduleModel =
    class
        inherit ScheduleItemModel
    end

The TransmissionScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | TransmissionScheduleModel | Initializes a new instance of the TransmissionScheduleModel class
Top
Properties
 | Name | Description
Public property | Duration | the duration
Public property | Interval | the interval
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | MaxBytes | the maximum bytes
Public property | StartTime | the start time
Public property | ThresholdBytes | the threshold bytes
Public property | ThresholdPercentage | the threshold as a percentage
Public property | Window | the time window
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TransmissionScheduleModel Constructor

TransmissionScheduleModel Constructor
Initializes a new instance of the TransmissionScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionScheduleModel()
Public Sub New
public:
TransmissionScheduleModel()
new : unit -> TransmissionScheduleModel
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel Properties

TransmissionScheduleModel Properties

The TransmissionScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | the duration
Public property | Interval | the interval
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | MaxBytes | the maximum bytes
Public property | StartTime | the start time
Public property | ThresholdBytes | the threshold bytes
Public property | ThresholdPercentage | the threshold as a percentage
Public property | Window | the time window
Top
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.Duration Property

TransmissionScheduleModelDuration Property
the duration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Duration { get; set; }
Public Property Duration As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Duration {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Duration : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.Interval Property

TransmissionScheduleModelInterval Property
the interval

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Interval { get; set; }
Public Property Interval As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Interval {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Interval : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.MaxBytes Property

TransmissionScheduleModelMaxBytes Property
the maximum bytes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> MaxBytes { get; set; }
Public Property MaxBytes As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> MaxBytes {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member MaxBytes : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.StartTime Property

TransmissionScheduleModelStartTime Property
the start time

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> StartTime { get; set; }
Public Property StartTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> StartTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member StartTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.ThresholdBytes Property

TransmissionScheduleModelThresholdBytes Property
the threshold bytes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> ThresholdBytes { get; set; }
Public Property ThresholdBytes As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> ThresholdBytes {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member ThresholdBytes : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.ThresholdPercentage Property

TransmissionScheduleModelThresholdPercentage Property
the threshold as a percentage

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> ThresholdPercentage { get; set; }
Public Property ThresholdPercentage As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> ThresholdPercentage {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member ThresholdPercentage : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.Window Property

TransmissionScheduleModelWindow Property
the time window

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeWindowModel Window { get; set; }
Public Property Window As TimeWindowModel
    Get
    Set
public:
property TimeWindowModel^ Window {
    TimeWindowModel^ get ();
    void set (TimeWindowModel^ value);
}
member Window : TimeWindowModel with get, set

Property Value

Type: TimeWindowModel
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel Methods

TransmissionScheduleModel Methods

The TransmissionScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TransmissionScheduleModel Class


UnicastIPAddressModel Class

UnicastIPAddressModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUnicastIPAddressModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UnicastIPAddressModel
Public NotInheritable Class UnicastIPAddressModel
public ref class UnicastIPAddressModel sealed
[<SealedAttribute>]
type UnicastIPAddressModel =  class end

The UnicastIPAddressModel type exposes the following members.

Constructors
 | Name | Description
Public method | UnicastIPAddressModel | Initializes a new instance of the UnicastIPAddressModel class
Top
Properties
 | Name | Description
Public property | IPAddress | the IP address as a string
Public property | IsDhcp | a value indicating whether this address is a DHCP-assigned address or not
Public property | IsNat | a value indicating whether this address is a public NAT address or not
Public property | IsOnline | a value indicating whether this Virtual address is online or not
Public property | Mask | the IPv4 mask
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UnicastIPAddressModel Constructor

UnicastIPAddressModel Constructor
Initializes a new instance of the UnicastIPAddressModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel()
Public Sub New
public:
UnicastIPAddressModel()
new : unit -> UnicastIPAddressModel
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel Properties

UnicastIPAddressModel Properties

The UnicastIPAddressModel type exposes the following members.

Properties
 | Name | Description
Public property | IPAddress | the IP address as a string
Public property | IsDhcp | a value indicating whether this address is a DHCP-assigned address or not
Public property | IsNat | a value indicating whether this address is a public NAT address or not
Public property | IsOnline | a value indicating whether this Virtual address is online or not
Public property | Mask | the IPv4 mask
Top
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IPAddress Property

UnicastIPAddressModelIPAddress Property
the IP address as a string

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IsDhcp Property

UnicastIPAddressModelIsDhcp Property
a value indicating whether this address is a DHCP-assigned address or not

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDhcp { get; set; }
Public Property IsDhcp As Boolean
    Get
    Set
public:
property bool IsDhcp {
    bool get ();
    void set (bool value);
}
member IsDhcp : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IsNat Property

UnicastIPAddressModelIsNat Property
a value indicating whether this address is a public NAT address or not

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
member IsNat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IsOnline Property

UnicastIPAddressModelIsOnline Property
a value indicating whether this Virtual address is online or not

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOnline { get; set; }
Public Property IsOnline As Boolean
    Get
    Set
public:
property bool IsOnline {
    bool get ();
    void set (bool value);
}
member IsOnline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.Mask Property

UnicastIPAddressModelMask Property
the IPv4 mask

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel Methods

UnicastIPAddressModel Methods

The UnicastIPAddressModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnicastIPAddressModel Class


UnicastNetworkAddressInfoModel Class

UnicastNetworkAddressInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUnicastNetworkAddressInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UnicastNetworkAddressInfoModel
Public NotInheritable Class UnicastNetworkAddressInfoModel
public ref class UnicastNetworkAddressInfoModel sealed
[<SealedAttribute>]
type UnicastNetworkAddressInfoModel =  class end

The UnicastNetworkAddressInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | UnicastNetworkAddressInfoModel | Initializes a new instance of the UnicastNetworkAddressInfoModel class
Top
Properties
 | Name | Description
Public property | IPAddress | the IP address
Public property | IPv4Mask | the IPv4 mask
Public property | IsDHCP | a value indicating whether this address is a DHCP-assigned address
Public property | IsNAT | a value indicating whether this address is a public NAT address
Public property | IsOnline | a value indicating whether this Virtual address is online
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UnicastNetworkAddressInfoModel Constructor

UnicastNetworkAddressInfoModel Constructor
Initializes a new instance of the UnicastNetworkAddressInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel()
Public Sub New
public:
UnicastNetworkAddressInfoModel()
new : unit -> UnicastNetworkAddressInfoModel
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel Properties

UnicastNetworkAddressInfoModel Properties

The UnicastNetworkAddressInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | IPAddress | the IP address
Public property | IPv4Mask | the IPv4 mask
Public property | IsDHCP | a value indicating whether this address is a DHCP-assigned address
Public property | IsNAT | a value indicating whether this address is a public NAT address
Public property | IsOnline | a value indicating whether this Virtual address is online
Top
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IPAddress Property

UnicastNetworkAddressInfoModelIPAddress Property
the IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IPv4Mask Property

UnicastNetworkAddressInfoModelIPv4Mask Property
the IPv4 mask

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string IPv4Mask { get; set; }
Public Property IPv4Mask As String
    Get
    Set
public:
property String^ IPv4Mask {
    String^ get ();
    void set (String^ value);
}
member IPv4Mask : string with get, set

Property Value

Type: String
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IsDHCP Property

UnicastNetworkAddressInfoModelIsDHCP Property
a value indicating whether this address is a DHCP-assigned address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDHCP { get; set; }
Public Property IsDHCP As Boolean
    Get
    Set
public:
property bool IsDHCP {
    bool get ();
    void set (bool value);
}
member IsDHCP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IsNAT Property

UnicastNetworkAddressInfoModelIsNAT Property
a value indicating whether this address is a public NAT address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNAT { get; set; }
Public Property IsNAT As Boolean
    Get
    Set
public:
property bool IsNAT {
    bool get ();
    void set (bool value);
}
member IsNAT : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IsOnline Property

UnicastNetworkAddressInfoModelIsOnline Property
a value indicating whether this Virtual address is online

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOnline { get; set; }
Public Property IsOnline As Boolean
    Get
    Set
public:
property bool IsOnline {
    bool get ();
    void set (bool value);
}
member IsOnline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel Methods

UnicastNetworkAddressInfoModel Methods

The UnicastNetworkAddressInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnmanagedConnectionOptionsModel Class

UnmanagedConnectionOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUnmanagedConnectionOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UnmanagedConnectionOptionsModel
Public NotInheritable Class UnmanagedConnectionOptionsModel
public ref class UnmanagedConnectionOptionsModel sealed
[<SealedAttribute>]
type UnmanagedConnectionOptionsModel =  class end

The UnmanagedConnectionOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | UnmanagedConnectionOptionsModel | Initializes a new instance of the UnmanagedConnectionOptionsModel class
Top
Properties
 | Name | Description
Public property | TargetStateInfo | the target state information for this connection
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UnmanagedConnectionOptionsModel Constructor

UnmanagedConnectionOptionsModel Constructor
Initializes a new instance of the UnmanagedConnectionOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UnmanagedConnectionOptionsModel()
Public Sub New
public:
UnmanagedConnectionOptionsModel()
new : unit -> UnmanagedConnectionOptionsModel
See Also

Reference

UnmanagedConnectionOptionsModel Class


UnmanagedConnectionOptionsModel Properties

UnmanagedConnectionOptionsModel Properties

The UnmanagedConnectionOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | TargetStateInfo | the target state information for this connection
Top
See Also

Reference

UnmanagedConnectionOptionsModel Class


UnmanagedConnectionOptionsModel.TargetStateInfo Property

UnmanagedConnectionOptionsModelTargetStateInfo Property
the target state information for this connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateInfoModel TargetStateInfo { get; set; }
Public Property TargetStateInfo As TargetStateInfoModel
    Get
    Set
public:
property TargetStateInfoModel^ TargetStateInfo {
    TargetStateInfoModel^ get ();
    void set (TargetStateInfoModel^ value);
}
member TargetStateInfo : TargetStateInfoModel with get, set

Property Value

Type: TargetStateInfoModel
See Also

Reference

UnmanagedConnectionOptionsModel Class


UnmanagedConnectionOptionsModel Methods

UnmanagedConnectionOptionsModel Methods

The UnmanagedConnectionOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnmanagedConnectionOptionsModel Class


UpdateRecommendedJobOptionsRequestModel Class

UpdateRecommendedJobOptionsRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUpdateRecommendedJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UpdateRecommendedJobOptionsRequestModel
Public NotInheritable Class UpdateRecommendedJobOptionsRequestModel
public ref class UpdateRecommendedJobOptionsRequestModel sealed
[<SealedAttribute>]
type UpdateRecommendedJobOptionsRequestModel =  class end

The UpdateRecommendedJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateRecommendedJobOptionsRequestModel | Initializes a new instance of the UpdateRecommendedJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | CandidateOptions |
Public property | Workload |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UpdateRecommendedJobOptionsRequestModel Constructor

UpdateRecommendedJobOptionsRequestModel Constructor
Initializes a new instance of the UpdateRecommendedJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public UpdateRecommendedJobOptionsRequestModel()
Public Sub New
public:
UpdateRecommendedJobOptionsRequestModel()
new : unit -> UpdateRecommendedJobOptionsRequestModel
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel Properties

UpdateRecommendedJobOptionsRequestModel Properties

The UpdateRecommendedJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | CandidateOptions |
Public property | Workload |
Top
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel.CandidateOptions Property

UpdateRecommendedJobOptionsRequestModelCandidateOptions Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel CandidateOptions { get; set; }
Public Property CandidateOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ CandidateOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member CandidateOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel.Workload Property

UpdateRecommendedJobOptionsRequestModelWorkload Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel Methods

UpdateRecommendedJobOptionsRequestModel Methods

The UpdateRecommendedJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


VcdVappOptionsModel Class

VcdVappOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVcdVappOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VcdVappOptionsModel
Public NotInheritable Class VcdVappOptionsModel
public ref class VcdVappOptionsModel sealed
[<SealedAttribute>]
type VcdVappOptionsModel =  class end

The VcdVappOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VcdVappOptionsModel | Initializes a new instance of the VcdVappOptionsModel class
Top
Properties
 | Name | Description
Public property | DoDiskDataEncryption | a value indicating whether or not to do disk encryption
Public property | IsSnapshotQuiescenceEnabled | a value indicating whether or not snapshot quiescence is enabled
Public property | ReplicationIntervalSeconds | the replication interval in seconds
Public property | SourceVappDisplayName | the source Vapp display name
Public property | SourceVappGuid | the source Vapp Guid
Public property | TargetVappDisplayName | the target Vapp display name
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | SourceOrgName | the source Org name
Public field | TargetOrgName | the target Org name
Public field | TargetOrgVdcName | the target Org Vdc name
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VcdVappOptionsModel Constructor

VcdVappOptionsModel Constructor
Initializes a new instance of the VcdVappOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VcdVappOptionsModel()
Public Sub New
public:
VcdVappOptionsModel()
new : unit -> VcdVappOptionsModel
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel Properties

VcdVappOptionsModel Properties

The VcdVappOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DoDiskDataEncryption | a value indicating whether or not to do disk encryption
Public property | IsSnapshotQuiescenceEnabled | a value indicating whether or not snapshot quiescence is enabled
Public property | ReplicationIntervalSeconds | the replication interval in seconds
Public property | SourceVappDisplayName | the source Vapp display name
Public property | SourceVappGuid | the source Vapp Guid
Public property | TargetVappDisplayName | the target Vapp display name
Top
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.DoDiskDataEncryption Property

VcdVappOptionsModelDoDiskDataEncryption Property
a value indicating whether or not to do disk encryption

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoDiskDataEncryption { get; set; }
Public Property DoDiskDataEncryption As Boolean
    Get
    Set
public:
property bool DoDiskDataEncryption {
    bool get ();
    void set (bool value);
}
member DoDiskDataEncryption : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.IsSnapshotQuiescenceEnabled Property

VcdVappOptionsModelIsSnapshotQuiescenceEnabled Property
a value indicating whether or not snapshot quiescence is enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSnapshotQuiescenceEnabled { get; set; }
Public Property IsSnapshotQuiescenceEnabled As Boolean
    Get
    Set
public:
property bool IsSnapshotQuiescenceEnabled {
    bool get ();
    void set (bool value);
}
member IsSnapshotQuiescenceEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.ReplicationIntervalSeconds Property

VcdVappOptionsModelReplicationIntervalSeconds Property
the replication interval in seconds

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReplicationIntervalSeconds { get; set; }
Public Property ReplicationIntervalSeconds As Integer
    Get
    Set
public:
property int ReplicationIntervalSeconds {
    int get ();
    void set (int value);
}
member ReplicationIntervalSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.SourceVappDisplayName Property

VcdVappOptionsModelSourceVappDisplayName Property
the source Vapp display name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceVappDisplayName { get; set; }
Public Property SourceVappDisplayName As String
    Get
    Set
public:
property String^ SourceVappDisplayName {
    String^ get ();
    void set (String^ value);
}
member SourceVappDisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.SourceVappGuid Property

VcdVappOptionsModelSourceVappGuid Property
the source Vapp Guid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceVappGuid { get; set; }
Public Property SourceVappGuid As String
    Get
    Set
public:
property String^ SourceVappGuid {
    String^ get ();
    void set (String^ value);
}
member SourceVappGuid : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.TargetVappDisplayName Property

VcdVappOptionsModelTargetVappDisplayName Property
the target Vapp display name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetVappDisplayName { get; set; }
Public Property TargetVappDisplayName As String
    Get
    Set
public:
property String^ TargetVappDisplayName {
    String^ get ();
    void set (String^ value);
}
member TargetVappDisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel Methods

VcdVappOptionsModel Methods

The VcdVappOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel Fields

VcdVappOptionsModel Fields

The VcdVappOptionsModel type exposes the following members.

Fields
 | Name | Description
Public field | SourceOrgName | the source Org name
Public field | TargetOrgName | the target Org name
Public field | TargetOrgVdcName | the target Org Vdc name
Top
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.SourceOrgName Field

VcdVappOptionsModelSourceOrgName Field
the source Org name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceOrgName
Public SourceOrgName As String
public:
String^ SourceOrgName
val mutable SourceOrgName: string

Field Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.TargetOrgName Field

VcdVappOptionsModelTargetOrgName Field
the target Org name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetOrgName
Public TargetOrgName As String
public:
String^ TargetOrgName
val mutable TargetOrgName: string

Field Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.TargetOrgVdcName Field

VcdVappOptionsModelTargetOrgVdcName Field
the target Org Vdc name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetOrgVdcName
Public TargetOrgVdcName As String
public:
String^ TargetOrgVdcName
val mutable TargetOrgVdcName: string

Field Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VerificationStatusEnum Enumeration

VerificationStatusEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerificationStatusEnum
Public Enumeration VerificationStatusEnum
public enum class VerificationStatusEnum
type VerificationStatusEnum
Members
Member name | Value | Description
InProgress | 0 |
Success | 1 |
Warning | 2 |
Error | 3 |
See Also

Reference

DoubleTake.Web.Models Namespace


VerificationStatusModel Class

VerificationStatusModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityStatusModel
DoubleTake.Web.ModelsVerificationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerificationStatusModel : ActivityStatusModel
Public NotInheritable Class VerificationStatusModel
    Inherits ActivityStatusModel
public ref class VerificationStatusModel sealed : public ActivityStatusModel
[<SealedAttribute>]
type VerificationStatusModel =
    class
        inherit ActivityStatusModel
    end

The VerificationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationStatusModel | Initializes a new instance of the VerificationStatusModel class
Top
Properties
 | Name | Description
Public property | Duration | a value the duration of the activity at the time this status was yielded (Inherited from ActivityStatusModel.)
Public property | MessageFormatParameters | the message format parameters (Inherited from ActivityStatusModel.)
Public property | MessageId | a value representing a message identifier (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | the user that initiated the activity (Inherited from ActivityStatusModel.)
Public property | Status | the current status of the activity (Inherited from ActivityStatusModel.)
Public property | StatusUri | the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted' (Inherited from ActivityStatusModel.)
Public property | Steps | the steps in the verification task
Public property | TimeStamp | the server time when the activity yielded this status (Inherited from ActivityStatusModel.)
Public property | Token | a token that identifies the request that initiated the activity (Inherited from ActivityStatusModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerificationStatusModel Constructor

VerificationStatusModel Constructor
Initializes a new instance of the VerificationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStatusModel()
Public Sub New
public:
VerificationStatusModel()
new : unit -> VerificationStatusModel
See Also

Reference

VerificationStatusModel Class


VerificationStatusModel Properties

VerificationStatusModel Properties

The VerificationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | a value the duration of the activity at the time this status was yielded (Inherited from ActivityStatusModel.)
Public property | MessageFormatParameters | the message format parameters (Inherited from ActivityStatusModel.)
Public property | MessageId | a value representing a message identifier (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | the user that initiated the activity (Inherited from ActivityStatusModel.)
Public property | Status | the current status of the activity (Inherited from ActivityStatusModel.)
Public property | StatusUri | the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted' (Inherited from ActivityStatusModel.)
Public property | Steps | the steps in the verification task
Public property | TimeStamp | the server time when the activity yielded this status (Inherited from ActivityStatusModel.)
Public property | Token | a token that identifies the request that initiated the activity (Inherited from ActivityStatusModel.)
Top
See Also

Reference

VerificationStatusModel Class


VerificationStatusModel.Steps Property

VerificationStatusModelSteps Property
the steps in the verification task

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<VerificationStepModel> Steps { get; set; }
Public Property Steps As IEnumerable(Of VerificationStepModel)
    Get
    Set
public:
property IEnumerable<VerificationStepModel^>^ Steps {
    IEnumerable<VerificationStepModel^>^ get ();
    void set (IEnumerable<VerificationStepModel^>^ value);
}
member Steps : IEnumerable<VerificationStepModel> with get, set

Property Value

Type: IEnumerable VerificationStepModel
See Also

Reference

VerificationStatusModel Class


VerificationStatusModel Methods

VerificationStatusModel Methods

The VerificationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerificationStatusModel Class


VerificationStepModel Class

VerificationStepModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVerificationStepModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerificationStepModel
Public NotInheritable Class VerificationStepModel
public ref class VerificationStepModel sealed
[<SealedAttribute>]
type VerificationStepModel =  class end

The VerificationStepModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationStepModel | Initializes a new instance of the VerificationStepModel class
Top
Properties
 | Name | Description
Public property | CanFix | a value indicating whether this step can be fixed.
Public property | Id | a value representing the identifier of this verification step
Public property | Index | the index of this verification step
Public property | MessageFormatParameters | the message format parameters for this step
Public property | MessageKey | a value representing a message key for this verification step
Public property | Progress | value that indicates the completion progress of this verification step
Public property | Status | the status of this verification step
Public property | TitleFormatParameters | the title format parameters for this step
Public property | TitleKey | a value representing a title key for this verification step
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerificationStepModel Constructor

VerificationStepModel Constructor
Initializes a new instance of the VerificationStepModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStepModel()
Public Sub New
public:
VerificationStepModel()
new : unit -> VerificationStepModel
See Also

Reference

VerificationStepModel Class


VerificationStepModel Properties

VerificationStepModel Properties

The VerificationStepModel type exposes the following members.

Properties
 | Name | Description
Public property | CanFix | a value indicating whether this step can be fixed.
Public property | Id | a value representing the identifier of this verification step
Public property | Index | the index of this verification step
Public property | MessageFormatParameters | the message format parameters for this step
Public property | MessageKey | a value representing a message key for this verification step
Public property | Progress | value that indicates the completion progress of this verification step
Public property | Status | the status of this verification step
Public property | TitleFormatParameters | the title format parameters for this step
Public property | TitleKey | a value representing a title key for this verification step
Top
See Also

Reference

VerificationStepModel Class


VerificationStepModel.CanFix Property

VerificationStepModelCanFix Property
a value indicating whether this step can be fixed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFix { get; set; }
Public Property CanFix As Boolean
    Get
    Set
public:
property bool CanFix {
    bool get ();
    void set (bool value);
}
member CanFix : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Id Property

VerificationStepModelId Property
a value representing the identifier of this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Index Property

VerificationStepModelIndex Property
the index of this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

VerificationStepModel Class


VerificationStepModel.MessageFormatParameters Property

VerificationStepModelMessageFormatParameters Property
the message format parameters for this step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.MessageKey Property

VerificationStepModelMessageKey Property
a value representing a message key for this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageKey { get; set; }
Public Property MessageKey As String
    Get
    Set
public:
property String^ MessageKey {
    String^ get ();
    void set (String^ value);
}
member MessageKey : string with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Progress Property

VerificationStepModelProgress Property
value that indicates the completion progress of this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int Progress { get; set; }
Public Property Progress As Integer
    Get
    Set
public:
property int Progress {
    int get ();
    void set (int value);
}
member Progress : int with get, set

Property Value

Type: Int32
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Status Property

VerificationStepModelStatus Property
the status of this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStatusEnum Status { get; set; }
Public Property Status As VerificationStatusEnum
    Get
    Set
public:
property VerificationStatusEnum Status {
    VerificationStatusEnum get ();
    void set (VerificationStatusEnum value);
}
member Status : VerificationStatusEnum with get, set

Property Value

Type: VerificationStatusEnum
See Also

Reference

VerificationStepModel Class


VerificationStepModel.TitleFormatParameters Property

VerificationStepModelTitleFormatParameters Property
the title format parameters for this step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TitleFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.TitleKey Property

VerificationStepModelTitleKey Property
a value representing a title key for this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string TitleKey { get; set; }
Public Property TitleKey As String
    Get
    Set
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}
member TitleKey : string with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel Methods

VerificationStepModel Methods

The VerificationStepModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerificationStepModel Class


VerifyJobOptionsRequestModel Class

VerifyJobOptionsRequestModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVerifyJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerifyJobOptionsRequestModel
Public NotInheritable Class VerifyJobOptionsRequestModel
public ref class VerifyJobOptionsRequestModel sealed
[<SealedAttribute>]
type VerifyJobOptionsRequestModel =  class end

The VerifyJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerifyJobOptionsRequestModel | Initializes a new instance of the VerifyJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | JobCredentials |
Public property | JobOptions |
Public property | JobType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerifyJobOptionsRequestModel Constructor

VerifyJobOptionsRequestModel Constructor
Initializes a new instance of the VerifyJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerifyJobOptionsRequestModel()
Public Sub New
public:
VerifyJobOptionsRequestModel()
new : unit -> VerifyJobOptionsRequestModel
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel Properties

VerifyJobOptionsRequestModel Properties

The VerifyJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials |
Public property | JobOptions |
Public property | JobType |
Top
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel.JobCredentials Property

VerifyJobOptionsRequestModelJobCredentials Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel.JobOptions Property

VerifyJobOptionsRequestModelJobOptions Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel.JobType Property

VerifyJobOptionsRequestModelJobType Property

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel Methods

VerifyJobOptionsRequestModel Methods

The VerifyJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyScheduleModel Class

VerifyScheduleModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsVerifyScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerifyScheduleModel : ScheduleItemModel
Public NotInheritable Class VerifyScheduleModel
    Inherits ScheduleItemModel
public ref class VerifyScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type VerifyScheduleModel =
    class
        inherit ScheduleItemModel
    end

The VerifyScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerifyScheduleModel | Initializes a new instance of the VerifyScheduleModel class
Top
Properties
 | Name | Description
Public property | Criteria | how to compare files when creating the verification report
Public property | Interval | how often a verification is to be run
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | Options | a value indicating whether or not to synchronize the data while creating the verification report
Public property | StartTime | the time that the first scheduled verification report will be run
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerifyScheduleModel Constructor

VerifyScheduleModel Constructor
Initializes a new instance of the VerifyScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VerifyScheduleModel()
Public Sub New
public:
VerifyScheduleModel()
new : unit -> VerifyScheduleModel
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel Properties

VerifyScheduleModel Properties

The VerifyScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Criteria | how to compare files when creating the verification report
Public property | Interval | how often a verification is to be run
Public property | IsEnabled | a value indicating whether or not the item is enabled (Inherited from ScheduleItemModel.)
Public property | Options | a value indicating whether or not to synchronize the data while creating the verification report
Public property | StartTime | the time that the first scheduled verification report will be run
Top
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.Criteria Property

VerifyScheduleModelCriteria Property
how to compare files when creating the verification report

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorComparisonCriteriaEnum Criteria { get; set; }
Public Property Criteria As MirrorComparisonCriteriaEnum
    Get
    Set
public:
property MirrorComparisonCriteriaEnum Criteria {
    MirrorComparisonCriteriaEnum get ();
    void set (MirrorComparisonCriteriaEnum value);
}
member Criteria : MirrorComparisonCriteriaEnum with get, set

Property Value

Type: MirrorComparisonCriteriaEnum
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.Interval Property

VerifyScheduleModelInterval Property
how often a verification is to be run

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Interval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.Options Property

VerifyScheduleModelOptions Property
a value indicating whether or not to synchronize the data while creating the verification report

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorOperationOptionsEnum Options { get; set; }
Public Property Options As MirrorOperationOptionsEnum
    Get
    Set
public:
property MirrorOperationOptionsEnum Options {
    MirrorOperationOptionsEnum get ();
    void set (MirrorOperationOptionsEnum value);
}
member Options : MirrorOperationOptionsEnum with get, set

Property Value

Type: MirrorOperationOptionsEnum
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.StartTime Property

VerifyScheduleModelStartTime Property
the time that the first scheduled verification report will be run

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel Methods

VerifyScheduleModel Methods

The VerifyScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerifyScheduleModel Class


VhdDeleteActionTypeEnum Enumeration

VhdDeleteActionTypeEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public enum VhdDeleteActionTypeEnum
Public Enumeration VhdDeleteActionTypeEnum
public enum class VhdDeleteActionTypeEnum
type VhdDeleteActionTypeEnum
Members
Member name | Value | Description
KeepAll | 0 |
DeleteAll | 1 |
UseVhdsToDelete | 2 |
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualNetworkInterfaceInfoModel Class

VirtualNetworkInterfaceInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceModel
DoubleTake.Web.ModelsVirtualNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualNetworkInterfaceInfoModel : NetworkInterfaceModel
Public NotInheritable Class VirtualNetworkInterfaceInfoModel
    Inherits NetworkInterfaceModel
public ref class VirtualNetworkInterfaceInfoModel sealed : public NetworkInterfaceModel
[<SealedAttribute>]
type VirtualNetworkInterfaceInfoModel =
    class
        inherit NetworkInterfaceModel
    end

The VirtualNetworkInterfaceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualNetworkInterfaceInfoModel | Initializes a new instance of the VirtualNetworkInterfaceInfoModel class
Top
Properties
 | Name | Description
Public property | Description | the description of the network interface (Inherited from NetworkInterfaceModel.)
Public property | DnsDomain | the DNS Domain (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | the DNS servers (Inherited from NetworkInterfaceModel.)
Public property | Gateways | the gateways (Inherited from NetworkInterfaceModel.)
Public property | Id | the unique identifier of the network interface (Inherited from NetworkInterfaceModel.)
Public property | Index | the index of the network interface (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | the index of the network interface (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | the IP addresses on the network interface (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | the MAC address (Inherited from NetworkInterfaceModel.)
Public property | Name | the friendly name of the network interface (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | the PNP instance id (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | the service name of the network interface (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | the virtual network
Public property | VirtualNicType | the type of the virtual nic
Public property | VLAN_ID | the replica's VLan ID
Public property | VLAN_ID_TestFailover | the replica's test failover VLan ID
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualNetworkInterfaceInfoModel Constructor

VirtualNetworkInterfaceInfoModel Constructor
Initializes a new instance of the VirtualNetworkInterfaceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel()
Public Sub New
public:
VirtualNetworkInterfaceInfoModel()
new : unit -> VirtualNetworkInterfaceInfoModel
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel Properties

VirtualNetworkInterfaceInfoModel Properties

The VirtualNetworkInterfaceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | the description of the network interface (Inherited from NetworkInterfaceModel.)
Public property | DnsDomain | the DNS Domain (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | the DNS servers (Inherited from NetworkInterfaceModel.)
Public property | Gateways | the gateways (Inherited from NetworkInterfaceModel.)
Public property | Id | the unique identifier of the network interface (Inherited from NetworkInterfaceModel.)
Public property | Index | the index of the network interface (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | the index of the network interface (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | the IP addresses on the network interface (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | the MAC address (Inherited from NetworkInterfaceModel.)
Public property | Name | the friendly name of the network interface (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | the PNP instance id (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | the service name of the network interface (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | the virtual network
Public property | VirtualNicType | the type of the virtual nic
Public property | VLAN_ID | the replica's VLan ID
Public property | VLAN_ID_TestFailover | the replica's test failover VLan ID
Top
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VirtualNetwork Property

VirtualNetworkInterfaceInfoModelVirtualNetwork Property
the virtual network

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualNetwork { get; set; }
Public Property VirtualNetwork As String
    Get
    Set
public:
property String^ VirtualNetwork {
    String^ get ();
    void set (String^ value);
}
member VirtualNetwork : string with get, set

Property Value

Type: String
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VirtualNicType Property

VirtualNetworkInterfaceInfoModelVirtualNicType Property
the type of the virtual nic

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualNicType { get; set; }
Public Property VirtualNicType As String
    Get
    Set
public:
property String^ VirtualNicType {
    String^ get ();
    void set (String^ value);
}
member VirtualNicType : string with get, set

Property Value

Type: String
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VLAN_ID Property

VirtualNetworkInterfaceInfoModelVLAN_ID Property
the replica's VLan ID

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VLAN_ID { get; set; }
Public Property VLAN_ID As Integer
    Get
    Set
public:
property int VLAN_ID {
    int get ();
    void set (int value);
}
member VLAN_ID : int with get, set

Property Value

Type: Int32
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VLAN_ID_TestFailover Property

VirtualNetworkInterfaceInfoModelVLAN_ID_TestFailover Property
the replica's test failover VLan ID

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int VLAN_ID_TestFailover { get; set; }
Public Property VLAN_ID_TestFailover As Integer
    Get
    Set
public:
property int VLAN_ID_TestFailover {
    int get ();
    void set (int value);
}
member VLAN_ID_TestFailover : int with get, set

Property Value

Type: Int32
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel Methods

VirtualNetworkInterfaceInfoModel Methods

The VirtualNetworkInterfaceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualSwitchInfoModel Class

VirtualSwitchInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualSwitchInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualSwitchInfoModel
Public NotInheritable Class VirtualSwitchInfoModel
public ref class VirtualSwitchInfoModel sealed
[<SealedAttribute>]
type VirtualSwitchInfoModel =  class end

The VirtualSwitchInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchInfoModel | Initializes a new instance of the VirtualSwitchInfoModel class
Top
Properties
 | Name | Description
Public property | Label | a value indicating virtual switch label
Public property | SwitchUuid | a value indicating virtual switch Guid
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualSwitchInfoModel Constructor

VirtualSwitchInfoModel Constructor
Initializes a new instance of the VirtualSwitchInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel()
Public Sub New
public:
VirtualSwitchInfoModel()
new : unit -> VirtualSwitchInfoModel
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel Properties

VirtualSwitchInfoModel Properties

The VirtualSwitchInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Label | a value indicating virtual switch label
Public property | SwitchUuid | a value indicating virtual switch Guid
Top
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel.Label Property

VirtualSwitchInfoModelLabel Property
a value indicating virtual switch label

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel.SwitchUuid Property

VirtualSwitchInfoModelSwitchUuid Property
a value indicating virtual switch Guid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SwitchUuid { get; set; }
Public Property SwitchUuid As String
    Get
    Set
public:
property String^ SwitchUuid {
    String^ get ();
    void set (String^ value);
}
member SwitchUuid : string with get, set

Property Value

Type: String
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel Methods

VirtualSwitchInfoModel Methods

The VirtualSwitchInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchMappingModel Class

VirtualSwitchMappingModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualSwitchMappingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualSwitchMappingModel
Public NotInheritable Class VirtualSwitchMappingModel
public ref class VirtualSwitchMappingModel sealed
[<SealedAttribute>]
type VirtualSwitchMappingModel =  class end

The VirtualSwitchMappingModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchMappingModel | Initializes a new instance of the VirtualSwitchMappingModel class
Top
Properties
 | Name | Description
Public property | SourceVirtualSwitch | a value indicating source virtual switch
Public property | TargetVirtualSwitch | a value indicating target virtual switch
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualSwitchMappingModel Constructor

VirtualSwitchMappingModel Constructor
Initializes a new instance of the VirtualSwitchMappingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchMappingModel()
Public Sub New
public:
VirtualSwitchMappingModel()
new : unit -> VirtualSwitchMappingModel
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel Properties

VirtualSwitchMappingModel Properties

The VirtualSwitchMappingModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceVirtualSwitch | a value indicating source virtual switch
Public property | TargetVirtualSwitch | a value indicating target virtual switch
Top
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel.SourceVirtualSwitch Property

VirtualSwitchMappingModelSourceVirtualSwitch Property
a value indicating source virtual switch

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel SourceVirtualSwitch { get; set; }
Public Property SourceVirtualSwitch As VirtualSwitchInfoModel
    Get
    Set
public:
property VirtualSwitchInfoModel^ SourceVirtualSwitch {
    VirtualSwitchInfoModel^ get ();
    void set (VirtualSwitchInfoModel^ value);
}
member SourceVirtualSwitch : VirtualSwitchInfoModel with get, set

Property Value

Type: VirtualSwitchInfoModel
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel.TargetVirtualSwitch Property

VirtualSwitchMappingModelTargetVirtualSwitch Property
a value indicating target virtual switch

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel TargetVirtualSwitch { get; set; }
Public Property TargetVirtualSwitch As VirtualSwitchInfoModel
    Get
    Set
public:
property VirtualSwitchInfoModel^ TargetVirtualSwitch {
    VirtualSwitchInfoModel^ get ();
    void set (VirtualSwitchInfoModel^ value);
}
member TargetVirtualSwitch : VirtualSwitchInfoModel with get, set

Property Value

Type: VirtualSwitchInfoModel
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel Methods

VirtualSwitchMappingModel Methods

The VirtualSwitchMappingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchMappingModel Class


VmInfoModel Class

VmInfoModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmInfoModel
DoubleTake.Web.ModelsReplicaVmInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VmInfoModel
Public Class VmInfoModel
public ref class VmInfoModel
type VmInfoModel =  class end

The VmInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmInfoModel | Initializes a new instance of the VmInfoModel class
Top
Properties
 | Name | Description
Public property | Address | the virtual machine guest DNS name/IP Address
Public property | BiosGuid | the virtual machine BIOS Guid
Public property | BootVolumeSignature | the VM boot volume signature
Public property | DisplayName | the virtual machine display name
Public property | GuestOS | the virtual machine guest OS
Public property | GuestUri | the guest URI
Public property | Id | the virtual machine Guid
Public property | Path | the virtual machine location
Public property | PathTransformations | the path transformations
Public property | SnapshotDataPath | the virtual machine snapshot location
Public property | SnapshotFileNames | the VM snapshot FileNames
Public property | SystemDirectory | the VM system directory
Public property | VirtualHardDiskPath | the virtual hard disk path
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VmInfoModel Constructor

VmInfoModel Constructor
Initializes a new instance of the VmInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel()
Public Sub New
public:
VmInfoModel()
new : unit -> VmInfoModel
See Also

Reference

VmInfoModel Class


VmInfoModel Properties

VmInfoModel Properties

The VmInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | the virtual machine guest DNS name/IP Address
Public property | BiosGuid | the virtual machine BIOS Guid
Public property | BootVolumeSignature | the VM boot volume signature
Public property | DisplayName | the virtual machine display name
Public property | GuestOS | the virtual machine guest OS
Public property | GuestUri | the guest URI
Public property | Id | the virtual machine Guid
Public property | Path | the virtual machine location
Public property | PathTransformations | the path transformations
Public property | SnapshotDataPath | the virtual machine snapshot location
Public property | SnapshotFileNames | the VM snapshot FileNames
Public property | SystemDirectory | the VM system directory
Public property | VirtualHardDiskPath | the virtual hard disk path
Top
See Also

Reference

VmInfoModel Class


VmInfoModel.Address Property

VmInfoModelAddress Property
the virtual machine guest DNS name/IP Address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.BiosGuid Property

VmInfoModelBiosGuid Property
the virtual machine BIOS Guid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
member BiosGuid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

VmInfoModel Class


VmInfoModel.BootVolumeSignature Property

VmInfoModelBootVolumeSignature Property
the VM boot volume signature

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] BootVolumeSignature { get; set; }
Public Property BootVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ BootVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member BootVolumeSignature : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

VmInfoModel Class


VmInfoModel.DisplayName Property

VmInfoModelDisplayName Property
the virtual machine display name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.GuestOS Property

VmInfoModelGuestOS Property
the virtual machine guest OS

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
member GuestOS : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.GuestUri Property

VmInfoModelGuestUri Property
the guest URI

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Uri GuestUri { get; set; }
Public Property GuestUri As Uri
    Get
    Set
public:
property Uri^ GuestUri {
    Uri^ get ();
    void set (Uri^ value);
}
member GuestUri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

VmInfoModel Class


VmInfoModel.Id Property

VmInfoModelId Property
the virtual machine Guid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

VmInfoModel Class


VmInfoModel.Path Property

VmInfoModelPath Property
the virtual machine location

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.PathTransformations Property

VmInfoModelPathTransformations Property
the path transformations

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

VmInfoModel Class


VmInfoModel.SnapshotDataPath Property

VmInfoModelSnapshotDataPath Property
the virtual machine snapshot location

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataPath { get; set; }
Public Property SnapshotDataPath As String
    Get
    Set
public:
property String^ SnapshotDataPath {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataPath : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.SnapshotFileNames Property

VmInfoModelSnapshotFileNames Property
the VM snapshot FileNames

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] SnapshotFileNames { get; set; }
Public Property SnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ SnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member SnapshotFileNames : string[] with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.SystemDirectory Property

VmInfoModelSystemDirectory Property
the VM system directory

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
member SystemDirectory : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.VirtualHardDiskPath Property

VmInfoModelVirtualHardDiskPath Property
the virtual hard disk path

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] VirtualHardDiskPath { get; set; }
Public Property VirtualHardDiskPath As String()
    Get
    Set
public:
property array<String^>^ VirtualHardDiskPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VirtualHardDiskPath : string[] with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel Methods

VmInfoModel Methods

The VmInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmInfoModel Class


VolumeGroupModel Class

VolumeGroupModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVolumeGroupModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VolumeGroupModel
Public NotInheritable Class VolumeGroupModel
public ref class VolumeGroupModel sealed
[<SealedAttribute>]
type VolumeGroupModel =  class end

The VolumeGroupModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeGroupModel | Initializes a new instance of the VolumeGroupModel class
Top
Properties
 | Name | Description
Public property | LogicalVolumes | the list of logical volumes
Public property | MaxPhysicalVolumeSize | the maximum size of the physical volume
Public property | Name | the volume group name.
Public property | PhysicalVolumes | the list of physical volumes
Public property | PreexistingDiskPaths | the preexisting disk paths
Public property | SourceVolumeGroupSize | the size of the source volume group
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeGroupModel Constructor

VolumeGroupModel Constructor
Initializes a new instance of the VolumeGroupModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeGroupModel()
Public Sub New
public:
VolumeGroupModel()
new : unit -> VolumeGroupModel
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel Properties

VolumeGroupModel Properties

The VolumeGroupModel type exposes the following members.

Properties
 | Name | Description
Public property | LogicalVolumes | the list of logical volumes
Public property | MaxPhysicalVolumeSize | the maximum size of the physical volume
Public property | Name | the volume group name.
Public property | PhysicalVolumes | the list of physical volumes
Public property | PreexistingDiskPaths | the preexisting disk paths
Public property | SourceVolumeGroupSize | the size of the source volume group
Top
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.LogicalVolumes Property

VolumeGroupModelLogicalVolumes Property
the list of logical volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalVolumeModel[] LogicalVolumes { get; set; }
Public Property LogicalVolumes As LogicalVolumeModel()
    Get
    Set
public:
property array<LogicalVolumeModel^>^ LogicalVolumes {
    array<LogicalVolumeModel^>^ get ();
    void set (array<LogicalVolumeModel^>^ value);
}
member LogicalVolumes : LogicalVolumeModel[] with get, set

Property Value

Type: LogicalVolumeModel
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.MaxPhysicalVolumeSize Property

VolumeGroupModelMaxPhysicalVolumeSize Property
the maximum size of the physical volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MaxPhysicalVolumeSize { get; set; }
Public Property MaxPhysicalVolumeSize As Long
    Get
    Set
public:
property long long MaxPhysicalVolumeSize {
    long long get ();
    void set (long long value);
}
member MaxPhysicalVolumeSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.Name Property

VolumeGroupModelName Property
the volume group name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.PhysicalVolumes Property

VolumeGroupModelPhysicalVolumes Property
the list of physical volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalVolumeModel[] PhysicalVolumes { get; set; }
Public Property PhysicalVolumes As PhysicalVolumeModel()
    Get
    Set
public:
property array<PhysicalVolumeModel^>^ PhysicalVolumes {
    array<PhysicalVolumeModel^>^ get ();
    void set (array<PhysicalVolumeModel^>^ value);
}
member PhysicalVolumes : PhysicalVolumeModel[] with get, set

Property Value

Type: PhysicalVolumeModel
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.PreexistingDiskPaths Property

VolumeGroupModelPreexistingDiskPaths Property
the preexisting disk paths

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] PreexistingDiskPaths { get; set; }
Public Property PreexistingDiskPaths As String()
    Get
    Set
public:
property array<String^>^ PreexistingDiskPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PreexistingDiskPaths : string[] with get, set

Property Value

Type: String
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.SourceVolumeGroupSize Property

VolumeGroupModelSourceVolumeGroupSize Property
the size of the source volume group

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long SourceVolumeGroupSize { get; set; }
Public Property SourceVolumeGroupSize As Long
    Get
    Set
public:
property long long SourceVolumeGroupSize {
    long long get ();
    void set (long long value);
}
member SourceVolumeGroupSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel Methods

VolumeGroupModel Methods

The VolumeGroupModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeGroupModel Class


VolumeModel Class

VolumeModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VolumeModel : PhysicalItemModel
Public Class VolumeModel
    Inherits PhysicalItemModel
public ref class VolumeModel : public PhysicalItemModel
type VolumeModel =
    class
        inherit PhysicalItemModel
    end

The VolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeModel | Initializes a new instance of the VolumeModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DriveFormat | the format of the drive
Public property | DriveType | the type of the drive
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume
Public property | VolumeType | the volume type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeModel Constructor

VolumeModel Constructor
Initializes a new instance of the VolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel()
Public Sub New
public:
VolumeModel()
new : unit -> VolumeModel
See Also

Reference

VolumeModel Class


VolumeModel Properties

VolumeModel Properties

The VolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DriveFormat | the format of the drive
Public property | DriveType | the type of the drive
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume
Public property | VolumeType | the volume type
Top
See Also

Reference

VolumeModel Class


VolumeModel.AvailableFreeSpace Property

VolumeModelAvailableFreeSpace Property
the available free space on this volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long AvailableFreeSpace { get; set; }
Public Property AvailableFreeSpace As Long
    Get
    Set
public:
property long long AvailableFreeSpace {
    long long get ();
    void set (long long value);
}
member AvailableFreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeModel Class


VolumeModel.DriveFormat Property

VolumeModelDriveFormat Property
the format of the drive

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveFormat { get; set; }
Public Property DriveFormat As String
    Get
    Set
public:
property String^ DriveFormat {
    String^ get ();
    void set (String^ value);
}
member DriveFormat : string with get, set

Property Value

Type: String
See Also

Reference

VolumeModel Class


VolumeModel.DriveType Property

VolumeModelDriveType Property
the type of the drive

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public DriveType DriveType { get; set; }
Public Property DriveType As DriveType
    Get
    Set
public:
property DriveType DriveType {
    DriveType get ();
    void set (DriveType value);
}
member DriveType : DriveType with get, set

Property Value

Type: DriveType
See Also

Reference

VolumeModel Class


VolumeModel.IsSystemDrive Property

VolumeModelIsSystemDrive Property
a value indicating whether or not this volume is the system drive

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemDrive { get; set; }
Public Property IsSystemDrive As Boolean
    Get
    Set
public:
property bool IsSystemDrive {
    bool get ();
    void set (bool value);
}
member IsSystemDrive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VolumeModel Class


VolumeModel.Label Property

VolumeModelLabel Property
the volume label

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

VolumeModel Class


VolumeModel.TotalSize Property

VolumeModelTotalSize Property
the total size of the volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalSize { get; set; }
Public Property TotalSize As Long
    Get
    Set
public:
property long long TotalSize {
    long long get ();
    void set (long long value);
}
member TotalSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeModel Class


VolumeModel.VolumeType Property

VolumeModelVolumeType Property
the volume type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VolumeType { get; set; }
Public Property VolumeType As String
    Get
    Set
public:
property String^ VolumeType {
    String^ get ();
    void set (String^ value);
}
member VolumeType : string with get, set

Property Value

Type: String
See Also

Reference

VolumeModel Class


VolumeModel Methods

VolumeModel Methods

The VolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeModel Class


VolumeOptionsModel Class

VolumeOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsLogicalVolumeModel
DoubleTake.Web.ModelsPhysicalVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public class VolumeOptionsModel : VolumeModel
Public Class VolumeOptionsModel
    Inherits VolumeModel
public ref class VolumeOptionsModel : public VolumeModel
type VolumeOptionsModel =
    class
        inherit VolumeModel
    end

The VolumeOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeOptionsModel | Initializes a new instance of the VolumeOptionsModel class
Top
Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume (Inherited from VolumeModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DesiredSize | the size that the user wants the drive to be
Public property | DiskControllerType | the type of the disk controller
Public property | DiskProvisioningType | the type of the disk provisioning
Public property | DriveFormat | the format of the drive (Inherited from VolumeModel.)
Public property | DriveType | the type of the drive (Inherited from VolumeModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive (Inherited from VolumeModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label (Inherited from VolumeModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | the path of preexisting disk
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume (Inherited from VolumeModel.)
Public property | VirtualDiskPath | the path on the host where the volume should be stored
Public property | VolumeSignature | the volume signature
Public property | VolumeType | the volume type (Inherited from VolumeModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeOptionsModel Constructor

VolumeOptionsModel Constructor
Initializes a new instance of the VolumeOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeOptionsModel()
Public Sub New
public:
VolumeOptionsModel()
new : unit -> VolumeOptionsModel
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel Properties

VolumeOptionsModel Properties

The VolumeOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | a value specifying the file system attributes of this item (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | the available free space on this volume (Inherited from VolumeModel.)
Public property | CreationTime | a value specifying the time this item was created (Inherited from PhysicalItemModel.)
Public property | DesiredSize | the size that the user wants the drive to be
Public property | DiskControllerType | the type of the disk controller
Public property | DiskProvisioningType | the type of the disk provisioning
Public property | DriveFormat | the format of the drive (Inherited from VolumeModel.)
Public property | DriveType | the type of the drive (Inherited from VolumeModel.)
Public property | Id | the item identifier (Inherited from ProtectableItemModel.)
Public property | IsContainer | a value indicating whether or not this item is a container of other items (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | a value indicating whether or not this item is read only; that is, its Saturation cannot be changed (Inherited from ProtectableItemModel.)
Public property | IsSystemDrive | a value indicating whether or not this volume is the system drive (Inherited from VolumeModel.)
Public property | ItemType | the type of this item (Inherited from ProtectableItemModel.)
Public property | Label | the volume label (Inherited from VolumeModel.)
Public property | LastAccessTime | a value specifying the time this item was last accessed (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | a value specifying the time this item was last written to (Inherited from PhysicalItemModel.)
Public property | Metadata | a value specifying additional meta data for this item (Inherited from PhysicalItemModel.)
Public property | Name | the name of this item (Inherited from ProtectableItemModel.)
Public property | Path | the path that uniquely identifies this item (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | the path of preexisting disk
Public property | Saturation | the saturation level of this item (Inherited from ProtectableItemModel.)
Public property | Size | a value indicating the physical size of the item (Inherited from PhysicalItemModel.)
Public property | TotalSize | the total size of the volume (Inherited from VolumeModel.)
Public property | VirtualDiskPath | the path on the host where the volume should be stored
Public property | VolumeSignature | the volume signature
Public property | VolumeType | the volume type (Inherited from VolumeModel.)
Top
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.DesiredSize Property

VolumeOptionsModelDesiredSize Property
the size that the user wants the drive to be

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DesiredSize { get; set; }
Public Property DesiredSize As Long
    Get
    Set
public:
property long long DesiredSize {
    long long get ();
    void set (long long value);
}
member DesiredSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.DiskControllerType Property

VolumeOptionsModelDiskControllerType Property
the type of the disk controller

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskControllerType { get; set; }
Public Property DiskControllerType As String
    Get
    Set
public:
property String^ DiskControllerType {
    String^ get ();
    void set (String^ value);
}
member DiskControllerType : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.DiskProvisioningType Property

VolumeOptionsModelDiskProvisioningType Property
the type of the disk provisioning

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskProvisioningType { get; set; }
Public Property DiskProvisioningType As String
    Get
    Set
public:
property String^ DiskProvisioningType {
    String^ get ();
    void set (String^ value);
}
member DiskProvisioningType : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.PreexistingDiskPath Property

VolumeOptionsModelPreexistingDiskPath Property
the path of preexisting disk

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string PreexistingDiskPath { get; set; }
Public Property PreexistingDiskPath As String
    Get
    Set
public:
property String^ PreexistingDiskPath {
    String^ get ();
    void set (String^ value);
}
member PreexistingDiskPath : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.VirtualDiskPath Property

VolumeOptionsModelVirtualDiskPath Property
the path on the host where the volume should be stored

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskPath { get; set; }
Public Property VirtualDiskPath As String
    Get
    Set
public:
property String^ VirtualDiskPath {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskPath : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.VolumeSignature Property

VolumeOptionsModelVolumeSignature Property
the volume signature

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] VolumeSignature { get; set; }
Public Property VolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ VolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member VolumeSignature : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel Methods

VolumeOptionsModel Methods

The VolumeOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeOptionsModel Class


VolumeQualificationResultsModel Class

VolumeQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVolumeQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VolumeQualificationResultsModel
Public NotInheritable Class VolumeQualificationResultsModel
public ref class VolumeQualificationResultsModel sealed
[<SealedAttribute>]
type VolumeQualificationResultsModel =  class end

The VolumeQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeQualificationResultsModel | Initializes a new instance of the VolumeQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupName | the name of the group that contains the resource
Public property | CurrentOwnerNodeName | the name of the resource's current owner node
Public property | DiskSize | the volume total disk size
Public property | DriveLetter | the volume drive letter
Public property | FreeSpace | the volume available free space
Public property | IsSystemVolume | the value if it is a system volume
Public property | IsVolumeCSV | the value if it is a cluster shared volume
Public property | MaxFileSize | the max file size
Public property | ProvisionedSpace | the volume provisioned space
Public property | Url | the url of a datastore
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeQualificationResultsModel Constructor

VolumeQualificationResultsModel Constructor
Initializes a new instance of the VolumeQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeQualificationResultsModel()
Public Sub New
public:
VolumeQualificationResultsModel()
new : unit -> VolumeQualificationResultsModel
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel Properties

VolumeQualificationResultsModel Properties

The VolumeQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupName | the name of the group that contains the resource
Public property | CurrentOwnerNodeName | the name of the resource's current owner node
Public property | DiskSize | the volume total disk size
Public property | DriveLetter | the volume drive letter
Public property | FreeSpace | the volume available free space
Public property | IsSystemVolume | the value if it is a system volume
Public property | IsVolumeCSV | the value if it is a cluster shared volume
Public property | MaxFileSize | the max file size
Public property | ProvisionedSpace | the volume provisioned space
Public property | Url | the url of a datastore
Top
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.ClusterResourceGroupName Property

VolumeQualificationResultsModelClusterResourceGroupName Property
the name of the group that contains the resource

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
member ClusterResourceGroupName : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.CurrentOwnerNodeName Property

VolumeQualificationResultsModelCurrentOwnerNodeName Property
the name of the resource's current owner node

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
member CurrentOwnerNodeName : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.DiskSize Property

VolumeQualificationResultsModelDiskSize Property
the volume total disk size

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
member DiskSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.DriveLetter Property

VolumeQualificationResultsModelDriveLetter Property
the volume drive letter

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
member DriveLetter : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.FreeSpace Property

VolumeQualificationResultsModelFreeSpace Property
the volume available free space

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
member FreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.IsSystemVolume Property

VolumeQualificationResultsModelIsSystemVolume Property
the value if it is a system volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemVolume { get; set; }
Public Property IsSystemVolume As Boolean
    Get
    Set
public:
property bool IsSystemVolume {
    bool get ();
    void set (bool value);
}
member IsSystemVolume : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.IsVolumeCSV Property

VolumeQualificationResultsModelIsVolumeCSV Property
the value if it is a cluster shared volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
member IsVolumeCSV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.MaxFileSize Property

VolumeQualificationResultsModelMaxFileSize Property
the max file size

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long MaxFileSize { get; set; }
Public Property MaxFileSize As Long
    Get
    Set
public:
property long long MaxFileSize {
    long long get ();
    void set (long long value);
}
member MaxFileSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.ProvisionedSpace Property

VolumeQualificationResultsModelProvisionedSpace Property
the volume provisioned space

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long ProvisionedSpace { get; set; }
Public Property ProvisionedSpace As Long
    Get
    Set
public:
property long long ProvisionedSpace {
    long long get ();
    void set (long long value);
}
member ProvisionedSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.Url Property

VolumeQualificationResultsModelUrl Property
the url of a datastore

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel Methods

VolumeQualificationResultsModel Methods

The VolumeQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeQualificationResultsModel Class


VraOptionsModel Class

VraOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVraOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VraOptionsModel
Public NotInheritable Class VraOptionsModel
public ref class VraOptionsModel sealed
[<SealedAttribute>]
type VraOptionsModel =  class end

The VraOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VraOptionsModel | Initializes a new instance of the VraOptionsModel class
Top
Properties
 | Name | Description
Public property | Hypervisor | the hypervisor
Public property | IsSourceHostCluster | a value indicating if source host is cluster or not
Public property | IsWANFailoverEnabled | a value indicating whether or not this instance is WAN failover enabled
Public property | LvmOptions | LVM information for volumes
Public property | ReplicaApplianceInfo | the Replica Appliance information
Public property | ReplicaESXHostName | the target vim host information
Public property | ReplicaNetworkInterfaceInfo | the replica network interface info
Public property | ReplicaVmInfo | the replica VM information
Public property | ReverseCount | the reverse count
Public property | ReverseRoute | the reverse route
Public property | SourceApplianceInfo | the source appliance information
Public property | SourceESXHostName | the source vim host info
Public property | SourceNetworkInterfaceInfo | the source network interface info
Public property | SourceProductLicense | the source product license
Public property | SourceVmInfo | the source information
Public property | VirtualSwitchMapping | the source and target virtual switch mappings
Public property | VirtualSwitchMappingTestFailover | the source and target virtual switch mappings for test failover
Public property | Volumes | the volumes to create and protect
Public property | WorkloadCustomizationOptions | the workload customization options
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VraOptionsModel Constructor

VraOptionsModel Constructor
Initializes a new instance of the VraOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VraOptionsModel()
Public Sub New
public:
VraOptionsModel()
new : unit -> VraOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel Properties

VraOptionsModel Properties

The VraOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | Hypervisor | the hypervisor
Public property | IsSourceHostCluster | a value indicating if source host is cluster or not
Public property | IsWANFailoverEnabled | a value indicating whether or not this instance is WAN failover enabled
Public property | LvmOptions | LVM information for volumes
Public property | ReplicaApplianceInfo | the Replica Appliance information
Public property | ReplicaESXHostName | the target vim host information
Public property | ReplicaNetworkInterfaceInfo | the replica network interface info
Public property | ReplicaVmInfo | the replica VM information
Public property | ReverseCount | the reverse count
Public property | ReverseRoute | the reverse route
Public property | SourceApplianceInfo | the source appliance information
Public property | SourceESXHostName | the source vim host info
Public property | SourceNetworkInterfaceInfo | the source network interface info
Public property | SourceProductLicense | the source product license
Public property | SourceVmInfo | the source information
Public property | VirtualSwitchMapping | the source and target virtual switch mappings
Public property | VirtualSwitchMappingTestFailover | the source and target virtual switch mappings for test failover
Public property | Volumes | the volumes to create and protect
Public property | WorkloadCustomizationOptions | the workload customization options
Top
See Also

Reference

VraOptionsModel Class


VraOptionsModel.Hypervisor Property

VraOptionsModelHypervisor Property
the hypervisor

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Hypervisor { get; set; }
Public Property Hypervisor As String
    Get
    Set
public:
property String^ Hypervisor {
    String^ get ();
    void set (String^ value);
}
member Hypervisor : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.IsSourceHostCluster Property

VraOptionsModelIsSourceHostCluster Property
a value indicating if source host is cluster or not

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSourceHostCluster { get; set; }
Public Property IsSourceHostCluster As Boolean
    Get
    Set
public:
property bool IsSourceHostCluster {
    bool get ();
    void set (bool value);
}
member IsSourceHostCluster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraOptionsModel Class


VraOptionsModel.IsWANFailoverEnabled Property

VraOptionsModelIsWANFailoverEnabled Property
a value indicating whether or not this instance is WAN failover enabled

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
member IsWANFailoverEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraOptionsModel Class


VraOptionsModel.LvmOptions Property

VraOptionsModelLvmOptions Property
LVM information for volumes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public LvmOptionsModel LvmOptions { get; set; }
Public Property LvmOptions As LvmOptionsModel
    Get
    Set
public:
property LvmOptionsModel^ LvmOptions {
    LvmOptionsModel^ get ();
    void set (LvmOptionsModel^ value);
}
member LvmOptions : LvmOptionsModel with get, set

Property Value

Type: LvmOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaApplianceInfo Property

VraOptionsModelReplicaApplianceInfo Property
the Replica Appliance information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel ReplicaApplianceInfo { get; set; }
Public Property ReplicaApplianceInfo As VmInfoModel
    Get
    Set
public:
property VmInfoModel^ ReplicaApplianceInfo {
    VmInfoModel^ get ();
    void set (VmInfoModel^ value);
}
member ReplicaApplianceInfo : VmInfoModel with get, set

Property Value

Type: VmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaESXHostName Property

VraOptionsModelReplicaESXHostName Property
the target vim host information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicaESXHostName { get; set; }
Public Property ReplicaESXHostName As String
    Get
    Set
public:
property String^ ReplicaESXHostName {
    String^ get ();
    void set (String^ value);
}
member ReplicaESXHostName : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaNetworkInterfaceInfo Property

VraOptionsModelReplicaNetworkInterfaceInfo Property
the replica network interface info

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel[] ReplicaNetworkInterfaceInfo { get; set; }
Public Property ReplicaNetworkInterfaceInfo As VirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfoModel^>^ ReplicaNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VirtualNetworkInterfaceInfoModel^>^ value);
}
member ReplicaNetworkInterfaceInfo : VirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VirtualNetworkInterfaceInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaVmInfo Property

VraOptionsModelReplicaVmInfo Property
the replica VM information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicaVmInfoModel ReplicaVmInfo { get; set; }
Public Property ReplicaVmInfo As ReplicaVmInfoModel
    Get
    Set
public:
property ReplicaVmInfoModel^ ReplicaVmInfo {
    ReplicaVmInfoModel^ get ();
    void set (ReplicaVmInfoModel^ value);
}
member ReplicaVmInfo : ReplicaVmInfoModel with get, set

Property Value

Type: ReplicaVmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReverseCount Property

VraOptionsModelReverseCount Property
the reverse count

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int ReverseCount { get; set; }
Public Property ReverseCount As Integer
    Get
    Set
public:
property int ReverseCount {
    int get ();
    void set (int value);
}
member ReverseCount : int with get, set

Property Value

Type: Int32
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReverseRoute Property

VraOptionsModelReverseRoute Property
the reverse route

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
member ReverseRoute : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceApplianceInfo Property

VraOptionsModelSourceApplianceInfo Property
the source appliance information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel SourceApplianceInfo { get; set; }
Public Property SourceApplianceInfo As VmInfoModel
    Get
    Set
public:
property VmInfoModel^ SourceApplianceInfo {
    VmInfoModel^ get ();
    void set (VmInfoModel^ value);
}
member SourceApplianceInfo : VmInfoModel with get, set

Property Value

Type: VmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceESXHostName Property

VraOptionsModelSourceESXHostName Property
the source vim host info

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceESXHostName { get; set; }
Public Property SourceESXHostName As String
    Get
    Set
public:
property String^ SourceESXHostName {
    String^ get ();
    void set (String^ value);
}
member SourceESXHostName : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceNetworkInterfaceInfo Property

VraOptionsModelSourceNetworkInterfaceInfo Property
the source network interface info

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel[] SourceNetworkInterfaceInfo { get; set; }
Public Property SourceNetworkInterfaceInfo As VirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfoModel^>^ SourceNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VirtualNetworkInterfaceInfoModel^>^ value);
}
member SourceNetworkInterfaceInfo : VirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VirtualNetworkInterfaceInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceProductLicense Property

VraOptionsModelSourceProductLicense Property
the source product license

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceProductLicense { get; set; }
Public Property SourceProductLicense As String
    Get
    Set
public:
property String^ SourceProductLicense {
    String^ get ();
    void set (String^ value);
}
member SourceProductLicense : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceVmInfo Property

VraOptionsModelSourceVmInfo Property
the source information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel SourceVmInfo { get; set; }
Public Property SourceVmInfo As VmInfoModel
    Get
    Set
public:
property VmInfoModel^ SourceVmInfo {
    VmInfoModel^ get ();
    void set (VmInfoModel^ value);
}
member SourceVmInfo : VmInfoModel with get, set

Property Value

Type: VmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.VirtualSwitchMapping Property

VraOptionsModelVirtualSwitchMapping Property
the source and target virtual switch mappings

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchMappingModel[] VirtualSwitchMapping { get; set; }
Public Property VirtualSwitchMapping As VirtualSwitchMappingModel()
    Get
    Set
public:
property array<VirtualSwitchMappingModel^>^ VirtualSwitchMapping {
    array<VirtualSwitchMappingModel^>^ get ();
    void set (array<VirtualSwitchMappingModel^>^ value);
}
member VirtualSwitchMapping : VirtualSwitchMappingModel[] with get, set

Property Value

Type: VirtualSwitchMappingModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.VirtualSwitchMappingTestFailover Property

VraOptionsModelVirtualSwitchMappingTestFailover Property
the source and target virtual switch mappings for test failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchMappingModel[] VirtualSwitchMappingTestFailover { get; set; }
Public Property VirtualSwitchMappingTestFailover As VirtualSwitchMappingModel()
    Get
    Set
public:
property array<VirtualSwitchMappingModel^>^ VirtualSwitchMappingTestFailover {
    array<VirtualSwitchMappingModel^>^ get ();
    void set (array<VirtualSwitchMappingModel^>^ value);
}
member VirtualSwitchMappingTestFailover : VirtualSwitchMappingModel[] with get, set

Property Value

Type: VirtualSwitchMappingModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.Volumes Property

VraOptionsModelVolumes Property
the volumes to create and protect

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeOptionsModel[] Volumes { get; set; }
Public Property Volumes As VolumeOptionsModel()
    Get
    Set
public:
property array<VolumeOptionsModel^>^ Volumes {
    array<VolumeOptionsModel^>^ get ();
    void set (array<VolumeOptionsModel^>^ value);
}
member Volumes : VolumeOptionsModel[] with get, set

Property Value

Type: VolumeOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.WorkloadCustomizationOptions Property

VraOptionsModelWorkloadCustomizationOptions Property
the workload customization options

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VraWorkloadCustomizationOptionsModel WorkloadCustomizationOptions { get; set; }
Public Property WorkloadCustomizationOptions As VraWorkloadCustomizationOptionsModel
    Get
    Set
public:
property VraWorkloadCustomizationOptionsModel^ WorkloadCustomizationOptions {
    VraWorkloadCustomizationOptionsModel^ get ();
    void set (VraWorkloadCustomizationOptionsModel^ value);
}
member WorkloadCustomizationOptions : VraWorkloadCustomizationOptionsModel with get, set

Property Value

Type: VraWorkloadCustomizationOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel Methods

VraOptionsModel Methods

The VraOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VraOptionsModel Class


VraQualificationResultsModel Class

VraQualificationResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVraQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VraQualificationResultsModel
Public NotInheritable Class VraQualificationResultsModel
public ref class VraQualificationResultsModel sealed
[<SealedAttribute>]
type VraQualificationResultsModel =  class end

The VraQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VraQualificationResultsModel | Initializes a new instance of the VraQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | PreexistingDisksFileName | we have a special format for the replica disks, so to use pre-existing disk that disk must have the same name which we expect
Public property | SourceServerMemorySize | the amount of memory on the server
Public property | SourceServerProcessorCount | the processor count of the server
Public property | TargetHost | the target server information
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VraQualificationResultsModel Constructor

VraQualificationResultsModel Constructor
Initializes a new instance of the VraQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VraQualificationResultsModel()
Public Sub New
public:
VraQualificationResultsModel()
new : unit -> VraQualificationResultsModel
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel Properties

VraQualificationResultsModel Properties

The VraQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | PreexistingDisksFileName | we have a special format for the replica disks, so to use pre-existing disk that disk must have the same name which we expect
Public property | SourceServerMemorySize | the amount of memory on the server
Public property | SourceServerProcessorCount | the processor count of the server
Public property | TargetHost | the target server information
Top
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.PreexistingDisksFileName Property

VraQualificationResultsModelPreexistingDisksFileName Property
we have a special format for the replica disks, so to use pre-existing disk that disk must have the same name which we expect

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] PreexistingDisksFileName { get; set; }
Public Property PreexistingDisksFileName As String()
    Get
    Set
public:
property array<String^>^ PreexistingDisksFileName {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PreexistingDisksFileName : string[] with get, set

Property Value

Type: String
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.SourceServerMemorySize Property

VraQualificationResultsModelSourceServerMemorySize Property
the amount of memory on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public long SourceServerMemorySize { get; set; }
Public Property SourceServerMemorySize As Long
    Get
    Set
public:
property long long SourceServerMemorySize {
    long long get ();
    void set (long long value);
}
member SourceServerMemorySize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.SourceServerProcessorCount Property

VraQualificationResultsModelSourceServerProcessorCount Property
the processor count of the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceServerProcessorCount { get; set; }
Public Property SourceServerProcessorCount As Integer
    Get
    Set
public:
property int SourceServerProcessorCount {
    int get ();
    void set (int value);
}
member SourceServerProcessorCount : int with get, set

Property Value

Type: Int32
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.TargetHost Property

VraQualificationResultsModelTargetHost Property
the target server information

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public ServerQualificationResultsModel TargetHost { get; set; }
Public Property TargetHost As ServerQualificationResultsModel
    Get
    Set
public:
property ServerQualificationResultsModel^ TargetHost {
    ServerQualificationResultsModel^ get ();
    void set (ServerQualificationResultsModel^ value);
}
member TargetHost : ServerQualificationResultsModel with get, set

Property Value

Type: ServerQualificationResultsModel
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel Methods

VraQualificationResultsModel Methods

The VraQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VraQualificationResultsModel Class


VraWorkloadCustomizationOptionsModel Class

VraWorkloadCustomizationOptionsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVraWorkloadCustomizationOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VraWorkloadCustomizationOptionsModel
Public NotInheritable Class VraWorkloadCustomizationOptionsModel
public ref class VraWorkloadCustomizationOptionsModel sealed
[<SealedAttribute>]
type VraWorkloadCustomizationOptionsModel =  class end

The VraWorkloadCustomizationOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VraWorkloadCustomizationOptionsModel | Initializes a new instance of the VraWorkloadCustomizationOptionsModel class
Top
Properties
 | Name | Description
Public property | NoReplication | a value indicating whether or not to replicate data
Public property | PowerupReplicaAfterFailover | a value indicating whether or not we should powerup the replica after failover
Public property | ShouldShutdownSource | a value indicating whether or not the source machine should be shutdown during failover
Public property | UseWin32 | a value indicating whether or not we should include a USEWIN32 in our connect line
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VraWorkloadCustomizationOptionsModel Constructor

VraWorkloadCustomizationOptionsModel Constructor
Initializes a new instance of the VraWorkloadCustomizationOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public VraWorkloadCustomizationOptionsModel()
Public Sub New
public:
VraWorkloadCustomizationOptionsModel()
new : unit -> VraWorkloadCustomizationOptionsModel
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel Properties

VraWorkloadCustomizationOptionsModel Properties

The VraWorkloadCustomizationOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | NoReplication | a value indicating whether or not to replicate data
Public property | PowerupReplicaAfterFailover | a value indicating whether or not we should powerup the replica after failover
Public property | ShouldShutdownSource | a value indicating whether or not the source machine should be shutdown during failover
Public property | UseWin32 | a value indicating whether or not we should include a USEWIN32 in our connect line
Top
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.NoReplication Property

VraWorkloadCustomizationOptionsModelNoReplication Property
a value indicating whether or not to replicate data

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool NoReplication { get; set; }
Public Property NoReplication As Boolean
    Get
    Set
public:
property bool NoReplication {
    bool get ();
    void set (bool value);
}
member NoReplication : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.PowerupReplicaAfterFailover Property

VraWorkloadCustomizationOptionsModelPowerupReplicaAfterFailover Property
a value indicating whether or not we should powerup the replica after failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool PowerupReplicaAfterFailover { get; set; }
Public Property PowerupReplicaAfterFailover As Boolean
    Get
    Set
public:
property bool PowerupReplicaAfterFailover {
    bool get ();
    void set (bool value);
}
member PowerupReplicaAfterFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.ShouldShutdownSource Property

VraWorkloadCustomizationOptionsModelShouldShutdownSource Property
a value indicating whether or not the source machine should be shutdown during failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldShutdownSource { get; set; }
Public Property ShouldShutdownSource As Boolean
    Get
    Set
public:
property bool ShouldShutdownSource {
    bool get ();
    void set (bool value);
}
member ShouldShutdownSource : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.UseWin32 Property

VraWorkloadCustomizationOptionsModelUseWin32 Property
a value indicating whether or not we should include a USEWIN32 in our connect line

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseWin32 { get; set; }
Public Property UseWin32 As Boolean
    Get
    Set
public:
property bool UseWin32 {
    bool get ();
    void set (bool value);
}
member UseWin32 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel Methods

VraWorkloadCustomizationOptionsModel Methods

The VraWorkloadCustomizationOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


WeekdaysEnum Enumeration

WeekdaysEnum Enumeration

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum WeekdaysEnum
<FlagsAttribute>
Public Enumeration WeekdaysEnum
[FlagsAttribute]
public enum class WeekdaysEnum
[<FlagsAttribute>]
type WeekdaysEnum
Members
Member name | Value | Description
None | 0 |
Sunday | 1 |
Monday | 2 |
Tuesday | 4 |
Wednesday | 8 |
Thursday | 16 |
Friday | 32 |
Saturday | 64 |
Weekends | 65 |
Workdays | 62 |
All | 127 |
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadModel Class

WorkloadModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadModel
Public NotInheritable Class WorkloadModel
public ref class WorkloadModel sealed
[<SealedAttribute>]
type WorkloadModel =  class end

The WorkloadModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadModel | Initializes a new instance of the WorkloadModel class
Top
Properties
 | Name | Description
Public property | Id | the workload identifier
Public property | LogicalRules | the logical replication rules that compose this workload
Public property | PhysicalRules | the physical replication rules that compose this workload
Public property | RecoveryImageDataPath | the path to the recovery image data for an image based recovery
Public property | RecoveryImageId | the image id for an image based recovery
Public property | RecoverySnapshotSetId | the snapshot set id for an image based recovery
Public property | Server | the server the workload is hosted on
Public property | WorkloadTypeName | the name of the workload type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadModel Constructor

WorkloadModel Constructor
Initializes a new instance of the WorkloadModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel()
Public Sub New
public:
WorkloadModel()
new : unit -> WorkloadModel
See Also

Reference

WorkloadModel Class


WorkloadModel Properties

WorkloadModel Properties

The WorkloadModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | the workload identifier
Public property | LogicalRules | the logical replication rules that compose this workload
Public property | PhysicalRules | the physical replication rules that compose this workload
Public property | RecoveryImageDataPath | the path to the recovery image data for an image based recovery
Public property | RecoveryImageId | the image id for an image based recovery
Public property | RecoverySnapshotSetId | the snapshot set id for an image based recovery
Public property | Server | the server the workload is hosted on
Public property | WorkloadTypeName | the name of the workload type
Top
See Also

Reference

WorkloadModel Class


WorkloadModel.Id Property

WorkloadModelId Property
the workload identifier

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WorkloadModel Class


WorkloadModel.LogicalRules Property

WorkloadModelLogicalRules Property
the logical replication rules that compose this workload

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member LogicalRules : string[] with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel.PhysicalRules Property

WorkloadModelPhysicalRules Property
the physical replication rules that compose this workload

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
See Also

Reference

WorkloadModel Class


WorkloadModel.RecoveryImageDataPath Property

WorkloadModelRecoveryImageDataPath Property
the path to the recovery image data for an image based recovery

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string RecoveryImageDataPath { get; set; }
Public Property RecoveryImageDataPath As String
    Get
    Set
public:
property String^ RecoveryImageDataPath {
    String^ get ();
    void set (String^ value);
}
member RecoveryImageDataPath : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel.RecoveryImageId Property

WorkloadModelRecoveryImageId Property
the image id for an image based recovery

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Guid> RecoveryImageId { get; set; }
Public Property RecoveryImageId As Nullable(Of Guid)
    Get
    Set
public:
property Nullable<Guid> RecoveryImageId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}
member RecoveryImageId : Nullable<Guid> with get, set

Property Value

Type: Nullable Guid
See Also

Reference

WorkloadModel Class


WorkloadModel.RecoverySnapshotSetId Property

WorkloadModelRecoverySnapshotSetId Property
the snapshot set id for an image based recovery

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Guid> RecoverySnapshotSetId { get; set; }
Public Property RecoverySnapshotSetId As Nullable(Of Guid)
    Get
    Set
public:
property Nullable<Guid> RecoverySnapshotSetId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}
member RecoverySnapshotSetId : Nullable<Guid> with get, set

Property Value

Type: Nullable Guid
See Also

Reference

WorkloadModel Class


WorkloadModel.Server Property

WorkloadModelServer Property
the server the workload is hosted on

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel.WorkloadTypeName Property

WorkloadModelWorkloadTypeName Property
the name of the workload type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string WorkloadTypeName { get; set; }
Public Property WorkloadTypeName As String
    Get
    Set
public:
property String^ WorkloadTypeName {
    String^ get ();
    void set (String^ value);
}
member WorkloadTypeName : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel Methods

WorkloadModel Methods

The WorkloadModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadModel Class


WorkloadSupportSummaryModel Class

WorkloadSupportSummaryModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadSupportSummaryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadSupportSummaryModel
Public NotInheritable Class WorkloadSupportSummaryModel
public ref class WorkloadSupportSummaryModel sealed
[<SealedAttribute>]
type WorkloadSupportSummaryModel =  class end

The WorkloadSupportSummaryModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadSupportSummaryModel | Initializes a new instance of the WorkloadSupportSummaryModel class
Top
Properties
 | Name | Description
Public property | Reason | the reason why the workload type is licensed or not
Public property | ReasonFormatParameters | the reason format parameters
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadSupportSummaryModel Constructor

WorkloadSupportSummaryModel Constructor
Initializes a new instance of the WorkloadSupportSummaryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadSupportSummaryModel()
Public Sub New
public:
WorkloadSupportSummaryModel()
new : unit -> WorkloadSupportSummaryModel
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel Properties

WorkloadSupportSummaryModel Properties

The WorkloadSupportSummaryModel type exposes the following members.

Properties
 | Name | Description
Public property | Reason | the reason why the workload type is licensed or not
Public property | ReasonFormatParameters | the reason format parameters
Top
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel.Reason Property

WorkloadSupportSummaryModelReason Property
the reason why the workload type is licensed or not

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
member Reason : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel.ReasonFormatParameters Property

WorkloadSupportSummaryModelReasonFormatParameters Property
the reason format parameters

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ReasonFormatParameters { get; set; }
Public Property ReasonFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ReasonFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ReasonFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel Methods

WorkloadSupportSummaryModel Methods

The WorkloadSupportSummaryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadTypeModel Class

WorkloadTypeModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadTypeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadTypeModel
Public NotInheritable Class WorkloadTypeModel
public ref class WorkloadTypeModel sealed
[<SealedAttribute>]
type WorkloadTypeModel =  class end

The WorkloadTypeModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadTypeModel | Initializes a new instance of the WorkloadTypeModel class
Top
Properties
 | Name | Description
Public property | IsLicensed | a value indicating whether or not this type of workload is licensed for the server
Public property | IsPresent | a value indicating whether or not this type of workload is present on the server
Public property | Name | the workload type name
Public property | SupportSummary | the summary of the licensing for this workload type
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadTypeModel Constructor

WorkloadTypeModel Constructor
Initializes a new instance of the WorkloadTypeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadTypeModel()
Public Sub New
public:
WorkloadTypeModel()
new : unit -> WorkloadTypeModel
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel Properties

WorkloadTypeModel Properties

The WorkloadTypeModel type exposes the following members.

Properties
 | Name | Description
Public property | IsLicensed | a value indicating whether or not this type of workload is licensed for the server
Public property | IsPresent | a value indicating whether or not this type of workload is present on the server
Public property | Name | the workload type name
Public property | SupportSummary | the summary of the licensing for this workload type
Top
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.IsLicensed Property

WorkloadTypeModelIsLicensed Property
a value indicating whether or not this type of workload is licensed for the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLicensed { get; set; }
Public Property IsLicensed As Boolean
    Get
    Set
public:
property bool IsLicensed {
    bool get ();
    void set (bool value);
}
member IsLicensed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.IsPresent Property

WorkloadTypeModelIsPresent Property
a value indicating whether or not this type of workload is present on the server

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPresent { get; set; }
Public Property IsPresent As Boolean
    Get
    Set
public:
property bool IsPresent {
    bool get ();
    void set (bool value);
}
member IsPresent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.Name Property

WorkloadTypeModelName Property
the workload type name

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.SupportSummary Property

WorkloadTypeModelSupportSummary Property
the summary of the licensing for this workload type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadSupportSummaryModel SupportSummary { get; set; }
Public Property SupportSummary As WorkloadSupportSummaryModel
    Get
    Set
public:
property WorkloadSupportSummaryModel^ SupportSummary {
    WorkloadSupportSummaryModel^ get ();
    void set (WorkloadSupportSummaryModel^ value);
}
member SupportSummary : WorkloadSupportSummaryModel with get, set

Property Value

Type: WorkloadSupportSummaryModel
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel Methods

WorkloadTypeModel Methods

The WorkloadTypeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadTypeModel Class